Once you sign in you will be able to subscribe for any updates here

Measuring energy from single-phase PV Inverter on the second phase of Energy Meter

The Victron Energy Meter Manual for the EM24 RS485 states:-

Single phase dual function

If you are considering using a 3-phase meter in a single-phase installation to measure the grid on one input of the meter and the PV inverter output on another input of the energy meter, use the ET340 instead"

Is that because the EM24 counts total power, with net differential readings from each phase cancelling each other out, whereas the ET340 counts energy on each individual phase and then sums those values?

Also, the EM24 FAQ says "Attempting to use other brand battery inverters and trying to substitute their lack of data connectivity to the GX device by using Energy Meters will not work as expected"

My system was installed with an EM24 doing exactly that. Has that now been deprecated and it is no longer possible to set an Energy Meter as a dual "Grid + PV invertor" function anymore?

editbear asked

0 Answers

VRM shows 0W PV Power, Grid shows only Critical Load not whole house consumption

[image]

In November 2022, VRM started showing ‘AC Loads’ as 0W and ‘Total Consumption’ & ‘Grid’ displayed only the Critical Load, rather than the figures for the whole house.

My Solar PV was fitted 5 years ago by a Victron dealer who has since gone bust and now the only Victron agent in Kent wants £780 to look at it. He told me to update the CCGX firmware from v1.74 to version v2.92 which I did (with trepidation) but I think this has made my situation worse.

Until this week, I knew nothing of PV systems, so please allow a little latitude while I try & explain;-

[image]

I believe i have a HUB 4 system, now known as ESS. It comprises: CCGX, MultiPlus Compact 12/1200/50-16, 3 x Lead Acid batteries, 2 x Solis PV Invertors and an EM24 energy meter. The EM24 is linked to the CCGX via Cat5 cable, but I think it is a serial model with an RS485 to USB interface hidden behind the CCGX.

The CCGX Settings (firmware v1.74) contained ‘Wired AC sensors’ and the EM24 appeared as “BQ21600350013” where it was set to ‘Grid meter + PV inverter’.

[image]

In firmware v2.92 there is no ‘Wired AC sensors’, but the EM24 appears under ‘Energy Meters’ but can only be set to ‘Grid meter OR ‘PV inverter’ (not both). The Phase type ‘Single Phase’ and ‘PV inverter on phase 2’ with ‘AC Input 1’ have been carried over from the previous firmware.

[image]

Whatever I do, I cannot get the EM24 to appear in the CCGX ‘Device List’. I think it is Modbus RTU (different to’ Modbus TCP’) but in desperation I enabled ‘Modbus TCP’ in ‘Services’ and scanned but of course nothing was found. Help! I am really out of my depth.

[image]

[image]

All I know is that VRM displayed accurate Grid and Solar figures up until November last year and no hardware has been changed. The EM24 local display is still showing the Grid on L1 and the PV Invertors on L2 so my theory is that an automatic CCGX update to v1.74 lost the connection with the energy meter and upgrading to v2.92 has not helped.

[image]

[image]

I have found that Victron now say “using an EM24 to measure both Grid and Solar PV on a single-phase installation does not work properly”, and they recommend using an ET340 instead. Is that because the firmware does not support the EM24 anymore? If so, what version of firmware will I need to downgrade to, in order to restore VRM back to reading correct Grid and Solar figures?

Lastly, am I doing any harm running the system without a Grid/Solar meter? I know it is still saving me energy because on a recent bright day, my smart meter was showing 0 watts and the EM24 had a negative figure on L1), I don’t think the solar battery was charging.

[image]

editbear asked
editbear edited ·

0 Answers

Firmware update Interface 1140

Can someone please point me in the direction of updating the firmware on an Interface 1140 (ASS030510000). Have checked on Professional and can't find a reference? Thanks, Colin

colins asked

0 Answers

Cerbo GX can turn off Multiplus but can't turn it back on

I have a customer using a Cerbo GX to control their Multiplus, and since I don't personally have much experience with the Cerbo I'm at a bit of a loss as to what the fix might be.

The Multiplus rocker switch is switched on, it shows up in the Cerbo just fine and settings can be adjusted, but when turned off via the Cerbo (with rocker switch still switched on) it disappears from the Cerbo. Once that happens, the rocker switch will no longer turn it on or off until the RJ45 cable is removed.

RJ45 is in the correct port on both ends. Firmware on the Cerbo may have been updated, firmware on Multiplus has most likely not been updated. My best guess is it's a firmware conflict and updating the Multiplus may resolve it, but I'd love confirmation or alternatives/tests before he buys the MK3-USB. I don't have firmware versions handy but can get them if they will be informative.

Thank you for your time, John.

John asked

0 Answers

I need MPPT 100/20 firmware V1,59

Can anyone forward me V1.59 or show me where I can download it?

fvdm asked

0 Answers

Blue Smart IP67 Charger FIRMWARE UPDATE FAILED - Now no power lights one

We have a Blue Smart IP67 Charger. I've collected it to the app, and started a firmware updated. It reached about 95% then failed. Now we have NO POWER to the charger. So can't reconnect via Bluetooth. The unit is now not working. Any ideas on a fix please?

kmel asked
Alexandra commented ·

0 Answers

Phoenix Multiplus 24/3000 (firmware 1912209) compatible with lithium batteries?

Hello,

My current inverter/charger Phoenix Multiplus 24/3000/70-16 works well with 12pcs of 2V OPzS batteries. Because of the weight, footprint and 'maintenance' of these batteries, I want to switch to lithium. Does anybody know of this inverter/charger is compatible with lithium batteries? I have installed the latest firmware version 1912209.

Thanks and regards,

Sander

svdhoorn asked

0 Answers

conflicting info 2.92 or VRM issue

After the new update / VRM issue, below screen is not reflecting my settings:

[image]

- 2 way comminication is ON

- VRM is working
- Update is set to auto check and update


Eighter an update mistake in the VRM, ot due to the new version.


Harold

harold asked

0 Answers

Interface 1140 Firmware upgrade

Good Day


I recently installed to Multiplus !! in parallel with a PV inverter and an energy meter and I am getting two errors

One is low battery even though SOC is showing as 100% (Octo FX with CAN Bus communication with Pylontech batteries)

The second erro is

Error 15 - VE.Bus combination error


I intalled an energy meter and the problem started AFTER this installtion. How do I upgrade the firmware


many thanks


Marc Heymans



Marc Heymans asked
Florian Mettetal commented ·

0 Answers

CCGX Firmware update over v2.18 results in stuck at Victron Boot Screen logo

Hi all,

I'd like to update the fimware of the CCGX unit in my EasySolar 24/3000/70 to the latest version.

Anything over v2.18 results in the CCGX being stuck in the Victron logo Splash screen on boot.

I tried updating it via Wifi, the SD card via the 3 button boot menu procedure and with and without the CCGX connected to anything as suggested here.
Tried replacing the USB cable aswel to no avail...

The SmartSolar and Multi plus units inside the EasySolar never gave me any issues and I could update them to their latest versions.
(Currently both running on the latest stable release candidates.)

With v2.18 running the CCGX sometimes looses all readings on the SOC and/or spontaneously reboots.

I'd like to update the CCGX to the latest version (v2.98), any idea's what I might have overlooked or can try?

Thanks in advance for your input !

noia asked
noia edited ·

0 Answers

MulitPlus2 Firmware 2611497 - Phantom Low Voltage Alarm when computer connects.

My MultiPlus 2 gives a Phantom Low Voltage alarm (and inverter shuts down or switches back to incoming mains) when I connect my computer to the VE.BUS - USB Mk3 (after removal of VE.BUS cable from Cerbo) with either Victron Connect or VE.configer software only when I enter into that part of either program which can alter any MulitPlus2 settings. The low voltage alarm and inverter response occur anywhere from 54seconds to a couple of minutes.

The system voltage is nominal and has no problem.


This Low voltage alarm (and inverter switching) has not occurred in earlier <491-2 firmware versions. Interestingly when I then disconnect the MulitPlus VE.BUS back to the Cerbo the low voltage alarm is reset after a few seconds, and with it the inverter functions normally.

I have repeated the problem many times and each time only after entering the password which would allow me to change any inverter setting, even though no changes were made.

I'm using an Apple Mac book Pro M1 and also using Parallels with Windows 11 operating VE.config.

I thought the Fantom Low Voltage Alarm issue with the latest Firmware 2611497 had been solved some time ago? My system has been working otherwise nominally for many months and exhibits the Fantom Low Voltage Alarm ONLY when connecting an external computer and trying to make changes with the inverter settings.

Question - Is the low voltage alarm related to the external voltage being sent from the BMV-712? My inverter is not set up for external voltage control but is certainly behaving as it is dependent on the voltage being sent by the battery monitor BMV-712. (I have set my MPPTs to accept voltage control from my battery monitor BMV-712.)


raymiller asked

0 Answers

older firmware files for Phoenix Smart Inverter 48/3000

I can only find latest firmware on Victron Professional.

I am sure the inverter was quieter on Eco mode before update to 1.27, I need to check whether I'm imagining it or not!

squowse asked

0 Answers

Venus GX versions and VEBUS firmware versions compatability list

Is there a table that identifies firmwares that will play nicely together.

Venus / VEBUS.


I have had it previously, where an update (remote / automatic) of the Venus device loses some sort of connectivity / data / functionality with the Multi / Quattro. (in varying levels of lobotomisation)

The effect hasnt necessarily been immediately obvious.

My current issue.... Multiplus on firmware 430 - CCGx on firmware 2.33 - do i risk a remote firmware update on the CCGx ? (system has only recently been provuded with remote internet access)


Thanks

Chris

Chris asked
Chris edited ·

0 Answers

New VE.Bus Dongle firmware not updating
New Victron User. I'm trying to connect to and update my VE.Bus Dongle on a Multiplus 3000. It has 12v, I connected via Bluetooth and the Victron app doesn't seem to have a problem connecting. However, when I try to connect, this is a initial setup, it tries to do version update from "none" to "v1.11" takes about a minute and fails with a B10 waiting for response error. Both lights on the dongle are fast flashing. The current version of "none" has me a bit worried.
Anyone have any suggestions?

matt-rensel asked

0 Answers

Multiplus does not turn on after VE configuration

Multi 24/5000 went off during running quick VEconfigure and does not appear in VE-bus anymore.

Three units in three phase configuration. Neutrals attached. No load or AC-IN connected. Battery negatives connected first and last rj45. Fuses, contacts, cables swapped and still that one unit is blank. Other two are working normally.

Reset by keeping fuse out 10mins without luck.

Any other ways to reset multi?

janieronen asked
mvader (Victron Energy) commented ·

0 Answers

Top Contributors - Community Supporters

Alexandra avatar image Alexandra 229 Answers & Comments
kevgermany avatar image kevgermany 173 Answers & Comments
nickdb avatar image nickdb 164 Answers & Comments
Matthias Lange - DE avatar image Matthias Lange - DE 159 Answers & Comments
klim8skeptic avatar image klim8skeptic 126 Answers & Comments
Kevin Windrem avatar image Kevin Windrem 76 Answers & Comments
JohnC avatar image JohnC 74 Answers & Comments