firmware update Image

firmware update

SmartShunt FW update got stuck at 2% with D26 error code.

Brand new SmartShunt 500A/50mV. Most things seems to work with the VictronConnect app on my LG phone. Except when I go to the settings menu, it tells me I must update before I can do settings. When I update it always fails at 2%. After couple of seconds it gives me a D26 error code. I need to power cycle (via the fuse) the PowerShunt to get Bluetooth connection back. I tried a 4 inch and 2 feet distance between my phone and the SmartShunt, it all got stuck at 2%. I tried bluetooth unpairing and resetting my bluetooth pin code. Nothing seems to work.

Anyone any idea what it can be? (before I send it back).

Thanks

Ronald


[image]

[image]


P.S. I'm already using my VictronConnect app with my SmartSolar SCC. I have done multiple successful firmware updates with that app for that device.

ronald-v-i asked
Thiemo van Engelen (Victron Energy staff) commented ·

0 Answers

Updating Firmware of All Devices From a GX device

With internet connected to a GX device, updating the firmware of the GX device is so simple (press check and update), just wondering why all Victron devices showing in the device list can't have a simple "check and update" button for updating the firmware of all devices from this location?

If this is possible, it would make commissioning systems (especially larger systems) much more efficient. @mvader (Victron Energy)

wesley-corbet asked
wesley-corbet answered ·

2 Answers

Quattro Firmware Update

Hello,

I’m trying to update the firmware of my Quattro 5000/12/110 system. Finding the correct firmware file is not clear. All online references point to a seven digit number. If I open my system, I see the following numbers:

2017051028hu

HQ1830W26RS

QUA12502110

HQ1830W26RS



Can someone please give me the correct firmware version? I’d like to know what each of the above numbers represent as well, if possible


I am performing the upgrade using ve.flash because my current firmware will not work via VictronConnect.

When I connect to my Quattro with VictronConnect, it says I’m running Firmware 413 and need to upgrade to 415 for it to function.

Thanks








beckwhoa asked
Matthias Lange - DE answered ·

1 Answer

Victronconnect stalls update at random percentage

After multiple attempts to install the 1.56 update. VC gives D26 Connection lost error. The 150/85 shows no version and doesn't work at all just flashes the tx/rx light sequence constantly. Install starts pauses at 3% at 4% the victron unit stop flashing and holds a solid green led. The the tx/rx sequence flashing starts again and the transfer data percentage rises. It has got as high as 75% though usually fails near 22%.


I ordered a ve direct cable but it didn't come with a USB end, just two "jst ph 2" ends. I'm frustrated. Any ideas on how to get it to update and start working again?

bigstig asked
Matthias Lange - DE answered ·

1 Answer

MK-3 USB / VEFlash Error at step 'Connect part 2'

Hello,

I have multiplus 40/3000 and my old FW is:

2620158 i believe i need 2620159 with im trying to update.

But having error.

I dont have problem to VeConfig, Victron Connect does not work becouse my FW is to old.

Swapped device, changed ports and all... still no luck.


Tried to google solution but cant find any,


I want to update FW and go with Generator configuration as every 60 sec there is a swap between charger to inverter.


[image]

I've tried another ethernet port and no luck still.

I'm under off grid so I only has batteries connected.

Closed

magicmike asked
magicmike answered ·

2 Answers

Firmware Update Notifications??

Is there a way to get notified about firmware updates for specific Victron products?

thechad asked
JohnC answered ·

2 Answers

Smart Lithium problem after firmware update

I don't know if anyone else has had this problem, i updated the firmware on my smart lithium batteries (mandatory updates V1.24) through the Victron Connect App, all of which were working perfectly before, now some of them even though the firmware stated completed, now come up with a E-SL24 hardware failure alarm and a E-SL2 internal communications failure, the recommendation is to reinstall the firmware to reset the controllers but you cannot do this as the App states "your product is already running the latest firmware version"...

The batteries are:-

24V 200AH smart LiFeP04

12V 90AH smart LiFeP04

Any ideas as i do not want have to replace these perfectly good batteries.

Regards


Steve

hampster21 asked
gregs answered ·

6 Answers

Why does the red LED on my smart dongle flash briefly...

...when I connect or reconnect through Bluetooth. And why has the blue LED stopped working at all? (I have the latest firmware.)

Otherwise, the app is getting data from the controller.

But I would like the blue LED to work.

3rdrichard asked
Matthias Lange - DE answered ·

1 Answer

Cerbo GX Firmware Issues

Hi All,

I have recently remotely updated a customers Cerbo GX Firmware from 2.65 to 2.72, via the internet. The site has a very slow internet connection but once completed the Cerbo rebooted on the the new firmware but we had an instant battery alarm. Through the Cerbo the BYD LVL battery was displaying a "internal failure alarm" and "cell imbalance alarm". I got the customer to reboot the Cerbo and also power cycling the battery system but the alarm would not resolve. I then rebooted the system on the old firmware which then locked me out of remote access but did fix the alarms. The customer can access the Remote Console via bluetooth but not via wifi. The Wifi is on and connected to the local Wifi account, but there is no data uploading to the VRM portal. I have looked compared the VRM ID's and the VRM ID in the remote console is an strange number and different to the VRM online settings.

Has anyone experienced this issues and have any potential solutions??

Thanks In Advance.

Andrew

andrew-mackenzie-bauer asked

0 Answers

VRM suggestion: track of FW updates

It would be not just nice, but actually very useful for professionals if VRM could track (keep log of) FW updates of devices in the installation.

VRM monitoring is good, but it is missing this information, where one could see e.g. "oh - the Quattros got updated from FW 465 -> FW486 on August, 22nd - that could explain behavior Y from August 23rd on..."

Graphically it could show simply as a small bar in VE.Bus Warnings and Alarms, so one could easily zoom into a time frame before / after the FW update.


petajoule asked
Paul B answered ·

1 Answer

Lithium firmware update to v1.25 voltage not sending to bmv

We have 2 X 160ah victron lifePO4 batteries, we recently updated their firmware and now they are showing their voltage as 13.18 but the bmv and the ccgx display are showing as 14.2 and the multiplus is "stuck" on absorption charge.


Has anyone had this issue with the recent battery update?

Lyndon Lewis asked
Paul B answered ·

1 Answer

VictronConnect Mac Catalina not working

Hi,

I failed to update a SmartSolar MPPT 100/30 from 1.56 to 1.59 on a MacBook with Mac OS Catalina, so I took an old MacBook with Mac OS Mojave and tried it on that. And it worked flawlessly. Somehow the code is broken for Mac OS Catalina 10.15.7.

Has anyone else experienced the same issue? I don't want to take 2 MacBooks in the field.

Best regards,

simon

simebone asked
jperez (Victron Energy Staff) answered ·

1 Answer

stuck in float state with 0 A - Why?

MPPT 75/15 with current FW

Smart Dongle w/current FW

issue resolves if I disconnect, then re-connect power at the MPPT

Overnight and into the next day, solar shows 0W (zero watts)

(appears to NEVER start charging the next morning)

In sun, Solar shows 18.35V and 0.0A

Battery shows 12.43V and 0.0A

I do not use the Load output or Streetlight

I have reset MPPT to Factory Defaults = no change

Cycling the Power to the MPPT fixes the issue...until the next day = 0W and not charging (again)

Seems "stuck" in Float state

[image]

[image]



J B asked
klim8skeptic commented ·

4 Answers

Disconnect BMVs SoC depended relay function and discharge floor

Guys, there have been several request now cause there are numerous applications, where a user wants to switch devices based on the SoC, WITHOUT changing the discharge floor.


In my application, I want to use the BMV-700 relay to switch a large power relay to reverse IN/OUT of my Orion, to charge the starter battery as soon as the AUX battery SoC is above 95%. But in regards to the time-to-go, I want to leave the discharge floor at 25% (75% DoD).


I urge you to take these request into account when determining the scope of the next firmware update. Please !!

cstenger asked
cstenger edited ·

0 Answers

Multiplus Compact 12/2000/80-30 230V: came with firmware 2608430, should I upgrade? And to which version?

As per the subject.


I have already registered on https://professional.victronenergy.com, reviewed the Changelog[1] and read the associated documents[2][3], and I understand that I need a 26084xx file; on https://professional.victronenergy.com/downloads/firmware, I can see that:


a) There is *no* 2608430 file, so I understand that, after I upgrade, there is no going back to the version that came with the equipment (unless I can download or back it up from the equipment itself?)


b) The only versions I can see are 2608433, 2608459 (these, located in separate subdirectories) and (in the main directory) 2608485; the latest version (486, as mentioned on the Changelog) is not available for my equipment (ie, there is no 2608486.vff file available), despite being available for very similar ones (eg 2609, which according to [3] would be a MultiPlus 12/3000/120-16). Any reason for it not being available for my equipment?


c) Between 2608433, 2608459 and 2608485, which one should I install?


Thanks in advance!


[1] https://professional.victronenergy.com/downloads/firmware/file-download/?name=VE.Bus%20%28Multis%2C%20Inverters%20and%20Quattros%29/Changelog%20firmware.docx

[2] www.victronenergy.com/upload/documents/manual-VE.Bus-firmware-versions-explained-EN.pdf

[3] https://professional.victronenergy.com/downloads/firmware/file-download/?name=VE.Bus%20%28Multis%2C%20Inverters%20and%20Quattros%29/VEBus%20firmware%20numbers.txt


-- Durval.

durval asked
durval answered ·

2 Answers

Is the VE Bus V1.11 safe to install?

Is this firmware safe to install?

s-signor asked
s-signor commented ·

1 Answer

BlueSolar MPPT 75/50 broken after software update

I connected to VictronConnect, it detected a new firmware and I had to upgrade to continue using VictronConnect.

After the update I got error on Victron software "#116 Lost Calibration Data" its not working anymore. Bulk and Absorption light flashing blue together.

According to Victron toolkit, it means a internal fault and I need replacement.

Its gone past its warranty, so cant send back to dealer, is there any way to roll back.

Any ideas?


told36 asked
tommy-1 commented ·

2 Answers

Multiplus Firmware Update 2609154

Hi All, new to this. I need to upgrade my existing firmware 2609154. What is the most stable version and can I upgrade straight to this or do I need to upgrade in steps?

Thanks in advance

Cheers

philkern asked
philkern commented ·

1 Answer

Cerbo GX Remote Console connection issues after FW update to 2.62 (also in 2.63 and 2.65)

Yesterday I updated my Cerbo GX from firmware 2.60 to the newly released 2.62.


Cerbo GX is connected to my Internet router using WiFi.


Several times already (first time it happened yesterday, while looking into the Cerbo GX settings after the FW update) Cerbo GX was not accessible using Remote Console via LAN for several minutes.

After a few minutes I can access it again (without doing anything to fix the issue).


When this happens, on VRM there are no updates for a few minutes (VRM portal log interval is set at 1 minute).


Not sure if this is a WiFi issue (haven't got a chance to try it with a LAN cable since updating the FW) or if Cerbo GX freezes for a few minutes and that is why I can't access it with Remote Console over LAN.


The WiFi and Bluetooth LEDs are blinking normally even when this happens (or I did not catch them in time).


Yesterday, after the first time it did this, I did a Cerbo GX reboot (from Remote Console menus), but again it had the issue today: once when I tried Remote Console from a phone and second time when I tried from a PC (both devices were in the same LAN with Cerbo GX).


I never observed this problem with 2.60 firmware.


Anyone else has this issue after updating the firmware to 2.62?


seb71 asked
Lourens answered ·

14 Answers

MultiPlus firmware update

When connecting my Mac with a MK3 cable, I can see there's a firmware update available for the MultiPlus. From what I've read, I shouldn't update unless there's a problem I'm trying to solve. All is working well but could there be some features I could be missing? When using my iPhone's app and checking the MultiPlus, I see a screen that doesn't allow me to change anything but I've seen others with a different screen.

[image]

andrecampeau asked
Alexandra answered ·

1 Answer

VRM Portal Firmware Update Error

Hi

I am attempting to use the Firmware Update process on my system from the VRM portal and get an error using this as per below.

On clicking the "Firmware Update" button the status shows as "Connecting..." and then "Connection established, retrieving list of devices...". After a minute I get an Error message box saying:

"
The site's two-way communication service did not respond. Have you enabled it on your GX device?
Note that due to an issue on June 30th 2019, a reboot of the GX Device might be required. More information
Error: 1392
"

The status is then shown as "An error occured during the querying devices process. Please try again later!"

I have tried rebooting the CCGX and also turning off and the on again the "VRM two-way communication". All to no avail the error still occurs.

On VRM device list the CCGX shows "Two way communication" as being enabled.

Equipment details as below:

CCGX
Firmware Version: v2.66

Multiplus Compact 12/1600/70-16 with VE.Bus BMS
Firmware Version: 469

BMV-712 Smart
Firmware Version: v405

SmartSolar Charger MPPT 150/60
Firmware Version: v1.56

SmartSolar Charger MPPT 100/20
Firmware Version: v1.56

Are there any other settings etc. that I can check to get the function working?

Thanks
Gary

gary-1 asked

0 Answers

New firmware

Can anybody please tell me what is new in the firmware v481=>482? for the multiplus II

Thanks

skykay asked
Matthias Lange - DE commented ·

1 Answer

What is the mean of BF in: Improved BF failure detection mechanism

Hello victron members, a new firmware has been released, do you know what is the meaning of BF in : Improved BF failure detection mechanism.

Thanks in advance.

[image]

palom170 asked
Guy Stewart (Victron Community Manager) answered ·

1 Answer

Multiplus-2 does not appear on victron connect

Hi all,

I am trying to update the firmware of my easy solar-2 GX 48|3000|35

I am using CAT5e (connected to one of the VE.bus ports) and Mk3 to USB to connect on my windows computer. When I open my victron connect app on windows laptop, on the device list page, in LOCAL section all I can see is EasySolar-2 and not multiplus 2.

What do I need to do for it to appear on victron connect?

I also looked online and found old method of firmware update using veflash. I can not find where I can download veflash anymore?

Please help

mo-awais asked
Paul B answered ·

1 Answer

How to update Multiplus firmware?

My Multi 12/1600/70 runs firmware 154. Product id # 2606

suavek asked
spicedreams commented ·

3 Answers

Phoenix Inverter VE.Direct 24/1200 alternately flashing red and green - needs a firmware file

I have a Phoenix VE.direct 24/1200 inverter with alternately flashing red and green leds, which apparently means a calibration or firmware error.

To try to fix it, it was recommended to re-flash the firmware, but VictronConnect says it is up-to-date with V1.22, and doesn’t allow re-flashing except with a manually downloaded file.

Does anyone know where to find the correct firmware file?

On Victron-Professional there is a whole list of V1.21 files - none of them are accepted by VictronConnect (they all give error D90, "firmware is not for this product").

With an older version of VictronConnect the Phoenix 24/1200 inverter identifies itself as unsupported but it gives the product ID as A2F2 so if I correctly understand the naming conventions, it would need a firmware file called “phoenix_inverter_A2F2_v01.21.dup” which is not listed under “Phoenix Inverter VE.Direct”.

This inverter was just bought and has had this problem since the very beginning, unfortunately it came from a dealer in Slovakia whereas I am in France, so I am hoping to be able to fix it without having to pay the rather expensive postage for returning it, since apparently Victron does not handle any warranty issues directly, i.e., only be going through the dealer who sold the device …

Many thanks for any insights!

Robert asked
Robert commented ·

1 Answer

24v Phoenix 1200w - Alternating flashing LEDs - no AC output

Hello,

I've had my 24v Phoenix 1200w (120v) inverter running solidly for a little less than a year now. Firmware is 1.21.

Switched it on this afternoon and there was no AC output. The red and the green LEDs flash in an alternating fashion every half a second or so. Toolkit shows this as "Calibration or Parameter Error".

I've tried checking and resaving all the parameters (all were fine) and then refreshing the firmware with A27A_01.21 but no luck.

Does anyone have insight into why this suddenly happened or what can be done to rectify this ?

Many thanks in advance,

Alex

akrolick asked
Paul B answered ·

1 Answer

75/50 problem after firmware update.

Hi.A while ago I updated my 75/50. I have had to reset the daily data to find my production figures for the next day.The KWHr meter is unaffected, but I have no graphs now..only one bar of today's info(that could hold months logged as today's figures).

Can you help ?



stevla asked
klim8skeptic commented ·

2 Answers

Smartsolar 150/100 Firmware 1.56.

Hi everyone !

Did you already have updated your Smartsolar MPPT (150/100) to the new firmware version 1.56 ? Does it has fixed the issue related to the Fw 1.54 ? Any information is welcome.

Thanks, Michel

michelg asked
michelg answered ·

2 Answers

Followers

138 Posts
134 Users
5 Followers

Topic Experts

Sabrina
0 Points