Venus OS Image

Venus OS

PWS (Personal weather station) integration.

now that wunderground supports API, it should be a simple integration.

In fact the output of the pantech is pure JSON so that way could be easier.

It would be nice to directly integrate into the venus os, however I could settle for VRM.

alan asked
mafu answered ·

1 Answer

Venus OS 2.73 on RPi 3b+ - How to add virtual devices

I've been working on a Nodered integration that includes some Victron Equipment and would like to use the Venus OS on a Raspberry Pi 3b+ to simulate my final configuration for development and testing. Just a side note the Nodered server will be running on another RPi so the "Venus Large" build is not needed.

I've got a lot working, but still a lot that is not.

What works:

  • RPi 3b+ with Venus OS 2.73
  • Boot via Ethernet cable to connect
  • Access to RPi using Victron Connect
  • Access RPi using Remote Console either from local network or VRM
  • Use remote console to set WiFi parameters and no longer need ethernet cable
  • Enable VRM and see demo configs on the portal

What doesn't work that I need some help with:

  • Access from local network with SSH. I've enabled Remote Console but still get either connection refused or no response when SSH'ng from my Mac
  • Being able to enable VNC to access Linux console
  • MOST IMPORTANT: Add additional devices (Inverters, MPPT Chargers, etc etc) to mimic my actual setup

If anyone can point my in the direction of how to enable ssh and/or vnc access, as well as add additional "virtual" devices I'd appreciate it. That way I can work on the other side, configuring my MQTT client to monitor the setup.

Thanks in advance,

ksaltman asked

0 Answers

Multiplus does not allow changes via Venus OS

I am playing around at the minute to test certain things.

Now it does not allow me to control my Multiplus 12/1600 with my Rpi Venus OS with the message:

[image]

I tried the dip switches ON/OFF, OFF/OFF and OFF/ON and i deleted the 2Signal BMS assistant...

The goal was, that the Tempsensor is configured as a OVP/UVP input from my BMS. And the operation mode should be set by the Touchscreen.

czarofak asked
czarofak answered ·

5 Answers

AC Input Not Saving

Hi,

Firstly thanks for all the information and support on here. It has really helped me deploy my system. It is all working except for a few little niggles.

The system is based in my campervan and whilst I have mains hookup I pretty much only ever run solar power or DC-DC charging. On the dashboard, it shows AC Inputs - I have tried to set this in the settings to 'not available' but it doesn't save after I click the tick and leave the menu.

My system is as follows:

RPI connected via VE Direct cable to Victron Smart Shunt and Victron Inverter.


Thank you.


On a side note - it does show AC loads but despite things being pugged into my inverter they don't appear on AC loads.


adamr100 asked

0 Answers

Error Message: 'MK2/MK3 with VEConfig sometimes

I often get the error message Error Message: 'MK2/MK3 when downloading Veconfig file over the internet. Mulitplus is v433 and venus GX 2.66. Internet connection is reliable and fast . Happens about 40% of the time . If I re do the request is works .

merlepeter asked

0 Answers

Multiplus with PV AC inverter on input and output

How does one setup up an ESS system with PV inverters on both input and output? Currently it seems you have to choose either input or output but not both.

merlepeter asked
merlepeter answered ·

2 Answers

Connect two banks with different voltages 12V and 48V to the Victron Venus and have them both on the VRM monitoring screen.

Hi,

I have a boat with two battery banks, 48V for propulsion with a Victron BMS-712 and a 12V for services with a SmartShunt. I also have smart solar and an inverter that goes to the 48V bank. I want to know if its possible to have everything in the same dashboard. As I read in this forum, the system only expect one battery, is there any other more complicated option to have both batteries in the dashboard? Ex. raspi, grafana, etc.

joanbr asked

0 Answers

Victron Phoenix inverter 24/1200 with Ve.Direct to Generic Venus Device how to change lower Voltage cut off.

Dear All ,

As far as I understand there is a way to change the inverter lower cut-off values for battery voltage.

when I installed the Inverter I didn't change any of the default settings ( I think, I couldn't get the software to work on my pc ), and now I have an issue with the Inverter not working under 24V when the battery bank gets drained under 24V

The main question is, IF I can change the setting for the lower cut off value from my raspberry pi running the official Generic Venus Device image and uploading data to the vrm of Victron.

and this preferably to be done remotely since I can't physically get to it.


Thank you in advance


The harvester.

helios-harvester asked
helios-harvester commented ·

2 Answers

Can monitoring the system out home

Hello, I have small solar system and I will install on my raspberry pi 4 Venus OS. But my question is when I am not at home can I view how many watts charge, consummation and etc? Thanks for advanced.

My system is 2x445w solar panels, invertor Victron Phoenix 24/800, smart charger controller Victron 100/30 l, smart shunt 500 and two batteries.

hrischo asked
hrischo commented ·

1 Answer

VE.Bus BMS and Multiplus, remote switch off off Multiplus

Good afternoon,

Is there any configuration or assistant that can be applied that will allow for a remote switch off of the MultiPlus when used with the VE.Bus BMS and Cerbo GX. I know that in this configuration a DMC will allow this to happen, but I really do not want yet another panel to install (cost and space). I had hopped that a switch between the Left and Middle pins of the remote switch on the main board would work, but no luck. I am sure at some stage the ability to turn the inverter on and off through the Cerbo will be available, just as it is when no VE.Bus BMS is used.

My reason for asking is that when I leave the boat the MultiPlus, even with AES applied has been the biggest parasitic load causing a drain of 158Ah in just a week. Having turned the Multiplus off at the switch on the front the parasitic load has dropped to just under 0.2A. With the Multiplus on and in ~AES Search mode the system was drawing between .4A and .8A, occasionally going as high as 1.2A.

OK, I know I can turn the inverter off on the front panel, but that is a pain due to it's location.

bathnm asked
bathnm answered ·

6 Answers

#1 device switched off -sometimes permanent

Hello all,

as you may know iam new to Victron (1 week now).

And unfortunately, I'm already getting a headache.

Besides all the minor problems (battery is discharged above the overcurrent limit, or not at all although I draw from the grid), I have since the beginning the problem that power outages happen from time to time. (Grid stays ok)

One time i had to manually turn down every Voltage (Bat + Grid) to restart the Multiplus.


I have 3 Multiplus 5k/48V


No alarm is recorded in the VRM.

Today I got the alarm "#1 device switched off" in Cerbo.



Since I have had several outages (about 2 per day), I set up a camera to film the Victrons.


What can I do here? No one was home, so consumption was very constant. There was no washing machine or dishwasher running or anything like that.


The battery was full and not in use.


[image]


FW Cerbo (Venus OS) : 2.72

Multi 2 : 482


The Inverter with the LED Code swaps always. Sometimes L1 (Master), sometimes L2 or L3.

Sorry for the Cablemess- i changed everyCable to nail down the Problem.

marv21 asked
shaneyake commented ·

4 Answers

VenusGX mqtt unstable after 2.72 firmware upgrade.

After upgrading the firmware of my Venus GX to version 2.72 I am having issues with it not continuously publishing to the mqtt broker.
When I connect a client to the broker in the GX I receive the subscribed messages for about a minute after which an empty message is received and no more messages are received until about 1 minute or 2 later. This just keeps on repeating.
I suspect there is a timeout issue or it somehow does not get the keep-alive messages.

I was unable to find a change-log for 2.70 to 2.72.
I would also rather not roll back but I also cant seem to find a way to even roll back the firmware.

EDIT:
After creating a profesional account I am able to access the changelog. Though that did not really explain why mqtt is misbehaving in 2.72.
It did however point out how to roll back so I rolled back to 2.66 which resolved the mqtt issues.

However that may cause me to be unable to configure my EM24 ethernet as that was not yet added in 2.66.

rwarps asked
mvader (Victron Energy) answered ·

2 Answers

Venus OS integration 'direction' - help required

I've been lurking here for a while and find the idea of running Venus OS (large) on a Pi an attractive option. However, my reading of the history (and documentation) of this impressive project has left me a little bewildered since there are so many options, some of which may now be obsolete.


I have N2K on my boat and have decided to replace some of my ageing electrical installation (from another dutch company :/ ) with the following: Multiplus II (12/3000), 2 x smartsolar MPPT, Smartshunt. My existing LiFePO4 is already protected by my own design BMS which speaks N2k.


It seems that I need to buy a bunch of Ve.direct to USB adapters and a Ve.Bus adapter. For the N2K, its unclear, I assume an available Pi hat - is data flow bi-directional? Will Venus OS pick up my BMS N2K messages and use them or will it prefer the Smartshunt values? Will the smartshunt values make it to the N2K bus so I can use them in my BMS (for comparison and backup)?


Sorry for the variety of questions :) Looking forward to a positive discussion.


P.S. I'm switching my purchasing decision towards Victron due to the open sourcing of Venus. I'm very grateful and find it very freeing to know that I can integrate whatever I want into my system now rather than being stuck with the straighjacket of closed systems offered by competitors

jram asked
shaneyake commented ·

0 Answers

mppt and b2b chargers what is the difference

Forgive my naive question.

What is actual difference between mppt and b2b chargers, both getting current from the source and processing according to the charging profile?

markmoto asked
markmoto answered ·

1 Answer

Can the Venus OS -running on beaglebone/rasp- work in ESS config on Multiplus 2 without GX capability

I want to build a system with

- Multiplus 2 5000VA

- Batteries

- MPTT for solar panels


The multiplus would be connected to the grid as a power backup or for extra power.

The multiplus must not feed in energy to the grid.


I first considered the Multiplus 2 5000 VA with GX option to manage ESS (well explained on website).

But recently I've been told that Venus OS running on Beaglebone (for instance) could replace the GX option, and would let me opportunities to save money and go deeper in the installation configuration.


Idea is in further step to connect management to my HomeAssistant raspberry.


Could you confirm I can make an ESS configuration with Venus OS on a beaglebone and a multiplus 2 without the GX option ?

For my knowledge, I understand the GX option, or Venus device/CCGX device just run this software on dedicated HW ?


Many thanks in advance for your help and patience :)

nico82 asked
nico82 commented ·

1 Answer

Alarm Relay Function - Set Alarm Relay On via dbus

I am trying to programmatically set the state of Relay 1 on & off on a VenusOS on an RPi via sending the following command but the change is not applied. Relay 1 function is configured as an Alarm Relay.


dbus -y com.victronenergy.settings /Settings/Relay/0/InitialState SetValue %1

While dbus command returns a successful result the "Alarm relay on" toggle switch in the UI under settings->relay does not reflect the issued command.

I can programmatically change the Function & Relay Polarity and the change is reflected in the UI immediately.

I looked at the var/log/localsettings/current file and confirmed that the UI and CLI command is affecting the same setting.


@400000006106581304f7c444 INFO:root:Setting /Settings/Relay/0/InitialState changed. Old: 1, New: 0 //UI "Alarm relay on" Setting Change
@4000000061065c1c04621bc4 INFO:root:Setting /Settings/Relay/0/InitialState changed. Old: 0, New: 1 //CLU dbus Setting Change

Has anyone else had the same issue before?

norman asked

0 Answers

Systeme coupure de decharge batterie suivant un créneau horaire (FR/ESS/EDF-HP-HC)

Bonjour,

voila mon architecture et la suivante

- j ai un Multiplus 5Kva raccorder à une batterie plomb carbone en 48V de 440ah

- un régulateur MPPT 150/85 avec 2640w de pv


le but serai de désactiver la décharge de la batterie sur le créneau horaire des heures creuse en France de 23h à 7h.

actuellement pour se faire je suis obliger de le faire de façon manuel en allant tous les jours dans le menu ESS de mon venus Gx et modifier le SOC minium (sauf défaillance réseau) pour qu'il arrête de décharger la batterie et repasser sur le réseaux.


merci


Hello,

here is my architecture and the next

- I have a Multiplus 5Kva to connect to a lead carbon battery in 48V of 440ah

- an MPPT 150/85 regulator with 2640w of pv


the aim will be to deactivate the battery discharge during the off-peak time slot in France from 11 p.m. to 7 a.m.

currently to do so I have to do it manually by going to the ESS menu of my venus Gx every day and modifying the SOC minium (except network failure) so that it stops discharging the battery and going back to the networks


thank you








baptiste bodier asked
Thierry Cortassa (Victron Energy Staff) answered ·

6 Answers

Should I still use Bluetooth MPPT synchronisation when also connected with Venus OS (RPi)

I have 2x SmartSolar MPTT 100 | 30, and a BMV 712.

I first used Smart Networking over Bluetooth to synchronise with the more accurate voltage from the BMV712, and have both chargers running in sync.

I have since added a RPi running Venus OS and also have VE-Direct connections to the 3 devices.

All is working well in Venus, but not sure if that now runs the show in terms of the synchronising via VE.Direct and the Bluetooth function is now redundant?
If redundant, should I leave the smart networking configured should be RPi go belly up?


rljonesau asked
porcini answered ·

2 Answers

Possible feature: Select time to discharge battery

Hi all!

I have a ESS grid paralell system (Victron Multiplus II 48/3000/35-32, Solaredge SE300H, Cerbo GX and Pylontech US2000C). Until now everything is working fine, it is charging the battery with the exceed of the PV inverter and then use the power of the battery during the non-solar moments). I see the option of "schedule a charge on battery" where you can select a time where you can charge the battery (per day, only once, etc), but I would like to know if it could be possible to select the other way around, select in which moment you want to use the energy from the battery -I read all the documentation several times and I don't see it, not sure if this is implemented now-

Why? In Spain, where I am living, at this moment we have two different electricity tariffs during the day (peak and valley), so in my case, I would like to use the battery especially during the "peak" tariff only and keep the charge if there is "valley" tariff (it is two times more expensive during peak than on valley).


Thanks in advance!

pabloguti asked
marv21 commented ·

0 Answers

WIFI rtl8188 not working with 2.72

Hello,

I installed the newest 2.72. I had my system up and running with the 2.6 version. My dongle worked perfectly. With the new version the follwing message comes up in dmesg:

usb 1-1.2: new high-speed USB device number 7 using dwc_otg

[ 175.823447] usb 1-1.2: New USB device found, idVendor=2357, idProduct=010c, bcdDevice= 0.00

[ 175.831852] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3

[ 175.839275] usb 1-1.2: Product: 802.11n NIC

[ 175.843580] usb 1-1.2: Manufacturer: Realtek

[ 175.847887] usb 1-1.2: SerialNumber: 00E04C0001

[ 175.854117] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)

[ 175.913522] r8188eu 1-1.2:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2

[ 175.922760] r8188eu 1-1.2:1.0: Firmware rtlwifi/rtl8188eufw.bin not available

[ 175.929907] MAC Address = 28:ee:52:17:50:88

[ 175.962361] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

[ 176.163659] usb 1-1.2: USB disconnect, device number 7

[ 176.169797] R8188EU: indicate disassoc


Seems like the driver is not compiled anymore. Would be great if this dongle could work again. Any hints?


Best

don-davici asked

0 Answers

Can I have a 2nd VenusOS device in my setup show information from the 1st?

In my RV I am installing VenusOS on a Raspberry Pi 4 and that will go with my equipment. I have another RPI4 that will have a touch screen that I am thinking will also have VenusOS on it to view control the main devices as well as take input from my tanks. Is it possible to see the devices from the 1st RPI on the 2nd RPI GUI? If there are better options on the 2nd device that don't include installing VenusOS and not monitoring the tanks, I am open to that too.

I will have the following devices installed:

- SmartSolar MPPT 150/100

- MultiPlus 12/3000/120-50 120V

- Lynx Distributor

- 2 DIY 12V 310Ah LifePO4 Batteries with JBD BMS.


nillerk asked
kvan answered ·

3 Answers

Venus OS v2.72 alarm text

Image CaptionDid upgrade to V2.72 yesterday. “No alarms” text left aligned in display box in pages.


[image]

steve-may asked
steve-may edited ·

0 Answers

Phoenix Inverter 12/375 - Venus OS - show AC Loads

Hello, I am new in the forum and german. so excuse my english. I have a Phoenix Inverter 12/375 with the lastest firmware 1.21 connected via ve.direct to a venus os 2.65-3 on a raspberry connect to the vrm portal. Both, the portal an the venus shows the loads as a factor of 23 Watt like 23, 46, 69 and so on. Why the loads are not the right value? is that a problem by the firmware or general? Will that be fix in the future?


Thank for an answer and I wish a happy weekend.


Greats from Berlin, Germany Norman

Norman Kühn asked
Norman Kühn answered ·

4 Answers

Multiple GX units Temp inputs

Does anyone know if the Temp inputs from a second unit (venus, cerbo etc...) will show on the CCGX and vrm? Like the multiple tank inputs do.


https://www.victronenergy.com/live/venus-os:v2.60

A) For in chapter 1.4 - Multiple GX Devices for increasing number of tank inputs

(or to be put in a separate chapter)

Introduction

The number of tank inputs of a GX Device, such as the Cerbo GX and the Venus GX can be expanded by connecting multiple GX devices together in a VE.Can network.

Make sure to designate one GX device to be the “main” one; and the other(s) to be the “secondary” one(s). There is no practical limit on how many can be used - most likely the number of source addresses on a VE.Can network is the limit, which is 252 addresses. A Cerbo GX, with 4 tank inputs, will use up 5 addresses: one for itself, and one for each tank input.


alan asked
alan edited ·

2 Answers

CCGX - Venus OS 2.66 - Frequent Grid Meter Warning/Alarm

We have a handful of installations that started producing frequent "No Grid Meter alarm: Warning".

This is exclusively related to installations that have a CCGX (Color Control), a Victron inverter, a grid meter, and ESS configuration with Venus OS that has been updated to 2.66 on the GX device.

We have resolved one of our installations that presented this issue by temporarily upgrading the client to a Cerbo GX.

2.66 has yielded the incredible feature in the form of the inverter remote update functionality, but it appears that the new firmware is not stable on the CCGX and is resulting in significant system instability.

Has anyone experienced the same?

I'm hoping Victron is working on an update to remedy this...

Nicholas Herbst asked
Nicholas Herbst commented ·

5 Answers

VictronConnect to Cerbo via bluetooth

I have discovered a bug in Cerbo's bluetooth PIN mechanism for use with VictronConnect.

A PIN that contains leading zeros is not handled properly. For example, 012345 does NOT work but 123456 does.

Entering a PIN of 000000 DOES work.

Changing the PIN from with VictronConnect appears to have the same issue with leading zeros.

Venus v2.72~4, VictronConnect v5.42, iOS 14.6

Also tested on a Raspberry PI 4 running the same version of Venus. Same results.

I've tried using dbus-spy to change the PIN but this has it's own set of problems. Alpha-numerics are accepted. Leading zeros are lost. E.g., entering 000000 results in 0; 0123345 results in 12345.

dubs-spy also prevents adding a 6-digit code again from the Cerbo menu IF I enter less than 6 characters or numbers that contain zeros at the beginning. E.g, 000000 results in 0, then the menu only allows a single number !!!!!

Kevin Windrem asked
Kevin Windrem commented ·

1 Answer

What is required for configuring and monitoring an Easyplus?

I have a RPI with Venus software running and a MPPT and a Smartshunt connected by VE.Direct over USB. Can I configure and monitor the Easyplus with a Victron Interface MK3-USB, or is it better to migrate the RPI Venus to a CerboGX. And can I configure the Easyplus via the CerboGX or do I need both?

The MK3-USB is much cheaper than to migrate to the CerboGX but the advantage is that I can hook up my tankmeters direct.

johnwi asked
Alexandra answered ·

1 Answer

Venus OS driver for Fronius Smart Meter

Updated with latest results on 17-Apr-2020

Situation

At home, I have three roofs (east, south and west) with 9.9 kWp PV feeding into a Fronius Symo 8.2-3-M. The setup has Fronius Smart Meter 63A-3.
In a few days I am adding a Multiplus-II 48/5000/70-50 and 2x Pylontech US2000 (4.4 kWh net) LiFePO battery.

Problem

I am running Venus OS on a Raspberry 3B+. It nicely shows the power fed in by the Symo, with all details.

Venus is not showing any data from the Fronius Smart Meter.

Vision

I would like to have the data from the Fronius Smart Meter available on the Venus.

My idea is that I need a driver for Venus OS, which gets the data from the Smart Meter via the http API that Fronius provides and passes that information onto dbus - where hopefully Venus treats the data as if it came from a meter that it knows.

Steps Forward

I searched for a solution to my problem on the internet.I thought that I can not be the first to have this issue. But I found no direct solution.

There are several projects that might be a good start for getting to a solution:

  • dbusdummyservice.py from velib_python
    A simple service on the dbus.
  • dbus-cgwacs
    Reads energy measuremens from Carlo Gavazzi Wired AC Sensors (hence cgwacs), and puts it on the D-Bus.

Both projects look like a good start for programming my own solution.

Python script emulating the Victron Grid meter

Using dbusdummyservice.py from velib_python as a basis, I wrote this script:

#!/usr/bin/env python

"""
Used https://github.com/victronenergy/velib_python/blob/master/dbusdummyservice.py as basis for this service.
Reading information from the Fronius Smart Meter via http REST API and puts the info on dbus.
"""
import gobject
import platform
#import argparse
import logging
import sys
import os
import requests # for http GET

# our own packages
sys.path.insert(1, os.path.join(os.path.dirname(__file__), '../ext/velib_python'))
from vedbus import VeDbusService

class DbusDummyService:
  def __init__(self, servicename, deviceinstance, paths, productname='Fronius Smart Meter', connection='Fronius SM service'):
    self._dbusservice = VeDbusService(servicename)
    self._paths = paths

    logging.debug("%s /DeviceInstance = %d" % (servicename, deviceinstance))

    # Create the management objects, as specified in the ccgx dbus-api document
    self._dbusservice.add_path('/Mgmt/ProcessName', __file__)
    self._dbusservice.add_path('/Mgmt/ProcessVersion', 'Unkown version, and running on Python ' + platform.python_version())
    self._dbusservice.add_path('/Mgmt/Connection', connection)

    # Create the mandatory objects
    self._dbusservice.add_path('/DeviceInstance', deviceinstance)
    self._dbusservice.add_path('/ProductId', 16) # value used in ac_sensor_bridge.cpp of dbus-cgwacs
    self._dbusservice.add_path('/ProductName', productname)
    self._dbusservice.add_path('/FirmwareVersion', 0.1)
    self._dbusservice.add_path('/HardwareVersion', 0)
    self._dbusservice.add_path('/Connected', 1)

    for path, settings in self._paths.iteritems():
      self._dbusservice.add_path(
        path, settings['initial'], writeable=True, onchangecallback=self._handlechangedvalue)

    gobject.timeout_add(200, self._update) # pause 200ms before the next request

  def _update(self):
    URL = "http://10.194.65.143/solar_api/v1/GetMeterRealtimeData.cgi?Scope=Device&DeviceId=0&DataCollection=MeterRealtimeData"
    meter_r = requests.get(url = URL)
    meter_data = meter_r.json() 
    MeterConsumption = meter_data['Body']['Data']['PowerReal_P_Sum']
    self._dbusservice['/Ac/Power'] = MeterConsumption # positive: consumption, negative: feed into grid
    self._dbusservice['/Ac/L1/Voltage'] = meter_data['Body']['Data']['Voltage_AC_Phase_1']
    self._dbusservice['/Ac/L2/Voltage'] = meter_data['Body']['Data']['Voltage_AC_Phase_2']
    self._dbusservice['/Ac/L3/Voltage'] = meter_data['Body']['Data']['Voltage_AC_Phase_3']
    self._dbusservice['/Ac/L1/Current'] = meter_data['Body']['Data']['Current_AC_Phase_1']
    self._dbusservice['/Ac/L2/Current'] = meter_data['Body']['Data']['Current_AC_Phase_2']
    self._dbusservice['/Ac/L3/Current'] = meter_data['Body']['Data']['Current_AC_Phase_3']
    self._dbusservice['/Ac/L1/Power'] = meter_data['Body']['Data']['PowerReal_P_Phase_1']
    self._dbusservice['/Ac/L2/Power'] = meter_data['Body']['Data']['PowerReal_P_Phase_2']
    self._dbusservice['/Ac/L3/Power'] = meter_data['Body']['Data']['PowerReal_P_Phase_3']
    self._dbusservice['/Ac/Energy/Forward'] = meter_data['Body']['Data']['EnergyReal_WAC_Sum_Consumed']
    self._dbusservice['/Ac/Energy/Reverse'] = meter_data['Body']['Data']['EnergyReal_WAC_Sum_Produced']
    logging.info("House Consumption: %s" % (MeterConsumption))
    return True

  def _handlechangedvalue(self, path, value):
    logging.debug("someone else updated %s to %s" % (path, value))
    return True # accept the change

def main():
  logging.basicConfig(level=logging.INFO)

  from dbus.mainloop.glib import DBusGMainLoop
  # Have a mainloop, so we can send/receive asynchronous calls to and from dbus
  DBusGMainLoop(set_as_default=True)

  pvac_output = DbusDummyService(
    servicename='com.victronenergy.grid',
    deviceinstance=0,
    paths={
      '/Ac/Power': {'initial': 0},
      '/Ac/L1/Voltage': {'initial': 0},
      '/Ac/L2/Voltage': {'initial': 0},
      '/Ac/L3/Voltage': {'initial': 0},
      '/Ac/L1/Current': {'initial': 0},
      '/Ac/L2/Current': {'initial': 0},
      '/Ac/L3/Current': {'initial': 0},
      '/Ac/L1/Power': {'initial': 0},
      '/Ac/L2/Power': {'initial': 0},
      '/Ac/L3/Power': {'initial': 0},
      '/Ac/Energy/Forward': {'initial': 0}, # energy bought from the grid
      '/Ac/Energy/Reverse': {'initial': 0}, # energy sold to the grid
    })

  logging.info('Connected to dbus, and switching over to gobject.MainLoop() (= event based)')
  mainloop = gobject.MainLoop()
  mainloop.run()

if __name__ == "__main__":
  main()

The script registers itself on dbus as "com.victronenergy.grid" and publishes values as defined on Venus wiki - dbus - Grid meter .

Before I run the script, I have the following situation on the remote console, feeding 3.9 kW to the grid:

[image]

When I run the script, I see the following situation on the remote console, as if the AC Loads would consume 3.9 kW:

[image]

So, clearly, my script does something. But not what I wanted.

As the next step, I added three paths to the script: "/Ac/L1/Power", "/Ac/L2/Power" and "/Ac/L3/Power" and then it worked. So, the "/Ac/Power" was not enough for Venus to accept the data as valid- it needed power for all three phases separately.

Now the remote console shows:

[image]

Final thoughts

So, it is possible to use a Fronius Smart Meter and make Venus see it correctly.

I think this could be useful for other users as well, therefore it now can be found together with some documentation on GitHub: venus.dbus-fronius-smartmeter

ralfz asked
unifiedcommsguy answered ·

3 Answers

Could VictronConnect show a display like Venus OS

Since the bluetooth functionality of Victron devices also includes the ability to setup the bluetooth network to share information in the VictronConnect app - couldn't the app show a combined display similar to the Venus OS?

It would be nice to show the inverter/solar charger/BMV all at once in the app instead of having to switch between devices to get the information.

I suppose the bluetooth network may be limited in how quickly it can refresh the data (maybe 30-60 sec) but it would still be preferable to have an averaged display for general power flow. Seems like all the data is there - it just needs to be shared over the bluetooth network.

Hopefully this is something that can be explored! Thanks for making great products!!

edit4ever asked
edit4ever commented ·

0 Answers

REC Active BMS for Victron GX - How many contactors ?

This new version of "REC-ABMS for Victron CCGX" communicates with a GX Device using CAN. It sends Max Charge Current & Voltage and Max Discharge Current along with Battery Voltage, Temp & SOC. The GX Device uses DVCC & SVS to control all Inverter / Charger & MPPT Solar controllers to comply with the charging / discharging limits. Ok, so that sounds good, huh? But I also want to have contactors set to voltage levels in case the CAN bus goes down.

The previous version of the BMS suggested just the traditional two contactors - HVD & LVD to provide High Voltage Disconnect of the charge bus and Low Voltage Disconnect of the DC load bus.

But this version offers a Main Contactor for both HVD & LVD for Victron inverter / charger devices. And another Contactor expected to be used for HVD on non-Victron Charging sources. And though it is not shown in this diagram, I am sure they expected a third contactor for LVD to disconnect DC Loads.

[image]

Is this genius or overkill?

I questioned the new functionality, and the manufacturer offered to disable it to make it functionally equivalent to the old version. But I am an Engineer, so I tend to think "here is a Solution, now lets go find a Problem..."

Any thoughts appreciated.....

Andy

----

P.S. And....

I was expecting the fail-safe MultiPlus Inverter/Charger control to be made with a Charge Control signal to AUX1 and Discharge Control to T1 with the Assistant loaded "Two wire BMS (016A)"...

But they are suggesting Charge Control using the Assistant "Input Current Limit Control (0142)" and the AUX1 signal. And programming the Inverter's DC Input Low Shutdown voltage for Discharge Control.

Some REC users I have enjoyed reading before: @paulb @drmi @Boekel @Poppycock @Hakon Ingvaldsen @Eirik @Ceri.w

andyalford asked
brets answered ·

3 Answers

728 Posts
356 Users
18 Followers

Topic Experts

markus
439 Points
Mark
282 Points
Stefanie
281 Points