Node-RED Image


SmartSolar Relay Remote Control

In the Firmware Changelog for v3.11 under "Improvements" there's a line that says "Add support to relay remote control mode, which allows the user to manually select the relay state."

How does one use this relay remote control mode? Is it accessible via NodeRed?

Jeremy Albrecht asked

0 Answers

Hulp met node red.

Ik ben bezig met node red maar ik vrees dat ik er gewoonweg te weinig van snap.

Voor dat ik heel veel verkeerd doet is mijn vraag, is er iemand in de positie en de mogelijkheid om mij even te helpen met een aantal instellingen.

Ik wil een instelling maken dat mijn grid feed in veranderd door de soc van de batterij.

En ik wil dat er een relai schakeld op de cerbo bij een soc van >95%

En ik wil een relai schakeling maken op basis van temperatuur.

Ik hoor het graag :)

richard-veghel asked
groningen commented ·

3 Answers

Feature Request: Write access to Multi RS Solar ESS Settings

I would like to request the ability to control the following via NodeRed/Modbus for the Multi RS Solar:

1) ESS Mode (Optimized with batterylife, Optimized without battery life, Keep batteries charged)

2) ESS Minimum discharge SOC

Both would be useful but either would do.

Charging batteries during cheap times is possible but requires fudges to make it work. I can use Generator rules to turn on the input relays at night and also if I have a large load. The downside is I end up charging the batteries during the day if I have a large load.

I currently have to use a Windows PC to automate clicking buttons in the VictronConnect App to set the ESS Mode!

Don't know if there is a formal method for asking for features but please accept this as one :)

Please Help.......

semlohnhoj asked
semlohnhoj answered ·

1 Answer

Problem installing vedirect.usb nodered contrib

Hello. Pretty new to Node-red here so i don't know if it's my fault. 2 days ago i had vedirect node installed just adding it with palette manager and i was able to connect to the device. Now i can't even add the contrib to Node-red. It installs but then it says a module is missing.

0|node-red | 19 Mar 20:27:22 - [info] Installing module: node-red-contrib-victron-vedirect-usb, version: 0.1.0

0|node-red | 19 Mar 20:27:27 - [info] Installed module: node-red-contrib-victron-vedirect-usb

0|node-red | 19 Mar 20:27:27 - [info] Added node types:

0|node-red | 19 Mar 20:27:27 - [info] - node-red-contrib-victron-vedirect-usb:victron-vedirect-usb : Error: Cannot find module '@serialport/bindings'

0|node-red | Require stack:

0|node-red | - /home/deunan/.node-red/node_modules/node-red-contrib-victron-vedirect-usb/src/nodes/vedirect-usb.js

0|node-red | - /usr/lib/node_modules/node-red/node_modules/@node-red/registry/lib/loader.js

0|node-red | - /usr/lib/node_modules/node-red/node_modules/@node-red/registry/lib/index.js

0|node-red | - /usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/index.js

0|node-red | - /usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/index.js

0|node-red | - /usr/lib/node_modules/node-red/lib/red.js

0|node-red | - /usr/lib/node_modules/node-red/red.js

I created a new clean VM and the error is still there.

deunan@victron-lab:~$ node -v


Welcome to Node-RED


19 Mar 20:38:21 - [info] Node-RED version: v3.0.2

19 Mar 20:38:21 - [info] Node.js version: v18.15.0

19 Mar 20:38:21 - [info] Linux 5.15.0-56-generic x64 LE

19 Mar 20:38:23 - [info] Loading palette nodes

19 Mar 20:38:27 - [warn] ------------------------------------------------------

19 Mar 20:38:27 - [warn] [node-red-contrib-victron-vedirect-usb/victron-vedirect-usb] Error: Cannot find module '@serialport/bindings'

Thanks in advance for any help.


deunan asked
deunan commented ·

1 Answer

How can I export data to a nas for evaluation


the idea: I was to create a program that regulates the grid setpoint by itself.

Eg;: if the battery is low and there isn't enough sun the grid setpoint need to be set a a certain value. this is working (inside the "change value of grid setpoint")

now I need to finetune this, so I would like to collect some data (Time, Solar Power, Battery level,...) before i let this system run on his own.

is there a way to get this data out of the Cerbo GX module and save it locally (a pc, my nas, maybe a raspberry pi,...)

I tried a few things already but i didn't find it, maybe someone knows how to realize this.

If interested I can share all the data that is in my program.

Maarten asked
hominidae answered ·

2 Answers

Node-red Deploy failing - flow.json is too large

Hi, I'm trying to deploy my file and I am getting...

Deploy failed:

413 Request Entity Too Large


if I delete a node then this goes away. I have quite a large file now

I have tried adding

apiMaxLength: '10mb', to /data/home/nodered/.node-red/settings-user.js which should be doubling the amount I can deploy. However it hasn't changed anything.

Does anyone know what I need to do to make it work please? My flows.json file is failing at 2 megabytes Thanks

andy156 asked
andy156 answered ·

1 Answer

Venus OS 2.93 and 3.0 no Access on Node Red "400 Bad Request"

Hello together,

I want to update my old Venus OS 2.82-Large-30 to the newest possible Venus OS version on my Raspberry 4. The Venus OS 2.82-Large-30 run fine and the Node Red works also fine on port 1880
But I want to have my system up to date soon.

For the installation, I use a new SD-Card, so i made a new clean Installation. After writing the Venus-large 2.93 image on the card, I start the setup on the GUI of Venus OS, I activate also the Node Red service over the menu point "Venus OS Large features" I got the message that the Access to Node Red is now possible under port 1881. A different port as on my old 2.8 installation!

When I try to get access over this port (1881) "" I get the message on my browser window: "400 Bad Request The plain HTTP request was sent to HTTPS port nginx/1.16.1"

I tried also the Venus OS version 3.0 with the same result!

Does anyone have any ideas to solve this problem?

rittschie asked
rittschie commented ·

1 Answer

Gridmeter L3 Current missing ?

I want to publish the data from a EM24 gridmeter to MQTT, but i could not select L3 current in the drop down menu.


Any ideas ?

b-tronic asked
xury answered ·

1 Answer

node-red firmware v3.00-15 dashboard problem

When I power on the RPI the dashboard function always asks a UI redeployment. A small modification (move a node for a few mm) and deploy restarts the dashboard. How can I avoid that?


bobke asked
Matthias Lange - DE commented ·

2 Answers

Recording of 29th nov NodeRed webinar?

I missed the webinar held on the 29th of November; I can not find the recording in Victron Professional or YT channel....does this come available? Thx!

Rene Mullie asked
fabian39343 commented ·

5 Answers

Control Multiplus GX relay?

How can I control the relays in my Multiplus GX via nodered?

der-neue asked
Matthias Lange - DE answered ·

1 Answer

Node-RED - unavailable from VRM


I'm using Node Red on Cerbo GX.

Now is Node Red unavailable from VRM Venus OS Large.
The system reported: "Too many sessions for site 166223".
Now it doesn't report anything anymore, it just loads the page.

I restarted the computer and the router, nothing helps.

Any advice?


martin-modr asked
martin-modr answered ·

4 Answers

Can I add more switches to controls on the dashboard.

I would like to add some more virtual relay/switches to the controls on the dashboard. The controls is a convenient connection to ‘Venus OS Lage/node red’.

claus asked

0 Answers

how feltch data PF and other parameter from ET112 to build node red dashboard

Dear team

I attempted to build my Node-red dashboard using the System parameters, however, I was unable to locate the ET112 parameter alongside other options like PF and MD.

Please give the solution for build own node-red dashboard

Dilip Kumar TD asked
Alistair Warburton commented ·

0 Answers

Enabling forced Export to grid with 3 phase Mutliplus 2. UK

I am considering installing a 3 x 48/5000/70-50 multiplus 2 in 3 phase configuration (UK) with a large battery to enable profitable export to grid at times of high income. My understanding that this is difficult without NodeRed, but possible with NodeRed. Am I correct in this assumption? Further, does the NodeRed flow work with a 3 phase setup? I currently use NodeRed, but cannot play with the Victron flows as you need a physical inverter connected to the VenusOS to progress. Thanks in anticipation.

brookydave asked
Jason - UK answered ·

1 Answer

273 Posts
200 Users

Topic Experts

Dirk-Jan Faber
455 Points
220 Points