Min and MaxCellVoltage not available in Node Red

Hi all, I have a Cerbo GX with the large image installed and running Node Red. It is connected to a lithium battery with a JBD BMS, which is interfaced using the driver here: https://github.com/Louisvdw/dbus-serialbattery/

Everything seems to be working fine, except I was really hoping to get access to the min/max cell voltages within Node Red. I can see this data on VRM, and using dbus-monitor while logged into the cerbo I can see that /System/MinCellVoltage and /System/MaxCellVoltage are being updated regularly. Looking through the node-red-contrib-victron repo it seems that this data should be available under the battery monitor node, but it is not showing up in the drop down. Nor is it in the System node.

Is this simply a case of the Large image containing an older version of the node red nodes, or is there something else going on here?


mahonrig asked
Dirk-Jan Faber answered ·

2 Answers

Raspbian oder VenusOS

Hallo Powerlovers ;) ,

komme leider nicht mehr weiter und hoffe hier ein paar Anregungen zu bekommen.

Hatte bisher folgendes Setup in meinem, in die Jahre gekommen Wohnmobil.

Raspberry Pi mit:

  • Raspbian
  • Node-Red
  • eine selbst gebastelte Gasflaschenwaage mit HX711 über die GPIOs (Node-Red)
  • Relais Steuerung meines Kompressors für Luftfederung über die GPIOs (Node-Red)
  • LED Steuerung über GPIOs (Node-Red)
  • RaspAp (Hotspot)
  • Huawei USB-LTE Stick

Nun hab ich mir den Victron SmartSolar Charger MPPT gegönnt und dachte ich könnte den problemlos über die USB Verbindung in Node-Red einbinden aber entweder finde ich nicht die passenden "Librarys“ um den Charger in Node-Red nutzen zu können oder es funktioniert nur über die Venus OS?

Nun habe ich Venus OS auf einer frische SD Karte installiert und der Charger wird sofort erkannt. Nun fehlen mir die folgenden Möglichkeiten die ich zuvor hatte.

Ist es möglich die folgenden Anwendungen in Venus OS zu realisieren?

  • eine selbst gebastelte Gasflaschenwaage mit HX711 über die GPIOs auszulesen?
  • Relais Steuerung meines Kompressors für Luftfederung über die GPIOs anzusteuern?
  • LED Steuerung über GPIOs zu steuern?
  • einen Hotspot zu generieren?
  • Huawei USB-LTE Stick Mobiles Internet über den Hotspot zu verteilen?

Bin über jeden Hinweis Link usw. dankbar

Power UP!


beatstreet asked
Jens Rephöhler answered ·

1 Answer

Weather forecast controlled Minimum SoC setpoint, using Node-red & Home Assistant

Since a while I wanted to have my Minimum SoC setpoint controlled by weather (solar yield) forecast and others parameters. So in the end to get a dynamic SOC control.
After digging into the matter I have a solution that might be interesting for others too.


My solution might be an overkill for many users, but it has some really nice feature as it allows to charge the battery with cheap grid power at night.
All the details you can find in the Github repo:

lucode asked
thomasw-1 answered ·

2 Answers

Node-RED dashboard on Cerbo GX Touch 50?

@Guy Stewart (Victron Community Manager)

Is it possible to launch and display the Node-RED dashboard, directly on the Cerbo GX - Touch 50 display?

Like swiping left and right between different default Venus OS screen layouts, could the Node-RED dashboard perhaps be accessible this way, as a fourth screen layout?

Thanks, Anton

plaaspondok asked
Rene Mullie answered ·

2 Answers

/Ac/Alarms/GridLost is not in the DBus on CCGX

@mvader (Victron Energy) @Scott Bender

I'm attempting to create a pushover alert with NodeRed using the Victron System node. The Dbus path: /Ac/Alarms/GridLost is missing in the node as well as on my CCGX 2.80~33 (missing in dbus-spy). I do have "monitor for grid failure" enabled on the CCGX.

Scott, I saw that you made a change in the scripts/missingpaths.json to "add support for /Ac/Alarms/GridLost". Maybe you have a suggestion as to why the Dbus path is missing?

Appreciate any help

Thank you

gharshaw asked
mvader (Victron Energy) answered ·

1 Answer

Node red UI via VPN?

Has anyone figured out a way to use the node red ui dashboard remotely without going through VRM? Right now it takes me an average of about 7-10 minutes to get it to launch the node red editor every time I want to see the dashboard. I get a bunch of messages about "token expired", or "SSH timeout" over and over before the node editor actually launches. There has to be a better way!

chris-wilberg asked
clives answered ·

3 Answers

Venus OS Large: Node-RED and Signal K

Hello all,

As some of you know, something new is in the works, called "Venus OS large". This post is intented to start getting a large audience for it, as well as to recruite more help in further developing it.

This story is a bit longer than I usually type, here we go:


Venus OS Large is an extended build of Venus OS, it adds Node-RED and Signal K server.

Node-RED is a tool for connecting hardware devices, APIs and online services. It provides a browser-based editor that makes it easy to wire together flows. With it, one can for example program something relatively simple such as a relay to open or close based on a temperature measurement. As well as make far more complex algorithms, tying voltage, current, power or other readings and other data available from Venus OS or elsewhere together with outputs such as relays or control points of the Victron system. All without having to write real source code.

Also Node-RED features a fully customisable dashboard, viewable in a webbrowser - both locally and remotely, via the VRM Servers.

Signal K server is aimed for yachts, and multiplexes data from NMEA0183, NMEA 2000, Signal K and other sensor inputs. It makes all that data available for Apps, such as WilhelmSK, a highly customizable boat instrument display. The Sailing with Signal K blogpost on our website is a great read for more information and ideas.

Customisation & automation without needing to be a software developer

The value of above is that now you can self configure and customise your GX Device to do many of the things asked for here. And doing so without having to posses software developer skills. It will require patience, time and to be not too afraid of trying things.

Its really extremely powerful and I'm super excited about the possibilities.

Documentation & how to install

See https://www.victronenergy.com/live/venus-os:large.

Venus OS Large is available for the Cerbo GX, Venus GX, MultiPlus-II GX and EasySolar-II GX as well as the RaspberryPi3 and RaspberryPi 4.

Want to help?

There are a few ways to help. First of all by simply installing and using it; and reporting any issues, or just that you're happily using it and what you are using it for.

The other is by helping others here on the Modifications section on Community. There is and will be no official support for Venus OS Large. Instead, we are referring users to turn here, the Modifications Space on Victron Community. You can help by answering questions.

Next, there is developing and improving the documentation; The manual needs further development, also the nodes and available measurements will need detailing and documenting, examples, screenshots, videos, it will all help adoptation and getting the best out of this. And we'll need more help for all of that that.

Lastly I am looking for help in development and support. First of all to further develop and support the Victron integration into Node-RED, ie. the node-red-contrib-victron package. Which will require nodejs experience, Linux experience, and preferably also experience with Victron products; ideally you'd be following and taking part of the discussions here on Community, (remotely-) debugging issues as well as suggesting and implementing new functionality in the said package.

Besides the node-red package, also the integration of Node-RED and Signal K in Venus OS needs to be maintained. Which requires a different skillset: deep experience and knowledge of Linux, but also the Open Embedded build system.


I can type a whole lot more about this, but have to stop now. Have a good Sunday! And if you have examples, or questions or comments, welcome to put them below.

Ps. Node-Red example flow:


mvader (Victron Energy) asked
Kevin Windrem commented ·

17 Answers

Proxy Relay Down?

Am I the only one who can't get to the proxy relay anymore? When I'm in the dashboard and change the URL to /proxy/ or /ui/ it just kicks me back to the installations page! It's been doing this for about 4 days now. Always worked before although slower than molasses.

chris-wilberg asked
John Stiekema answered ·

1 Answer

Venus Node-RED - Example flow: Temperature controlled relay

Does anyone have a good example of flows for maintaining lithium battery temperature via GX relays?

I have one that I slapped together but it's pretty basic and I don't really have a very good grasp on node-red yet.

Seeing as how this is one of the most common reasons for someone to want node-red, I'm pretty surprised that I can't find this already out there! The flows/dashboard from section 6.2 of the following link are very similar to what I am trying to do....but I can't see the rest of the flow and I'm lost. https://www.victronenergy.com/live/venus-os:large?utm_source=offline&utm_medium=qr&utm_campaign=qr%20code%20products#

I would also like to throw in some other variables such as warming the batteries to a higher temperature when the PV & battery voltage is above a certain threshold, and disabling warming when the battery voltage is too low.

chris-wilberg asked
pau1phi11ips commented ·

2 Answers

Two Multiplus II in series


I am working on installing a Multiplus II 48/5000 at my home, where I already have an on-grid photovoltaic inverter SMA Sunny Boy 4kW and I have some questions I haven't found answers anywhere:

1. Is it possible to install two Multiplus II inverters in series (one of them connected to the other critical loads output) with non-shared batteries? How should I configure them? That would enable me to add a new Multiplus II in the future with another new battery on grid-parallel mode connected to first Multiplus II critical loads output.

1.1 If 1. question is possible, should I configure second one to not exporting to grid? Or first one could use frequency shifting (or similar) to control how much energy could export the second one?

1.2 Continuation of 1.1 question. Would be possible to have SMA Sunny Boy 4kW connected to the same critical loads output than second Multiplus II, having both controlled by frequency shifting? Or that is not possible as maximum power would exceed Multiplus II maximum power?

It appears a similar configuration could be done by using CerboGX large firmware, to be able to use Node-red to control some inputs:
- first Multiplus II critical loads frequency (could be updated depending on first Multiplus II is able to receive more power from critical loads or it cannot accept many more
- first Multiplus II AC In grid status (availabe/not available)
And to be able to control some things:
- second Multiplus II power exportation limit, being configure to 0 power exporattion into second Multiplus II if grid on first Multiplus II is disconnected

I've seen some other questions about similar solutions, but they were trying to control batteries load between two Multiplus II at the same time at the same battery load. I'm not interested on that. What I'm looking for is to:
1. If second Multiplus II (with AC In connected to first Multiplus II critical loads AC OUT) has batteries fully loaded, then it will share power with the other one if the other requires it; if the other doesn't require it and external grid is connected, power could be exported to grid; and if the other doesn't require it and external grid is disconnected, 0 power export should be configured into second Multiplus II
2. If first Multiplus II (connected to grid and with second Multiplus II connected to it's critical loads AC OUT) has batteries fully loaded, if second Multiplus II requires power, first Multiplus II can provide that power as if it were coming from real grid

tcircuns asked

0 Answers

signalk-subscribe with NodeRed embedded in Venus OS Large


regarding NodeRed that i used in the past with SignalK installation, i liked signalk-subscribe, signal-send-pathvalue ... kind of nodes to get directly the SignalK informations.

Now, i moved to Venus OS Large with NodeRed already embedded (also SignalK) and i'm glad to find all the powerful new Victron Energy nodes.

So, my question is ... i do not found anymore the previous SignalK nodes like signalk-subscribe

On one side a great benefit (Victron nodes), but on the other side a loss (SignalK) !

Probably, many points that i do not understand (sorry, i'm not an expert).

I'll appreciate to receive some help on this topic.

Best regards, Christian

Sophie & Christian asked
Stefanie commented ·

1 Answer

Venus Os Large " Flows stopped due to missing node types. influxdb"


first time using the Venus Os Large on my running RPI

i am getting this error

Flows stopped due to missing node types.

  • influxdb

Any help would be appreciated

fenix asked

0 Answers

Node Red pi and sms

Runs Venus Os large latest version on a raspberry pi 3b, which works quite well. Want to configure more options for other components, something I hope can be done with node red.

I'm not very good at such things, but have got something working, like meters and the relay in BMV-712.

I'm offgrid full time in a camper, so the rasberry pi is wired to a tplink lte 4G router.

Have installed some software on pi so I can send sms via ssh to tp-link integrated sms app

The real question is, can one connect this via node red so I can send alarms to my mobile phone?

command to send sms

./sms-send.js --url = "" --login = "admin" --password = "myrouterpassword" "0612345678" "my text message"

Maybe I'm looking at the wrong end so it's nice if someone can put me in the right direction

johnny-brusevold asked
johnny-brusevold commented ·

1 Answer

How to load node-red dashboard on startup, replacing venus GUI


I've developed my own node-red dashboard on venus large image on RPI. Everything ist running fine now and thats why I would like to access my node-red dashboard directly from my RPI touchscreen display. How can I achieve this ? Is there a startup bash script somewhere on venus@Pi, where I can point to my local node red dashboard ? Or can I even load both UIs and switch with a gesture between them ?

This is how my node-red dashboard looks right now ;) :


dave68 asked
ironman edited ·

3 Answers

No Output nodes available on multiplus

Hi! Just started a new Node red system on a Cerbo with a Multiplus -II 3000.

I've used both Node red and Multiplus-II before but with this installation its fighting back.

I can read input nodes from the multiples just fine, but when I try to use an output node on it, there's is none. The Solar charge output node works just fine.

What am I missing? The firmware is 481 (Newest is 489)

Skærmbillede 2021-11-02 kl. 13.55.54.png

philipr asked
philipr answered ·

2 Answers

Weather controlled Minimum discharge SOC example using Node-red

I have an interesting NodeRed project - based on next day weather, it is changing the minimum discharge SOC on the GX device. So if next day it is sunny, it will configure the SOC to a lower level, if it is cloudy it is increasing the SOC. At this moment I have only 4 levels, but it can be improved. How I'm doing this - you need to create a free account on https://openweathermap.org. After doing that use the API generated on that site, put it in the openweathermap node, add your city name or coordinates, and you will receive the details for the next 5 days. I'm looking only at next day, between 9AM-6PM and the value used is called visibility. Having the average value for next day, the system will decide (every day at 3PM) how the SOC should be for the next 24h. There are lots of things that can be added. If you need any other info, you can ask. Or if you have something similar, please share.



Lucian Popescu (Victron Energy Staff) asked
lucode answered ·

3 Answers

Expected traffic to the mqtt{1 to 128}.victronenergy.com server farm?

I am running Venus-large and have a fairly extensive Node-Red flow consisting of about 100 nodes. My router is reporting a permanent TCP/IP session with one of the mqtt{1 to 128}.victronenergy.com servers with constant traffic of just over 10 kbit/s upload and just under 1 kbit/s download. This seems high to me but maybe it's because of my 100-node flow. Is this level of traffic to be expected?

paulcooper asked
paulcooper answered ·

1 Answer

node-red: start fresh from 0

Hi, I tested node red, but there are some faults in the installation because of me. I would like to start from the beginning. But when I install the original firmware and then the venus large image again all is like it was before. I would like to start with all wiped out. How to?


skykay asked
mvader (Victron Energy) answered ·

4 Answers

node red dsahboard install

getting an error when installing node red dashboard.

root@beaglebone:~# npm i node-red-dashboard
npm WARN saveError ENOENT: no such file or directory, open '/data/home/root/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/data/home/root/package.json'
npm WARN root No description
npm WARN root No repository field.
npm WARN root No README data
npm WARN root No license field.

How do I correct this ?

jan-kees asked
jan-kees answered ·

1 Answer

How to display Solar Charger 30 day history on Node Red Dashboard?

I'm using the Node Red feature in the Large version of venus os and buiding my own FUN Dashboard :) .I'm trying to access the 30-day history that one can see in Venus OS in the corresponding tab of Solarcharger that is connected to VenusGX and show it in some form on the Dashboard, but I can't seem to find the right building block. The Solarcharger block only contains the current value variables.

How to access and display History data with Node Red?

Elimac asked
Elimac commented ·

1 Answer

how can i emulate a bmv700 with input from a votronic smartshunt


i have a raspi 4 with the large Venus OS image on it and a connected mppt100/30 .

output is a 7inch ips touch panel. This works very well.

Node red is activated and i use this to decode the serial output from a vortronic 400A Shunt so i have now following values in node-red at the moment:

- Voltage from the Board and Starter battery in V

- strength of the electrical current in A

-Battery level of the board battery in %

-size of the Boardbattery in AH

now i would like to send this as input to emulate a bmv7xx to the venus os to show it on the display as a bmv.

has someone a idea , best of would be directly in node-red itself

thanks in advance

Holger Blume asked
Holger Blume edited ·

0 Answers

Connection to Victron MQTT - Node Red

I've read many threads but still cannot connect to Victron's MQTT server. I know I should be using mqtt62.victronenergy.com and have everything set as I understand it, including the venus-ca.crt but it fails to connect. Any help would be appreciated.



wmsmitty asked
jmeintjes answered ·

2 Answers

Hello Victron please help us with ESS Phase compensation!

Hi Victron, we are discussing in several threads a nearly similar question without an expert comment by victron-staff:




This main problem of an „symmetrical“ or „balanced“ ESS in a three phase grid-parallel setup is absolutely essential for the German and Austrian market. Please let us know what you think about it! Thank you very much!

woliver asked
n-dee commented ·

3 Answers

Node-Red timezone

I thought it might be helpful for others in the Venus OS extended image I found time based flows were all in UTC time even though I set the time zone in the Venus menu. i ended up linking my timezone to /etc/localtime from the command line and time worked as expected in Node-Red after a reboot. Might be good for Victron developers to make this link when the timezone is set in the Venus interface?


I've changed this to set the timezone in Node-Red instead of setting system wide

edit ~/.node-red/settings.js and this right above the module.exports = { line

process.env.TZ = 'America/Los_Angeles';

Eli Hunter asked
Mark commented ·

3 Answers

updating @victronenergy nodes in node-red failing

Raspberry pi 3B+, VenusOS Large V280.11/20

I clicked "update to 1.4.2" by the victron energy nodes in the node-red palette. I currently have 1.4.1 installed and working. The installation failed with the following output in the event log:

2021-09-07T04:44:28.988Z Install : @victronenergy/node-red-contrib-victron 1.4.2

2021-09-07T04:44:29.152Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @victronenergy/node-red-contrib-victron@1.4.2

2021-09-07T04:45:08.431Z [err] npm

2021-09-07T04:45:08.432Z [err] WARN rollback Rolling back @victronenergy/node-red-contrib-victron@1.4.2 failed (this is probably harmless): ENOTDIR: not a directory, lstat '/data/home/root/.node-red/node_modules/@victronenergy/node-red-contrib-victron'

2021-09-07T04:45:09.965Z [err] npm

2021-09-07T04:45:09.965Z [err] ERR! code EEXIST

2021-09-07T04:45:09.966Z [err] npm ERR! syscall

2021-09-07T04:45:09.967Z [err] mkdir

2021-09-07T04:45:09.967Z [err] npm

2021-09-07T04:45:09.967Z [err] ERR! path /data/home/root/.node-red/node_modules/@victronenergy

2021-09-07T04:45:09.967Z [err] npm

2021-09-07T04:45:09.968Z [err] ERR! errno -17

2021-09-07T04:45:09.989Z [err] npm

2021-09-07T04:45:09.989Z [err] ERR! EEXIST: file already exists, mkdir '/data/home/root/.node-red/node_modules/@victronenergy'

2021-09-07T04:45:09.990Z [err] npm ERR! File exists: /data/home/root/.node-red/node_modules/@victronenergy

2021-09-07T04:45:09.990Z [err] npm

2021-09-07T04:45:09.991Z [err] ERR! Remove the existing file and try again, or run npm

2021-09-07T04:45:09.991Z [err] npm ERR!

2021-09-07T04:45:09.992Z [err] with --force to overwrite files recklessly.

2021-09-07T04:45:10.080Z [err]

2021-09-07T04:45:10.080Z [err] npm ERR! A complete log of this run can be found in:

2021-09-07T04:45:10.080Z [err] npm

2021-09-07T04:45:10.081Z [err] ERR! /home/root/.npm/_logs/2021-09-07T04_45_10_053Z-debug.log

2021-09-07T04:45:10.204Z rc=239

When I ssh into the raspi and go to the node_modules directory I see that @victronenergy is not a directory but a file with 0 bytes. The file config.nodes.json file, however, seems to point to "/usr/lib/node_modules/@victronenergy/node-red-contrib-victron/src/nodes/config-client.js" so maybe that's why the update do not work.

My question is, how do I make it work without screwing something up? :)

mrhappy asked
mvader (Victron Energy) commented ·

1 Answer

Node-RED victron nodes bug report

The node "VE Bus System", system "multiplus-II" chosen.

The measurement "Battery current" do not show positive charging current, only negative current pulled from batteries. While charging, msg.payload is strictly 0. I don't know if this is intentional, but it is in my view not logical. No big deal, I can calculate what I need from other input and output measurements of the multi, just wanted to report this if it is indeed a bug.

Love your work.

mrhappy asked
Dirk-Jan Faber commented ·

2 Answers

repair node red on my victron gx device

Is there a process for reinstalling node red on a gx via ssh, I have installed a node which seems to have crashed it

David Gould asked
Dirk-Jan Faber answered ·

1 Answer

Node-Red - node specification file for new measuraments from DBUS

Hi All,

reading Github page for Node-Red:


It's possible to define new measurament for each Victron nodes available in Node-Red.

As described in Git, It is possible to have the 2 configuration files CSV:

- dataAttributes.csv

- dataAttributeEnums.csv

We want to insert new measuraments in Battery Monitor Node:

- Max Cell Voltage

- Min Cell Voltage

Thank you!

csmblocker asked

0 Answers

[VenusOS 2.80~large20] @victronenergy/node-red-contrib-victron update from 1.4.1 to 1.4.2 fails

Hi, after manually updating the OS to the 2.80~large20 version I've noticed that there was also an update for the "@victronenergy/node-red-contrib-victron" NodeRED package, raising it up to the 1.4.2 from the 1.4.1.
The update procedure fails because it needs the "/data/home/root/.node-red/node-modules/@victronenergy" folder, but on the filesystem it is a file! Here is the failure log:

2021-08-27T08:34:16.028Z Install : @victronenergy/node-red-contrib-victron 1.4.2

2021-08-27T08:34:16.380Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @victronenergy/node-red-contrib-victron@1.4.2
2021-08-27T08:34:53.239Z [err] npm
2021-08-27T08:34:53.241Z [err]  WARN rollback Rolling back ms@2.1.2 failed (this is probably harmless): ENOTDIR: not a directory, lstat '/data/home/root/.node-red/node_modules/@victronenergy/node-red-contrib-victron/node_modules/ms'
2021-08-27T08:34:53.858Z [err] npm
2021-08-27T08:34:53.859Z [err]  ERR! code ENOTDIR
2021-08-27T08:34:53.859Z [err] npm ERR! syscall mkdir
2021-08-27T08:34:53.859Z [err] npm ERR! path
2021-08-27T08:34:53.860Z [err]  /data/home/root/.node-red/node_modules/@victronenergy/node-red-contrib-victron/node_modules
2021-08-27T08:34:53.860Z [err] npm ERR! errno -20
2021-08-27T08:34:53.876Z [err] npm
2021-08-27T08:34:53.877Z [err]  ERR! ENOTDIR: not a directory, mkdir '/data/home/root/.node-red/node_modules/@victronenergy/node-red-contrib-victron/node_modules'
2021-08-27T08:34:53.955Z [err]
2021-08-27T08:34:53.957Z [err] npm ERR! A complete log of this run can be found in:
2021-08-27T08:34:53.957Z [err] npm ERR!     /home/root/.npm/_logs/2021-08-27T08_34_53_933Z-debug.log
2021-08-27T08:34:53.992Z rc=236

I've also tried to manually create the folder and re-issue the update, but some error and warnings about the downloaded code raise:

2021-08-27T08:43:12.742Z Install : @victronenergy/node-red-contrib-victron 1.4.2

2021-08-27T08:43:12.936Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @victronenergy/node-red-contrib-victron@1.4.2
2021-08-27T08:43:46.776Z [out]
2021-08-27T08:43:46.776Z [out] > abstract-socket@2.1.1 install /data/home/root/.node-red/node_modules/abstract-socket
2021-08-27T08:43:46.776Z [out] > node-gyp rebuild
2021-08-27T08:43:46.776Z [out]
2021-08-27T08:44:12.468Z [out] make: Entering directory '/data/home/root/.node-red/node_modules/abstract-socket/build'
2021-08-27T08:44:12.472Z [out]   CXX(target) Release/obj.target/bindings/src/abstract_socket.o
2021-08-27T08:44:19.619Z [err] In file included from ../../nan/nan.h:58,
2021-08-27T08:44:19.619Z [err]                  from ../src/abstract_socket.cc:5:
2021-08-27T08:44:19.619Z [err] /home/root/.cache/node-gyp/12.21.0/include/node/node.h:737:43: warning: cast between incompatible function types from 'void (*)(v8::Local<v8::Object>)' to 'node::addon_register_func' {aka 'void (*)(v8::Local<v8::Object>, v8::Local<v8::Value>, void*)'} [-Wcast-function-type]
2021-08-27T08:44:19.619Z [err]   737 |       (node::addon_register_func) (regfunc),                          \
2021-08-27T08:44:19.619Z [err]       |                                           ^
2021-08-27T08:44:19.619Z [err] /home/root/.cache/node-gyp/12.21.0/include/node/node.h:771:3: note: in expansion of macro 'NODE_MODULE_X'
2021-08-27T08:44:19.619Z [err]   771 |   NODE_MODULE_X(modname, regfunc, NULL, 0)  // NOLINT (readability/null_usage)
2021-08-27T08:44:19.619Z [err]       |   ^~~~~~~~~~~~~
2021-08-27T08:44:19.619Z [err] ../src/abstract_socket.cc:181:1: note: in expansion of macro 'NODE_MODULE'
2021-08-27T08:44:19.619Z [err]   181 | NODE_MODULE(abstract_socket, Initialize)
2021-08-27T08:44:19.619Z [err]       | ^~~~~~~~~~~
2021-08-27T08:44:22.148Z [out]   SOLINK_MODULE(target) Release/obj.target/bindings.node
2021-08-27T08:44:22.800Z [out]   COPY Release/bindings.node
2021-08-27T08:44:22.843Z [out] make: Leaving directory '/data/home/root/.node-red/node_modules/abstract-socket/build'
2021-08-27T08:44:23.847Z [out] + @victronenergy/node-red-contrib-victron@1.4.2
2021-08-27T08:44:23.847Z [out] added 29 packages from 72 contributors and removed 13 packages in 58.326s
2021-08-27T08:44:23.904Z rc=0

After that I've tried to restart NodeRED (actually I've restarted the controller, if you can suggest how to do that I'll be really grateful) but it won't start anymore, always for the same problem about the file/folder "@victronenergy".

I've also tried from console, by running "npm install @victronenergy/node-red-contrib-victron" but the same problems verifies.

Someone has encountered the same problem?

elquero asked
mvader (Victron Energy) commented ·

1 Answer

Automate more than 2 relays using Node-Red on RPi


Following the notes from here I've managed to get as many relays as I want configured on my RPi. These work on the GUI and in hardware.


The problem I'm having is that if I configure more than two relays, they stop apprearing as an option for me to control in Node-Red. Has anyone had a look at this or have a work around?



dharryman asked
mrhappy answered ·

1 Answer

Top Contributors - Community Supporters

kevgermany avatar image kevgermany 201 Answers & Comments
Matthias Lange - DE avatar image Matthias Lange - DE 189 Answers & Comments
mvader (Victron Energy) avatar image mvader (Victron Energy) 159 Answers & Comments
Alexandra avatar image Alexandra 136 Answers & Comments
nickdb avatar image nickdb 95 Answers & Comments
snoobler avatar image snoobler 95 Answers & Comments
wkirby avatar image wkirby 89 Answers & Comments