Once you sign in you will be able to subscribe for any updates here

Is this a normal ESS behaviour

Calling out to the collective brain trust on this forum, hoping to get some glimpses of wisdom back that would help lead the way for me :)

About two weeks ago, I switched on my newly installed a three-phase MultiPlus II system in my house for the first time. Pure excitement. The ESS system and I are currently in the getting-to-know-each-other phase. It's mostly nice, but some of the excitement has tapered off and instead transitioned into uncertainty.

I understand that the job of the ESS is to try to keep the grid meter close to its set-point, and that this can be done with or without phase compensation. Something feels off though... I have nothing connected on AC2. Beside the pool which is connected on "the grid side" everything else, the whole house is connected to AC1. Despite this, at first, the Cerbo/VRM showed Phase 1 and 3 under Critical Load, and Phase 2 under AC loads?!...


When changing grid metering under the ESS settings to Inverter/Charger, now everything shows up as AC loads. (see last picture for how that looks) ...


...when setting the virtual switch on the MultiPlus:es to On I become the neighbourhood's electrical grid equivalent to a wave machine at a water amusement park. Phase 1 and 3 are gently bobbing along with a few hundred watts up and down while Phase 2 is oscillating widly between +2,5KW <--> -2,5KW (roughly)


Even when setting the ESS mode to "Keep batteries charged" phase 2 seem to think that it's suitable to start discharging and sending 2-3 KW back out on the grid...


Only way to cool things off and maintain a more steady flow of electrons is to flip the virtual switch back to charger only.

... and now, to tie it together with the topic of this thread; Is this normal ESS behaviour ... or have I done something wrong? Is something faulty? I'm using a EM340 meter (The EM24 seems to be the preferred choice in most cases), could that have anything to do with it?

Any essential information that I left out, please enlighten me.

Any suggestions, insights or just some friendly cheering no to loose hope will be very appreciated. :)

Best regards,


odnacon asked

0 Answers

Setup a schedule for inverter power limit on an ESS system?

I am trying a way to better utilize my battery. It turns out that limiting inverter power during the night, allows me to keep the battery from overloading and switching to sustain mode.

So, question is, is there a way to set up an automatic schedule to enable and disable inverter power?

thanar asked

0 Answers

ESS - Grid consumption is high and PV limited when battery soc is 100%

Please can soumeone help with my home instalation? I have 3phase system 2x MultiPlus-II 3000/35-32 and 1x EasySolar-II GX 3000 with MPPT250/70 for east PVs 2,7kWp and MPPT 150/35 for west PVs 1,8kWp. 2x pylontech 3.6kWh 48V

I use ESS asistant with regulation for each phase. Grid setpoint is set to 100W. But regulation doesn't work well. It use grid when it is no neccesary. When battery is 100% soc grid setpoint 100W is not reached. When battery is under 100% grid setpoint works fine.



michalc187 asked

0 Answers

ESS-wizard niet gevonden

Na firmware updates geeft mijn multiplus II GX bij de instellingen voor ESS: "ESS-wizard niet gevonden". Heeft iemand een idee hoe ik het ESS wel kan benaderen of installeren?

haddock asked

0 Answers

Understanding and improving ESS charging performance - timeshifting MP2/Pylontech

I'd like to better understand how charging is managed and hopefully find a way to improve charging speed if possible. I have a four hour cheap rate window in which to maximally charge my battery stack. It is problematic to get the system close to fully charged from its minimum SoC. System is 2x parallel MPII 48/5000/70 with 6x Pylontech US5000.

If I understand correctly, the charging process or, at least the overall parameters for it, are mostly managed by the Pylontech BMS. From the victron doc it clearly states the dynamic charge voltage and charge current limit (CCL) are controlled by the Pylon. I don't however understand *what manages the overall charge current supplied* at any given time. The CCL certainly changes, but only when charging gets close to full SoC ~90%, or if the battery is particularly cold. The system charge level rarely gets close to the CCL.

Looking at the graphs, during the ESS scheduled charge window, charging seems typically to have three phases - an initial relatively high level until ~1.5hrs in and around 50% SoC, then a medium charging phase that bounces around, and finally a very slow charging rate as we approach full past 90% SoC.

What part of the system controls the charge current level?

Why does it drop from the higher current charging to the lower after ~1.5hrs / ~50%?

Is there any way I can influence this control algorithm?

Perhaps the Pylontechs or Multiplus' are doing thermal management to an extent - though it doesn't seem that warm? Pylontech charge derating is supposedly only active outside of ~12C and 43C.

Appreciate any insight into the charge algorithm, and/or comparisons with other peoples systems.

Cheers, Paul.

A good night - starts at 16% SoC and gets to 98%:


Not so good, start 11%, finish 88%:


Start 11% end 92%:


Start 11%, end 92%:


Final example, start 34%, end 98.8% (highest ever seen):


Paul Beskeen asked

0 Answers

Feature Request: Write access to Multi RS Solar ESS Settings

I would like to request the ability to control the following via NodeRed/Modbus for the Multi RS Solar:

1) ESS Mode (Optimized with batterylife, Optimized without battery life, Keep batteries charged)

2) ESS Minimum discharge SOC

Both would be useful but either would do.

Charging batteries during cheap times is possible but requires fudges to make it work. I can use Generator rules to turn on the input relays at night and also if I have a large load. The downside is I end up charging the batteries during the day if I have a large load.

I currently have to use a Windows PC to automate clicking buttons in the VictronConnect App to set the ESS Mode!

Don't know if there is a formal method for asking for features but please accept this as one :)

Please Help.......

semlohnhoj asked

0 Answers

The Multiplus-II 48/5000/70-50 smell on one of the phases (3 phase installation) during operation.

The Multiplus-II 48/5000/70-50 smells on one of the phases (3 phase installation) during operation.

I have an installation:

3x Multiplus-II 48/5000/70-50 (3 phase)
2x MPPT 250/100
Cerbo GX - Ve.CAN, Ve.Bus connected
Lynx Smart BMS
2x Lynx Distributor
4x Smart Battery 200Ah/24V (400Ah 48V system)
1x Fronius Symo 6.0-3

The installation worked perfectly for 4 months, but today for the first time there was a smell like burnt laminate/plastic from the Multiplus on the L1 phase. It smells more on the left side of the Multiplus at the bottom. Now in the evening I opened the housing of the Multiplus, nothing smells at all anymore. I looked carefully, there are no burnt cables or components, everything looks like new, everything is clean, the fan is spinning.

I checked all the cables again, they are tightened with the correct torques, there are no suspicious things anywhere.

- Wires:
AC 5x10mm2
DC 2x70mm2

- ESS set with PV inverter on AC-OUT
- Fronius works properly set as Microgrid MG50 - checked, frequency control works.
- Charging current set to DVCC max 200A (wasn't exceeded because I watched almost all day)
- Room temperature around 15°C
- There are no error messages
- Everything works fine, it just smells.

What has changed in use for 2 days is:

- export of energy to the grid was performed for the first time

- almost the first time the battery was charged by Multiplus from 230V (before that I only charged it twice from the mains to balance it and it was charged from MPPT)

- Fronius Symo 6.0-3 has been connected to AC-OUT1



What to do next?

What to check?

Thank you in advance for your help

marion asked

0 Answers

Unusually low input

Why would I get only 11amps input from a source that usually gives me 30amps? I have an ac to dc charger that usually inputs from 25 to 30 amps but according to SMARTBMV input is only 11amps. The only 12v device that is powered on is a small fridge that pulls about 4amps. SOC is only 80% Any thoughts would be appreciated.

brian49 asked

0 Answers

ESS oscillates between charging and discharging

In my ESS system, the maximum inverter power is externaly set to 0 W when a certain SOC is reached to prevent further battery discharge. In the range between 100% and 60% this regulation worked without problems. As now slowly more sun is available again I have lowered the limit to 50%.

Now a strange behavior shows up here:

If the limit value is reached, the inverter switches off as configured. At the same time, the Multiplus starts to charge the battery with 100-200W from the grid, so that the limit value is exceeded again after a short time and the inverter switches on again. Thus, the system oscillates between discharging and charging for hours.



Why does the MP charge from gird at all when ESS is set to Optimized (w/o Battery Life)? The battery voltage never falls below the low voltage threshold and the SOC never reaches below the ESS minimum SOC. Do you have any idea how to prevent this behavior?

felr asked
felr edited ·

0 Answers

ESS NOT feeding back to grid

HI All, I'm having an issue where my system is not feeding back to the grid anymore (batteries are at 100%). I have two PV charge controllers one with 16 panels and the other with 4. It seems what is happening is that the PV controllers are limiting power produced to match what my AC loads are using. When I switch more electronics on the PV ramps up so its not a fact that I cannot produce more power. I have 6.6KW worth of panels.



andrebotha asked
andrebotha commented ·

0 Answers

ESS limited feedin to grid causes smart chargers to toggle mode

Dear Community,

i have following setup:

Multiplus 5000
2x Smart Solar Charger 250/65
620 Ah Hoppecke OpSZ 48V
Venus GX on Raspberry Pi 3
10kWp PV.

I am running ESS mode with feedin of excess Energy to the grid when the battery is full.
After the last firmware update of all components 2 weeks ago, even the limitation of feedin power seems to work. Due to the single phase connection i would like to limit the feeding to for e.g. 2kW.

The Problem:

When my battery SOC is at 100% and feedin is limited, the solar chargers toggle from absorbtion to bulk operation quite quickly (within seconds). This leads to pulsing power between roughly 0 Watts to 1600Watts to the battery, allthough it should be kept in float voltage and roughly steady 60 Watts. Also the voltage rises to ~56V for seconds. The power of the chargers also varies from 0 Watt to 1200W.

It seems the ESS System tries to reach the feedin limit but the controller oscillates very strong.

When I disable the feedin limitation, the chargers run steady up to the availlable solar power.

I was wondering if I can adjust settings of the controller or somehow prevent the smart chargers from toggling operation modes.

Help is much apprechiated, as I think the pulsing power to the charged battery is not beneficial for battery lifetime and also for the electronic components.

Thanks in advance,


matteng asked
larsea-dk commented ·

0 Answers

ET340 energy meter AC loads disappear and exporting to grid

Hi all,

I am having a scenario where I can note that my AC loads are "disappearing", and the value of the AC loads are being exported back to the grid between 20 and 30 seconds as noted in the image below, this occurs every 30mins so. Feed-in is disabled and grid point set to 150W but still an unexpected amount of feed-in happens.

The only factor that I could think is an issue is the distance from the ET340 energy meter and the Venus GX - ~47M. I have used the RS485 with a shielded Mylar cable extension (as recommended after failing with CAT5 and CAT6), this seems to have had improved but his still happens. I have contacted my distributor as well as asked a few local experts but there is no definite reason why this would happen, I have also had a look at numerous issues related but tried and no success, I have tried the 3,5mm audio jack hack as well. Feedback to the grid is an issue since in Cape Town, South Africa importing excess power requires an additional meter at a cost which is not a feasible solution.

The system is running ESS as well.

Any help or suggestions or at least a point in the right direction would be appreciated. Let me know if additional information is required about the site.


It seems to be related to phase rotation issue, we have traced the phases from the main kiosk and ensured L1 = L1; L2 = L2; L3 = L3. (red, white, blue). This is consistent right through, however then the phase rotation warning message appears and only when swapping around L1 and L3 does the phase rotation message disappear, this only seems to be a work around and the below image is still relevant. We have found no issues during blackouts, only when running normal ESS.


Phase rotation has been eliminated as an issue. The energy meter seems to "disconnect" at this point in time. I have tried new data cables and new RS485 cable, but the issue still remains, a new energy meter has been installed as well.


Site summary:

  • 3 phase house with ET340 energy meter.
  • Venus GX
  • 3 X 5KVA multiplus 2
  • 3 MPPT (2x 250/100, 1x 150/45 - 2 x connected VE.Direct and 1 connected USD to VE.direct)
  • Freedom won 20/16Kwh LiFePo4 module.
  • RS485 to usb with extension (47M)

Juan van der Merwe asked
Juan van der Merwe edited ·

0 Answers

Microinverter at MultiPlus AC-OUT

Good day,

I use a MultiPlus and on the AC-Out I have a Deye 300 Microinverter.

In the ESS wizard I have also activated the PV point on the output.

Nevertheless, wide feeds beyond the set zero point.

Do I have to tell the Venus OS separately about the power, or should the ESS Assistant regulate this itself?





ESS assistant




regards and thx for any hints


juf asked

0 Answers

V-TAC LFP batteries, trying to source information

There's a new distributor of LFP batteries in Europe for a couple of months now, under the V-TAC brand. V-TAC was founded some 20 years ago at UAE and has a very strong presence in Europe, particularly eastern Europe and the UK. They've been hard into the LED and lighting business. They've recently started offering LFP batteries for solar projects, along with other energy bundles of dubious quality. I am interested in their 10kWh model (model name: AT48-200H or VT-12040), since I can source them locally for under €250/kWh and they come with a full 5-year warranty.



It's an certainty that their 10kWh model is a branded generic Chinese unit, however you can't argue that at this price, it's a no - brainer, particularly for smaller installations.

I am trying to figure out the model of their BMS and whether there is any chance of it getting along with an ESS GX setup, either officially or through Louis' excellent serial tool. Here's a photo of the BMS they are using, in case it rings any bells (searching for "CPES-BMS16S" online wouldn't produce any results):


They have published lots of documentation on their website for all models, and there's also a compatibility chart that displays Victron among the compatible brands; it doesn't mention to what extent, though.

I would appreciate any additional information or insights.

thanar asked
thanar edited ·

0 Answers

Changing ESS settings in 3-phase system


I'm working with VE Configure via the VE.Bus system configurator on 3x Multiplus-II in a 3-phase configuration, up and running fine.

It's very clear in manuals and videos that the ESS assistant must be uploaded to each unit. I ran the assistant, saved it to a file, uploaded to #1, then loaded that file before uploading to #2 and #3.

What is the procedure when updating settings in the ESS-assistant, such as Sustain-voltage, the dynamic cut-off curve etc. Is it enough to re-upload the assistant to #1 as a master, or do I need to go through and enter the same settings by running the assistant in VE Configure three times, once for each unit?

I get the sense that #1 acts as a master with regards to those settings. The file size for the assistant displayed in VE Configure is higher for #1 than for #2 and #3, and the only time I tried loading an updated ESS-file to then upload to #2 nothing happened indicating no changes had been made. I just want to check if I'm doing this right?

When a low battery alarm is triggered for example, only #1 will show a red light - correct behaviour?

(When changing settings in the other tabs, I always send to all three units)

flenis asked

0 Answers

Top Contributors - Community Supporters

Alexandra avatar image Alexandra 262 Answers & Comments
Matthias Lange - DE avatar image Matthias Lange - DE 162 Answers & Comments
netrange avatar image netrange 153 Answers & Comments
kevgermany avatar image kevgermany 145 Answers & Comments
ojack avatar image ojack 104 Answers & Comments
JohnC avatar image JohnC 90 Answers & Comments
matt1309 avatar image matt1309 89 Answers & Comments