vrm firmware update Image

vrm firmware update

Do I save the config for Remote Firmware update for multiple inverters?

When doing a remote firmware update via VRM do I need to save config of the Quttro first, and also will the firmware be updated to all 3 inverters?

Excuse the ignorance :-(

Hannes Swart asked
Hannes Swart commented ·

1 Answer

Measuring energy from single-phase PV Inverter on the second phase of Energy Meter

The Victron Energy Meter Manual for the EM24 RS485 states:-

Single phase dual function

If you are considering using a 3-phase meter in a single-phase installation to measure the grid on one input of the meter and the PV inverter output on another input of the energy meter, use the ET340 instead"

Is that because the EM24 counts total power, with net differential readings from each phase cancelling each other out, whereas the ET340 counts energy on each individual phase and then sums those values?

Also, the EM24 FAQ says "Attempting to use other brand battery inverters and trying to substitute their lack of data connectivity to the GX device by using Energy Meters will not work as expected"

My system was installed with an EM24 doing exactly that. Has that now been deprecated and it is no longer possible to set an Energy Meter as a dual "Grid + PV invertor" function anymore?

editbear asked

0 Answers

Error 1342

Will Victron solve Error 1342 in remote firmware update in MK2 devices soon?


rodolfo asked
rodolfo commented ·

2 Answers

Mppt starting new day at history tab everyday @ 15:00 o'clock


I did something I guess Im not supposed to do and upgraded my solar charger's (BlueSolar Charger MPPT 75/15 (large micro) A042) firmware via vrm portal to the latest 1.61. Update is not published via victron connect yet.

After updating device acts weird. Starts a new day while its around 15:00 o clock locally and sun is still shining. In addition to that vrm connected victron connect app(android or windows doesnt matter) changing charge settings are saved and shown with green thick but does not effect the charger. What I mean is I am turning of the charger but it does not stop charging. (etc).

My question is where can I find one step older firmware? Even victron professional portal is only offering the latest firmware. Are there any github like archive of device firmwares so I can revert it back?


Emre asked
Me commented ·

1 Answer

quattro 48/5000/70 + 2 pylontech US2000C = no bms communication
I installed a backup system (Back up mode) for an office. Includes 1 victron Quattro 48/5000/70 inverter + 2 pylontech US2000C+cerbo gx .
  The problem is that when starting the system, the cerbo did recognize the bms of the 2 batteries for a few minutes, but later it did not recognize the bms again.
The cable conforming to the pin out was changed for type A cable, tried with type 5, type 6 cable and finally with the cable that victron sells. The cable was also installed in the ve.can port with a terminator and finally in the can.bms without terminator (actually Tx ok but any Rx and no errors) and with no wire communicated. The batteries were also moved.
I updated the firmware of the cerbo from 2.75 to 2.92 and I did the same when I changed the cables and the batteries position (which will be the most stable version for US2000C batteries?).
I suspect that it could be the version of the cerbo or the pylontech batteries, but no supplier or mabager of victron or pylontech in Mexico or latinoamerica or Spain answered me (they haven't given me a solution for more than 1 month).
In the past, I repaired cell phones and I had experience changing the charge controllers of inflated batteries, so I solved some failures by changing the controllers or updating the firmware (it could be a programming problem with the cerbo having only 2 x 50Ah batteries instead of 4 as recommended as minimun? for 5000VA quattro inverter?).
Please help.


rafael-mx asked
Alexandra commented ·

0 Answers

temperature nonsensical values

Between 2022 12 20 05:45 and 2022 12 29 14:31 the reported temperature changed from a stable accurate value of about 10 degc with negligible spread to nonsense values ranging between -20:80 degc with huge spread(changing sample to sample) AND INCIDENCE of nan. it was a real effect with temperature faults reported. it the reverted to normal behaviour. ??? candidate is a bad firmware update with say a units mistake eg float rather than int? ideas

david-p-1 asked
kevgermany answered ·

5 Answers

Firmware update from VRM returning error 1300


This started today, I never had this issue before. I logged in today to check if there are any new updates and got the below:


This usually checks for the Quattro 48/8000/110-2x100 rev2 firmware and the two BlueSolar Charger MPPT 150/45 rev3 firmware.

Everything else is working for me. VRM is fine, local connectivity with modbus to homeassistant is fine as well.

Any ideas?

micmak asked
Luit Jan answered ·

8 Answers

Can not log into VRM

Hi All

I am having trouble signing back into VRM portel after not using it for a few weeks.

I can not remember which e mail account / password I used when I set the account up.

I have tried to do a password reset using a e mail account I believe I may have used.

I get the return e mail to it as shown below.

On trying to use the link to reset all I get is a blank screen .

I have tried this x3 times with same result.

Any ideas what is happening.

Thank You

Graham O


A password reset for your account was requested through the VRM website.

If you did not request this email you may disregard it, no changes will be made to your account.

To reset your password, visit the following link:

Please note that this link is only valid one time, once it is used you will have to request another one.

Kind regards,

Victron Energy

graham-o asked

0 Answers

Parallel single phase Multiplus II VRM Firmware update

Can I update the firmware on 2 Multiplus in parallel in a single phase system over VRM or do I have to go on site with the laptop? 48/5000's on 2623 waiting for 497


ponzoa asked

0 Answers

How to confirm if CCGX can update VE.Bus firmware via VRM?

Instructions for remote verification of CCGX ability to update VE.Bus firmware via VRM are ambiguous.



3 options listed:

I am offsite and unable to verify my serial number.

The serial number is not listed in the VRM device list.

I find the last option ambiguous. What needs to say MK3? Does it need to be the items on the left or the right?

Maybe a better example would be to show a CCGX that DOES meet the requirements and identify the specific criteria?

Here's what mine shows:


This was purchased in 2019, so I would hope it's newer than 2017, but given the instructions, I can't confirm if it meets the serial number requirements per the example.

snoobler asked
snoobler answered ·

2 Answers

17 Posts
17 Users

Topic Experts

64 Points
53 Points
50 Points