Node-RED Example flow – automation with dynamic on/off thresholds and time delays?

Hi all,

Did somebody already create a similar dynamic on/off flow for Node-RED?

As shown in the 3rd part of the online webinar:
Victron and Node-Red - Webinar - Part 3/3

I thought to find it in the example flows, but no luck :-(
GitHub wiki Example-Flows

@Dirk-Jan Faber, could you ask Mark Corluka if he would like to share it with the community?

I want to use the SOC and solar forecast date i.c.w. such a dynamic on/off flow to enable/disable the boiler and maybe even 2 other devices in an off-grid environment.

Mike Weerdenburg asked
Mike Weerdenburg edited ·

0 Answers

VRM Not showing solar yield for over a week

I have Venus OS installed (2.92) on a RPi4 (working on updating OS) and everything is still working charging wise etc, but I noticed that when I go into VRM the Solar Production hadn't been working over the last week. I thought it was just that Victron had removed the feature from VRM. But when I change the date range for the summary at the bottom of the dashboard I see that Solar Production yields dropped off abruptly on March 19 (see photo), yet the system is still charging and working perfectly fine from a production standpoint as far as I am aware (battery charges to 100% daily, etc) I don't recall making any changes around that time that could have caused this, is there a setting messed up somewhere?

The only other odd thing I noticed poking around in the Remote console was that the device was displaying the incorrect UTC time, and therefore device time, despite being connected to the internet. It is saying it is March 16 currently (about 2 weeks behind, see second screenshot). I am wondering if this is causing the anomaly in VRM as the data being uploaded may be overwriting past dates? I have tried rebooting the device and will report back if the time updates, but thought I would see if anyone else has this issue.

EDIT: Rebooting the device had no effect on UTC time, it is still displaying incorrectly.

EDIT the second: I changed the local time from the remote console and it changed the UTC time displayed as well. This changed was also reflected on the Rpi system by running "date" in terminal. I guess the question now is why the time isn't updating correctly from the internet.




smallsolar asked
smallsolar edited ·

0 Answers

Smart Shunt 500 firmware update got stuck at 44%

Yesterday I've tried to update firmware but the process has failed. This is my first unsuccessful firmware update attempt.

This firmware update was related to bluetooth improvements on the shunt but unfortunately caused the built-in BT got unusable.

Today I know more. Using the VE.Direct Bluetooth Smart dongle from my Blue Solar 100/20 I was able to connect the shunt. The update process was completed, and the shunt works well except BT what I didn't know yesterday.

I've done the factory reset but built-in BT still remains faulty. The blue and red LEDs blink alternating

I've created the service report and can send it if necessary.

So, is there a possibility to get the built-in BT to work ?

Thanks !

dogec asked
dogec edited ·

0 Answers

USBIP Support in Victron GX devices?

Does anyone from Victron think it could be possible - in time - to equip at least the modern GX devices with usbip support? Richt now we have a dedicated RasPi for that in some projects where we e.g. left a Mk3 on site to be able to remotely adjust parameters of VE.bus devices when necessary.

Should be not too much of a hassle to add that functionality and it would IMHO greatly extend the remote service capability of the installation. (not just for the Mk3 application, we also need to pass data incoming via a RS485->USB cable to another monitoring station).

petajoule asked

0 Answers

Can I control the Peak Power Pack via a VE.Direct connection to a SmartShunt?

I have read and searched the forum without an answer to my question (or I have not found it...):

When I connect the Peak Power Pack VE.Direct Port with an cable to the VE.Direct Port of the SmartShunt, can I then control the Peak Power Pack via a Bluetooth connection to the SmartShunt? My mobile connects to the SmartShunt and with the App I can then control the SmartShunt (Mobile->Bluetooth->SmartShunt) and the PeakPowerPack (Mobile->Bluetooth->SmartShunt->VE.Direct->Peak Power Pack).

maxmeister asked

0 Answers

cerob gx pin not working

hi having a nightmare i have fitted 10 of these with out to much trouble but now the cerbo will not allow the 000000 pin just keeps asking to par with device i have tried a new phone tried to reset but no luck the only thing wi have changed is the BVM712 for us is a wast of time so gone for the tbs made one with no bluetooth but cant see how this would affect it is there any way i can conect via usb to change the pin many thanks

richard-warry asked

0 Answers

is bluetooth GPS supported with the Cerbo?


I only found an old thread to this topic here, but looks this is outdated..

Does the Cerbo support Bluetooth GPS devices? As there are now the Ruuvi and the Mopeka devices feeding in data via BT, are there any GPS devices that are also supported for this? As I have to place a BT stick to the Cerbo and need one USB for USB-to-VE-direct, there is no more port left for a USB GPS, and if I could avoid an active USB hub, I'd be happy :)

Thank you!

christianf asked

0 Answers

VRM dashboard, minor bug

@Guy Stewart (Victron Community Manager)

The running dots showing current flows between the components shows current going to my Easysolar, even though it's switched off. (Switched off from VRM, physical switch on unit is on).

kevgermany asked
kevgermany commented ·

0 Answers

Unexpected current/voltage step with Multiplus 12/500/20 while charging LiFePO4

Hi everyone,

I set my Multiplus 12/500/20 to LiFePO4 charging curve yesterday when I replaced my former AGM with my new LiFePO4 (integrated BMS) in a camper van. Now I just had a look at the overnight charging curves and I am a little bit curios what triggered this current/voltage step? I would have expected the current to go down to ~0Amp continuously without interruption.

Any suggestions? Help is much appreciated and therefore thanks in advance.


thorben asked
thorben edited ·

0 Answers

Power flows not displaying correctly on main remote console page

3 Phase Ac coupled system, 10kW of production, 4kW of battery charge, whcih would the AC power flows not be showing under AC loads? Would I need an external current meter?


dbx120 asked

0 Answers

Smart solar MPPT 100/20 48V

Our VW camper has leisure battery, solar panel, electric hookup setup. Following installation of the leisure electrics, everything worked as expected for about a year. For the last 6 months, I noticed on the Victron app that the MPPT charger is "off" almost all the time. I assumed during the UK winter that this was due to low light and short days. We're now in Spain. The charger seems to come on for about an hour at sunrise, and the panel voltage gets up to about 18-19v. However, the leisure battery state of charge continues to diminish, and then the MPPT switches off as the sun gets higher. There is bright sunshine in the middle of the day, but the app shows no solar voltage generated. This pattern seems the same whether we're plugged in to a campsite EHU or not. Can anyone suggest what might be happening?

mcs asked
Andrew Ford commented ·

0 Answers

Multiplus II + 4* US3000C - Low Battery Voltage

Hi Community,

for 3 month i run 3* Victron Multiplus II + 3*US3000C. Firmware Version of all the Multiplus II is 502; Cerbo GX is v2.92 and Pylontech 1.7 (was already running 1.8).

The System run without any issues for the last 8-12 weeks, but since Monday evening I get “low battery voltage reported” and this in all flavors: At 52.00 Volt, at 51.50 Volt and at 49.00. Sure, the whole bandwidth is included.

I did a lot of research, thought one out of fours Pylontech (or even more) are defective, so connected all of them individual, but the issue remains.

I did a complete reset and fresh install of all Multiplus II, same behavior. As soon the MP2 come up proper, Low Voltage gets reported on Multiplus II Phase I (so the first one out of three).

I connected a Power Supply and started at 52.00 V. As soon all Multiplus II are up and running, the Voltage drops from 52.00 V to 45.00 V. Goes up again and down, until a Relays? Disconnect the input for a while.

Anyone knows or had a similar problem before?

Thanks and best,


steigman230 asked

0 Answers

Circuit breaker or supplementary protector: which to use?

My Mulitplus 24V2000 will be connected to a 20A circuit breaker in my basement subpanel. On the AC OUT side, I was looking at installing two 15A "breakers". Now I see that there are two different type MCBs: circuit breakers that are UL 489 and supplementary protectors that are UL 1077 certified. Given that I have circuit protection at my subpanel , can I simply use a UL1077 breaker on the AC Out side?

sneruh asked

0 Answers

Can I use 2 ET112

I’m currently using a Carlo Gavazzi energy meter on my ess install supplying all my loads with 66kwh of battery and it works really great. I was asked today if I could do a single install supplying 2 separate houses each with their own grid supply using an ET112 on each house supply. I can’t imagine this would work but just wanted to check before saying it wasn’t possible.

Also wanted to ask if the zigbee works well or not.

chapelier asked

0 Answers

vrm online but no history

I have a client with a system that is online, can look at it realtime, but since 19/3 there are gaps in the history, and since yesterday the history is completly empty. The ESS system is working normal.

Any fixes for this?

jejochen asked
jejochen commented ·

0 Answers

Top Contributors - Community Supporters

Alexandra avatar image Alexandra 286 Answers & Comments
kevgermany avatar image kevgermany 167 Answers & Comments
netrange avatar image netrange 159 Answers & Comments
Matthias Lange - DE avatar image Matthias Lange - DE 140 Answers & Comments
ojack avatar image ojack 101 Answers & Comments
matt1309 avatar image matt1309 77 Answers & Comments
Jons Collasius avatar image Jons Collasius 76 Answers & Comments