Raspberry Pi Image

Raspberry Pi

Data path of a USB stick on the Rasperry pi with Venus Os

Hello everyone

I have a Raspberry pi with Venus OS large and would like to write data to a USB stick plugged into the Pi using Node Red. Unfortunately I couldn't find out what the path of the USB stick is, and all Linux commands don't work to find it out. can someone help me?

saintgtr34 asked
jpetzrick answered ·

4 Answers

Node red login

All of a sudden when I go to Venus.local:1880 a screen comes up requiring username and password

i don’t believe I did anything to set this up and I don’t know what the username and password is

is there a default or a way to stop this happening ?

bear asked
Dirk-Jan Faber answered ·

5 Answers

BUG Node Red Phoenix Inverter Output Power Node only outputs null

I have a flow that is reading the Victron "Inverter" node and outputting the Output Power (W AC) to a gauge on the node red dashboard. I cannot get the node to output a value other than "null" both to the gauge and debug nodes. Other nodes that read the voltage and state from the inverter in question work fine. I also thought perhaps I could read the output amps and just multiply by the output voltage for the gauge but that also shows "0" no matter what the load. The inverter displays its output load in VRM and VIctron connect so I am assuming it is some sort of communication glitch.

I have Venus OS v2.90 running on an RPI4 with I think Node Red v. 3.02

Any suggestions would be helpful. TIA


smallsolar asked
smallsolar commented ·

3 Answers

Node red commando's via raspberry op cerbo krijgen

Ik ben het even kwijt.....

Als new be met Node red aan het spelen. Via het VRM portal lukt het om bv een dashbord te maken. So far so good.

Nu heb ik op mijn Raspberry (ook nieuw voor mij...) Node red draaien. Hoe krijg ik mijn data welke ik maak in de raspberry omgeving nu op mijn VRM portaal? Ik weet het even niet meer.....

castijn asked
castijn answered ·

1 Answer

node-red firmware v3.00-15 dashboard problem

When I power on the RPI the dashboard function always asks a UI redeployment. A small modification (move a node for a few mm) and deploy restarts the dashboard. How can I avoid that?


bobke asked
Matthias Lange - DE commented ·

2 Answers

I2C relay board or GPIO

I purchased an i2c relay board (DockerPi 4 CHannel Relay) that I hoped to use with my RPI running Venus OS to control some DC circuits based on temperature, battery voltage, etc. When I bought it, I wasn't aware of the differences between controlling the relays with i2c vs the GPIO pins (still not really clear on it). I see many instructions for installing extra relays that are controlled via node red etc by mapping the GPIO pins but not really anything on an i2c controlled relay board.

Is it possible (for an average diy enthusiast) to use this board in the manner I am desiring, or should I just look for a different GPIO relay board that others have already used to make this work?


smallsolar asked
smallsolar edited ·

2 Answers

Venus OS Large 2.92 - Debug and Logging etc

I'm working on some customizations to my Venus/Pi setup and running into some issues.


(A) Does leaving my desktop connected to Node Red ( for long periods (overnight) lead to problems that would not occur if I close the browser window when I'm not actively editing Flows?

Hunting around the Raspberry/Venus filesystem I'm not finding detailed logs so far.

(B) Where do I find detailed log files on Venus OS Large 2.92



Node Red?

Can Node Red log locally (on Pi3+ under /data) what appears remotely in the browser "debug" window pane?




(C) If, by default, Venus is not keeping detailed / debug logs, can someone tell me how to enable them?

(D) Does Venus OS Large v3.00~15 fix bugs in 2.92 that would make it a better choice now than continuing with 2.92? (I'd keep 2.92 SD card as-is for fallback and use a new SD card for 3.00)


Raspberry Pi 3+ - re-installed fresh in January 2023

Brand new SanDisk SD Card

apt update / upgrade done

Venus OS 2.92 - installed fresh

Node Red & Signal K enabled

MQTT enabled

Programming Node Red

Working as intended

Disabled MQTT via Remote Console at end of day

Had experimented with it, but didn't really need it

Left Node Red desktop browser window open overnight


In the morning, Node-Red in desktop browser unresponsive

SSH connection from Desktop to Pi3+ "broken pipe"

SSH reconnect attempt timed-out

Attempt to reload Node Red webpage (on desktop PC)

Refreshing web page very slow

took much longer than I was willing to wait for

Left for 2 hours

Checked Pi3+ again

Pi3+ does show up on router as connected device

Router shows Pi3+ is still sending/receiving data

Router indicates 2+ days connection time to Pi3+

Desktop browser to Pi3+ Venus Remote Console DOES respond

Checked Node Red

Responding, showing messages in debug panel again

Checked SSH

Responding, now it does connect to Pi3+ successfully

Seems like everything has returned to normal...?

texascharlie asked
Kevin Windrem answered ·

1 Answer

Controlling a 120V outlet based on temperature using Venus OS on RPi

What's the easiest way to control a 120V outlet, based on outdoor temperature, using the Venus OS running on a Raspberry Pi 3B+?. I've updated the OS to version 2.92, and have ordered several Ruuvi sensors. I also have the Victron Smart Battery Sense module installed.

I store my off-road camping trailer high in the Colorado mountains, where we have many nights with temperatures below the 25F threshold for my LiFePO4 battery. It's plugged-in though when stored, and I have a battery warming wrap -- I just don't want to leave the wrap plugged in all the time.

I'd love to be able to use something like a TP-Link smart outlet (WiFi), or anything Zwave or Zigbee would be fine too. I'd also consider using DuPont wires off of the GPIO pins on the Pi, though that would be my last choice as the length of these control cables seems pretty limited.

For those that have something like this setup -- what are you using, and has it been reliable?

techie4hire asked
techie4hire edited ·

4 Answers

SmartSolar MPPT 100/20 48V missing Load Current option in Node-RED in OS v2.92

I have just updated my 'operational' system from OS v2.80 to V2.92 and Load Current is no longer available in the list of available values in the Victron Node. It is however still present in the VRM displays and Victron Connect



Has anybody else experienced this problem and are there any suggestions on how to get the Load Current data into Node-RED? So far I have checked with dbus-spy and it does not seem to be present on the dbus either.

pcurtis asked
pcurtis answered ·

3 Answers

Node Red controlling Energenie ENER314-RT add-on board on Raspberry Pi running VenusOS Large


I've been trying to get an ENER314-RT add-on board working on my Raspberry Pi 3B running VenusOS Large and control it via Node-Red. This board is able to wirelessly control the Energenie remote controlled sockets, and I thought this would be perfect for switching loads on and off on the output of my inverter using Node-Red, when certain conditions are met.

There is a plug-in under Manage Palette in Node-Red called "node-red-contrib-energenie-ener314rt" and this loads fine on VenusOS, but errors saying it "cannot communicate with device" when I try using it.

I have tried the exact same Raspberry Pi running Debian with Node-Red installed, and the board works perfectly.

This board plugs in to the GPIO header on pins 1-26, and according to other posts on here, the relay out and IO in ports used by VenusOS are on later GPIO header pins. The board uses GPIO (not header pin numbers) 27,22,10,9,11,25 and 07 according to the datasheet.

Unless I'm missing something, this add-on board is not very popular with Pi users, and I've not seen it mentioned anywhere running on VenusOS, but any ideas to help get this working would be appreciated.



mopatops asked
mopatops answered ·

3 Answers

Add Relays - Does anyone have a an ‘idiots guide' on how to add more Relays to a VenusPi set up?

I’m only semi-computer literate - everything is trial and error and cut and paste and hours of google research… If the details include what software should be used and exactly what to type then I can usually muddle my way through. But when it comes to ‘just add a few lines of code in the xxx” I’m completely lost.

I have managed to burn an image to a sd card and install Venus Pi v2.60 large image on to a raspberryPi 3.

I have 1 Victron mppt 75/15 connected successfully to it vie ve-direct usb cable.

I have successfully got node-red running (and can even see it all via VRM Portal - including node-red which is amazing).

I’m still at beginnings of how node red works but can see its potential.

So far so good

But I’d really like to add more than 1 relay so I can control multiple external devices (like pumps, irrigation valves etc) and also control them through node red.

I’ve read the comments and half guides for adding extra relays - but they are incomplete or presume you know how to do certain un-explained steps. So I'm completely lost.

So - anyone have a step by step guide to add relays ? (and I’m on a Mac so Mac instructions would be great!)

Thanks in advance for all the amazing guides so far - and for the missing bits I hope someone will write soon…

thomas-g asked
Rob Duthie commented ·

4 Answers

ffmpeg installation package on Raspberry Pi

I would like to install the ffmpeg package on venus OS with raspberry Pi.

This package is not included in the standard repository of Venus os, i tried:

opkg install ffmpeg

i also tried to find a correct package which has the .ipk archive, but no result.

Does anybody have succesfully installed ffmpeg package onto a raspberry Pi with Venus OS?

stijnl asked
stijnl answered ·

3 Answers

Modbus Register for Relay 3,4,5&6 for Raspberry pi

Where might I find the Modbus registers for the Extra relays the Raspberry pi has? I have looked in the Excel Modbus-TCP register list, but can only find Relay 1 and 2.

I used the RpiGPioSetup add-on to assign the extra relays. I can see and control the extra relays using Remote Console.

I currently have NodeRed running on external device controlling Relay 1 and 2. I am looking to control the other relays (3-6). NodeRed is also pulling data from my BMV-712 / other Victron items.

mrorange asked

0 Answers

Raspbian oder VenusOS

Hallo Powerlovers ;) ,

komme leider nicht mehr weiter und hoffe hier ein paar Anregungen zu bekommen.

Hatte bisher folgendes Setup in meinem, in die Jahre gekommen Wohnmobil.

Raspberry Pi mit:

  • Raspbian
  • Node-Red
  • eine selbst gebastelte Gasflaschenwaage mit HX711 über die GPIOs (Node-Red)
  • Relais Steuerung meines Kompressors für Luftfederung über die GPIOs (Node-Red)
  • LED Steuerung über GPIOs (Node-Red)
  • RaspAp (Hotspot)
  • Huawei USB-LTE Stick

Nun hab ich mir den Victron SmartSolar Charger MPPT gegönnt und dachte ich könnte den problemlos über die USB Verbindung in Node-Red einbinden aber entweder finde ich nicht die passenden "Librarys“ um den Charger in Node-Red nutzen zu können oder es funktioniert nur über die Venus OS?

Nun habe ich Venus OS auf einer frische SD Karte installiert und der Charger wird sofort erkannt. Nun fehlen mir die folgenden Möglichkeiten die ich zuvor hatte.

Ist es möglich die folgenden Anwendungen in Venus OS zu realisieren?

  • eine selbst gebastelte Gasflaschenwaage mit HX711 über die GPIOs auszulesen?
  • Relais Steuerung meines Kompressors für Luftfederung über die GPIOs anzusteuern?
  • LED Steuerung über GPIOs zu steuern?
  • einen Hotspot zu generieren?
  • Huawei USB-LTE Stick Mobiles Internet über den Hotspot zu verteilen?

Bin über jeden Hinweis Link usw. dankbar

Power UP!


beatstreet asked
Meine_Energiewende answered ·

1 Answer

updating @victronenergy nodes in node-red failing

Raspberry pi 3B+, VenusOS Large V280.11/20

I clicked "update to 1.4.2" by the victron energy nodes in the node-red palette. I currently have 1.4.1 installed and working. The installation failed with the following output in the event log:

2021-09-07T04:44:28.988Z Install : @victronenergy/node-red-contrib-victron 1.4.2

2021-09-07T04:44:29.152Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @victronenergy/node-red-contrib-victron@1.4.2

2021-09-07T04:45:08.431Z [err] npm

2021-09-07T04:45:08.432Z [err] WARN rollback Rolling back @victronenergy/node-red-contrib-victron@1.4.2 failed (this is probably harmless): ENOTDIR: not a directory, lstat '/data/home/root/.node-red/node_modules/@victronenergy/node-red-contrib-victron'

2021-09-07T04:45:09.965Z [err] npm

2021-09-07T04:45:09.965Z [err] ERR! code EEXIST

2021-09-07T04:45:09.966Z [err] npm ERR! syscall

2021-09-07T04:45:09.967Z [err] mkdir

2021-09-07T04:45:09.967Z [err] npm

2021-09-07T04:45:09.967Z [err] ERR! path /data/home/root/.node-red/node_modules/@victronenergy

2021-09-07T04:45:09.967Z [err] npm

2021-09-07T04:45:09.968Z [err] ERR! errno -17

2021-09-07T04:45:09.989Z [err] npm

2021-09-07T04:45:09.989Z [err] ERR! EEXIST: file already exists, mkdir '/data/home/root/.node-red/node_modules/@victronenergy'

2021-09-07T04:45:09.990Z [err] npm ERR! File exists: /data/home/root/.node-red/node_modules/@victronenergy

2021-09-07T04:45:09.990Z [err] npm

2021-09-07T04:45:09.991Z [err] ERR! Remove the existing file and try again, or run npm

2021-09-07T04:45:09.991Z [err] npm ERR!

2021-09-07T04:45:09.992Z [err] with --force to overwrite files recklessly.

2021-09-07T04:45:10.080Z [err]

2021-09-07T04:45:10.080Z [err] npm ERR! A complete log of this run can be found in:

2021-09-07T04:45:10.080Z [err] npm

2021-09-07T04:45:10.081Z [err] ERR! /home/root/.npm/_logs/2021-09-07T04_45_10_053Z-debug.log

2021-09-07T04:45:10.204Z rc=239

When I ssh into the raspi and go to the node_modules directory I see that @victronenergy is not a directory but a file with 0 bytes. The file config.nodes.json file, however, seems to point to "/usr/lib/node_modules/@victronenergy/node-red-contrib-victron/src/nodes/config-client.js" so maybe that's why the update do not work.

My question is, how do I make it work without screwing something up? :)

mrhappy asked
mvader (Victron Energy) commented ·

1 Answer

17 Posts
354 Users

Topic Experts

Kevin Windrem
1192 Points
340 Points