wifi Image


Cerbo WiFi Won't Auto Connect to WiFi

My Cerbo will not automatically connect to any wifi source. All connections have to be manually initiated through the menu. Rebooting the Cerbo or the WiFi router does not help. Other networks and phone hotspot all show exactly the same behavior. Connections can be manually initiated, but never automatically.

The installation is on a sailboat where the wifi environment is challenging. A connection rarely lasts more than a few hours, so having a lack of automatic reconnection is more than a bit of a pain.

Is there a setting I am missing?

billknny asked
billknny answered ·

2 Answers

Cerbo Wifi error stays after reboot

We are remotely helping a boating client who in 1000 klms from us, has lost mains power at the marina, batteries have drained and WIFI has been lost. Our last data on the VRM portal was 4 days ago. After power is restored, we have not been able to get the Cerbo to connect to his onboard WIFI as it has a "timeout error" after 30 retries. Understandable given the WIFI network was down so the Cerbo tried to reconnect many times.

We asked the client to bluetooth to the Cerbo with the phone Connect app and it says it is connected to the WIFI network, however the Cerbo touch 50 screen says it still has the timeout error even after the Cerbo has been rebooted.

We thought the reboot would clear all errors but this one seems to be a bit elusive. What are we missing?



trevor-bird asked
trevor-bird answered ·

3 Answers

Cerbo GX WiFi Frequency

I am unable to see my 5GHz WiFi networks with my Cerbo GX. I can’t find any documentation specifying what type of WiFi networks the Cerbo can connect to. Does it only support 2.4gHz?

jsalbre asked
usmc370 commented ·

4 Answers

Cerbo GX not connecting to WiFi

Cerbo GX Running Firmware 2.63 with GX Touch 50 Display.

I just got home from having the solar install completed. The installer connected to my Verizon MiFi without a problem and it worked for two days while learning the system and on the two days to drive home.

HOWEVER, when I got home I noticed it was no longer connected. The last time the stars updated was 17 hours ago - so it disconnected sometime around midnight. I tried reconnecting using the VictronConnect app and all I get is a "Connection to XYZ network Failed" error. This is just a reconnection attempt to the same MiFi that it was connected to for the past two days. No configuration changes to either the MiFi or the Cerbo GX.

I tried connecting to my home eero WiFi network and I get the same connection failed message. The eero WiFi system broadcasts both 2.4 and 5GHz networks under the same SSID. It has the ability to turn off the 5GHz and only broadcast 2.4GHz for 10 minutes to help with connection problems. But, that didn't help. I also tried turning off the 5GHz on the MiFi and only broadcasting 2.4GHz with no joy.

This is not a bad password issue, because I did mistype the password on one connection attempt and got an "Invalid Password" error - completely different.

It is very frustrating to have just spent all this money of a state of the art system to have it not work before it's a week old.

Any ideas will be greatly appreciated.

John McDermon asked
usmc370 commented ·

5 Answers

Cerbo GX wifi issues

I have had my Cerbo GX with touchscreen installed in my motorhome for a couple months now. Most of the time it won't stay connected to my WiFi, which is about 8 ft above it. I use a Pepwave Max Transit Duo WiFi modem, so it's a pretty strong unit and the Cerbo shows around 75-80% signal strength. I can force it to connect, and sometimes it stays connected, sometimes it doesn't. Even when it's connected, I can't connect to the remote console much of the time. I'm on Firmware 2.57. Any suggestions?

evin-carr asked
lorenzo-cavallo commented ·

7 Answers

Cerbo GX and 5.8Ghz WiFi

Can anyone suggest a USB WiFi adapter that supports 5.8Ghz
Looks like mine has the common WiFi + Colour Screen issue and is super unreliable. And to think I blamed the router.
For many reasons I prefer my equipment on 5.8

rdcat asked
nickdb answered ·

1 Answer

Can Color GX use Wifi for remote VRM comms and wired LAN for direct comms to SolarEdge HD Wave

My system has a Multiplus 2 with color GX and SolarEdge HD wave solar inverter.

I can successfully connect to remote VRM using the recommended Asus USB-N14 Wifi router.

I can also conect the SolarEdge to the Color control via wired LAN.

Can I enable both interfaces to work at the same time. The Wifi is intermittent at this location so I want to use the simple (reliable) LAN connection to the SolarEdge and then use the unreliable Wifi for remote VRM updates.

Is there only one ethernet stack in the Color Control which can only be switched to either Wifi or LAN or is there a way I can enable both, but with only the wifi being used for remote VRM use?

Regards - Jeremy Dale

j-n-dale asked
av1um edited ·

1 Answer

802.1x (WPA2-Enterprise) WiFi Support on Victron CCGX

Is there support for connecting the Victron CCGX to an 802.1x WiFi network using WPA2-Enterprise? This would require authentication using both a username and password, rather than just a shared password as in WPA/WPA2-Personal.

Even though the UI doesn't reflect this option, is there support available in the underlying operating system, and could you point me towards the relevant config files if so?

Matt Knight asked
Thiemo van Engelen (Victron Energy staff) answered ·

1 Answer

Solution to Cerbo GX Wi-Fi issue when having the GX Touch connected

Dear all,

This message is to inform about a Wi-Fi related problem in the Cerbo GX. Some Cerbo GX-es will not properly work on certain Wi-Fi networks when having a GX Touch display installed. If they do or not depends on the (channel of the) Wi-Fi network, and on how exactly an antenna cable inside the Cerbo GX ended up when manufactured.

Its obviously not good and I’m not happy with it, but it is what it is and you’re better off knowing all the details than not knowing them.

There are a few solutions, one is to simply send it back to your dealer; to have it repaired.

The other is to make the wifi network work on a one of a few specific channels; which don’t have the issue (details in the pdf)

And lastly, if you’re technical, you can fix it by opening the unit up and repositioning the antennas to make sure its cable is no longer close (or even touching) the hdmi connector or surrounding area.

Now, don’t get me wrong wrt the repair: you’re more than welcome to return it for repair. But still I chose to share the details of the repair as I can imagine that for some it will be the preferred option.

Lastly, my apologies! Especially to those who have spent a lot of time trying to find out why it wouldn’t connect to wifi.

And a big thank you to @WKirby who helped uncover the issue and even to find the solution. Warwick has been a great help in this.

All the best,

Matthijs Vader

Ps. All distributors and dealers have been informed about the issue via email.

2021-03 Cerbo GX Wi-Fi issues when combined with GX Touch - v2.pdf

mvader (Victron Energy) asked
anders-3 answered ·

6 Answers

Best Wifi USB for CCGX (As of August 2020)

I'm adding solar to a boat that I built and it's docked at my brother's house on the river. His wifi is good, but the boat will be about 120 feet away from the house, so I need a long range usb wifi dongle.

I'm confused on the best solution for the CCGX.

The current documentation (Section 1.6.2) found here: https://www.victronenergy.com/live/ccgx:start#internet_connectivity

says that there are 4 solutions, but only shows the 2 with victron part numbers. What are the other 2 options?

Also, when I google BPP900200300, the result is a 1 antenna device, and the ASUS model has 2 antennas.

Which is better?

Has anyone experienced this weird gap and confusion of information in the documentation?

Any insight would be very helpful!



unckdecamp asked
corkery answered ·

8 Answers

WIFI rtl8188 not working with 2.72


I installed the newest 2.72. I had my system up and running with the 2.6 version. My dongle worked perfectly. With the new version the follwing message comes up in dmesg:

usb 1-1.2: new high-speed USB device number 7 using dwc_otg

[ 175.823447] usb 1-1.2: New USB device found, idVendor=2357, idProduct=010c, bcdDevice= 0.00

[ 175.831852] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3

[ 175.839275] usb 1-1.2: Product: 802.11n NIC

[ 175.843580] usb 1-1.2: Manufacturer: Realtek

[ 175.847887] usb 1-1.2: SerialNumber: 00E04C0001

[ 175.854117] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)

[ 175.913522] r8188eu 1-1.2:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2

[ 175.922760] r8188eu 1-1.2:1.0: Firmware rtlwifi/rtl8188eufw.bin not available

[ 175.929907] MAC Address = 28:ee:52:17:50:88

[ 175.962361] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

[ 176.163659] usb 1-1.2: USB disconnect, device number 7

[ 176.169797] R8188EU: indicate disassoc

Seems like the driver is not compiled anymore. Would be great if this dongle could work again. Any hints?


don-davici asked

0 Answers

Cerbo GX Turn off Wifi?

My Cerbo GX (v2.63) is connected via an Ethernet cable to the router (very stable now). Is there a way to turn off the WiFi on the Cerbo GX?

I've been looking in the menus and this forum, find references to the reset button, etc. but still confused if can turn it off.

Thank you

shicks3 asked
seb71 commented ·

2 Answers

Disabling Cerbo WiFi

I am considering deploying the Cerbo GX product, but I absolutely cannot have it running WiFi on the 2.4 GHz band as it will interfere with the very weak access point at my harbor. I know - I've tried this. I can't even have the Cerbo transmitting in "client" mode on 2.4 GHz. I need to either disable the Cerbo WiFi from transmitting entirely on 2.4 GHz and use ethernet connectivity to my router (preferred solution), or use the Cerbo Wifi on the 5 GHz band.

Reading the manual, it appears I can not do either. Am I correct?

cpt-pat asked
wkirby answered ·

1 Answer

Cerbo GX Remote Console connection issues after FW update to 2.62 (also in 2.63 and 2.65)

Yesterday I updated my Cerbo GX from firmware 2.60 to the newly released 2.62.

Cerbo GX is connected to my Internet router using WiFi.

Several times already (first time it happened yesterday, while looking into the Cerbo GX settings after the FW update) Cerbo GX was not accessible using Remote Console via LAN for several minutes.

After a few minutes I can access it again (without doing anything to fix the issue).

When this happens, on VRM there are no updates for a few minutes (VRM portal log interval is set at 1 minute).

Not sure if this is a WiFi issue (haven't got a chance to try it with a LAN cable since updating the FW) or if Cerbo GX freezes for a few minutes and that is why I can't access it with Remote Console over LAN.

The WiFi and Bluetooth LEDs are blinking normally even when this happens (or I did not catch them in time).

Yesterday, after the first time it did this, I did a Cerbo GX reboot (from Remote Console menus), but again it had the issue today: once when I tried Remote Console from a phone and second time when I tried from a PC (both devices were in the same LAN with Cerbo GX).

I never observed this problem with 2.60 firmware.

Anyone else has this issue after updating the firmware to 2.62?

seb71 asked
Lourens answered ·

14 Answers

Fronius ccgx issues

I have an ess system with an ac coupled fronius on the ac out, both the ccgx and fronius are connected to the LAN via WiFi, the ccgx will not find the pv inverter and after being on line for about 2 hours is now off line showing a DNS server error, is there something wrong with this configuration? Any suggestions? Would be disappointing if the solution was hard wiring the Ethernet as the tech docs say you can do either..

dane asked
chuff answered ·

3 Answers

Easy solar 2 3000va wifi signal is very weak

I recently install the Easy solar 2,

The wifi router is maybe 4meter (LOS) from the Easy solar unit, and it shows like 40% signal.

The remote console is so slow its barely useable.

Somethign does not seem correct on this unit with the wifi? Mine also seems to go offline sometimes, it doesn't try and reconnect.

Anyone else having issues like this?

dylan-hyslop asked
Paul B answered ·

1 Answer

Easysolar II GX 3000VA Venus WiFi issue

I installed a 48V 3000 Easysolar II GX in Feb this year, when I was commissioning the plant and setting it up on the portal we had an issue with the Wifi network from the Venus and for the life of me couldnt get it to come on again. Does anyone know what we can do to sort this out? I know on the Venus you can reset the wifi network but with the Easysolar its not easy to get to the Venus.

rossmuller1 asked
dylan-hyslop answered ·

1 Answer

Question about relocating the WiFi antennas in the Cerbo


I need to relocate the WiFi antennas in my new Cerbo. I am concerned about removing the pcb closest to the antennas as the connectors all fit or nest in the case without too much margin. I fear damaging or cracking the case. Has anyone who has made that antenna change have any suggestions or comments?

cabezonbd asked
Mark Maritz commented ·

0 Answers

EasySolar II - Network Reset?

Hey Victron Community,

We recently had an Easy Solar II installed at our house.
While trying to connect to the local WIFI, I have unchecked the "Create Access Point"... (yeah rookie mistake Im now aware of :) )

Ive tried connecting to the device via the LAN connection, but remember while browsing the settings prior to disconnection that LAN was disable (how it was installed).

So... Is there a means to reset just the Network Settings outside of the Digital Control panel?
I see there is a reset button on the Easy Solar II, and I have tried to search online for what this button does, but have come up short.
Is this a factory reset button? Reboot? or Network reset?
I do not want any of my other settings (charge level/battery settings) to be lost if possible.

blitzkonig asked
kkiksu commented ·

2 Answers

Is there anyway i can monitor my Victron equipment via wifi?

I've got a Victron MPPT and a Victron battery monitor installed in my camper trailer. The trailer is also equipped with a 4g router that runs off of 12v power. While i love the ability to monitor my Victron equipment via bluetooth, it would be amazing if i could remotely monitor the setup from home when i'm not at the camper trailer. Any solutions?

lorettaboy asked
wkirby answered ·

1 Answer

Cerbo GX WiFi stop working when GX Touch 50 is connected


My Cerbo GX is connecting fine on WiFi without the GX touch 50 connected, but as soon I connect the GX touch 50 on it, the WiFi State goes from Disconnected to Connecting many times then Failure state

The WiFi signal strength is 76%

Cerbo firmware v2.60

Thank you for your help

steve777 asked
mvader (Victron Energy) commented ·

7 Answers

IEEE 802.1x

Why is there no IEEE 802.1x support on any device?

mbr89 asked

0 Answers

Is there any Compatible usb Wifi Module for the Victron Colour Controller CCGX

I am looking for a Compatable wifi module for the CCGX Victron colour controller or how to configure eg, TPlink usb wifi module to be recognised by the CCGX.

email: ebrahim@brighthousesolar.co.za Country: South Africa

Ebrahim Railoun asked
markus answered ·

4 Answers

Cerbo GX Wifi access point connectivity issues

Hi all,

I installed an off grid system in my home last April which has been running fine with no issues.

Set-up: Cerbo GX (firmware 2.60 - no touch screen), Smartsolar MPPT150/60, MultiPlus 48/5000/70-100, 4x pylontech US2000

No AC input from grid or generator.

Mostly it is connected to the house wifi with no issues - in fact I didn't need to touch it until December.

During the middle part of December and up to the present I have been shutting down the Multiplus over night to conserve the batteries due to overcast days and/or thick frozen snow on the panels reducing production.

The problem: Connecting to the wifi access point after several hours. More precisely if I use the reset button on the Cerbo I can connect using an iphone or ipad, but after some time (variable between 2 and 12 hours) it seems impossible to reconnect without recourse to the reset button. I get a message that connection is impossible, or the password is incorrect etc.

I've tried using the "forget network" on the iphone and trying to reconnect, a la Blue tooth etc, but no joy. The only solution seems to be to physically reset on the Cerbo. This is somewhat inconvenient as access to the Cerbo is difficult.

I've also tried connecting with a Linux laptop with the same symptoms.

Question: Is there something I am missing in the network setups - I haven't changed any settings form the defaults. Networking is a bit of a dark art to me! Any ideas????

Thanks in advance


matt09 asked
matt09 commented ·

2 Answers

Cerbo GX WIFI connection

I have a Cerbo GX and cannot connect to WiFi. I am using my phone (android) To share its 4G connection via a hotspot. I have also done the same thing with 2 laptops. I manage to get it to connect once. I am using firmware 2.60. Any help would be appreciated. Thanks

gls asked
gls answered ·

1 Answer

Wifi issue with a 48/3000 EasySolar-II not connecting

An installation I did a few months ago has developed a problem which I’m hoping someone here might have a solution to.

The firmware in all components of the ES-II were updated to current prior to installation.
WiFi is via hotspot on the customer’s mobile phone which he takes off-site frequently, but also places in range (close proximity) of the ES-II to allow data to be uploaded to VRM at least daily.

For the approximately two months from installation it all ran smoothly, but now the WiFi in the GX device is not connecting to the phone.
When I went onsite it appeared the unit had ‘lost’ the WiFi password.

After re-entering the password the unit displayed ‘Connecting’ for a few minutes (maybe 5-min?) then after logging on, lost that connection almost immediately.

I repeated the logon attempt using a different phone (mine) and saw the same thing.

Back to the customer’s phone and it happened again.

Is it possible there’s a fault with the unit, or is it likely to be a programming issue, or something in the recent firmware?

Along with the EasySolar-II, the system comprises 12 x 285W PV, 3 x PowerPlus Lithium Cells (in parallel)

Any advice or information greatly appreciated.

diamond asked
diamond commented ·

0 Answers

Preferred wifi setting of Venus GX

I keep losing wifi

What is preferred wifi setting of Venus GX i.e. WPA-PSK, WEP or other parameters

stuart-a asked

0 Answers

y a t'il moyen de désactiver le wifi sur easysolar II GX ?


Existe t'il un moyen de désactiver complètement le wifi sur le dispositif gx equipant l'easysolar II ? Un client potentiel qui a des problèmes d'hypersensibilité aux ondes EM me soumet le problème suite à mon devis de système autoconso ESS.


yann asked
Thierry Cortassa (Victron Energy Staff) answered ·

1 Answer

Currently available and cost-efficient USB Wifi adapter for **GX devices

It would be good to have an updated list of Wifi modules that the CCGX supports. Because the article about it on the Victron website (https://www.victronenergy.com/blog/2014/12/12/color-control-gx-accessories-tips/) is almost 3 years old and for example the ZyXel NWB2105 isn't available anymore!

I tried 3 other USB Wifi modules: 1 works, but doesn't fit in the CCGX housing (Sitecom WL-344), 1 doesn't work (Sitecom WLA-2100 v1001 > no driver support, isn't recognized), 1 sort of works, but is very slow and unstable. (Generic Nano USB)

Could someone please provide the brand/type specification of a few USB Wifi modules that work with the CCGX and that are generally available. (I am curious which USB Wifi module Victron uses in house for testing purposes at this moment.)

What would help me (and other users) mostly is the specific brand and type of USB Wifi module that 100% works well with the CCGX and is generally available at this moment in time.

I have been trying to figure out which currently available USB Wifi module is a good replacement for the ZyXel NWB2105 (antique by now), but the "buy-and-test" approach is costing me a lot of money and time, as I am down to my 3rd module that doesn't work...

If other users have good tips (with a link to the shop that sells them. I am in The Netherlands, BTW, but we should aim for a Wifi module that can be bought everywhere), that would be appreciated as well! ;-)

Thanks in advance! :-)

Dave van Dongen asked
johnfr answered ·

11 Answers


73 Posts
69 Users

Topic Experts

11 Points
0 Points