MK3 Image

MK3

Macbook, Parralells MK3 USB driver not available

I have a new 2021 M1 Macbook, running Windows 11 on Parallels.

I need to add a PV inverter assistant to a three phase Multiplus system.

The MK3 USB connected seemlessly with Victron Connect in Apple but no matter what I have tried I cannot get the MK3 USB to be recognised - "Driver is unavailable" by Windows or Ve configure tools.

I have have read numerous community posts and searched Victron information manuals, reinstalled the configure tools, rebooted, updated, set the USB drive, tried through VE Configure 3, tried numerous ports, tried through apple terminal, tried through windows many times and no luck.

The VE config says use the "found new hardware" assistant to specify the location but I can't find such an assitant any where.

How do I get the driver and MK3USB recognised ?????



greg0448 asked
bathnm edited ·

8 Answers

Old multiplus cannot change state or current limit from venus os

I have an old multiplus compact 12/800/35 with old processor and firmware updated to 1903209 (original is 1903141) connected with mk3-usb to raspberry pi running venus os 2.80~29. no other ve.bus devices connected


The problem is that I cannot control the inverter state or change the input current limit remotely. Even when I connect the mk3-usb to computer and use ve.configure 3 virtual panel, none of the virtual switches work.


If I communicate directly with mk3-usb using commands from this link:https://community.victronenergy.com/questions/1096/mk3-usb-s-state-command-does-not-change-panel-swit.html

I can successfully switch the inverter on/off and change the input current limit.


What I noticed is that the inverter name in venus os is "phoenix multi compact 12/800/35-16" which is not exactly correct as it is not phoenix branded but propably doesn't matter. Also ModeIsAdjustable is zero in dbus which indicates that the remote inverter mode change is not supported?


Should this work or is the multiplus too old? Also I am not sure if I set the dip switches correctly. Now they are set to use the main switch on the inverter as if set otherwise I cannot turn the inverter on.




ileeezi asked
ileeezi answered ·

2 Answers

Multiplus 12/3000 shows as "initialising" when connected to VictronConnect via MK3-USB

Hello,

My Victron Multiplus 12/3000va will connect properly via bluetooth when connected to my bluetooth dongle, but when I try to connect to my Mac laptop via the MK3-USB, it shows as "initialising" and I can't change any of the settings as a result. I've tried to download the VE Configuration tools to see if that would help, but i get an error message that states "invalid format" when my Mac tries to extract the zip file. I assume this is because these files are made for Windows?


Any help would be appreciated. Thanks,

rjensen25 asked
rjensen25 edited ·

0 Answers

VEConfig "Internal error occurred" when setting up assistant.

Hi All

I get the error "Internal error occurred! Please contact Victron Energy" when I am setting up an assistant in VEConfig. I am able to do firmware updates and all other settings but not the assistants. This happens whether I am using a mk3 or through VRM remote VEConfigure.

Also each time I open VEConfigurator3 it updates the assistants.

The issue started when I had updated the first inverter to 489, after the update it had to update the mk3 and VEConfig. Since then I am unable to load assistants on any inverter. Same happens with inverters on 490 and older versions as well.

I have uninstalled, redownloaded and reinstalled VE Configuration tools but still have the same issue...

Hope someone can help.

Thanks

mike90 asked
mike90 commented ·

2 Answers

VictronConnect and Multiplus with MK3

Hi All,

I just bought an MK3-USB and tried to connect to my Multiplus Compact 24/1600, firmware 1916137 with VictronConnect, latest version, it said firmware not supported and I need to upgrade to 200. After the firmware upgrade, it now says v209 is not compatible with all the functionalities in VictronConnect and I should contact the dealer for 415 or higher upgrade.

Also, once its eventually connected, all the settings are greyed out, when I click enable, it seems to accept the password ZZZ biut still I am unable to make any changes.

Any ideas?

roks asked
Matthias Lange - DE answered ·

1 Answer

USB MK3 FOR old multi with firmware 1918141c

Hi guys.

Am I reading it right that even my multis are old (have been in the boxes since 2012..) I should buy MK3 USB and not the old MK2?

My firmware is 1918141c.

I also understand that I cannot use Connect but should use Configure?

Pls advise, dont want to buy sth that is not compatible..

Thanks!


Minas Papageorgiou asked
dwmarine answered ·

1 Answer

settings MultiPlus-II GX and MultiPlus-II via VE.Bus

Change settings MultiPlus-II GX and MultiPlus-II

I have a few questions that I can't seem to find an answer to anywhere. That's why I hope this group could help me.

We are looking for a Victron setup. At home we have a 3 phase suply. That is why we have chosen for ourselves 1x a Multiplus-II-GX(L1-N) and 2x Multiplus-II (L2-N and L3-N).

We would like to be able to configure these devices. Everywhere in the manuals they talk about an accessory (Interface MK3-USB) for configuring the devices. But I was wondering since we have a Multiplus-II-GX we can set it through the internet port. And if this Multiplus-II-GX is connected via the VE.bus ports to the other 2 Multiplus-II could these devices be set up like this trough the GX? Or is It realy nasecary to configure these units to heave a MK3-USB converter. We would also like to keep our system in check via the (VRM system). For that you would need a Cerbo GX. If I understand correctly, this device would ensure that all data about my Multiplus-II is available via the VRM. But since I will have a Multiplus-II-GX is it still necessary to add such a Cerbo GX? Or can the Multiplus-II-GX version also talk to the VRM-online system?

Hopefully my question is loud and clear. Hopefully someone knows if this would be possible.

Thx!

Sander Callewaert asked
Alexandra edited ·

1 Answer

MK-3 USB / VEFlash Error at step 'Connect part 2'

Hello,

I have multiplus 40/3000 and my old FW is:

2620158 i believe i need 2620159 with im trying to update.

But having error.

I dont have problem to VeConfig, Victron Connect does not work becouse my FW is to old.

Swapped device, changed ports and all... still no luck.


Tried to google solution but cant find any,


I want to update FW and go with Generator configuration as every 60 sec there is a swap between charger to inverter.


[image]

I've tried another ethernet port and no luck still.

I'm under off grid so I only has batteries connected.

Closed

magicmike asked
magicmike answered ·

2 Answers

Is my MK3-USB Faulty?

Please see the attached unlisted Youtube video.

Basically when I plug the ethernet cable in to the MK3 the inverter faults, unplug the cable from the MK3 it will recover ~20 seconds later. I've ensured the cable is not faulty, tried a few different ones, all none crossover.

When I first plugged the MK3 usb cable into the computer and ran VEConfigure3 the software found it no problem and asked to update the firmware which was successful.

Video link
https://youtu.be/54naMCYx7w4

drdiesel asked
drdiesel answered ·

3 Answers

MK3 Case Lost

Hi,

Unfortunately I lost the top part of the case from my MK3 interface.

The interface is still fully functional but like this it is vulnerable.

It is somewhere in the bilge of a large ship under the motor, not able to find it there.

So if someone has a defective MK3 lying around I would be helped.

Any other cheap solution is welcome.

I suppose Victron is not able to deliver an empty case...

[image]

[image]

[image]

Peter Buijs - NL asked
wkirby commented ·

1 Answer

Mk3-USB an absolute nightmare

I'm starting to regret buying a Multiplus II as setting it up is proving impossible.

The Mk3 adaptor is working fine as it feeds data to a raspberry pi.

I run Linux, which Victron don't support, but I have an old Windows XP laptop which will run the software. However it will not connect to the Mk3. I have followed all the instructions multiple times. The download driver from the internet does not work. The one that VE config provides does not work. Does anyone know of a driver that does work with XP and where I can get it ?

It is a shame the Multiplus is so difficult to setup, the other kit is all very simple via bluetooth. Having various bits of software which half do the job is a complete waste of time. Victron need one cross platform program that will deal with everything, and built in bluetooth for the Multiplius, it costs enough...

muddy1 asked
muddy1 answered ·

9 Answers

How to parallel two 3000 multiplus 3000

Is there a site which explains how to upgrade and connect two multis in parallel using the mk3 ?

philippanama asked
Matthias Lange - DE answered ·

1 Answer

MK3-USB driver unavailable 10 seconds after installing it.

Every time I install the MK3-USB driver it becomes unavailable again in on a few seconds. Then i have to remove device, unplug it, replug and try again. Dozens of times, no luck.


gary

JedTheFed asked
JedTheFed edited ·

1 Answer

How to set inverter and charger current with mk2 bus

Hello, i want to set the Victron Multiplus 24/1600/50 inverter or charger current with the mk3 usb interface. i read the VE.MK2 protocoll but it is not clear for me how to do.

i tryed to create a 'S' command, but it do not work.

if i switch the inverter with the switch on the inverter to inverter mode it starts to invert full power.

i do not know why?

i tryed the command

07 FF 53 02 03 05 01 01 9B -> answer is OK

but nothing happens.

br

Franz


franzwi asked
juan3211 answered ·

1 Answer

Unable to connect with Multiplus via MK3 USB

Hi

I am installing a system using Multiplus charger/inverter. I need to configure the Multi. Hence communication between PC (Lenovo Win10) and Multi is required.

I have installed the VE configure III and I have a MK3 USB interface.

When I let the VE Config auto detect nothing happens i.e. the programme is doing a search and eventually times out.

When I try manual connection to e.g. Com3 an error message apperas saying "Cannot open Com3" - it does not help to change Com port no.

I have removed and re-installed the MK3 driver. In device manager I am able to locate the virtual serial port i.e. that part seems to work fine.

I have also tried to use the VE Bus Quick Configure software - and the error is the same

Any good suggestions?

p.s. I have tried on a different Multi and the error message is still the same. I have not tried a different PC yet - not so easy due to remote location

gustav74 asked
nay73972 answered ·

7 Answers

MK3-USB Causes laptop to reboot

Connecting the MK3 to USB cable to the USB port on my computer causes the computer to reboot. It will continue this reboot cycle until the MK3 to USB is removed. Any other USB cable plugged into the computer does not cause this problem.

embthree asked
Kevin Windrem commented ·

1 Answer

MK3 interface to usb

Is an MK3 interface the same as an USB 3.0 to RJ45 interface?

The USB 3.0 interface communicates but there is no communication with my Multiplus Compact 12/800/35.

paulleten asked
sigmund answered ·

5 Answers

VictronConnect v5.45 upgrade - now no connection to my Multiplus 12/3000/120

Multiple previous connections using VictronConnect on Win 10 using MK3 to my Multiplus. Upon launch of VictronConnect application today it auto upgraded to v5.45, now I am unable to connect to my Multiplus. Verified proper wiring, connections, and MK3-USB is active on COM3 in Windows 10 device manager. NO other changes on the PC that I had previous connection success with. Force Connection also does not work.

john-gibson asked
john-gibson answered ·

1 Answer

VictronConnect 5.42 not finding Multiplus device on Windows with MK3-USB LAN

Hi

I am familiar with VictronConnect on bluetooth and Android - no problems there.

Today I purchased MK3-USB interface, installed VictronConnect 5.42 on laptop and desktop PCs, tried 2 brand new LAN cables to connect to new Multiplus 12|500|200 (which is powered on). VictronConnect simply reports "No devices found"

Have tried different computers and cables, reinstalled VictronConnect, turned firewall off, run as administrator. But result always the same, after a few seconds of searching: No devices found

What else can I try?

Thank you

gerald-d asked
gerald-d edited ·

2 Answers

VeConfigure3 and VictronConnect don't recognize Multiplus via MK3

I can't get my Multiplus to be recognized in VEConfigure. I've got an MK3-USB, dowloaded the drivers, restarted the computer, reinstalled VEconfigure. My USB drivers are working OK, computer is fine, but for whatever reason I can't get my Multiplus recognized on VEConfigure3. It also won't show up on VictronConnect.

My CerboGX and Touch50 recognize the Multiplus just fine. What else can I do to adjust the parameters of my Multiplus?


I need to adjust some setting on the multiplus for my pylontech batteries.

agroventuresperu asked
agroventuresperu commented ·

1 Answer

Mk3 defekt? Keine port Auswahl

Ich möchte mein multiplus 12v 2000 mit der HQ2101 gerne konfigurieren. Der multiplus ist über AC angeschaltet. Nun findet das Mk3 Dongle aber das Gerät nicht und ich habe nur die Möglichkeit zur automatischen Port Auswahl. Was mache ich falsch?

razer05 asked
razer05 answered ·

9 Answers

MK3 ok with victronconnect but not ve config

With two installers at site, two laptops, two MK3's (both with moulded in cables) both can connect to the Mulitplus-II GX with VictronConnect. But when they close VictronConnect and open VE Config (to set up PV Support assistant) they cant connect. They get 'Help on Connection' notification, etc, Have tried downloading drivers, running Prolific_DriverInstaller , etc etc but no change. (have also tried setting up via VRM but limited connection at site)

Any thoughts?

David asked
Guy Stewart (Victron Community Manager) answered ·

1 Answer

15KVA Quattro Programmable Relay And Safety Switch Assistant

I have a 15KVA Quattro running ESS Assistant and set to use 60% of battery capacity for self consumption (Optimised without battery life).

I am looking to switch off/disconnect the AC output at 30% SoC in case of grid failure/load shedding/poor quality mains supply using assistants ( I understand from the ESS manual that the settings in the Ve Configure 'Inverter' tab for DC low voltage shutdown and shutdown on SoC are completely ignored while running ESS.

In the VeConfigure assistants page, I have set after the ESS assistant;

1) Programmable Relay (Drive on SoC), set 'Primary Programmable Relay' ON when SoC at 30%

2) Safety switch assistant set to switch off when the Aux 1 relay is set to ON.

3) Programmable Relay (Drive on SoC) to set Aux 1 back to OFF when SOC at 35%

I have written the assistants but nothing happens when SoC gets to 30%, the inverter keeps going and drains the battery beyond my desired setpoint.

I understand there is some additional physical wiring to be done for the safety switch to work - I have three questions.

1) Are the Primary Programmable Relay and Auxilliary Input 1 thesame?

2) If they are thesame is it safe to short the + and - on the Auxilliary input 1 without damaging the inverter?

3) Can anyone please help identify the specific physical contacts/safety switch connection points to use on a 15KVA Quattro and how to wire it up correctly?

neeyee asked
Daniël Boekel (Victron Energy Staff) commented ·

1 Answer

Configuring Multiplus with Pylontech Batteries (Possible with just CerboGX and Touch 50)?

I have a solar kit I bought recently with a Multiplus 48/5000/70 and a SmartSolar 250/100. The system has a CerboGX and Touch 50. The battery bank is 4 Pylontech US3000.

I was reading the Victron-Pylontech compatibility article, and just watched a webinar on the topic, but I'm still unclear.

To make sure all my Victron components are configured properly according to what the batteries need, can I just use the VictronConnect app via my smartphone? Does this operate via some sort of bluetooth connection internal to the CerboGX?

Or do I need to buy the Smart Dongle or MK3 USB separately?

Doesn't the CerboGX and Touch50 replace the need for the VictronConnect app or at least replace the need for the SmartDongle/MK3-USB?

agroventuresperu asked
Alexandra edited ·

2 Answers

Updating Multiplus yes/no

Dear readers,

In my boat I’ve got a Multiplus since 2013 (former owner placed it). I don’t think it has ever been updated. But now I want to connect it to a Cerbo which I bought recently: do I have to update the firmware of the Multiplus? I understood I have to buy a MK3-dongle then and it’s a waste of money when not necessary.

Please your advise.

Kind regards,

Pim

pim asked
5teve answered ·

2 Answers

New install, no power after updating with MK3- Multiplus 12v/3000

New install in an RV with lithium batteries, all lights were on and working. Inverter was working properly. I got a MK3 dongle to be able to program the charge parameters for the lithium battery bank, and after doing so and updating all firmware and uploading settings, now I have no lights in the Multiplus and the inverter won't power up. Voltage measured at the terminals on the inverter checks out good. I suspect that my computer is being recognized as a virtual switch and it is waiting for a signal to power on, but now I can't connect to the inverter because it is off. Is there a way to do a "hard reset" or "trick" the unit into turning on?

JB Hughes asked
Matthias Lange - DE commented ·

2 Answers

Does mk3 interface work with Acer chromebook?

Hallo


I try-out to communicatie with a multiplus 12/3000 by a mk3 interface connected to my chromebook. The multiplus want show up in victron connect.


Last week i treed to connect a multiplus compact 12 /1600 by a ve-direct to usb connected to my chromebook. The multiplus dient show up in victron connect.


Is the mk3 compatible with chromebook?


Thanks in afvangen



Kind regards, Piet

piet-hein-van-asselen asked
jperez (Victron Energy Staff) commented ·

1 Answer

Do I need the Victron Energy Interface MK3-USB? Is anything else required?

Ok...finally got hold of a windows laptop. (Apple not working - no workarounds etc...)

Q1 - Do we 100% need the Victron MK3-USB in which to connect and use VEcConfigure?

Q2 -can you use VEConfigure via wifi??

Q3 - are there any other cables I need?

Thanks


willowfarm asked
piet-hein-van-asselen answered ·

5 Answers

Mac user configuration of Multiplus using MK3 USB

I've downloaded the Mac VictronConnect app on the Victron website, but it doesn't see my Multiplus, even while I'm connected using the MK3 USB. All other discussion here discusses using Wine or Parallels, yet there is a Mac app on the site for this purpose. Anyone have any luck using the app and seeing their device?


Thanks

Randy Repass Jr asked
valden commented ·

7 Answers

Problems connecting to multiplus with mk-3

Although I have in the past been able to connect just fine, after a remote panel firmware upgrade I am now unable to get past the loading data in victron connect or any other app. Seems the mk-3 is connected but cannot find the multiplus. I have tried Uninstaling the apps and drivers, and have used a second pc and dongle.


leroy-kehl asked
falkol answered ·

1 Answer

Followers

90 Posts
87 Users
1 Follower

Topic Experts

ascherg
0 Points