Venus OS Image

Venus OS

Inverter state control doesn’t seem work for “power on” mode from vrm

Multiplus 3K connected to venus os 2.92 on Raspberry Pi


The image above shows the 4 ways that I should be able to control inverter state. If the inverter is on, i can set to the other 3 states (off, charge, invert only). However, if inverter is off, the only way I can turn it on is using the victron connect app (bottom left of image). With any of the other 3 interfaces, the buttons indicate the unit is on after pressing on and then refreshing displays but the inverter remains in the off state.

Michael Ziegler asked a potentially related question on Mar 16 2022 at 8:52 PM under the topic: “Control your devices in VRM showing incorrect inverter state” and i attempted to ask if this had been resolved but there was no response.

I have tried reinstalling venus OS and that did not help. The general settings for remote access/remote control are set to True. I would have to believe this isn’t an issue on a true cerboGX and touch control otherwise it would be a major issue. My reason for implementing venus was to allow my wife (not overly technically inclined) easy control of the inverter. Without this functionality I will just have to depend on Victron connect app as I have for the last year.


ste7of1 asked
ste7of1 edited ·

3 Answers

Reduce charge current based on SOC Multiplus

I want to reduce the charge current from the Multiplus II based on SOC from smartshunt using NodeRec via Cerbo.

I have tried in NodeRed but cannot find a setting to change charge current.
Have anyone tried this?
I see that I can reduce charge current via an analog in and use an assistant in the MP, but this is not a desired solution.

Any advice?

slapperia asked
nevller commented ·

4 Answers

Victron Multi RS Solar 48/6000 connect to VRM (CCGX or RPi)

Hi everyone,

Can someone give a bit more clarity on how to bring the Multi RS in VRM?

The manual is... limited in this regards.

I have a CCGX (on my existing quattro installation) and just bought a RaspberryPi on which I installed VenusOS and I also purchased a MK3 adapter.

From what I can tell, only VECan is available on the Multi RS, but when I connect to CCGX it won't show anything. Do i need the little RJ45 end plugs (which didn't came with any device...) ?

What would I need to connect it to RPi?



iromeo asked

0 Answers

Venus OS v2.92 Bluetooth Missing from Settings Menu and Bluetooth Sensors missing from I/O Menu

I just upgraded to Venus OS v2.92 on my Cerbo GX. When I did, my RUUVI sensors stopped communicating with VRM. I went to the Cerbo settings menu and found Bluetooth was gone from the menu list. I then went to the I/O menu in Settings and found that Bluetooth Sensors was gone from that list. I rebooted the Cerbo, but this did not correct the issue. The menu items are still missing. What happened to Bluetooth and Bluetooth sensors in v2.92? My Ruuvi sensors were functioning perfectly before I updated the Venus OS.

chad-heiser asked
Matthias Lange - DE commented ·

4 Answers

Controlling a 120V outlet based on temperature using Venus OS on RPi

What's the easiest way to control a 120V outlet, based on outdoor temperature, using the Venus OS running on a Raspberry Pi 3B+?. I've updated the OS to version 2.92, and have ordered several Ruuvi sensors. I also have the Victron Smart Battery Sense module installed.

I store my off-road camping trailer high in the Colorado mountains, where we have many nights with temperatures below the 25F threshold for my LiFePO4 battery. It's plugged-in though when stored, and I have a battery warming wrap -- I just don't want to leave the wrap plugged in all the time.

I'd love to be able to use something like a TP-Link smart outlet (WiFi), or anything Zwave or Zigbee would be fine too. I'd also consider using DuPont wires off of the GPIO pins on the Pi, though that would be my last choice as the length of these control cables seems pretty limited.

For those that have something like this setup -- what are you using, and has it been reliable?

techie4hire asked
techie4hire edited ·

4 Answers

DC Power shows incorrect consumption on unloaded phoenix inverter

After some time wondering why my "DC Power Consumption" some times report incorrect values in the dashboard i started trying to figure out why.

System components:
* Phoenix Inverter 12V 800VA 230V
* Smartshunt 500A
* EPEver PC charge controller (reporting to venus)
* Pi3 with Venus os
* 100Ah 12v Lifepo4 battery

While running on battery and no or a small load on the inverter, the "DC Power" reports a power consumption of approx. 23w or 46w more than that the actual power used displayed on the battery shunt on the Venus and in VRM.

Display when inverter is loaded with approx 12w(bulb) + 6w of inverter idle consumption:


(The shunt reports correct all the time, checked with a clamp meter)

I've seen the difference between shunt and dc power to been up to 46w when the inverter is completely idle(ON but nothing connected on AC side)

After some peeking into `dbus-spy` i think i've found the issue, and it seams to be that the inverter reports between 0 and -0.2A load on `AC/Out/L1/I` when idling, reporting -0,1A on 230v will report to -23w of usage and shown as 42w( -1*(-19+-23) ) extra ont the "DC Power" block in the UI. This is also the reason why the issue disappears when the inverter is loaded, as this negative reading then will be gone.

As for now it looks like the current reading on my inverter could be out of sync inside the device, or that it just displays incorrect values when idling... Is there a way to get this reading "in-sync" again (a form of calibration?) or something else that could be done to make my reading more exact? eg. ignore current readings bellow zero from the inverter ? as the inverter have no way of generating back power there should never be a negative value reported on the AC side.

Anyone have an advice for this issue?

runar-borge asked
rpetrovski-forum answered ·

2 Answers

SOC fall down over night


In my system (Multiplus 2-48, GWL 4,8 kWh, Venus OS) falls des SOC overnight quickly from 75 % to 10 %, but no big consuption or feed was observed. Battery life was activated.

What can be the reason?

anddittma asked
Paul B answered ·

1 Answer

Venus OS 2.92 and Smart Solar bluetooth connection

I just got Venus OS installed and running on a RPi 4, is was able to connect and get data from multiple Ruuvi Tags but can't find my Smart Solar MPPT. Isn't bluetooth connection to Victron's own devices still implemented? Connecting using a VE.Direct cable is not an option.

oscarck asked
oscarck edited ·

1 Answer

MPPT as a DC to DC converter

I have a large battery with a nominal voltage of slightly over 48v. On the solar side, I have 2x MPPT 100/20 and 1x MPPT 150/35, with 48v loads made up of a 48v Phoenix 1200w inverter and a 48v to 12v DC to DC converter buck converter (non-Victron). I have all of the Victron devices monitored via Venus OS

I'm hoping to use a spare SmartSolar MPPT75/15 as a replacement to the DC to DC buck converter, where I would connect the 48v battery to the PV input and use either the load output or battery output of the MPPT75/15 as a 12v power source to my 12vDC system. I have three questions.

  • First, is it better to use the battery output or load output of the MPPT75/15 as the DC output to my 12v system?
  • Second, is there anything I need to configure beyond setting the battery voltage on the MPPT75/15 to 12v in order for this to work and to have Venus OS understand this as a DC to DC converter, not a PV charger?
  • Third, generally, my 12v DC sources draw less than 15 amps; however, given that I already have the buck converter, I plan to wire it in parallel with the MPPT75/15, and have both the input and output connections of the buck converter switched so it will normally be disconnected but can be manually connected in the event of a higher current need. Does anyone see any issues with this setup?

jonathanr asked
jonathanr commented ·

1 Answer

trouble with ET340 connection by new Zigbee 485(DRF2659c), USB (DRF2658c) module

Hi there,

please, let me ask for help if possible with the new zigbee RS485 (DRF2659C) and USB(DRF2658C) module that I would like to use for wireless connection of ET340 to Venus OS.

I have trouble with them to be recognized be Venus OS (2.73 and 2.80). I find out that zigbee modules come with quite new firmware v8.5 and it has ID_MODEL=USB_Serial, that I have adjusted in "serial-starter.rules", in "" and I have played around also with serial-starter.conf. Without success till now.

When I do wired connection all works well and ET340 is recognized as device ID:345 with 2571291A number and is visible by Venus OS . See screenshot 1.

When I set it with zigbee, there is no info about find cgwacs device. See screenshot 2.

Any suggestion what I could try is welcome? Thank you.

Best Regards,


1. Wired connection


2. Zigbee connection


3. USB-zigbee module


hsaman asked
dimiwa commented ·

3 Answers

Cannot access Remote console ( Local ) from PC

HAve always been using the Remote console from my PC but today it is no longer working. It works via VRM and also via a mobile device on local ip address but not from windows PC. Venus OS is 2.91 . Also tried http://venus.local/ - same problem . Tried Chrome, FireFox and Edge - all the same - comes up with screen below. Checked ip address and that has not changed. I have rebooted the device , my PC and router - still no success.


Merle.Peter asked
matt1309 answered ·

3 Answers

Is vedirect-dbus open source - where to find ?

Hi, I can see vedirect-dbus running on my rpi4 and am interested in the source code but can't find any reference to it. Is this open source - and where might I find it ?

majh asked

0 Answers

New fronius Gen24 product support

Does anyone know if victron are supporting the new Symo/Primo Gen24 models?

Anybody know if they are detected and read by the VenusOS?

alan asked
jon-lowbank commented ·

0 Answers

Where to download colorcontrol ccgx large image

Good day, as I read on the Victron OS large page also ColorControll gx can run OS large.

It seams that the new install routine over the display is not implemented in the ccgx firmware.

Following the link for the raspberry pi images, I can find the ccgx image pack, but not the large version. Did I got something wrong or where can I find the os large for ccgx?

Thanks for your help

Silvio Franceschini asked
Silvio Franceschini commented ·

1 Answer

MPPT lost VE.Direct connection to Venus


my MPPT 250/100 seems to have lost connection to the venus OS (2.89). The initial connection via VE.Direct-to-USB cable has worked. I think I messed around with DVCC settings and disabled it again. Since then the MPPT was first "disconnected" and has disappeared from Venus after rebooting the RPi.

There was a message about resetting VE.Direct, but I cannot find any instructions. What do I need to do to ?


larsac asked
larsac answered ·

1 Answer

1276 Posts
599 Users

Topic Experts

Kevin Windrem
3769 Points
764 Points