Venus GX - VGX Image

Venus GX - VGX

Force charge/discharge of Multiplus using VenusGX & Node-Red

What am I trying to achieve?

Charge the battery, or discharge the battery based on external input (via MQTT, but ultimately based on variable electricity tariff status)

I am up and running in Node-Red on the Venus GX 'large' image and am able to set the Multiplus to the following modes;


However if I set the multiplus to 'charger only' it obviously won't charge if I'm not in a scheduled charge slot.

If I set up a scheduled charge slot to be active at all times, then I can charge / not charge on demand by setting the 'Disable Charge' flag to either 0 or 1.


However when in the 'don't charge' state, it also won't discharge the battery as I'm in a scheduled charging slot.

I've tried setting the AC power setpoint instead of charging within a scheduled charging time, but it doesn't seem to do anything if I try the following;


Can anyone offer any recommendations on how I can switch between charging or discharging to meet my requirement?

homestorage-77 asked
homestorage-77 commented ·

3 Answers

Node-Red running on Venux GX is not loading in browser, and restarting several times a day

As per the question title, I have Node-Red running on a Venus GX, it has been running just fine for over a year, I've been gradually adding functionality and it looks like something might have been messed up.

The flow is still running, I can see the results of the flow broadcast to my MQTT broker and logged on my dashboard - however I cannot open up the Node-Red flow in my browser. I've tried locally (http://192.168.86.XX:1880/) and via the VRM with the same result (perpetual loading, or sometimes the following stage: (even after left for >20 mins)


I've tried stopping and starting the Node-Red instance via the Remote Console, it successfully stops and starts it but doesn't help me access it.

Are there any solutions to fix? Ideally to access the stopped flow to make modifications to allow debugging. One thing I want to try is dramatically reduce the load in the flow by reducing message frequency, some of which are occuring far more frequently than needed.

homestorage-77 asked
Stefanie (Victron Energy Staff) answered ·

1 Answer

Push Data from NodeRed to Venus GX Device on same system?


is there a possibility to put data from the same NodeRed installation to the Venus GX device (maybe to dbus)?

I've created a http-request in a NodeRed flow to an external URL and I want to show parts of the json-result on the GX Device Screen

itsme asked
itsme edited ·

0 Answers

Add Relays - Does anyone have a an ‘idiots guide' on how to add more Relays to a VenusPi set up?

I’m only semi-computer literate - everything is trial and error and cut and paste and hours of google research… If the details include what software should be used and exactly what to type then I can usually muddle my way through. But when it comes to ‘just add a few lines of code in the xxx” I’m completely lost.

I have managed to burn an image to a sd card and install Venus Pi v2.60 large image on to a raspberryPi 3.

I have 1 Victron mppt 75/15 connected successfully to it vie ve-direct usb cable.

I have successfully got node-red running (and can even see it all via VRM Portal - including node-red which is amazing).

I’m still at beginnings of how node red works but can see its potential.

So far so good

But I’d really like to add more than 1 relay so I can control multiple external devices (like pumps, irrigation valves etc) and also control them through node red.

I’ve read the comments and half guides for adding extra relays - but they are incomplete or presume you know how to do certain un-explained steps. So I'm completely lost.

So - anyone have a step by step guide to add relays ? (and I’m on a Mac so Mac instructions would be great!)

Thanks in advance for all the amazing guides so far - and for the missing bits I hope someone will write soon…

thomas-g asked
Rob Duthie commented ·

4 Answers

Switch Multiplus with Venus GX and NodeRed


I have a switch connected to the I/O of my venus, now i would like to switch the multiplus 24/5000 on and off.

the I/O signal is working, it sends 3 or 4 to the multi. Sounds alright so far. But the strange thing is the multi is swiching on for maybe 3 sec and turns off. Same thing if i repeat pushing the switch.

thanks to help

brezzi asked
Sten edited ·

1 Answer

Switch Multiplus with Venus GX and NodeRed


I have a switch connected to the I/O of my venus, now i would like to switch the multiplus 24/5000 on and off.

the I/O signal is working, it sends 3 or 4 to the multi. Sounds alright so far. But the strange thing is the multi is swiching on for maybe 3 sec and turns off. Same thing if i repeat pushing the switch.

thanks for help

brezzi asked
brezzi edited ·

0 Answers

Node-red on Cerbo: can read but not write value

Hi there,

I've installed "venus-swu-einstein-20210416100626-v2.70~5-large-18.swu" image firmware to be able to use node-red.

All seems to be good. I can read different values with nodes like "ESS control" but impossible to change values !

Any ideas .....

lalluyn asked
Mark answered ·

2 Answers

Node Red Time Zone And Such...

I realize this is a couple of related questions, but here goes:

Is that any way to read the timezone offset that the user sets in the Venus GUI into NodeRed? I am trying to make decisions based on local time, which since I am a sailboat, that changes and changing it when it is hard coded into NodeRed is a bit awkward... I do have access to the GPS position that is on the CANbus, and could calculate a "solar time" based on latitude, but that seems clunky...

The vaguely related question: Is there any way to access the user set value for the "Quiet Hours" used by the generator autorun function?

Even further afield from the original question: Are the other parameters set by the user and used by the generator autorun function accessible to NodeRed?

I haven't found any of these on the published Modbus register listings.

billknny asked

0 Answers

Help with using Node-Red with Venus GX

Could anyone please give me a bit of support in gettig started with Venus GX interfacing via Node-Red?

I've got Node-Red installed on a Raspberry Pi & am looking to switch on / off my Multiplus II based on certain input conditons.

I've loaded in the Victron nodes to Node-Red but am stuck on step 4 of the Installation Instructions;

enable d-bus over tcp in your Venus device if you want to use dbus over TCP, otherwise skip this step. Edit /etc/dbus-1/system.confand add the following directly above <policy context="default">:


How do I actually go about doing this? How to I connect to the Venus GX in a way that allows me to edit the files?

Any advice of next steps would be greatly appreciated too, as the instructions are not clear for me.

Many thanks in advance

homestorage-77 asked
Mark commented ·

1 Answer

VenusGX + Node-RED - Modbus TCP Communication Issues


I have installed the recent VenusGX v2.42 FW build with integrated Node-RED from

I am trying to communicate with an external device via Modbus TCP (a My PV AC Thor - which is a modulated AC heater power control unit) and control it via logic developed within Node-RED.

I have successfully installed the additional contrib node 'node-red-contrib-modbustcp' and am able to communicate with the unit.

However I'm unable to setup a flow to BOTH write to the unit (with a power request) at regular intervals AND read from any registers (such as temperature) at regular intervals.

For example;

Write only - connects/works fine


Write & Read - no connection



Write & Read after a few minutes - write connects/works but read doesn't


Read only (write node deleted) - connects/works fine


I do know that a Modbus TCP read and write event can't occur exactly simultaneously (and it doesn't need to), but I'm not sure how to sequence the read/write requests or what I can change to get this working with the Modbus TCP node-set that I'm currently using...

My next step was to attempt installing a different / mode advanced Modbus contrib node 'node-red-contrib-modbus' (I have seen examples of write and read nodes successfully coexisting with this node-set) but unfortunately I get a bunch of installation errors - see below;


I have also tried to install manually via Putty using the npm install command (including the suggested variations) but still get the similar errors.


My programming/Linux skills are very limited, so troubleshooting this myself is a bit beyond me.

If anyone is able to offer some advice on how I can possibly get write and read communication working with the current Modbus node-set I'm using ( or how to get the more advanced Modbus node-set ( successfully installed on the VenusGX it would be greatly appreciated.

PS. I do know that my other option is to run node-red externally to the VenusGX unit (such as on a RPi), but I want to leave this as a last option for now.

Thanks in advance, Mark.

Mark asked
shaun commented ·

1 Answer

10 Posts
555 Users

Topic Experts