DVCC Image


Smart Shunt Temperature DVCC

I have just installed a Smart Shunt with a the correct Temperature sensor but the Cerbo is still using the other type of sensor that conects the the Negative pole , it cant see the Shun Sensor . Looking at the lis it has Multiplus , Battery Temperature sensor 1 ( the one conected to the negative termnal ) Automatic or No Sensor , no mention of the Shunt .

Also how can i tell if DVCC is using the Voltage from the Shunt or from the Bus bar as berofr Shunt was installed , theres no list showing the options .

ako asked
Alexandra commented ·

1 Answer

MPPT power is limited for DC feed in if battery is full


MultiPlus-II 48/3000/35-32 / FW: v501
BlueSolar Charger MPPT 150/35 rev3 / FW: 1.61 with 2kWp solar panels
GX Device / FW 2.92
48V CAN Battery connected to the GX device
EM24 Ethernet smart meter
PV inverter at AC IN

I have configured ESS with DVCC for the system. As long as the battery is charging, the MPPT provides full power (even if battery takes less power than the MPPT provides). But as soon as the battery is full and the excess power shall be feed in to the grid, the power of the MPTT is limited (about the half of the theoretical available PV power.

Battery is charging (MPPT DC power is 1021 W):


Battery is no longer charing (MPPT DC power is limited to 602W)


Do you have any suggestions?

Best regards


This is my configuration:








blackmarlin asked
blackmarlin answered ·

16 Answers

How to control Battery charge current with ESS + DC coupled feed in

Hello community, i have a very interesting Question from my side because no one can answer me this. Also not my Victron parts seller.

  • Standard ESS System with 3 or 6 Multiplus. 48-54V System!
  • A Few Victron MPPTs
  • Cerbo GX
  • Shunt

Over the DVCC there is a current Limit for Battery. If the DC coupled feed-in is OFF, then everything is working fine and you can limit the current for the Battery with the DVCC Limits.

But if the DC coupled feed-in is ON, the cerbo-gx ignore the DVCC settings accordings victron manual and also tested in reality. The MPPTs need to be always on full power, to be able to feed in.

But how can i control now the Batterie current? Also the DVCC Voltage Limit doesn't work. This was my second idea, to adjust for example 45V Limit, then the Multiplus should move the MPPT Power into the grid, but it doesn't?!

I want to prevent overcharging the Batteries, so activate some current or Voltage Limit, that the Batterie will not rise up more and more. Doesn't matter a few amperes in or out, but should be around +-5A. So the MPPT power should be used for the house + grid if the shunt shows 100% and then the multiplus should control the shunt current to 0A.

Is there any parameter to write in Node-Red to Limit the battery shunt current? Normally DVCC, but system doesn't listen to it with DC-coupled mode! Thank you a lot!

kevstone122 asked
kevstone122 commented ·

16 Answers

Multiplus Parallel ignores the battery charging voltage

Hello, I have a problem with my Multiplus 2 and Pylontech batteries. I added a second Multiplus 2 to my system a few weeks ago. Now every time I charge to 100% from the battery I get a message that the voltage is too high. The battery reports a charge voltage of 53.2, but it charges to 53.98/99. I've been trying all sorts of settings for days, but the error won't go away. I suspect that the multiplus in the slave mode does not have the correct values from the DVCC or the battery parameters. Has anyone had a similar problem? How can I solve it?

leo9412 asked
Alexandra commented ·

6 Answers

CCL issue if dc feed is on

Is Victron working on a solution for the not working CCL setting in DVCC with DC-feed on?

I use seral driver with JK-BMS but with DC feed on, it is impossible to reduce the current load to battery. The driver settings are completely ignored and the solar charger power goes to battery till the BMS disconnects it.
I would like te reduce the battery charging-current to lower values in general and also would like to use SOC based limits.

I am happy with victron but this behavoir and the fact, that every reboot of my venus raspi makes doubled devices are really awful. The issues are alreday well known, many users have the same problems.

I created a node red based workaround to reduce the battery current (setting grid target value based on watt calculation) it works in general but in case of grid disconnection I will again run into problems.

Would be really great if a solution could be implemented!


stefan1967 asked

0 Answers

What exactly does "Has DC System" mean and when is it required?

Dear community members

I understand from the manual the Has DC System option is used if one has for example a wind generator in addition to e.g. a smartsolar PV charger. So, for sake of clarity. I have a smartsolar which is of course DC, but nothing else so do I keep it off or why will I need it?

Secondly, DVCC, I turned it on to ensure the correct control of the Smartsolar charging parameters from my BlueNova BMS and more accurate readouts from the BMS to the Colour Control GX. Is my interpretation of the manual correct?

Finally, Shared Voltage / Temp sense is in my view best left turned off as the BMS should have the most accurate information being embedded in the battery? What do you think?

Thank you for your thoughts and experiences on the matter.

Kind regards


ejrossouw asked
Alexander Sucker commented ·

5 Answers

DVCC - FeedIn

Why is ignore DVCC charge limit when is enable DC Feed In?

Tibor Kocsis asked
gazza answered ·

3 Answers

DVCC limit charge current does not work

I installed a new Mulitplus 2 48/5000. DVCC limit charge current does not work. With the old Quattro, DVCC worked without any problems. Did I make a mistake somewhere? 

System setup: 
ESS with Cerbo 
MPPT chargers show "external control".




user0815 asked
larsea-dk commented ·

5 Answers

DVCC Limit charge current not working with grid feed in enabled

My System:

ESS with:
3x Multiplus II 48/5000
2x MPPT 250/100
1x Fronius Symo 15 on AC out
8x Pylontech US3000
Cerbo GX

I have a problem with the DVCC feature "limit charge current". I have set the max charge current in DVCC to 60A.
If i enable grid feed-in (AC & DC) the system ignors the max charge current and charges up to the max current of the pylontech battery 296A.
With grid feed-in disabled everything works as expected, the system limits the charge current to 60A.

Is this normal? Am i missing something?

Nico Bayer asked
larsea-dk commented ·

4 Answers

tension de batterie


qu'est ce qui fait qu'une fois mon SOC à 100%, la tension de ma batterie monte jusqu'à 53V ? Quel élément augmente cette tension à 53V ? Mon VE.config est à 52V en Abs et 51V en Float.

Dés que le SOC redescend, la tension batterie repasse au alentour des 49,5v !!!

Ce qui bloque la production de mon MPPT et donc pas de réinjection.




lalluyn asked
Thierry Cortassa (Victron Energy Staff) answered ·

1 Answer

SmartShunt ne mesure pas l'autoconso

Bonjour à tous,

J'ai mis en service une installation hier et le SmartShunt ne fonctionne pas bien.

Cerbo/MPII 5kVA/2x MPPT 150/60/SmartShunt/Batterie LFP avec BMS non communicant.

Il n'y a encore rien de connecté en AC-IN et AC-OUT du MPII.

Le shunt ne mesure pas l'autoconsommation de l'installation (MPPTs/MPII/Cerbo), il reste fixe à 0A :


Il a pourtant bien vu la charge des MPPT aujourd'hui :


Comme s'il ne savait compter que dans un sens...

Tous les éléments sont à jour. Configuré avec ESS et DVCC. J'ai remis la configuration d'usine et reconfiguré le shunt mais rien à faire.

J'en viens à me demander si c'est pas un problème hardware. Une idée ?

Merci !

kylefr33 asked

0 Answers

Plus d'injection une fois le SOC à 100%


Ma configuration est la suivante :

Multiplus II 5000 + MPPT150/70 + PV inverter sur AC Out + Cerbo + batterie SEPLOS 10.3 kWh 48V

J'ai deux sites identiques. Le premier fonctionne correctement, c'est à dire qu'une fois la batterie chargée (SOC 100%), le MPPT continu à produite et réinjecte sur le réseau.

Le deuxième réinjecte sur le réseau tant qu'il charge la batterie. Une fois la batterie chargée (SOC 100%), il s'arrete de produire.

J'ai vu des tonnes de posts à ce sujet mais jamais de réponse claire ou de solution précise.

Les configurations sont identiques.

Quelqu'un aurait il une expérience à concernant ce problème ?

config qui ne réinjecte pas une fois SOC à 100%


config qui réinjecte apres SOC à 100%


lalluyn asked
lalluyn answered ·

5 Answers

PV inverter support assistant and DVCC


I have been succesfully using the PV inverter support assistant of a Multiplus 2 to control an external heater (excess solar energy dump in off grid system) via frequency shifting. My system had lead acid batteries.

Now I changed to Pylontech batteries. Charge control is now done via DVCC.

This caused the PV inverter assistant to stop working. I can configure the assistant, and as long as I don’t plug in the VE.bus cable of the inverter in the Cerbo unit, it works: ac output frequency is increased by Multiplus, as expected.

However, as soon as I plug in the cable, and thus establish communication with the inverter, the DVCC seems to overrule the inverter and PV inverter assistant stops frequency shifting.

Is there a way to make this work?



alexander-aerts asked
alexander-aerts commented ·

1 Answer

ESS Multiplus not charging above 47% with forced DVCC


I have a working ESS setup, using a Multiplus-II 5000/48 and two imported 48V LifePo4 batteries connected trough CANbus.

After adding two additional batteries and changing the primary battery to the new version, suddenly, the batteries won't get charged passed ~47% at 52.5V. Even when i set the grid setpoint at +1000W or schedule a forced charge, it won't go above. When letting it discharge below 45%, it will gladly recharge back to ~47% max.

I've checked the DVCC parameters from the battery and the CVL is set to 57. The working battery advertised 57,6. In ESS the charge voltage nor charge current are capped.

The only difference i can see is that the new version of batteries get recognised as Pylontech batteries whereas the previous versions did not. This causes DVCC to be 'forced on' instead of just 'on'.

I have a second setup on a different site which has exactly the same issues (i've tried swapping batteries between sites).

Any idea on how to troubleshoot/debug the ESS loop to figure out why ESS stops charging at ~47%/52.5V, or what other settings could possibly be of effect in this?

My guess is that the GX/ESS is somehow treating a 'recognised Pylontech' battery different internally from the same type of battery, but with a different name/vendor.

Kind regards,

p.s. Yes, swapping the batteries back in order fixes the issue for now. But that's not an option on the second site, hence my attempt of solving this issue.

vos23 asked
vos23 commented ·

2 Answers

DVCC to limit total charge current?

I have a parallel multiplus system, with a BMV712, and CERBO GX connected to a FLA battery bank on my boat.

I am interested in limiting charge current when the engine alternator is producing as well as the generator as to not exceed the charge current acceptance rate of my batteries.

A method that we have discussed is using a AUX input on the master multiplus to trigger a reduction in the output capability of the multiplus units. This aux contact would be tied to a “main engine running” signal.

I am certain that this method would work, but there might be a better way.

Could I turn on DVCC on the CERBO GX and have it limit the charge current by using the value supplied by the BMV712?

That would be the best method in that it would be dynamic.

Please let me know.


blskevin asked
kevgermany answered ·

5 Answers

209 Posts
179 Users

Topic Experts

423 Points
231 Points