bug report Image

bug report

Bug Report: VRM solar yield wrong after clearing SmartSolar history

Hi,

I've recently cleared the history of my SmartSolar, and ever since the hourly yield on the VRM portal is incorrect. It seems to add the lifetime total yield (which I cannot reset) to the yield of every hour, yielding crazy numbers.

I was hoping it would correct itself after a day or two, but it did not. I have tried deleting and re-creating the installation but that did not help either.

The installation ID is 02160482c318.

Is there anything I can do from my side to fix it?

Thanks!

pleriche asked
pleriche edited ·

0 Answers

Feature Request/Bug Report: Venus GUI Diagram incorrect topology

Hi, I am now using Venus to monitor my system. However, I was surprised to see that the diagram of connected devices is incorrect. I am guessing it was done to try and oversimplify things for beginners?

This is how my system looks right now:

[image]


Firstly, this diagram has inconsistently applied design principles. The AC inverter load is not connected to the battery, but rather to a central "busbar", so by that formalism, the DC load also should be.

Secondly, this diagram prevents the system from being accurately represented, for example in the case where the solar system is producing enough power to simultaneously charge both the battery and power the DC load. In that case, this diagram depicts the power going through the battery first, and then to the DC load, which physically wouldn't happen - electrons being moved from the solar charger would literally never pass though the battery.

Would it be possible to correct this diagram? I am being driven mad by this nonphysical depiction. This is how I believe it should look:

[image]

vulture asked

0 Answers

MPPT 100/30: Temperature compensation completely wrong

I found out that the temperature compensation does not work correctly. It is too high by a factor of 6! I tried out some things and found out that I need to enter the compensation value per cell and NOT per battery bank as the app is asking for.


Test situation:

  • The manufacturer of the used lead acid batteries prescribes a compensation value of -4mV/°K per cell.
  • I have 6 cells, thus I use the MPPT controller at 12V.
  • The floating voltage is set at 13.36V and the controller is in floating mode.
  • Temperature and battery voltage is measured directly at the battery through a BMV-712 battery monitor and send to the MPPT via bluetooth. They are interconnected with each other (which is a pretty cool feature anyway).


The app is asking the temperature compensating coefficient explicitly as per bank and not per cell.

Thus I multiplied the -4mV/°K per cell by 6 and get -24.00mV/°K per bank which I entered in the app.

Today the battery temperature was measured at 19°C. This is 1°C below 20°C (20°C means no compensation).

Expected result:

13.36V + (19°C - 20°C) * -0.024V = 13,384V

Observed result:

13,50V (which is obviously too high for a lousy delta of 1°K)


Then I entered the coefficient as per cell (-4.00mV/°K) and got 13,39V which is what I wanted all the time but never got.


For testing, I also tried to switch off the compensation and got exactly the configured 13.36V.


It looks like the controller is multiplying the entered value internally by 6 as it knows I am using the controller at 12V with lead acid cells (can only be 6 cells as 12V / 2V = 6).


Because of this I killed my new bank last winter as the voltage was too high all the time!!!


Example:

0°C in winter means (0°C - 20°C) * (-0.024V * 6 [6 because of the bug]) compensation

= -20 * -0.144V = 2.88V (WTF?!?)

=>

Floating voltage: 13.36V + 2.88V = 16.24V

Absorbing voltage: 14.40V + 2.88V = 17.28V

Balancing voltage: 15.10V + 2.88V = 17.98V


BTW:

I updated the MPPT to FW v1.50 today which has still the same bug. :-(


Did anyone noticed the same?

R2-D2 asked
Espen edited ·

4 Answers

Bug Report: VRM Portal Economic Report will only report "Today"

Early last month I had gotten my site finally working with VRM Portal (once I finally got 24/7 internet there) and I had discovered the economic report functionality. While it doesn't give as much detail as I would like (I would hope for breakdown of used energy vs. max production if grid tied and selling, since production drops when batteries are full), I was eagerly awaiting digging into the reports at the start of this month once I had more data.


I had tried to check it a week or two ago and noticed that I still could not enter or select a date range, only "today". I was guessing that maybe there was an issue with database logs or something that would be temporary, but not today I still cannot select a start date beyond "today" or the automatically filled in date of yesterday. Both clicking the left arrow and trying to click any date except yesterday does not work.


Image of the screen: https://imgur.com/a/LXAuKB8

Browsers tested: Vivaldi 2.5.1525.40 (Stable channel) (32-bit), Firefox 67.0.3 (64-bit)


Section9Bateau asked
dunnp commented ·

3 Answers

MPPT 100/50 Firmware bug V1.50

After upgrading firmware through Victronconnect, the Battery current display is wrong. For example 650W of solar power displayed, close to 50A actually coming out of unit but Battery Current display shows only 9A for 3 or 4 minutes, then correctly shows 49A. The Battery current display used to be correct and vary continuously with the actual current out of the unit but now just seems to be (very slowly) randomly updated. How do I revert to previous firmware whilst the bug gets fixed?

jimwsmith asked
Thale commented ·

4 Answers

Editing and removing custom presets in Smart Solar

I have made a couple of battery presets and would like to delete one. I press the blue remove button but nothing happens. I also cannot save changes when I edit a preset.


Is this a bug or am I missing something here?

mahdi asked
Allan Fraser answered ·

6 Answers

Smartsolar 150/35 only shows 1% of the actual Watts in Mobile App after disconnect during sync

I am running Smartsolar 150/35 units. I have had a problem twice now where the VictronConnect app (Android) has dropped bluetooth connection mid-sync to a device. Once this happens, the app will reconnect fine to the device, but the wattage only displays 1% of what should be the actual wattage. For example, if the actual wattage is expected to be 1200w, the app was only displaying 12w. The input and output voltages were correct and the charger state was correct (bulk), but no amps. The trends amps graph also drops from where it should be to the incorrect values.


I tried closing and re-opening the app, but it didn’t fix it. The only way to get it to display the correct wattage again was to totally power off the unit and power it back on again. I don’t know whether the unit was still charging correctly as I don’t have an independent ammeter inline and didn’t have the time to wait for an extended period and take the chance of it not actually charging the batteries.


The devices have run fine for a very long time without being powered off and I believe it is the disconnection mid-sync that has caused this to happen. I thought I would report this here in case it hasn’t been noticed by the developers yet.


Update: The problem has just happened for the third time, so I've attached some before and after (reset) screenshots.

[image]

[image]



Update 5/5/2020: It has just happened again and I can confirm that it is definitely not charging at full power when this happens, so it looks like the problem is with the charging, not the communications.



Jaspar asked
Jaspar commented ·

1 Answer

Load output inrush current HW fix availability for Bluesolar 75/15

Hello @mvader (Victron Energy),

I'm wondering whether your HW fix for the issue "smartsolar 100/20 load switches off in float mode" and other loads is already available today in the BlueSolar 75/15 series design?

Documented by "mvader" in

>> "smartsolar 100/20 load switches off in float mode" on

Mar 02 um 9:39 PM:

Here are the serial numbers per when the (hardware) change was implemented:

  • SCC075010060R SmartSolar MPPT 75/10 Retail HQ1935
  • SCC075015060R SmartSolar MPPT 75/15 Retail HQ1935
  • SCC110015060R SmartSolar MPPT 100/15 Retail HQ1947
  • SCC110020060R SmartSolar MPPT 100/20 Retail HQ1911

The 100/20 that we currently ship from our warehouses has the improvement. As do the 75/10 and the 75/15. The 100/15 is still shipping with hardware from prior to this improvement, due to stock levels of older production batches.

<<

Has my two week earlier bought (from Offgridtec) BlueSolar 75/15 (+ BT dongle) with serial nummer (pls. see below) also fixed this BD35 compressor inrush current issue yet (that I highly rely on) or do I need to replace this device with which SmartSolar charger instead or when will it be available?

Many thanks in advance for your help and BR!


[image]

edmond99 asked
edmond99 commented ·

0 Answers

Victron Connect App - History Frozen

[image]

Hi Victron and Forum!


I use a MPPT 75/10 with Bluetooth Dongle on a (very ;-)) small water power installation.

To make the system look nice, I have all installed in a box with a Lenovo 7" Tab as display with VictronConnect for people to see what is going on. The Tab is powered by the water power and always on.

The history bars that show the daily generation are not moving forward. Is that bug or feature?

Attached a picture taken on Feb 14th. The display is still on the 7th.

PS1: earlier, the whole display (trends, wattage, …) got stuck after 2-3 days. This seems to work now after the latest updates.

PS2: to bring the bar charts back to the actual date, I have to completely close down the app and restart. After the restart, VictronConnect does not find the MPPT controller via Dongle. I always have to stop Bluetooth on the tablet, restart it and then start the VictronConnect app. I know now, so small nuisance, but may be worth fixing?


KaLi the Miller asked
KaLi the Miller commented ·

3 Answers

Excel VRM kWh Export anomalies

Every time I expert this data, there are these gaps which simply just does not make sense. Thoughts anyone?

[image]

ejrossouw asked
Riaan Barkhuizen commented ·

1 Answer

I cannot set my location in the VRM portal map

The location of my device defaults to 0S 0E and I cannot set it using the map control in the portal. It has an error 'This page can't load Google Maps correctly'. So all the times are in the wrong time zone.

gfleming asked
gfleming commented ·

5 Answers

Forum jumping up when hitting backspace while typing

Whenever I write an answer to one of the questions on here and there is a lot already up top it jumps a page up when hitting backspace to correct something. That is really annoying as one cannot see what one is deleting and has never happened before anywhere else. The instance one then goes back to writing it jumps back all the way down to where the answer box is. Anybody got the same problem?

Using an old Android Samsung Tab A to get this behavior.

ripper asked
Mark commented ·

2 Answers

Time to go from BMV on VRM, considers infinite as 0

I have an alarm rule on my BMV, in VRM, set to trigger when the Time To Go value is less than 5 hours. The rule works well enough and allows me to trap high-load scenarios before they deplete the batteries too much.

However, when the system is charging, the time to go value is set to "infinite", but on VRM, it sees that value as 0, which is less than 5, and it erroneously triggers the alert. Even worse, it sort of reverses the logic when I'm discharging, thus clearing the alarm.

Is there a way to get around that behavior?

Also, some of the trigger points for several alarms on VRM don't even make sense. There are several examples where alarm trigger value make no sense at all. Like why necessitate a "high" value for time to go -it's a "required" value so I fudge the value at 1000.

If I've got 1000 hours to go on my batteries, I don't want an alarm on that, except perhaps one hooked up to streamers and ticker-tape :)


Geomz asked
ben commented ·

1 Answer

Seems bug was introduced in Venus OS v2.23

@Guy Stewart (Victron Energy Staff)


It seems a bug was introduced in last firmware Venus OS v2.23.

The system is allowed to feed-in excess solarcharger power.

From 20/02 the system started to push energy to the grid till night.

[image]

Previously it worked without night feed-in. Also please see another one attached figure.

[image]

Zakhar asked
Tommas edited ·

2 Answers

PeakPowerPack Shows wrong Status

After reconnection to the PeakPowerPack 40 with the VictronConnect App (iOS), the actual Status shows ON (30 Minutes), but the output is set to ON. Also the Status LED shows this status.

Has anybody an idea what is going wrong?



Peak Power Pack 12,8V/40Ah Firmware: v1.08

VE.Direct Bluetooth Smart dongle (Rev2) Firmware v2.12 with Bootloader v1.06.

VictronConnect v5.1 (iOS)

SvenPA asked
mvader (Victron Energy) answered ·

3 Answers

VRM app update?

Good afternoon

I have had a popup since today. After the popup the vrm app (ccgx) will be closed. A new update is displayed on the screen. I can not find the update anywhere.

is there a solution?

Remco asked
BackYardSolar commented ·

2 Answers

Bug in SmartSolar MPPT 75/15 ?

I disconnected the SmartSolar from the solarpanel in my sailboat 16 NOV, but in the app it erroneously indicates that it is still producing solar power, please see the enclosed picture.
The MPPT is still connected to the batteries and therefore flashing the blue LED every 3 s. The batteries are connected to an IP 12/15, that is being powered by 230 V.
Is there a bug in the SmartSolar firmware?

Cheers/ Michael (Denmark)

[image]

Sputnik asked
Sputnik commented ·

1 Answer

Bug in Lithium BMS assistant on Multiplus

Hi,

After updating the assistant using VEconfigure on my 5kVA Multiplus, I got an error message regarding the BMS assistant for Lithium batteries (see the screenshot below).

I assume the error comes from a translation bug, although I'm using VEconfigure in english (I'm located in France).

QUESTION : is this bug gonna affect the assistant ? I'm worried for instance my lithium batteries would get overcharged...

I've updated the Multipus to the latest firmware (2624430), it doesn't change anything.

Thanks

[image]

flomoto asked
flomoto answered ·

2 Answers

Followers

19 Posts
51 Users
1 Follower

Topic Experts

There are no topic experts for this topic. Participate in the posts in this topic to earn reputation and become an expert.