Venus OS Image

Venus OS

Venus OS is the software that runs on our GX Product range

No data on Venus OS on Raspberry Pi 4


Hardware: Raspberry Pi, battery, and SmartSolar charge controller.I have a Raspberry Pi 4B and a Raspi CM4 with an I/O board.

Installation:For testing purposes, I have only connected a battery to a SmartSolar charge controller MPPT 100/30, which is in turn connected to the Raspberry Pi via to USB.

Goal:My goal is to obtain metrics from the solar charge controller using a Python script and periodically send them to a Grafana server.


  1. Is there any project that provides a step-by-step guide for achieving my goal?
  2. I have tried testing Venus OS by installing its image from However, when I access venus.local on my PC, it shows the connection graphically but does not display any data from the battery. How can I troubleshoot this issue?

soroush asked
soroush commented ·

0 Answers

Docker Venus/Grafana on Raspberry Pi 4 installed, but not reading serial from /dev/ttyUSB0

Good morning,

I've cruised this and other forums for resources but can't seem to get un-stuck. When Venus OS is loaded to the Pi it works fine, but I'm hoping to use the Pi for more than just that purpose, so I'm trying to use the docker container with Grafana.

The containers install fine, but no measurements are picked up:


When I run cat /dev/ttyUSB0 I get this result, so it looks like the MPPT 75|15 is outputting as it should:


I've tried a few options but none seem to achieve the desired effect:


The log isn't reporting any errors, but when debug us turned on, it looks like its rapidly connecting and closing connections through the USB cable.


Any advice would be greatly appreciated.

Here's my .yaml file:

version: '3.4'



image: "victronenergy/venus-docker-server:armhf-latest"


- "8088:8088"


- "config-storage:/config"

restart: always


image: "victronenergy/venus-docker-upnp:armhf-latest"

network_mode: host

restart: always


image: "influxdb:1.7"


- "8086:8086"


- "influxdb-storage:/var/lib/influxdb"



restart: always


image: "victronenergy/venus-docker-grafana:armhf-2.0.0"


- "grafana-storage:/var/lib/grafana"


- "3000:3000"

restart: always





km6slf asked
bathnm answered ·

1 Answer

VRM data source for Grafana

Is it possible to get the data source into an existing grafana solution... without installing the composed file with grafana?

tomas-sailing asked

0 Answers

Calculating PV yields over time in Grafana

I'm trying to display a total for PV yield over a given period.

DBus values are available for /system/DC/PV/Power which I understand is the figure for all PV sources on the system, but I cannot work out how best to work out a yield/hr for this.
Suggestions welcome. Yield totals are the one thing that I am missing from Grafana that make VRM so useful.

Steve Byrne asked
arghhh40k answered ·

1 Answer

Grafana + Venus + Reference Points


Could someone tell me what the difference is between :




I am trying to create a panel that displays the sum of the 2 solar chargers. The issue is that "solarcharger/Pv/I" reports correctly for each instance, but the value retrieved for "system/Dc/Pv/Current" is more than double the cumulative value of the solar chargers?


insanesplash asked
Mark commented ·

4 Answers

MPPT is not showing up in Grafana, but is connected and working through VenusOS

Just set up VenusOS on an old raspberry pi I had and has been working well for all devices. Then I added the Grafana docker stack to another pi and it works really well for getting data about my 712 battery monitor, but my MPPT is not showing up. Any ideas?



whlla asked
Justin Cook - Bay Marine Supply USA commented ·

0 Answers

Venus OS & InfluxDB Grafana on one divice

Hi everybody,

I am currently setting up my RV with some Victron equipment (BMV, smart MPPT, etc) as a central element I use a pi with Venus OS.

My question is, is it possible to have Grafana/InfluxDB on the same device? I do not what to run a second pi just for that as energy consumption is always critical.

I am not a Linux guru and struggling installing the docker-composer on my Venus OS pi.

Thank you for any help and/or tips.



dirkmuc asked
ben answered ·

2 Answers

7 Posts
724 Users

Topic Experts

Kevin Windrem
4443 Points
855 Points