ess grid setpoint not reached Image

ess grid setpoint not reached

Multiplus II ESS / 400W Restriction


Is there any update /plan on making the 400w ramp-up-speed restriction of ESS configurable (i.E. deactivate or make it changable)?


There are multiple factors that determine the response time to a (digital-) command to feed in: [..]

  1. Hard coded rate limiting in the inverter/charger firmware: as per ESS version 162 it is set to 400W per second. The reason for this rate limiter is that without that there are regulation problems (overloads and such) when the mains is weak (long cables and such resulting in a relatively high impedance). More information on that here, as well as in the main ESS manual.

Not really my top priority, but it would still be nice to be able to react faster.


techmuc asked
disaster123 edited ·

2 Answers

2 x Multiplus 2 48/3000 (parallel on phase 1) in ESS: grid setpoint not reached


I am using 2 x Multiplus 2 48/3000 (parallel on phase 1) in an ESS configuration with a Pylontech Battery US2000b+ (9.6kwh total) and a Venus device with EM24DIN. There also is a Fronius Symo 15-M AC coupled inverter with 10kwp PV connected.

All this in Germany on a 3Phase grid ("Schieflast" is avoided by other measures).

The second Multiplus was only installed yesterday, since then I observe that the grid-setpoint is never reached, there is, especially on battery, always a much greater consumption from the grid than set.

Grid Setpoint is set to 10W, true average consumption from the grid is almost 200W all through the night. As I stated: this is only true since the installation of the second multi.

If I adjust the setpoint to -200W, consumption drops but as soon as the solar kicks in during daytime I am exporting more than I want.

What could be the reason?

Thank you very much!


jfleissner asked
gnsa14 answered ·

5 Answers

Current transformer settings

I have attempted to install the current transformer in place of the "shunt" in the MPII but not had success. The MPII fan starts up immediately and the values on VRM are wild and extreme.

Please can anyone tell me the settings required to input into ESS to make the CT work along side the ET112?

I am searching for the Holy Grail of accurate values on VRM combined with rapid response time to load changes from the MPII.


usernamepasswordbs asked
usernamepasswordbs answered ·

2 Answers

MultiPlus-II ESS mode 2: doing it's own thing from time to time

So I use Mode 2 to set the grid set point. Using it for several months. From time to time, the MultiPlus-II completely ignores the grid set point and acts erratically. It switches between Bulk (charging) and Discharging every few seconds, and sometimes shows "PassThru" in the GX interface.

Normally this rarely happens (once every few months). Or at least, I rarely notice it happens. But recently, I noticed this behavior twice on a single day.

In the morning, the custom control had the grid set point set at 2690W. I noticed that the grid set point was not reached at all. Even though the battery was not full or there was any other obvious cause for this behavior.

The MultiPlus-II was drawing 1000-1200W from the grid at that point. Far from the 2690W requested. I switched to Mode 1 by disabling the custom control. The MultiPlus-II did not "recover" even though the grid set point was now fixed at 2690W for quite a few minutes. I finally ended up taking some screenshots before resetting the MultiPlus-II through the GX menu. After all was back up, the MultiPlus-II behaved nicely again and I re-enabled the custom control.

A few hours later, I noticed the MultiPlus-II was behaving erratically again, seemingly doing its own thing, completely ignoring the grid set point. I again disabled the custom control and set the grid set point to 0W manually (in the GX device). To no avail.

In stead of resetting the MultiPlus-II, I decided to try something different this time. I shut down an electric fan heater (consuming approx. 500W) and low and behold, the MultiPlus-II started honoring the grid set point!

I am collecting some key metrics of the MultiPlus-II like input and output voltage, current, frequency, power. When storing these metrics however, they get averaged out over 10 seconds. So the quick charging/discharging behavior is lost in the process.

I am using a MultiPlus-II 48/5000/70-50, firmware version 494. Any idea if there is a known firmware bug on this?

If not, would it help the firmware development team having "debug" data every second?

bjorn-n asked
sandebs commented ·

3 Answers

Et340 grid meter values issue. ESS not working correct


There seems te be a problem with the data comming from the et340 grid meters that we have installed for multiple clients and they are all acting strange.

The Total grid value is fluctuating a lot and it is forcing the batteries to go into charge and discharge all the time. The Ess phase compensation for a single multiplus2 in a three phase grid was working before and it reacted to the values from the grid meter, only problem is that these now go from minus to positive in 5sec and forces the ess to change constantly. Is there a problem with the meter, rs485 connection or do we need a current transformer to get these readings correct?

All firmware updates have been done to latest version and still no changes.

apollo-technics asked

0 Answers

Issue with ESS taking power from Grid


I am an installer who has installed THIS system more than 30 times. Total of about 60 installs on VRM.

The problem is ESS keeps on taking power from grid instead of DC/battery/PV. Day and night. It also does not export power to 'non-essential' loads ("AC Loads" as per VRM).


We have:

  • MultiPlus II 48/5000/70
  • Smart Solar 250/70
  • Lynx Distributor
  • Cerbo GX + Touch
  • ET112
  • Freedom Won 5/4 battery


  • See attached VE.Config file.20220106 MPII 48-5000-70
  • ESS as per manual for Freedom Won, set to 35% SoC in 'with battery life'
  • DVCC as per manual (I will gladly give access to VRM if needed)
  • NRS097 country code selected
  • Victron cables, no crimped cables

What I have done so far:

  • All items display 100% correct on Cerbo (MultiPlus, MTTP and Battery)
  • Contacted 2 Victron distributors, neither can help me (one who I bought the inverter from, and the other the battery);
  • We had the latest firmware on inverter, but distributor recommended to roll back to 481 (last stable version) to test, not difference;
  • Check all AC cables one by one;
  • System work 100% when AC is disconnected;
  • If I discharge batteries, and chage ESS to 'keep batteries charged' it works 100% to charge from grid;
  • Tried it both with and without 'battery life';
  • I checked all RJ45 cables with a tester, even tried a new cable between inverter and Cerbo;
  • exchanged the Cerbo;
  • I have bought another MPII, but distributor told me I would waste my time, try the community first;

I understand the normally way for anyone to help me is to check basics, and I know I might have not given all info one might need to check all this. I will gladly comply, pictures, just ask. However, have spend 2 days checking everything over and over. I am convinced it is something else I might have missed. I hope another installer of someone from Victron has come across this, as both my distributors who is massive in RSA, is stumped.

Schalk van der Merwe asked
neville answered ·

9 Answers

ESS DC Coupled Solar Export Issues


The feed in limits don't seem to work for my ESS.

The AC coupled solar is metered by a Energy Meter ET112, it's not a fronius, it's just generic. The grid meter is also an ET112.

If I allow any DC solar to be exported it doesn't know how to limit production, it's either all or nothing.



DVCC is currently off. I tried with it on, and it didn't seem to fix the issue.

Battery is LG Chem RESU 9.8kWh x 2.

It's been like this forever, I'm just trying to fix to to maximise the Auto EV charging mode.

Isaac Shannos asked

0 Answers

Multiplus 2 ESS (charge / décharge a fond la batterie dans le réseau)

Bonjour à tous,

Je rencontre une bizarrerie que j'ai du mal a expliquer et qui me pose de sérieux problèmes. Et malgré mes recherches (quelques nuits d'insomnies) je ne trouve rien qui s'apparente à ce mystère.

J'ai installé un Multiplus 2 48/3000/35 + Cerbo GX + ET112 + Sonde AC + 2 Pylontech (US2000C) sur mon installation PV (3kWc micro-onduleurs) pour faire de l'ESS sur réseau. Le système est en parallèle du réseau et de l'onduleur (Voir schéma ci-dessous)

Lorsque les PV produisent bien pas de souci la batterie charge (même si j'ai du baisser le courant de charge à 15A, mais je pense que c'est en lien avec mon souci) et le système se maintien autour du point de consigne réseau.

En revanche dès que la production PV baisse et passe sous les 15A du courant de charge le système "perd les pédales" et décharge la batterie dans le réseau a fond (50A), ce qui fait chuter la tension de la batterie jusqu'a la tension de maintien (48V sur pylon) et du coup, pour compenser il charge les batteries a fond depuis le réseau. Et cela oscille comme ca d'un extrême à l'autre toute les 15 à 30 s. (ci-dessous mes paramètres). J'ai tout coupé pour l'instant et essayer pas mal de combinaison (y compris réinit complet d'usine) mais rien n'y fait toujours le même comportement. (tous les Firmware sont à jour).

Quelqu'un pourrait il m'aider? Merci de votre aide précieuse.


Davy Rio asked
Davy Rio answered ·

7 Answers

Grid Setpoint not tracking very well when running Parallel Multiplus

Started with a single MultiPlus-II 48/5000/70-48 and would maintain fairly well desired grid draw of about 50W with a steady load.

I now have two unit's in parallel, build dates are within about a week of each other (2022) and running 497 firmware.

Overall it seems to work and is stable apart from the grid setpoint tracking. With it set to 10W it will vary between 50-100W when the general draw is about 1000W. With a 4000W draw it will bounce around between 100-300W and so on with higher loads.

Are the unit's fighting each other to balance the load?

  • Running in ESS mode,
  • 6 x Pylon 3k Batteries
  • Smartsolar MPPT VE.Can 150/82 rev2
  • ET112 Grid Energy Meter before consumer unit
  • 240V single phase.
  • AC input is 20A MCB via 2.5mm2 cable to each inverter
  • AC Out 1 on both units connected together but not used which leads to an emergency outlet.
  • AC Out 2 are not connected at-all
  • DC side is 70mm2 cable, identical lengths.

mezo asked
rata1 edited ·

6 Answers

ESS ou HUB2 sur EasySolar 48/5000/70-100 MPPT150/100

Question 1/ le colorcontrol est-il GX sur ce modèle ?

Voici le schéma simplifié actuel de l’installation (voir photo)


Cette installation a été installé en début d’été 2022 sans problèmes car 0 injection réseau, le temps ensoleillé a pourvu aux charges de la maison sans problèmes, seulement avec l’arrivée de l’hiver et le manque de soleil, les tracas arrivent.

La config dans VECONFIG actuelle :

Grid : None

Convertisseur : activé avec powerassist Pas d’AES

Chargeur : activé courbe de charge : adaptative + batterysafe

Inter virtuel : pas utilisé

Assitants : pas utilisé (par faut HUB1 dansl'Easysolar vu sur le Controlcolor)

Je précise est c’est important, que la connexion Edf dans AC-in vient d’être mise en place il y a 3 semaines et que c’est a partir de ce moment-là que les choses doivent être modifiées.

Actuellement l’Easysolar est fonctionnel, la config sur le controlcolor est en HUB1.

Le problème : avec cette config HUB1, quand les batteries ne sont pas chargées complétement, c’est le réseau qui charge les batteries et qui alimente la maison, normal je dirai, sauf que ça coupe la charge avec les panneaux solaire !

J’envisage de mettre en place un système ESS sans réinjection du surplus dans le réseau mais avant ça n’y aurait-il pas une façon de avec les assistants de modifier ce problème ? L’assistant HUB2 ?

Le but est :

Si pas de soleil, alors utilisation de Edf depuis AC-in pour les charges de la maison sans utiliser le parc batterie et recharge batterie modérée. (Priorité à la charge des batteries par les PV quand il y a un peu de soleil)

J’espère avoir été clair dans mes propos.

gege asked
Thierry Cortassa (Victron Energy Staff) answered ·

1 Answer

ESS system is pushing back to the grid after adding a second MP2

Good day,

I had an ess installation working perfectly fine. It was set to 10W grid set point and we had no issues.

We now added a 2nd MP2 in parallel to the same system.

When doing that we had to clear all ESS assistants on the BUS and then re-configure them.

According to the docs we had to go and add ESS assistant onto each inverter on the system. This we did.

However now that the 2nd inverter is installed and up and running I have noticed that we are now pushing ~370W back into the grid, this is even at night when there is no Solar and the battery is low. This is obviously not an ideal situation.


I have tried increasing the grid set point to 100W and that didnt help either?

What settings could I have wrong here?

dylan-hyslop asked
dylan-hyslop commented ·

1 Answer

How do I set three-phase grid setpoint ESS mode 2 through pymodbus?

How do I set three-phase grid setpoint ESS mode 2 through pymodbus? the only register at the site is 2700, only this register is necessary to limit the gird?

I set the setpoint with this register but the grid was not limited

vinicius asked

0 Answers

Grid Setpoint not working on parallel 2x Multiplus II 3000-48-230-35-32? How can I fix?



ESS Grid Setpoint feature not working. Inverters consuming grid unnecessarily, costing me money.


2x parallel Multiplus II 3000/230/48/35-32 firmware 2629-497, ESS, Venus GX on ver2.89, bluesolar mppt 150/45, bluesolar mppt 150/35, 4x pylontech us3000 min SoC set at 30%.

Installed a parallel inverter 6 days ago and immediately the grid consumption tracks above the grid setpoint. It worked perfectly when I had 1 inverter.

I have redone setup with QuickConfigure and added the assistants on each inverter. This has not helpled.

The problem gets worse when in Power Assist mode via AC-In, even with enough PV Solar and battery, at this stage, grid consumption increases to hundreds.

Please assist with a solution if you have thanks in advance. Haven’t found a solution on the community pages.

bonie-wanda asked
marekp commented ·

3 Answers

Feed fronius output to quattro output 2

Hello, when we have an ac coupling system, it is possible to feed grid tie inverter to the Quattro output 2? And not feed it in the network.?

depute-wilondja-watutakubi asked

0 Answers

VRM and local Dashboard show incorrect wiring after install AC current sensor on Multiplus 2


i'm just finish to install my Victron system based with this devices :

- Smartsolar MPTT, VE-can ,

- smart shunt, Ve-direct,

- Cerbo GX,

- Multiplus II -

This morning i installed an AC current sensor to my multiplus II in order to prevent power feedback to the grid.

..but after that, the power in/out measured to the grid is correct but the wiring on dashboard appare incorrect.

Now i'm draw zero power to critical load ( AC out disconnencted ) but in dashboar all power coming to the grid ,are considered draw for critical load.

In real this power are loaded only by AC load.

I'm not discovering what is wrong in my configuration... i'm load ESS assist .

Someone can help me ?

Thanks in advance,


( the wrong wiring is visible also in VRM : )


fcattaneo asked
fcattaneo edited ·

0 Answers


Topic resources

Additional resources still need to be added for this topic
35 Posts
35 Users
1 Follower

Topic Experts