macOS Image


how do i use ve configure with a mac?

i am trying to connect to a multiplus to use ve config tools using a mac(not windows) i have downloaded wine bottler and have the software installed and it seems to run fine but when i try to connect using auto detect it cannot connect? any help would be greatly appreciated, cheers, stuart

stuart asked
celts88 commented ·

16 Answers

how to edit config file on Mac as VE configure only exists for windows

Before I bought an EasySolar I had read everything was possible through VRM portal. I had downloaded the app both for IOS and OSX so I was under the impression that the Apple ecosystem was fully compatible.
But now as I see no ESS assistant found I only seem to be able to activate that through downloading the rsvc file and edit it. When I click on the download VE.Configure3 link, I get to a software download page where Victron Connect is available for different OS but VEConfigure is only avail for windows!?

I've looked around on the VRM portal and I can't find how to edit that config file.
As you can imagine I'm not keen to buy parallel or Fusion just for editing that file.

Am I missing something?


philippe-rigollet asked
philippe-rigollet commented ·

2 Answers

macOS VictronConnect can't connect over MK3-USB/VE.Bus to Parallel Multipluses.

Situation: Initial setup of Dual Multiplus situation. Everything appears working, but no ability to communicate with Multipluses.

1. The MK3-USB was loaned to a friend who had no trouble using it. macOS shows it in the USB bus tree. Running the latest Ventura version of MacOS.

2. The Multipluses are reasonably late model, running 27xxx413 and 27xxx481 versions. They are giving different LED flashes but according to manual these are not VE.BUS errors. (no opposition flash to the inverter light, which is solid.)

3. The Cables connecting are highly rated Cat 6 cables, premade. Everything appears correct.

How to debug?

The VictronConnect app has two tabs, Bluetooth and VRM. Both of these work. When the MK3-USB is connected should another tab appear with the multiplusses? Or is there something that needs to be done in the app?

sailing-cat asked
sailing-cat commented ·

1 Answer

Mac VictronConnect doesn't work with SmartSolar 150/35

Here's my config:

MacBook 12,1 - OS X 10.15.7 (Catalina) - VictronConnect 5.77
SmartSolar 100/15 - SmartSolar 150/35

100/15 connects and works fine, 150/35 doesn't (doesn't get past 20%); It doesn't even show the live bluetooth digest when on the devices screen prior to connecting.

Both SmartSolars connect fine to iOS app using bluetooth.

thanar asked
thanar answered ·

1 Answer

Configuration materiel viction via Apple mac, possible ?


J'ai installé victron connect sur mon mac, pas de soucis, mais on me dit qu'il faut un PC pour utiliser pleinement les produits victon, cela est juste ?


christian54 asked
axelenergie answered ·

1 Answer

When will VictronConnect on Mac support assistants?

Prior posts indicate Victron will not be making VE Configure available on Mac, and have also stated that their direction is to move the VE Configure functionality to VictronConnect.

Have just installed new Victron lithium batteries (plus VE BMS) on existing Multiplus-II/CCGX system and Assistant is required - seems like adding the Assistant this should be mainstream as all Victron gear and a common application?

andy-2xs asked
andy-2xs commented ·

3 Answers

VictronConnect v5.70 Update Quitting Unexpectedly With Monterey 12.4

Updated to VictronConnect v5.70 through App Store on my MacBook Pro. V5.70 is quitting unexpectedly since doing update.

Deleted V5.70 with AppCleaner & Uninstaller, removed Bluetooth settings and rebooted MBP and reinstalled VictronConnect v5.70 through App Store.

Same issue - VictronConnect quitting unexpectedly.

kevinvh asked
kevinvh commented ·

9 Answers

VEConfigure functionality for macOS availability update?

I've glanced through many messages here and some years old that say Victron is working to move everything over to VictronConnect which is cross platform so that you do not need a Windows OS to run VEConfigure. Is there any update on the status of this?

My computer is an M1 MacBook Pro and from reading here it seems like even running Parallels to run Windows in a VM is not that straightforward since you have to use the ARM version of Windows.

I need this to configure my Quattro to prioritize using PV input and use battery down to certain state of charge.

dbainbridge asked
shaneyake commented ·

3 Answers

.rvms file conversion: security danger of publicly posting file

This is a follow-up to .rvms file needs to be opened on a Mac without Windows emulation...

Turns out I live deeply inside of the walled garden that is the Apple ecosystem. Finding a friend with a PC to convert the file is proving harder than expected.

Would there be a security risk if I posted the .rvms file here and asked if someone from this forum would be willing to covert it and post the converted file? In that scenario should I be able to upload the converted file from my Mac?


minus1psi asked
shaneyake edited ·

2 Answers

.rvms file needs to be opened on a Mac without Windows emulation, are there options?

Our Multiplus had a firmware update pending. I thought I was being careful but failed to realize that the update would create a .rvms file that needs to be uploaded from a piece of software that is not available for a Mac. The firmware instructions included this

"At this moment the first stage is complete. Next you’ll need to open the provided file in VE.Bus System Configurator by double clicking it. The settings will automatically be converted to the new firmware version; and a popup will show in case anything needs double checking. When finished, close the Configurator, it will prompt to store the file."

I ran the first phase of the firmware update at night. As far as I know everything has gone smoothly enough to this point. I have the .rvms file but no way readily apparent way to upload it. The Multiplus restarted automatically and now reports as inverting.

Our installation is used on a camper and includes the Multiplus 12/3000/120, (2) solar charge converters, SmartShunt, Cerbo GX, and the display panel for the GX . It also includes a DC-DC charger that is ready for use camper-wise but not towing-vehicle-wise.

What are the options here?

Your advice is appreciated! Thank you!

minus1psi asked
Paul B commented ·

3 Answers

VictronConnect Bluetooth pairing on macOS 12.1 aka Monterey broken?

Ive just upgraded to Mac OS 12.1 and VictronConnect is still not paring with devices it seems. Has victron registered the issue with Apple? As a developer its likely to have more clout than us as users. It would be really useful to get this sorted. Im using the Beta Test version of the connect app.

frangar asked
raymiller answered ·

4 Answers

VictronConnect now working on Mac OS 12.3

I know some have put posts on older threads but just in case others are not seeing them the latest update to Mac OS 12.3 seems to have fixed the bluetooth issue where devices weren't pairing to the Mac. Many thanks to all concerned in getting Apple to sort this issue.

frangar asked
frangar edited ·

0 Answers

Is Victron planning to recompile the Victron Connect App to target the new Apple M1 MacBook Air and MacBook Pro?

Merry Christmas!

Is Victron planning to recompile the Victron Connect App to target the new Apple M1 MacBook Air and MacBook Pro?

I know you can run it in compatibility mode but this isn't optimal. It would be really nice for Victron to specifically target the new M1 Silicon!

jonmarinello asked
nickdb answered ·

2 Answers

Mac user configuration of Multiplus using MK3 USB

I've downloaded the Mac VictronConnect app on the Victron website, but it doesn't see my Multiplus, even while I'm connected using the MK3 USB. All other discussion here discusses using Wine or Parallels, yet there is a Mac app on the site for this purpose. Anyone have any luck using the app and seeing their device?


Randy Repass Jr asked
valden commented ·

7 Answers

Using a Macbook to program a multiplus

Is there specific software tools for mac OS as i don't own a windows computor?

davidb asked
sieade245 answered ·

3 Answers


Topic resources

Additional resources still need to be added for this topic
16 Posts
10 Users
1 Follower

Topic Experts