mk2 Image


Multiplus on 1910159 firmware with Cerbo GX: No real time data

I have a 230v MultiPlus 24/3000/70-50 running firmware 1910159 (latest Non assistant). Upon connection with a Cerbo GX (firmware v3.00~14) via VE.Bus I have noticed the Cerbo recognizes the Multiplus but is unable to retrieve data from the Inverter in real time. It only works manually - if I press the "Press to redetect" button in Remote Console it does refresh the values.

I was wondering if any of the following would improve this:

1) Updating the firmware on the Multiplus to 1910209 (latest Assistant Firmware).

2) Connecting the Multiplus to the Cerbo via USB using the MK2 adaptor.

Would appreciate any feedback.

hvalentim asked
hvalentim edited ·

2 Answers

question about MK2/MK3 protocol for setting AcPowerSetPoint / ESS 'Grid Setpoint'

Hi, i am programming some simple functions on top of the MK3 USB interface. I have read the 'Interfacing with VE Bus MK2 protocol' pdf from the site and i have most of the thinks working. My goal is to implement the AcPowerSetPoint via the MK3 interface.

Does anyone know that the correct MK2/MK3 protocol variable is for setting and getting the AcPowerSetPoint? (aka Grid Setpoint)

When i look at 'RAM variables' from the MK2 protocol pdf, i see ID 's 14,15 and 16 and that could be what i am looking for. Unfortunately these ID's don't seem to give the right values.

(Does anyone know the difference between ID 14 and 15? The text is the exactly same for both ID's but they return a different value..)



jeroenw asked
symbioquine answered ·

2 Answers

Multiplus 24/1600 with MK2 for parallel operation

I recently bought and installed 2 Multiplus 24/1600 inverters and an MK2 USB. I'm just trying to program them for parallel operation, but VE Config3 and VE.Bus Quick Configure won't let me into the inverter. VE Config3 says it detects the MK2, but then goes to a screen asking to select a coms port. The VE.Bus Quick Configure doesn't seem to detect the MK2. I'm using windows 10, which recognizes the MK2 as a device, and I'm pretty sure I managed to install the drivers correctly, after all VEConfig3 says the MK2 is detected. Please help.

critterfer asked
mirek answered ·

3 Answers

Cannot connect old Multiplus (19 59 139) with VeConfigure

I have an old MultiPlus (firmware version 139 in VRM, product id 1959) and I would like to configure it with VEConfigure. In the past, I could successfully connect, but I cannot any more.

I connect with MK3-USB, and it didn't work, so I tried again with MK2-USB with the same errors (except that when I connect with the MK2, the Multiplus stops when I plug it in, but that's normal).

I tried with VEConfigure 3 (the latest, version v90.04.230) and I get the following error:


Auto option mechanism not supported
for software version: 1959139
Use VeConfigure (version 9003119 or later) instead of this program.
(There is a small chance that this message shows up when a communication error occurs. In that case one should retry instead of using VeConfigure)

Do you want to retry?

With old version v90.03.120 (with datfile v20050703 placed next to the veconfigure.exe executable) I get:


Software version: 1959139 is not supported!

Why is that ?

How can I connect? In the past, I could connect to the MultiPlus and it worked.

Is there somewhere I can download old versions of VeConfigure that should work ?

mildred asked
kevgermany commented ·

1 Answer

Victron Connect on Mac OS to Multiplus 12v/3000/150A with MK2-USB?

I am trying to verify the configuration of my Multiplus 12v/3000/150A with a MK2-USB interface on my Mac OS 11.6 (Big Sur) with Victron Connect. Victron Connect isn't able to find the device. I've looked at the downloads web page and don't see the old VE.Connect app that I previously used.

The last time I configured it was Oct 2017 and I have a screenshot of the configuration.

I'm checking the config because it doesn't seem to be charging our 540Ah Lithium bank correctly (it used to work). I wanted to verify that it was not the Multiplus before diving into the battery bank.


terry-slattery asked
Matthias Lange - DE answered ·

3 Answers

10 Posts
9 Users

Topic Experts

9 Points