veflash Image

veflash

Inverter/Charger 12/2000/80 VE.Flash Connection issue

Hello, my Inverter/Charger 12/2000/80 was working correctly until I was required to update the firmware to make changes because I am changing from AGM to lithium. I was using the Victron Connect program and had it connected to AC input 1 and also to the new battery. But the battery was dead. I was hoping to get the inverter/charger going to charge the battery. The update was going fine until it switched off AC input 1 then the unit shut off. (Didn't realize you need DC power and it would shut off AC power during the upgrade.) After that it would no longer display within Victron Connect. But when I use VE.Flash it will detect the com port but when it attempts to connect it displays a connection error.

I have used several computers and all have the same issue. Has anyone had the issue where the com port is detected but the unit can you connect? It was working before so is it possible to do a factory reset?


Below is a picture of the image of the board and DIP switches. I do not know of the exact version it was attempting to because it automatically detected it. But the version I am using with VE.Flash is 2708490 Currently when I set the second switch to true the middle yellow LED blinks rapidly. Any help would be appreciated. Thanks.

[image]


Jon Baxter asked
Paul B answered ·

1 Answer

problème Mise à jour du multiplus d'un Easysolar 2013

Bonjour,

Je suis Philippe et je cherche à faire la mise à jour de mon multiplus d'un easysolar de 2013. C'est un EASYSOLAR 48/5000/35-50 MPPT 150/100 COLOR CONTROL. J'ai tenté de faire la mise à jour avec mon câble MK3 et en utilisant le logiciel VeFlash du package VEconfigure3. Je me suis branché sur la carte directement à la place du branchement RJ45 du Color control. J'ai bien sûr changé les 2 premiers dips et pressé 2 secondes sur le bouton up de la carte.

Ma question, s'il vous plait : Comment faire une mise à jour et accéder aux assistants pour un Multiplus 2624 en version logiciel 158 datâtes de 2013 ?

En vous remerciant par avance.

Bien cordialement,

Philippe.


philippe-b asked
philippe-b commented ·

1 Answer

Help!! 19XXXXX "General Error Occurred" at end of VEFlash update

Hi there,


Relatively new to the Victron world but I've got a multiplus - a 24 3000 70 - Hex.1912125 and I need to update it to the latest firmware in order to connect it to Victron Connect.

- I downloaded VEFlash

- I downloaded firmware version 1912209 (is this correct) via Victron Professional?

- I have a MK3 dongle.

- The multiplus is recognised by my PC

- I'm running windows 10

However upon going through the VeFlash update I get to the very last screen (after it says it's uploaded etc.) and it says "General Error Occurred". How on earth do I resolve this?


Thanks,

damjeff asked
damiano edited ·

1 Answer

Quattro fails to turn on after firmware upgrade

Quattro 48/8000/110 s/n HQ17426YBN5 CHIPSET 6955161.HEX

using VE flash attempted to upgrade firmware to 6955476. The uploaded appeared to work. after the upgrade quattro did not turn on.

I have tried firmwares 69552xx and also 6955161 as above the upgrade appears to work but inverter fails to turn on.

I have powered the entire system down after each firm ware update but inverter fails to turn on

After upgrading to 6955476 was able to communicate with VICTRONCONNECT but still unable to turn inverter on.

PROBLEM SOLVED

I connected to the inverter with VICTRONCONNECT and did a firm ware upgrade with that. the firmware loaded was 6955475 and the inverter is now running.

wal-clothier asked
Paul B answered ·

1 Answer

MK1 Multi 48/3000 "Bootloader" LED indication

Mulitplus Indicating Bootloader LED error. Victron toolkit app states to recover firmware on the chip using VE.Flash. Is this even possible or is the chip stuffed?

I tried to proceed with the process of VE.Flash but it wouldn't connect to chip.

barendvdevill asked
Daniël Boekel (Victron Energy Staff) answered ·

1 Answer

Quattro 3k firmware update failure

Hello,


I tried to update my Quattro but the process failed. I have tried several options and no success so far and need to help to get back on track.


The equipment:

- Quattro 12|3000|120, PCB version 010021-4, original FW 1931119

- UTP cable of 1 meter

- UTP cable of 2 meter

- MK2 (I don’t have an MK3)

- Windows 10 DELL notebook with latest VE toolset

- Windows 7 desktop with latest VE toolset


What I did:

1) I downloaded the firmware from the professional Victron site. I have now two files: 1931159.vff and 1931209.vff

2) I stated VE-Firmware on my notebook and followed the instructions. I selected the 1931159 firmware without the assistant support.

3) I made sure that the dip switches were set ok (DS1-off, DS2-on)

4) At first the boot-loader was updated. This went apparently well, as subsequently the firmware was updated.

5) The update failed during the postprocessing phase (a windows pops up labeled: updating / post processing and shows a progress bar. The progress bar stops at about 80%.

6) A “General Failure” is reported and I can only click “OK”, after which the application is terminated.

7) I repeated the process, with hopes that a second time the update would be successful. The bootloader was not updated this time. The general failure appeared at the same moment.


I have recorded the process, see movie at: https://www.dropbox.com/s/92r7y4s6qw53ew9/Quattro_FW_Update_failure.MOV?dl=0


8) For a second try I used a desktop with Windows 7. I also downloaded the firmware again from the professional Victron site. The process of updating and failing is identical to the notebook process.

9) I now tried it again with the 1931209 (with assistant support) version of the firmware. Same result.

10) Next, used a longer cable, no result again.


I now have an unusable Quattro with 8 flashing LEDs. My questions:

a) What to do? How can I make the update work?

b) What happens at about 80% of the postprocessing phase? Is this a CRC check for example?

c) What is exactly going on? A “General Error” is not providing my any guideline to resolve the situation. Is there a log file, or can I enable generating one?


Thanks in advance for your help.

Bertus

bertus asked
wkirby answered ·

2 Answers

Has anyone tried using VEFlash via Wine?

I don't have a Windows laptop currently, and would like to keep it that way, so I have been running VEConfigure via Wine on Linux which seems to work perfectly well. I would like to be able to do the same with VEFlash, but I know the consequences of something going wrong there are potentially significant. I'm quite familiar with embedded Linux, and am used to flashing things via serial or JTAG from the command line, so if there is a way to achieve this for Victron products too I'd love to hear it.


Otherwise, has anyone here tried flashing a Victron device using VEFlash on Wine?

aeneby asked
aeneby commented ·

5 Answers

7 Posts
7 Users
0 Followers

Topic Experts

There are currently no experts identified for this topic. Can you answer questions in this topic area? Community members who provide answers that are marked as correct earn reputation and may become recognized as topic experts.