question

Bertus avatar image

Quattro 3k firmware update failure

Hello,


I tried to update my Quattro but the process failed. I have tried several options and no success so far and need to help to get back on track.


The equipment:

- Quattro 12|3000|120, PCB version 010021-4, original FW 1931119

- UTP cable of 1 meter

- UTP cable of 2 meter

- MK2 (I don’t have an MK3)

- Windows 10 DELL notebook with latest VE toolset

- Windows 7 desktop with latest VE toolset


What I did:

1) I downloaded the firmware from the professional Victron site. I have now two files: 1931159.vff and 1931209.vff

2) I stated VE-Firmware on my notebook and followed the instructions. I selected the 1931159 firmware without the assistant support.

3) I made sure that the dip switches were set ok (DS1-off, DS2-on)

4) At first the boot-loader was updated. This went apparently well, as subsequently the firmware was updated.

5) The update failed during the postprocessing phase (a windows pops up labeled: updating / post processing and shows a progress bar. The progress bar stops at about 80%.

6) A “General Failure” is reported and I can only click “OK”, after which the application is terminated.

7) I repeated the process, with hopes that a second time the update would be successful. The bootloader was not updated this time. The general failure appeared at the same moment.


I have recorded the process, see movie at: https://www.dropbox.com/s/92r7y4s6qw53ew9/Quattro_FW_Update_failure.MOV?dl=0


8) For a second try I used a desktop with Windows 7. I also downloaded the firmware again from the professional Victron site. The process of updating and failing is identical to the notebook process.

9) I now tried it again with the 1931209 (with assistant support) version of the firmware. Same result.

10) Next, used a longer cable, no result again.


I now have an unusable Quattro with 8 flashing LEDs. My questions:

a) What to do? How can I make the update work?

b) What happens at about 80% of the postprocessing phase? Is this a CRC check for example?

c) What is exactly going on? A “General Error” is not providing my any guideline to resolve the situation. Is there a log file, or can I enable generating one?


Thanks in advance for your help.

Bertus

Firmware Update IssueVE.Busveflash
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
WKirby avatar image
1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Many thanks for the suggestion to use the older version of VEFlash (90.05.150). This did the trick. Update went smooth now. System is up and running again.

WKirby avatar image

Hello All


A new version of VE.Flash which fixes the firmware updating issues has just been released.

Allow your VE.Flash software to Auto-update to receive the latest version.


Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.