question

canarias avatar image

New VE.Can MPPT charger doesn't use BMV current value for tail current

Hello Community,

in december 2019 a great feature was added to the firmware 1.47 of the VE.direct MPPT chargers:

tail current mechanism improved: it can now use the real battery current. The current can be received via VE.Smart Networking (Bluetooth) as well as from a GX Device

This is a useful feature I'm using in most installations since it has been released. A week ago I tried to do the same with a VE.Can SmartSolar and unfortunately it doesn't seem to work at all.

The system consists of a CCGX, BMV700, Multiplus 5000 and VE.Can 250/100 SmartSolar. Other devices have been removed to keep things more simple.

There is no ESS/HUB assistant installed and therefore no active external control of the charger. Also no bluetooth smart network has been created and the firmware is up to date on all products. In the system the BMV is set as the default battery monitor to use and SOC syncs well with the multiplus. DVCC and SCS are enabled and SCS status is active. In the carger the absorption time is set to a fixed time with a tail current of 10A. If the current value falls below that value for more than one minute the charger should end absorption stage earlier and pass over to float. But it doesn't. Nevertheless DVCC is working with voltage, temperature and even current (tried a limit on the system). It seems the charger just has no use for the value "battery current" sent from the BMV and uses it's own current value instead to end absorption.

I have asked dealers, distributors and victron support, but all of them told me the charger would be able to do this without testing it. So I'd really appreciate if someone with a new CAN system (the old chargers can't) could test this. Of course a load must be switched on to have different current values between charger and BMV. I just want to know if this feature is working or has not been implemented yet and victron doesn't know about itself. If it works probably someone finds a mistake in my settings? I would prefer I made a mistake.


Thank you very much!

not-working.png
tail-current.png
BMV.PNG
SCS-active.PNG

CCGX Color ControlVenus OSmppt smart solarDVCCVE.Can
not-working.png (64.8 KiB)
tail-current.png (168.1 KiB)
bmv.png (22.3 KiB)
scs-active.png (22.1 KiB)
2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @CANarias, just to let you know I spotted this and will check internally.

Matthijs

canarias avatar image canarias mvader (Victron Energy) ♦♦ ·

Hello Matthijs, I didn't expect that, but I'm glad to hear. Thank you! :)

2 Answers
canarias avatar image
canarias answered ·

Many thanks to @mvader (Victron Energy),

this was the fastest fix I've ever seen. It's working like a charm now! :)

5 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @CANarias,

I suppose you found the firmware update v3.04 already?

You’re welcome! And thank you for reporting. There was (once checked in detail at the right place) an obvious mistake that needed fixing.

For which my apologies and good that its solved.

seb71 avatar image seb71 mvader (Victron Energy) ♦♦ ·

Any chance to re-enable solar chargers tail current when using ESS?

yes, thats high on the whishlist. The product that then needs to get the functionality is the inverter/charger, not the solar charger.


and, as that is a far more complex product, with a long list of planned projects, it will take quite long before we get to that, I’m afraid

canarias avatar image canarias mvader (Victron Energy) ♦♦ ·

Yes, it's working since v3.04 as the changelog promises.

Even more good news for me that anytime soon even the multi will probably be able to do so. Or central settings in the system. Whatever, I'm looking forward to it. :)

Well, anytime soon I’m not so sure :-).


but yes. Have a good night! (Or day)

Al avatar image
Al answered ·

I haven't got the panels attached to my 250/100 VE.Can to test, but I have also found other gremlins with DVCC, (Adaptive absorption doesn't work- MPPT's stop their output when a multi / Quattro is charging from mains at the same time) my question: https://community.victronenergy.com/comments/80135/view.html

So It's quite possible tail current also doesn't work for Ve.Can too which would be a real shame.


6 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Just to add to this, when powered on my VE.CAN 250/100 disables Shared Current Sense, when I disconnect it I have SCS back for the other Bluesolars and Quattro?

250/100 v.3.03

CCGX v2.63

SmartShunt v4.05

Quattro v481

Bluesolar v1.54

scs-disabled-with-vecan-mppt.jpg

Hello, that's quite normal. When disabling the maximum charge current this will be enabled again. So that hasn't to do with the problem I have :)

Hey @Al, also we found a possible issue with the maximum charging current. (Developer-) details are here: https://github.com/victronenergy/venus/issues/792.


This will take a little longer to fix; but current plan is to have it as part of v2.65; targeted for release before end of this month.

Al avatar image Al mvader (Victron Energy) ♦♦ ·

Great, thanks, @mvader (Victron Energy) I'll keep an eye out for updates.

I'm not sure if it's another part of the anomaly or by design, but I have a feeling the Quattro is following the VE.Can charge profile whilst DVCC says SCS: Disabled (External Control). It Would be great to see what the external control actually was. The DVCC manual is a little unclear on this, but I realise updates and improvements are still constantly changing.

Hey Al, this is now fixed in the current beta version, Venus OS v2.65~7. More information here:
https://community.victronenergy.com/questions/81796/venus-os-v2657-available-for-testing.html

Thank you again for reporting.

Could you let me know if that other issue you saw was fixed with this?

Al avatar image Al mvader (Victron Energy) ♦♦ ·

Hi @mvader (Victron Energy) Thanks, for looking into this and fixing, yes everything seems to work well now! Do you guys ever sleep!?

So using DVCC with SCS I can now use tail current as seen by the battery bank to share with all MPPT's for ending Abs, SCS also works now with VE.Can MPPT's and with Max Current Limit. Also Multi Charging when triggered from AC Ignore due to Cloudy day (Low SOC) is working happily and allowing MPPT's to be prioritised - before they would have been pushed into float with Zero output, but all is working well.

(These fixes should all be in the next Venus 2.65 update, if not already working for others)

Many Thanks

Al