question

brian-mullen avatar image

MPPT no showing in CCGX

My MPPT will not show up on my CCGX via the VE.Can ports. If I use a VE.Direct, it shows up just fine. My problem with the VE.Direct cable is, it's only 5' long and won't reach my MPPT, so I have to use ethernet. My CCGX firmware is up to date, my MPPT firmware is up to date. The only devices I can see in the devices section of the VE.Can settings are the CCGX and The Quattro.

MPPT ControllersCCGX Color ControlVE.Canconnection issue
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
brian-mullen avatar image
brian-mullen answered ·

I ended giving up after a few days and jusy bought the direct cable. I couldn't get the CAT6 cables to communicate with either MPPT to the CCGX.

One good thing that did come out of all of this, was that I found a nice wifi dongle that works flawlessly with the CCGX. I was able to network my system and do updates without the MicroSD cards now. If any one is looking for a cheap and working dongle, I just bought the $12 dongle that works for RasberryPi computers off Amazon. Works great!

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@Brian Mullen

An after thought here the bit rate for the ve can can be changed to accommodate different battery bit rates. It is possible it was on the wrong setting.

Settings - services - ve can port-- can bus profile.

Can mppts use 250k.

brian-mullen avatar image
brian-mullen answered ·

Pictures of the firmware versions and other info to help. Worst case, I buy a longer VE.Direct cable, rather figure this out though. Not to save a buck, but find and resolve the issue.
screenshot-20220114-183059.jpg20220114-183031.jpg20220114-183001.jpg20220114-182929.jpg


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Al avatar image
Al answered ·

I assume you have the other ve. Can terminator in the spare mppt port?

Have you tested other rj45 cables to rule that out?

I have one ve direct mppt on a 10m usb cable to the ccgx using the ve direct to usb adaptor cable, but your issue could just be a dodgy rj45 cable?

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Also


The RJ45 cable must have all connectors wired. Many have a reduced set, although the plugs are the same. Reduced ones will not work, even if they work as lan cables.
I do have the other terminator on the MPPT. It isn't the cable. I put my Fluke cable tester on it, all good. I even swapped cables with the Quattro in case it was a length issue. That was my first check when it wasn't working.
Did you swap the VE.CAN port, guess you did, but...

Guess you don't have another VE.CAN device to test with.

Looks like a dealer job.


brian-mullen avatar image brian-mullen kevgermany ♦♦ ·
I did swap them on the MPPT and CCGX. I also put my fluke on to see if they were getting a TX and RX signal from each. The ports seem to be fine via the readings.


Any one know if there is a max cable length for an MPPT using ethernet CAT6? Pretty sure I'm well under any max, just want to verify. My cable is roughly 25'.