question

Norbert avatar image

VRM Remote firmware update freezes at status 'Querying VE.Direct devices...'

VRM firmware update freezes at status 'Querying VE.Direct devices...' after succesful update of the first SmartSolar Charger VE.Can 150/70 from v1.06 to v3.02.

There is no error message generated except the warning 'Installation too busy, realtime date link disabled'.

The SmartSolar Chargers VE.Can 150/70 are connected with VE.Direct to Venus GX v2.60

Any suggestions to fix this to update the leftover chargers without using local Bluetooth and without the need of travelling to the site in Corona times?



VRMmppt smart solarVE.Directfirmware updateVE.Can
2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Just a suggestion to a possible cause, but no solution for you sorry

I have had a similar problem, but my smartsolar units were connected using USB, and the usb was just that bit two far away to get a reliable firmware update, the usb cable was 10mtrs long. so maybe that's a possible cause yes I know you are using the VE direct but maybe there is some interference or something. I had to get the customer to do the updates via there mobile phone, for that site.

On the same site I had a BMV connected by VE Direct and that updated fine

Thank you for your suggestion. I think, this new firmware is buggy coded. Former firmware updates on this devices could handle the co-existance of VE.direct and VE-Can. The new firmware is looping without error handling routines consuming exessive venus gx cpu time.
Victron can do a better job in quality assurance in the füture.

5 Answers
Teun Lassche (Victron Energy Staff) avatar image
Teun Lassche (Victron Energy Staff) answered ·

Hi all!


I'm glad to announce that we've released a fix for this issue. All devices should load again.

Sorry for the inconvenience!

Ps. the fix was made in the VRM Portal: no need to update Venus OS or anything else to make the Remote Firmware updates operational again.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I confirm that it is now working on my side. :)

mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hello all, we found an issue and are working to fix it. Hopefully today, but surely within one two weeks.

I’ll post a conment here once solved.


thank you for reporting and apologies for inconvenience caused!

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

And sorry for accepting my own answer, but thats to save some reading and discussion time for other coming across this one.

mediacut avatar image
mediacut answered ·

Same issue on MPPT. Please also check this cerbo error.9113eba6-8086-4b64-bd4c-6a8292028c08.jpeg


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Norbert avatar image
Norbert answered ·

Thank you Guy for the support and your recommendations.

I had already performed the Venus GX reboot without solving this issue.

In the meantime, i have had someone on site update the firmware over his cell phone with instructions over the phone.

It was possible without any problems via bluetooth.

A downgrade to the old v1.06 is not, however. VictonConnect-Remote (VC-R) lets me manage the charge controllers remotely, detects the new installed firmware and then I cannot downgrade.

I wasn't really aware of this new method in the past.

The error is not due to the device firmware functions, but rather to the detection process within the VRM portal when updating this firmware via the device list.

In the past, the update to v1.06 was carried out successfully on the devices one after the other and now freezes after the successful update of the 1st device with v3.02 during the step of detecting VE.direct, and that without gernerating an error message.

firmware-update-freeze-query-vedirect-on-vecan-con.png

In the next few days I will be commissioning a few more charge controllers without VE-CAN and update them remotely too. I will report, if it fails similar.


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Are you able to use Remote Console, then the General Menu, to Reboot the GX device to see if that helps?

Otherwise, could you try using VictronConnect Remote, rather than the VRM web interface?

Just to see if that helps to isolate what the issue is?

Lastly, if you think this issue might be related to a GX firmware update, could you regress to a previous known working version, and if that fixes the issues, please let us know to help find what the issue might be.

6 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, I have exactly the same issue. In my case I have a Quattro running on firmware version 430 and my Cerbo GX is on version 2.60. I have rebooted both several times and it made no difference.

Thanks for reporting @Upetr, to confirm you have tried through both VRM website, and via the VictronConnect Remote?

upetr avatar image upetr Guy Stewart (Victron Community Manager) ♦♦ ·

I have only tried it via the VRM website. Do I need a MK3 cable to do it via Victron Connect Remote? If yes, then I have to get my hands on one first.

What is it exactly that you are trying to do?

This question is about VE.Direct devices.

VictronConnect Remote is only for the MPPTs, BMVs (and other VE.direct devices). More info in that linked manual.


An MK3 is not necessary, that is for VE.Bus devices - such as for the Quattro - if this is about a Quattro you will need to start a new question.

upetr avatar image upetr Guy Stewart (Victron Community Manager) ♦♦ ·

All I am trying to do is a firmware update in VRM. It starts the process and gets stuck on "Querying VE.Direct devices..."

I didn't realise that it doesn't impact the firmware in the inverter.

However, I ran multiple tests. I have two direct.ve devices connected to the Cerbo GX. A BMV-712 Smart running V4.03 & SmartSolar MPPT VE.Can 250/100 rev2 running V3.02 firmware.

VictronConnect via phone connects to both devices and confirms that they are up to date. So that works fine.

If I disconnect the SmartSolar, I can run the VRM Remote successfully (with the BMV connected). I have tried changing ports and cables and the end result was always consistent.

After plugging in the SmartSolar, VRM Firmware Update will get stuck on "Status: Querying VE.Direct devices...".

Thanks for that extra info, I’ve passed it onto the VRM team, hopefully they can get it sorted out.