question

tomx avatar image

Victron SmartShunt bluetooth is busy

screenshot-20210808-114302.jpgI have been using my SmartShunt for some time successfully. This weekend while monitoring my battery from the app it suddenly disconnected and greyed out in the app. Now when I try to connect it says bluetooth is busy.

Here's what I tried, nothing has recovered:

1. Turning off bluetooth on my phone, waiting couple minutes then turning on

2. Setting airplane mode, turning back on after a couple minutes.

3. Rebooting my device

4. Powering off device, leaving off overnight, turning back on

5. removing the SmartShunt from bluetooth settings

6. Clearing app cache/data

7. Removing and re-installing the app


Here's my log:

VictronConnect_report.log

Can anyone assist?

smartshuntBluetooth
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, I’m in the process of changing my components to Victron.

I started withe the smart shunt, trying to find the full charge and feel confident that my SOC is accurate, feeling that it’s my experience and will understand soon.

Now im having the same problem connecting with the “connected to another device” error and resetting the power to the shunt seems to work.

Second time in two weeks and feel the SOC is not accurate as after the full charge and calibration was messed

Im up to date on the updates

im sure Victron will fix this bug, in the meantime my confidence in Victron is challenged and my planned ordering is stopped for now


please help us folks at Victron

Hi @Tage solar , I’m sure we can sort this out.


Can you, after restoring the connection by power cycling the SmartShunt, post a screenshot of the firmware versions in the SmartShunt? Especially the Bluetooth Fw version. When at v2.37, its up to date.


And then, next time you have an issue connecting, make a service log and also post that here. Thanks!

8 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

UPDATED JANUARY 24th 2022: VictronConnect v5.53 release is out, which has the new firmware as a mandatory update. Its the same fw version as in the previous VictronConnect version, but now the update is mandatory.

Hi all,

the issue is fixed. The solution has been tested by several people that had the problem, and it fixed it for all of them.

Finally!

To get the fix, follow these steps:

  1. Make sure you have the latest version of VictronConnect. It must be v5.53 or newer, which was released on January 24th 2022.
  2. Then connect to the product (via Bluetooth). In case you can't connect because it says "Cannot connect, Bluetooth busy", like in above screenshot, then you need to power cycle the Victron products.
  3. Directly once connected, it will prompt to update the Victron product.

The firmware versions containing the fix are:

  • SmartShunt and Solar Chargers to v2.37
  • Smart Battery Sense to v1.10.


For those interested, change log is here: https://www.victronenergy.com/live/victronconnect:beta

Note that these instructions are specifically towards the Bluetooth Busy issue, where a Victron product refuses a new connection because it "thinks" that its already connected, while it is not. This issue affected some systems, not all, perhaps depending on phone make or other variables.


Lastly, my apologies for the trouble caused and that it took us so long to properly fix this issue.

Matthijs



8 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dear all, meanwhile, the VictronConnect version that carries this fix has been released officially. I've updated by above answer to that affect.


Again my apologies to those that were affected and had to go around, sometimes regularly!, and power cycle their Victron products. I know what a hassle that can be.

anthonygaybls avatar image anthonygaybls mvader (Victron Energy) ♦♦ ·

I have the newest version if firmware but my smartshunt started with the same issue this morning. No problems for 10 months until today.

Hi @anthonygaybls that doesn’t sound too good. Would be the first!


could you post the service report here? Open VictronConnect, look for the SmartShunt, and then once you see it in the greyed out state open the menu and go to help (or settings) and make a service report. You can post it here as a file.

And a screenshot of the fw version in the SmartShunt? You’ll need to do something to get it connected. Also, do you know when you last updated its firmware?

Thank you, Matthijs

VictronConnect_report.logI am having the same problem today. My controller is greyed out. I have been using the app for 6 months now with no issues. I was using it last night and now today I can't access my controller. Please help.

I have version 5.52 of the app.

Dear all, especially @Tage solar and @SteveNL , I've updated above post. While checking why you were having issues, we found out that just installing the new VictronConnect is not enough.


You have to yourself go into the product information page and there start the update. See my amended text above.

I'm quite certain that this fixes your issue. And would be great if you can let me know the result.

I have a phoenix inverter and a smart solar MPPT controller with the Bluetooth problem. The problem is they won’t connect via Bluetooth. The first step in your solution seems to be to connect via Bluetooth to update the firmware. How do I do that if they won’t connect?

Hi @rmorgansd , this thread is about a quite specific issue: that, in the VictronConnect app on your phone, you do see the device, but its greyed out and when clicking it to connect you get a popup saying that Bluetooth is busy, like in the screenshot of the original question above. Do you have that problem? Then the solution is to first power cycle the device (ie your Phoenix Inverter and your Solar Charge controller), and then follow the steps above. After which, due to the firmware update, such drastic step of having to power cycle the equipment is no longer needed. I'll amend the steps to include that information - thank you!


Or, in case you cannot connect at all, so something other than the "Bluetooth Busy issue", then please first refer to the VictronConnect manual, trouble shooting section: https://www.victronenergy.com/media/pg/VictronConnect_Manual/en/troubleshooting.html..

And in case following those steps don't help, then this thread is the wrong one. I recommend to make a new post, or read a few others around the Bluetooth Topic.

All the best, Matthijs

rmorgansd avatar image rmorgansd mvader (Victron Energy) ♦♦ ·

Yes this is exactly the issue I have. The devices are grayed out in the iOS app and say that they are connected via Bluetooth to some other device. I will try power cycling them and see if I am able to connect to complete the firmware update. It would be good to include that as part of your instructions. Will have to wait until tonight because they are in use at the moment. I appreciate your quick response.

lexi avatar image
lexi answered ·

I am having this exact issue with my bmv712 and its certainly not the phone/tablet because I have an ipad, iPhone, Samsung s9, and two Android tablets that all show the bluetooth greyed out and busy at the same time, and even with a pin number on the bluetooth that only one of the devices knows, its fine for around 24hrs and then all of a sudden the bluetooth is busy, and the only way to refresh it is to unplug the bmv712 remote head and plug it in again. Then the bluetooth works again for 24hrs or so, and goes grey again on all devices I try to connect with. I would desperately like a fix for this especially now I know I'm not the only one having the same problem!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ddarby avatar image
ddarby answered ·

Removing the small 1A fuse from the holder in the red power wire resolved this issue for me. BT now connects fine.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

aernout-hetem avatar image
aernout-hetem answered ·

This problem keeps repeating itself. I've resorted to connect from two different Android devices. SmartSolar 100/30 and BMV 712 communicate though. Pulling the fuse is the only way to let me reconnect to the Smartshunt.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi! Its a known issue, super hard to reproduce in the office for us, but definitively a bug; and in one or two weeks there will be VictronConnect beta version that has a new firmware for the smarthshunt; and the official release will follow a few weeks later.

7 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ps my apologies for the trouble around this

Ik werk van huis en de camper staat voor mijn raam. Wanneer je wat testen wil ben je welkom.


The update today seems to have fixed it. SmartSolar 1.59 Smartshunt 4.08 Android app 5.48
Goedemorgen!


That surprises me :-). The fix I had in mind is not included in there. Please keep an eye on it. The fix I have in mind will be in the BLE-controller firmware, which is in both the SmartShunt and the MPPTs. I’m not 100% sure what its called in the VictronConnect info page.


we’re expecting to have a VC beta with that new fw out in max a few weeks from now.


aernout-hetem avatar image aernout-hetem mvader (Victron Energy) ♦♦ ·

Wat achtergrond info,

We did have a massive android update on Wednesday also. Maybe that made an update in the BT software. The connecting time is also significantly shorter.
Thanks. Do you know from what to what version? And which phone(s)/tablet(s) are you using?
Hi @mvader (Victron Energy), I think I already spammed you in another thread but I could reproduce the issue 3 times in the last 2 weeks (see my comment in this post). I'm happy to try a beta version.

Regards Ronald

mihaitaiosub avatar image
mihaitaiosub answered ·

I have the same problem with the BMV-712 Smart. It is very annoying that once every few days this error occurs, and the only solution is to turn off the power supply.Then the calibration and synchronization with the battery are reset, which is not at all ok. I use an android smartphone that I keep permanently connected to the BMV-712.I think it is a software problem, maybe the BMV-712 or the application. Please Victron solve this problem!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mihaitaiosub avatar image
mihaitaiosub answered ·

Hi everyone, the past few days there have been some updates to the Victron Connect application (v5.48) and the BMV-712 Smart (v4.08).BMV-712 was already in failure, the phone could not be connected via bluetooth, and after the update it was possible to connect. But this morning, so after a few days, the problem reappeared again, you can no longer connect via bluetooth until after the power cycle. I sincerely hope that updates will follow to solve this annoying problem, not only for us users, but especially for the VICTRON company.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

scottsayweather avatar image
scottsayweather answered ·

I'm getting a similar issue with SmartSolar MPPT 100/20. Worked fine for a few weeks, then last week after doing something else on my phone, I could not connect, with messag identical to this thread- grayed-out Cannot connect, Bluetooth is busy message. I tried several things in the VictronConnect manual- airplane mode, forgetting the previously paired device, restarting phone, waiting an hour+. Another person's phone has similar issue and I could connect to a BlueSmart Charger 10/25 (120VAC) charger.

Today, same issue. I'm using the Android app v 5.51. Just did app update and it still shows as v 5.51. The SmartSolar is still grayed out and BlueSmart is connectable from my phone.

Last time this happened I disconnected battery and solar from the Victron and it connected fine, but this is highly undesirable long-term solution.

During all of this, I'm getting consistent 1/second TTL serial out of the Victron.Direct TX port, so the SmartSolar is not 'hung'. Also, the signal strength is active as I can walk away and signal bars go down.

Seem a good firmware solution is to 'forget' any connected devices if the pairing fails after some time (eg 10 minutes), so at least you don't have to power off the connected system to get it to work again. The reason I'm using SmartSolar 100/20 is for load monitoring and cutoff, so puling the fuse or disconnecting turns my whole system off.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.