question

theboatcapt avatar image
theboatcapt asked

Repeated Bluetooth reset on smartshunt

I keep getting a repeated disconnect and followed by an error that the shunt is connected to another device. This is a problem with the shunt as when this happens I cannot connect any device to it. I use the smart shunt to talk to an old android cellphone to use as my data monitor it works great but randomly it looses connection and won’t reconnect. Through my own debugging The only solution I’ve found is to crawl into my battery compartment and reboot the shunt by disconnecting it to power cycle it. This is the only answer I’ve found while searching the q&a. This has become quite annoying. Are there any other options?

Thanks

@Theboatcapt

SmartShuntBluetooth
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

8 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi all, an update on this: the issue is fixed. The sution has been filed tested by several people that had the problem, and it fixed it for all of them.

Finally!

To get the fix, you need to update the firmware in the bluetooth controller of your SmartShunt, or your Solar charger.

For now, this is available in the VictronConnect 5.52 beta version. Install instructions here: https://www.victronenergy.com/live/victronconnect:beta

And one or two weeks from now we’ll release that officially, meaning its in all the app stores etcetera.

My apologies for the trouble caused and that it took us so long to properly fix this issue.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi

Does it also help enabling airplane mode on the Android phone for 15 seconds?

Kind regards,

Thiemo van Engelen

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

theboatcapt avatar image
theboatcapt answered ·

No that does nothing. It is absolutely something with the shunt. As all devices see it but it is listed as connected already. I have 3 different phones and 2 tablets that I’ve tested it with. The only thing that works is to power cycle the shuntitself. None of the other devices are set to automatically connect and Bluetooth is off on everything else. It’s like the phone gets disconnected as I get an error message on the screen but the shunts Bluetooth never releases the connection. One thing I did notice while resetting it this last time is that the Bluetooth light on the shunt is on but solid there is no flashing not sure if that says anything. It’s not hard to do but annoying. Sometimes it will go 3 weeks other times just a day. I may just put a switch online that is somewhere easier to reach. To facilitate an easy reboot.
Any other thoughts?

Thanks

Tim

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

R Robinson avatar image
R Robinson answered ·

Just installed my smart shunt yesterday, blue tooth light started flashing immediately upon powering up, maintains connection up to about 50 feet. I have to re-connect when I am back in range. Any possibility you could have some kind of interference near the device?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

theboatcapt avatar image theboatcapt commented ·
No there’s noninterference
0 Likes 0 ·
theboatcapt avatar image
theboatcapt answered ·

I am using an old cellphone (Samsung galaxy s7). As a permanent display permanently mounted about 5 feet from the shunt Bluetooth signal strength is great. I had to reset the shunt yesterday followed by reprogram as you loose the current battery state each time. Then woke up this morning to the warning on the screen that “the device disconnected and could not be reconnected. Try placing the device into airplane mode if this persist contact support “ message. Ugh!!! So annoyed. I’ve pretty much determined that the Bluetooth on these this is just horrible and only meant to be used occasionally from right next to the shunt. I have Bluetooth on my BMS and it runs flawlessly even when continuously connected. I had high hopes for this because of the great reviews but I’m really getting frustrated with it. It appears the only effective answer is to just buy VE direct Bluetooth dongle or a be direct wired display. Yay spend more money. The Bluetooth on this device needs a major overhaul.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

scubadoo avatar image scubadoo commented ·
Likewise I have an older Nokia 5 android phone permanently wall mounted about 2m away solely to monitor our motorhome 500A Smartshunt LiFePO4 battery data.

Airplane mode is on.

The phone is powered 24/7 and has never lost Bluetooth connection or crashed in the nine months or so since installation.

Victron Solar controller, BatteryProtect, BatterySense and battery charger are monitored casually on other android phones and tablets again without any issues.

We have been lucky.


0 Likes 0 ·
theboatcapt avatar image
theboatcapt answered ·

So while typing the below as a final edit, thinking I figured it out and I’m content, I walk over and tap my screen and it won’t connect as another device is already connected. UGH! I’m done with this device and 2 months of nothing from VictronConnect tells me I’m done with them to. That was a waste of $150

(Ok so it’s been a month since my last post and here is what I have figured out. I changed my setup I still use the VictronConnect shunt but Im no longer using the Bluetooth as an always on display. I setup the phone to sleep after 1 minute and all I have to do is walk over and press the home button to wake it. I can’t get battery stats at a glance but it’s not hard to step over and push the button. When the phone sleeps it disconnects from the shunt then reconnects when it wakes. I have not had to reset the shunt at all this month. So my guess is that the Bluetooth on the shunt is not able to maintain a constant connection without freezing. It might be a memory issue in the shunts Bluetooth module who knows. But since I gave up on the idea of it always being connected and displaying it seems to be working. )


So that being said I now pretty much rely on the Bluetooth info from my bms and wish I never spent the money on this shunt as it doesn’t really do anything for me. Except give me heart ache.

Anybody want a paperweight?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

theboatcapt avatar image theboatcapt commented ·
Not sure why the text is so big but it formatted itself that way.
0 Likes 0 ·
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi @Theboatcapt , my apologies about all your troubles; the good news; even though it took very long; is that we have a fix underway that I am quite certain will solve the issue you are having.

Maximum a few more weeks; and then we’ll have that.

All the best, Matthijs / Victron.

5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

scph9002 avatar image scph9002 commented ·
Great news. I also have this issue since i have an ipad constantly connected to the smart shunts bluetooth.


You know what would be a great addition to your update note list? Have a section with known issues that are yet to be fixed.


0 Likes 0 ·
theboatcapt avatar image theboatcapt scph9002 commented ·
That’s a great idea in the auto industry they called those service bulletins
0 Likes 0 ·
theboatcapt avatar image theboatcapt commented ·
That’s good to hear I look forward to seeing what you all come up with
0 Likes 0 ·
ronald-v-i avatar image ronald-v-i commented ·

Hi @mvader (Victron Energy) , I'm suffering from what looks to be the same issue (happened 3 times in 2 weeks). Do you have any update on the fix?

(edited: if found multiple related posted, my related comment (not the original post) can be found here)

0 Likes 0 ·
scottsayweather avatar image scottsayweather commented ·
Any firmware fix on this? Same issue has been occurring on my SmartSolar 100/20, too.
0 Likes 0 ·
geoffph avatar image
geoffph answered ·

I thought I had the same problem, but I was entering thew wrong passcode. Der!

And I apologise for all the nasty words I muttered.
As usual, Victron products preform faultlessly

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.