question

evin-carr avatar image

Cerbo GX wifi issues

I have had my Cerbo GX with touchscreen installed in my motorhome for a couple months now. Most of the time it won't stay connected to my WiFi, which is about 8 ft above it. I use a Pepwave Max Transit Duo WiFi modem, so it's a pretty strong unit and the Cerbo shows around 75-80% signal strength. I can force it to connect, and sometimes it stays connected, sometimes it doesn't. Even when it's connected, I can't connect to the remote console much of the time. I'm on Firmware 2.57. Any suggestions?

cerbo gxBluetoothwifi
2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The Pepwave Max Transit Duo WiFi has a LAN port, just to be sure WiFi is not bothering you maybe you can try and connect that and see if the problem is really the WiFi connection...

I have updated the router's wifi frequency from 2.5 to 5 to GHz. It is working better, NOT perfect.

Victron should step on with a solution here. I paid quite a bit chunk of money for this device and expect it to work accordingly

7 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi all, there is a wifi related hardware issue in the Cerbo GX, when having a GX Touch 50 installed. The HDMI signal disturbs (some of the) wifi channel frequencies.

Details and solutions here: https://community.victronenergy.com/questions/82877/cerbo-gx-wi-fi-issue-when-having-the-gx-touch-conn.html


my apologies for the trouble!

4 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ps. I’ll accept my own answer so its quickly found by anyone that happens to find this thread

tilo avatar image tilo mvader (Victron Energy) ♦♦ ·

Hi Matthijs,

Maybe the possibility for a manual selection of the Wifi-channel for the Cerbo access point might help in some cases (independent of the above mentioned antenna issue)?

Hi Tilo, that won't help: the issue is for the client function, not the built-in access point function. And in that case the channel is determined from the access point, which would usually be the internet router of the customer.

This fix worked perfectly. Kudos to the customer who figured it out! Took all of 15 minutes. Just be careful removing glue not to scratch circuit board traces. And be careful with the little nubs and pins etc around the enclosure lid as it’s easy to pry against one and break them off.

My Cerbo and Touch 50 are now online, stable and working.

mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi all,

Can you try with v2.60 and let me know if that works better for you? We have made various improvements in v2.60, released on Monday this week, wrt WiFi stability. More precisely they are improvements concerning recovery from errors.

We're using a network connection manager (Connman) that was very persistent in giving up to reconnect after a while. We worked on it before, but that wasn't enough. And what we did this time is go all the way and remove all definitive error states from the source code, completely. It can no longer give up - never.

For those into the details, here are the changes: https://github.com/victronenergy/meta-victronenergy/commits/master/meta-venus/recipes-connectivity/connman/connman. (the two from 2020 are new in v2.60)

For any issue reporting, please include Venus OS firmware version used.

We're all for and ready to make WiFi as stable as possible. It shouldn't be that all devices in your house work well, but the Victron one doesn't! :-)

Best regards, Matthijs

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

dylan-hyslop avatar image
dylan-hyslop answered ·

I also have the same issue,

I have an easy solar 2 gx.

The wifi is terrible, its disconnects all the time. The signal shows 45% and the router is like 4m away. Im using ubiquity wifi which works 100%

I have been reading online and there clearly seems to be a big issue with the wifi that Victron is simply not dealing with, Yes we all know wifi is not ethernet. But it should still work. If there is the noise it should re-connect. Mine disconnects and then just doesn't connect again.

One of the big sales points of choosing this unit was the wifi. The modern world is moving towards wifi only setups. We can't run an ethernet cable to this unit.

I would expect better from a high end product and company like Victron.

Just my 2 cents.




1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

torstein avatar image
torstein answered ·

Just hoocked up a Touch 50 to the cerbo.
and lost my wifi. Also serious problems with cable.
loosing ip adress. Will not update ipadress. No connection to vrm.

if i disconnect the touch restart cerbo. Everything works really good. Both wifi and using ethernet.

my guess is that tje touch is messing up the ip of the cerbo in any way.

also a wild guess. Is that touch is running somekind of software to be able to be functional. This software is doing something to the cerbo.

updated cerbo to latest software. Still NoGo

update to latest release candidate yesterday. Till NoGo


i guess Victron is aware of this and are working their but of to fix it.

happy days folks.

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I’m having the exact same issue with my new Cerbo GX and GX Touch 50. The Wi-Fi will work only if the GX Touch is connected. I have upgraded to version 2.6 and this does not help.

typo- GX touch 50 must be disconnected for the wifi to work.

The Cerbo GX Wi-Fi doesn’t work with the Touch 50 attached. Crickets from Victron. I had to purchase a Ethernet to Wi-Fi bridge to have my system work. Disappointing!

michelg avatar image
michelg answered ·

Hi, I will suggest to make a reset of the CERBO and retry. Eventually add manually the gateway as 192.168.01 (usually, gateway and DNS are the same in this kind of configuration, LTE modems provide such data, but it can also be disabled into the modem parameters).

Michel.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Eddy avatar image
Eddy answered ·

Saldly no chance. The cerbo does not safe any manuell gateway input. And this seems to be the problem. Sometimes (extreme rarely & without any changes bevor) I see the wifi symbol upper left beside the clock and then I see also the gateway adress.

This is a customer configuration. My own cerbo with really the same surfstick makes no problems and is always online.



2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Eddy avatar image
Eddy answered ·

I have no solution, but nearly the same problem by a customer. I found out, that the time he is offline, the surfstik we are using gives no gateway in his WiFi Settings. We are always connected, but have no full access. The short times we have a gateway in the settings (without changing anything) we also have full access. Have you maybe recognized something like this?

11 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I haven't payed attention to that, but I'll take a look

Most WiFi LTE Surfsticks have a fixed private IP address for WiFi, for example 192.168.8.1, and supply their WiFi users with a private IP number in the same range 192.168.8.x (DHCP)

Maybe it is an idea to configure the Cerbo with a fixed IP address for example

IP 192.168.8.9

SubnetMask 255.255.255.0

Gateway 192.168.8.1

Eddy avatar image Eddy Peter Buijs - NL ·

Thank you for this information. I will definetly try your solution.

What you're suggesting seems like it might be effective for dealing with DHCP problems, but DHCP presupposes that the wifi connection is up. If the wifi isn't working then assigning static gateway/DNS/etc. isn't going to have any effect.

Eddy avatar image Eddy Peter Buijs - NL ·

Hello @Peter Buijs - NL,

sadly it it not possible to make any changes in the gateway. The Cerbo does not accept any gateway address, it keeps to stay blank.

But I can log into the surfstick wifi network with every Laptop, iPhone, iPad and use the internet without any problems.

I drove the camper near our company to login into our office-wifi, but no improvement.

Meanwhile I have no idea and my customer is not really happy with it. My last hope is to change the Cerbo. Must contact my Victron Dealer and start a warranty claim.

I think it’s a problem in the dhcp client running on the Cerbo. You tell it to reconnect and it comes back. It’s as if it won’t accept the new lease from the dhcp server. Happens with any WiFi it seems, nighthawk M1, Verizon Jetpack, and the MoFi router. I even connected it to my house WiFi, same issue.


you really should fix this. Maybe an auto-reconnect on failure to send data to the VRM portal? As it is I can’t leave it remote since I’d have to drive back to tell it to reconnect every time it wobbles off the net.


incidentally, everything else stays connected, no issues. Even the raspberry pi. So I don’t buy that it’s a user config issue.

I got so fed up with the Cerbo's worthless wifi (terrible reception and of course the lack of automatic reconnect) that I just hooked up a cheap WISP router and wired it to the Cerbo's ethernet/RJ45 jack. Yet another disappointment.

On another note, it seems like the "remote console" functionality actually transmits a freaking bitmap of the console over the internet; hence the extreme slowness of the refresh. That is such amateur-hour programming. Obviously there should be an abstraction layer such that the only thing that has to be transmitted are the settings themselves and the webapp for the console simply applies them to a template so it doesn't have to transmit a couple of megabytes every time you click into a different screen.

Hi, yes there are many things that could be improved. We have to choose though, unfortunately.

Thanks for your constructive feedback!

jersey-dirtbag avatar image jersey-dirtbag mvader (Victron Energy) ♦♦ ·

Thanks, I know the abstraction layer for the remote console is a bit of work but the automatic reconnect should be less than a day's work for a software engineer. It's a single "while" loop. Allowing the user to specify a list of preferred networks (and order of preference) would be good too.

Unfortunately its not a single while loop or less then a days work in this case (Linux & a connection manager that tries to automate lots of things).

And dropping the connection manager all together to get total control is tempting, but also bound to lead us into lots of issues.

anyway: what we did in v2.60 is exactly what you describe. It will now retry forever. See my answer on top of this page. I also included a link that shows the changes made to the source code.



Btw: reason to not retry forever is that some access points exist that then ban you, in case of wrong password. And on the edge of reception (low signal), the wifi protocol can't distinguish between lost packet and wrong password. Just to explain a bit around all this.

jersey-dirtbag avatar image jersey-dirtbag mvader (Victron Energy) ♦♦ ·

I stand corrected and appreciate the technical explanation.

I guess since the alternative is to remain disconnected, infinite retry -- even at risk of being banned -- doesn't really seem have any downsides. Being able to specify a prioritized list of SSIDs, each with its own retry parameters (number of retries, intervals between attempts, etc.) would make the system much more robust. This isn't a big deal for me (RV application) but if you're installing this stuff on top of a mountain and intend to leave it alone for weeks/months at a time it could be a different story.

Also, an external wifi antenna coax jack would be cool so folks could attach longer range or directional antennas.