question

gs-nz avatar image
gs-nz asked

VRM firmware update not working for VE.Direct MPPT - Error 1300

I’m having problems with VRM remote firmware updates. I’m on latest release v2.20. It's happening with a stable fibre internet connection, as well as 3G/LTE connection on two different modems.


With all VRM settings enabled etc…


Remote VEConfigure works OK – I can download and upload configuration for my multiplus no problems:


But the remote firmware doesn’t work most of the time – after a minute or so of this:


I get:


A couple of times it showed me a list of devices (very very rare) – sometimes incomplete, and still with a warning message:



But I managed to update two of my MPPTs that way… Also, I sometimes get, which I know is untrue:



During the scans my remote console goes like that – I guess this is intended?


Then after a few minutes it slowly comes back on:


The system is located in New Zealand, and the lag to victron servers is approx 400-500ms - could that be possibly related?



Should I try something else to get this working better somehow?

VRMfirmware updateerror
vrm-1.png (45.0 KiB)
vrm-2.png (59.1 KiB)
vrm-3.png (6.7 KiB)
vrm-4.png (56.0 KiB)
vrm-5.png (28.5 KiB)
vrm-6.png (17.3 KiB)
vrm-7.png (33.0 KiB)
vrm-8.png (42.0 KiB)
vrm-9.jpg (23.3 KiB)
15 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, I’ll ask support to take a look. Is it ok if they login to your system for Diagnostics?

0 Likes 0 ·
gs-nz avatar image gs-nz mvader (Victron Energy) ♦♦ ·

Yes, absolutely! I'm over 1000km from home, but within reasonably good internet coverage - most stable connection would be during European business hours (when we're parked for the night). VRM ID 16907.

0 Likes 0 ·

The problem appears to be on a much lower level, it is not the firmware update feature itself, but in communicating with the USB-serial devices. I created a bug report and assigned it to my more hardware-savvy colleagues.

0 Likes 0 ·
gs-nz avatar image gs-nz Izak (Victron Energy Staff) ♦♦ ·

Thanks, let me know if you need anything. In case this is relevant - I'm only using Victron USB dongles, except for the USB hub.

0 Likes 0 ·

What type of USB hub are you using? Is it self powered or bus powered? Are all USB cables of good quality and not unusually long (more than 2m/6ft)? Any other USB devices apart from the VE.Direct cables? That's probably enough questions.

0 Likes 0 ·

hi @mansr. Thanks for replying so quickly. My apologies for replying so late. I needed to pull things apart a bit and troubleshoot on a live system - so it took some time.

I would like to note upfront that I have had no issues with any of the devices without using the firmware update function on VRM. What I mean is that all the devices correctly report status and stats to VenusGX on a normal daily basis.

For the last 12 months I've been using a standard USB2.0 hub . Cable is 15cm long.

[continued below...]
0 Likes 0 ·
01.jpg (207.1 KiB)

The external power was NOT connected, so it was self-powered. The hub itself consumes 95mA when active. The USB ve.direct dongles consume 5mA each. So the total power consumption on the USB port from the single hub was no more than 120mA.
However, I have powered this hub, and the results are the same. I can confirm that in powered state, the hub did not consume any power from the VenusGX.


I have sourced another USB2.0 hub with 5cm cable, and that one comes with a built-in Ethernet adapter. There's no way to turn off the Ethernet.

That hub consumes 125mA when active.

[continued below...]

0 Likes 0 ·
02.jpg (59.9 KiB)
03.jpg (133.5 KiB)


That hub behaved exactly the same whether it's self-powered or externally-powered.

All the above in my mind eliminates the theory of the power consumption being an issue with my setup.

I tested the setup by plugging in the hub on the bottom and top USB on the VenusGX. No change in behaviour.

I removed ONE USB Ve.Direct MPPT and now the firmware update VRM screen works!

I plugged in both of the hubs and as long as there were no more than 2 devices plugged into each hub, then everything seems to be working - I can see all my devices in the list now!

[continued below...]

0 Likes 0 ·
04.jpg (71.7 KiB)
05.jpg (97.5 KiB)

Adding 3rd device to either hub causes this problem.

I don't really want to be running 2 hubs consuming each 100mA 24/7. Is there anything else I can do to troubleshoot this?

0 Likes 0 ·

Can someone else confirm that the issue is with more than 3 devices on the hub causing this problem?

0 Likes 0 ·

Hi Gs! Sorry for the long silence.


Sofar still we havent seen this issue anywhere else; which made us think its specific to your usb hub make & model. But I see now that you tried two already. Quite weird.


I’ll ask R&D to check it again; they’ll need to reproduce it before being able to solve anything.

0 Likes 0 ·
gs-nz avatar image gs-nz mvader (Victron Energy) ♦♦ ·

Hello @mvader (Victron Energy Staff) - are there any logs we can watch while the scan is happening? Is there anything else I can do to try it? I'm happy to go out and fork out for another brand of hub - if that helps at all... I just updated to v2.30~27 hoping that the MTU fix might be it, but no - no diff, back to the dreaded 1300...

0 Likes 0 ·

Hi, @gs_nz if you are searching for a cheap and stable USB hub, i can suggest this one: https://www.digitus.info/de/produkte/computer-zubehoer-und-komponenten/computer-zubehoer/usb-hubs/da-70216/

But it is related on my own experience and research and testing, it is not a Victron suggestion...

I am using it for 3 Ve.Direct USB devices and 1 MK3 Interface without external power (external power is indeed a requirement from Victron) and it is working very stable so far on 2 installations. (VenusGX and Raspberry Pi)

I have had several unstable hubs before. Some were 5 times higher in price AND ext. powered...

But i never saw Error 1300, the problem was in freezing USB devices stop reporting to Venus until you plug them out from USB and reconnect... Or had to power cycle the hub at once...

Not a single connection error occured with this hub for months now. I am satisfied.

Hope this helps somehow,

Markus

1 Like 1 ·

@Markus many thanks for your reply. So today I bought an identical make and model as you suggested:

It cost me NZD$15, which is 9 Euro. So that's good. I plugged it, but without supplying power to it:

and lo and behold - the firmware update scans are working, every time! Wow. That's very interesting... Some kind of incompatibility between the hubs and beaglebone. @mvader (Victron Energy Staff) are you interested in me sending the not-working hub to you, so you can debug the problem further? Up to you.

0 Likes 0 ·

Yes; Thats a great idea. I’ll contact you off list

0 Likes 0 ·
2 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

The problem was sourced down to be particular to a certain type of USB hub. Its was solved by replacing it by something else.

The details, for example why with that particular USB hub (-chipset) normal operation does work; and firmware updates don't is on the list to be investigated by Victron.


For details; read the comment thread.



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Paul B avatar image
Paul B answered ·

Have you tried to manually update this to the latest firmware now 2.23 and see if that helps.

I am using a wifi extender to connect to my Venus GX thus I am hard wired using RJ45 to the range extender. wirks very well for me. but then I only have the multi connected off that, and no other ve direct products.

anyway this may help and may not


I found My venus GX was very slow when using the internal wifi modem and very short on range


Good luck and I hope you get it sorted.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.