mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v3.00~27 available for testing

UPDATE 2023-03-28: v3.00~27 is now available for testing. Minor changes, see below.
UPDATE 2023-03-25: v3.00~26 is now available for testing. Minor changes, see below.
UPDATE 2023-03-20: v3.00~25 is now available for testing. Minor changes, see below.
UPDATE 2023-03-16: v3.00~24 is now available for testing. Minor changes, see below.
UPDATE 2023-03-13: v3.00~23 is now available for testing. Minor changes, see below.
UPDATE 2023-03-06: v3.00~22 is now available for testing. Minor changes, see below.

Good evening, or any other time of day,

Per just now, v3.00~21 is available for testing. Two minor updates compared to the previous version.

The status of v3.00 is that we're finishing up, ie. testing for stability, making sure all is as it should be.

What is new in v3.00?

  • Peak shaving for ESS
  • Disable the touch feature on a GX Touch: great for rental and other systems where the whish is to display system status while not allowing any other user interaction.
  • Improved ESS control speed
  • RV-C canbus protocol for (mostly USA-built) motorhomes: lots of improvements
  • Many other small changes, see below.

Introduction to Venus OS beta testing

In case you don't know what this message is about, please start with reading this link, which explains the Venus OS beta program. Venus OS is the software running on all our GX devices, such as the Cerbo GX.

How to post an issue?

By posting an answer below. Do please keep all findings organised: one answer issue per issue. So first check the existing threads if your issue has already been seen. And if it does, add a comment saying "me too". And preferably some more details. And in case its not listed yet, add a new Answer.

Note that Answers and Comments are two different things on this portal.

Lastly, before posting issues, preferably first revert to the latest official release (v2.93), to double check if the issue you're seeing was present there as well. Regressions require a different treatment than other issues and bugs.

And include information about the results/differences in behaviour in your report.

Changes v3.00~26 -> v3.00~27

  • RV-C protocol, related to VE.Bus Inverter/charger DGNs

    • Add the ability to change the maximum charge current using the CHARGER_CONFIGURATION_COMMAND DGN. This is a volatile setting and will be reset to the value the inverter/charger was configured with once the unit restarts.
    • Add support for CHARGER_CONFIGURATION_STATUS to report the maximum charge current.
    • Report maximum charger current as percentage in CHARGER_CONFIGURATION_STATUS_2 instead of the fixed 100%.

  • Node-RED (part of Venus OS Large)
    • node-red-contrib-victron v1.4.32

    • Move ActiveSocLimit to new path
    • Fix pathData undefined error
    • Added EnableDisplay and Scheduled mode (evcharger) (#169)
    • Rename VE.Bus System reset to VE.Bus system restart (#170)
    • Updated documentation
    • Add L3 current for input-grid meter
    • Update dependencies

Changes v3.00~25 -> v3.00~26
All rather minor:


  • Recognise Batrium BMS (this actually wasn't included in the previous version). No functional changes.

Signalk-Server (part of Venus OS Large)

  • minor change: call sync after modifying files before starting the server, to make sure they're written to disk immediately.

Changes v3.00~24 -> v3.00~25

Signalk-Server (part of Venus OS Large)

  • On start-up, check if any of the now default installed plugins was installed manually, and remove that one.

Changes v3.00~23 -> v3.00~24


  • Recognise Batrium BMS; no functional change

Signalk-Server (part of Venus OS Large)

  • Add and default-enable plugins sending NMEA data out on TCP, includes AIS data
    • With this change, the GX device is a LAN and wireless AIS and navigation server for popular apps like Navionics, iSailor, iNavX, and Aqua Map on phones and tablets. This blog post by S/V Renaissance explains it nicely; but ignore all explanations about configuring plugins: that is all already done. Two examples: (1) Aqua Map App (link to Wifi connections page), (2) Navionics Boating App (link to AIS feature page).
    • This feature requires a NMEA2000 connected AIS receiver on board. No internet is needed.
    • The data is available as NMEA0183 packets on the default TCP port (10110), as well as signalk messages on the default websocket port.
    • Note that this is not tested. If you have a navigation system, please test and let us know if it works; and if indeed no further configuration was required.
    • All powered by the opensource signalk-server.
  • Fix pre-installing venus-signalk-plugin, it was missing. Unknown since which version; on v2.93 it was missing; most likely many prior versions as well.
  • Fix disabling updates of the pre-installed plugins
  • Known issue with signalk-server: mDNS advertisements most likely don't work.

Changes v3.00~22 -> v3.00~23

  • Internal changes

Changes v3.00~21 -> v3.00~22

  • RV-C out: increase timeouts on some battery and tank messages to match the maximum send interval. The previous timeout was too strict.

Changes v3.00~20 -> v3.00~21

Developer / Venus OS large related:

  • Node-RED (v1.4.29 & v1.4.30)
    • Fix default for the new "Only changes" setting, it now defaults to off.
    • Add option to round float values
    • Filling out service and path of a node is now required
    • Fix reporting relay state changes when the "only changes" option active. As well as other changes that use the dbus PropertiesChanged instead of ItemsChanged signal.
    • New paths:
      • /Settings/SystemSetup/AcInput1 and 2 for input and output-settings
      • /Ac/Frequency for input-gridmeter
    • Update documentation
    • Thank you @mr-manuel for your help with above!
  • MQTT: Improve response when receiving a R/<portalid here>/system/0/Serial message. Instead of just activating the keep-alive, it will now always also respond by publishing the VRM Portal id.

Changes v3.00~19 -> v3.00~20

  • Fix the issue that was introduced in ~19.

Changes v3.00~18 -> v3.00~19

  • Internal changes only
  • Has known issue related to MQTT and also the HTML5-App and possibly VRM real time controls. A new version, v3.00~20 is expected later today.

Changes v3.00~17 -> v3.00~18

  • Node-RED: fix the Node-RED Victron control nodes. The previous version (v3.00~17) broke all control nodes.

Changes v3.00~15 -> v3.00~17


  • ESS: Add peak shaving option (by observing the AC input current limit using PowerAssist)
    • Peak shaving already worked in Keep batteries charged mode; no changes there, other than making it more obvious by adding in the Peak shaving menu entry.
    • Peak shaving did not work will in the Optimised modes. It did work as long as battery SOC was above the configured ESS Minimum SOC level, but once discharged there the system would not assist the loads. This is now solved: use the new peak shaving option in the ESS menu, to let the system keep PowerAssisting when needed. And as soon as the peak is over, it will recharge the battery using power from the grid, while prioritising solar. Note that there is a 5% hysteresis on that: lets say Minimum SOC is set to 80%, it will then start recharging back to that 80% once (by peak shaving) the battery dropped to 75%.
    • The default setting, when using the Optimised mode, is off. To not change behaviour of running systems.
    • Warning: this works for the critical loads only. Not by energy meter.
    • For further details, see screenshots below.
  • GX Touch: add option to disable the touch input. See settings -> I/O -> Digital inputs for the new feature. This is intended for systems where the GX Touch is wanted to show the users what the system is doing; but nothing else. The status of the touch (enabled/disabled) is toggled by pulling the gpio down to ground. More information about locking a system down is here; that text was recently updated, amongst other things a "Hardening a GX device" chapter was added.
  • EV Charging Station: show progress indication during a firmware update.
  • GUI, in the Multi & Quattro advanced menu, reword Reset to Restart. Less ambiguous in relation to a factory reset.
  • VRMLogger: add various new fields to be sent to VRM to improve the dashboard and dashboard controls.
  • Support the Fronius Tauro via SolarAPI: This is a rare edge case. Customers should use Sunspec instead of SolarAPI whenever possible, as per documentation. This change allows using SolarAPI in cases where Sunspec cannot be used. For example where modbus-RTU is in use on the DataManager and modbus-TCP cannot be used.
  • Energy meters:
    • Fix issue with EM24 reported values being more erratic since earlier v3.00 releases. Now the behaviour is back to how it was pre v3.00
    • Fix issue with EM540 phase sequence check for three phase systems. It reported the phase sequence as being incorrect while it wasn't.

Few changes that were also made available in v2.93:

  • Fix a problem where Remote Console wouldn't work, and required a factory reset to be repaired. Any systems now having the issues will be fixed automatically once updated to v2.93 or v3.00~16.
  • Fix timezone bug related to ESS Scheduled Charging: after changing the time zone, a reboot was required to make that use the new time zone. Bug was introduced in v2.80. Thank you Patrick M. for your help on this!
  • Add the new Scheduled mode and more for the EV Charging Station. Fixes "unknown" showing when the EV Charging Station is configured for that mode. For more information on that, read here.

Developer related

  • RaspberryPis: fix bluetooth connection to VictronConnect using the rpi-built-in bluetooth radio. This was broken during v3.00 development.
  • Node-RED, update node-red-contrib-victron from v1.4.26 to v1.4.27:
    • Added option to input nodes to only broadcast changed values (see issue #147)
    • Added missing input-vebus paths: /Bms/PreAlarm and /VebusChargeState
    • Update documentation
  • Update the uPnP data (see this commit)
  • Update PHP from v7.4.28 to v7.4.33; next step is no longer using PHP at all.


  • Update MK3 firmware from v215 to v216. If already on v215, this update will happen automatically. If running an earlier version, the update will need to be triggered manually, as explained below.
  • Prepare VE.Bus firmware updater for some internal changes.

Changes v3.00~14 -> v3.00~15


  • add logging of generator runtime to VRM Portal (actual visualisation might still need work)
  • ESS: add support for all EM300 meters
  • ESS: add option to scheduled charging to allow discharging the battery (if SOC is below the configured minimum) while in the window; and more.
  • EV Charger: various features and fixes
  • Add support for Pylontech batteires having 16 cells in series (rather than usual 15 cells). Thank you Brian Finley!
  • Force good settings for Hubble batteries (DVCC on, STS off, SVS recommended off)


  • Lots of improvements concerning RV-C; to be detailed
  • Modbus-TCP: fix issue related to inverter/charger state vs “ext control”.

Changes v3.00~8 -> v3.00~14


  • Fix Zigbee (DRF2685C) detection. (also available in Venus OS v2.93)
  • VE.Bus BMS v2: Improvements to remote firmware update feature
  • VE.Bus BMS v2: Add sending the pre-alarm status to VRM.
  • Bluetooth improvements for Cerbo GX with serial-nr HQ2208 and later, as well as all Cerbo-S GX production. The temperature issue which makes the built-in bluetooth unreliable/unusable no longer applies:
    • Per mentioned serial numbers, a second Bluetooth radio has been added to the hardware. And per v3.00~14, Venus OS also uses that one; rather than the unreliable one. In more detail:
    • For VictronConnect connection, new radio is used.
    • For Ruuvis, all radios are used including any externally inserted ones (USB).
  • Fix bugs in the GUI that could cause it to show glitches and/or get stuck.
  • Add Thai language


  • Fix register 31, the /State path for the VE.Bus inverter/chargers. Since v2.89 it returned value 252, Ext Control, for systems where the Inverter/charger is externally controlled. Instead of 3 (Bulk), 4 (Absorption) and so forth. Breaking customer integrations. (also available in Venus OS v2.93)

Venus OS Large

  • Update signalk-server from 1.44 to 1.46.2

Changes v3.00~4 -> v3.00~8


  • Multi/Quattro: Fix issue causing a repetitive low battery alarm in case the battery is disconnected
  • ESS: Fix bug introduced in v3.00~2 related to external control mode.
  • Add progress indicator (0 to 100%) to Venus OS firmware download.
  • Fix tank temperature unit (Fahrenheit)
  • Add new VE.Bus product ids (2681, 2723, 2766, 2776)
  • Add diagnostic fields for Multis/Quattros (uptime counter per unit, terminal voltage, Vsense voltage for L1 master and DC ripple)


  • com.victronenergy.battery: Add /Dc/0/Power and /Mode, add missing fields to /State enum
  • com.victronenergy.digitalinput: Add "Generator" to /Type enum
  • com.victronenergy.multi (applies to RS products): fix in enum /State

Venus OS Large

Changes v2.92 -> v3.00~4

  • For systems having multiple BMSes connected, allow selecting which one should be used for DVCC. It also allows the use of a BMV for SOC tracking -- by selecting BMV as battery monitor -- while still using the BMS for DVCC. A bit of a niche issue for special systems, more technical background here: (but please don't start posting on our github - thanks).
  • Detect Hubble batteries, untested as of yet.
  • Add Polish translations, thank you Jakub T for helping with that!
  • ESS: increase control speed of systems using todays supported meters (ET112, ET330, EM24, and also the ABB ones) a little. But, for faster meters, such as the EM540 which is not available yet, increase it very significantly. Requires updating the built-in MK3-chip, see next bullet.
  • Include a newer version of onboard MK3-chip firmware, v215. Updating that has a 1 to 10% chance of a short system outage (Multi/Quattro shuts down in VE.Bus Error 14, restarts after 30 seconds). And therefore the update needs to be initiated manually from within the menu. Note that this is a reversible action, no need to worry about being unable to roll back. After updating, and then rolling Venus OS back to v2.92 or some other earlier version, the MK3 will automatically (and silently) be downgraded to the for that version of Venus OS required MK3-firmware version.
  • Improve text for tank sensor name in pump configuration.
  • ESS: Fix bug where PV is not used for loads when scheduled charging to 100% during daytime
  • Fix bug where a PV-inverter on AC-in-2 would not be shown in the ESS overview. The workaround was to configure the PV inverter as being on AC-in-1. Not needed anymore.

Venus OS Large

Under water / developer

  • Various small under the hood changes, mostly resulting in small reductions of CPU load
  • Replace Hiawatha webserver with nginx; which is better kept up to date (security)
  • Include various OE Dunfell fixes
  • DVCC: simplify transmission of the charge voltage setpoint by sending it always, rather than only if devices that work with it are detected. This won't make a difference to any commonly known system type.

MK3 firmware update related screenshots

On systems not updated yet, you'll see this (after going to the Device list, and then into the MultiPlus, Quattro or EasySolar listing):


And for anyone wanting to make sure its updated, in that same menu, scrolling all the way down to the Device submenu, and going in there, and scrolling down again, you'll find this listing:


Wherein the 212 digits are the version number, and thats the old one. And here is what you see after the update:


Note that this is necessary only for this one update. Hereafter, updates will be silent again, like they used to be; since there is no longer a risk of a short system outage.

Prior threads:

Venus OS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

v3.00~22 is now available. One minor change, related to RV-C; see changelog for details.
0 Likes 0 ·
v3.00~24 is now available. Recognises the Batrium BMS and update to Signalk-Server, default enabling all plugins and config needed to get navigation and AIS data on WiFi/LAN.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ commented ·
v3.00~25 is now available. Small change wrt signalk-server
0 Likes 0 ·
v3.00~26 is available for testing. Changes are minor/neglectable.
0 Likes 0 ·
v3.00~27 is available. RV-C protocol improvement and Node-RED
0 Likes 0 ·
19 Answers
ceriw avatar image
ceriw answered ·

Remote VE configure for my Quattro does not appear to be working with this version. When I click download, I get the following error


Remote firmware update also fails when i try to update my Quattro from V500 to V502.



I've disabled Node Red, but still no difference.

rolled back to v3.00~15 and remote VE Configure works, but firmware update still failed with Error 1302

1677926430926.png (6.8 KiB)
1677926625902.png (22.4 KiB)
1677926681613.png (9.2 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Ceri.w thank you for reporting and noted. We’ll look into it.
0 Likes 0 ·
ceriw avatar image ceriw mvader (Victron Energy) ♦♦ commented ·
thanks, just for completeness, i rolled the setup back to v2.93 normal, and it worked completely as intended.


0 Likes 0 ·
Hi @Ceri.w. We where not yet able to reproduce the issue. Can I ask you to try v3.00~22? If it does not work right after the update perhaps you can retry it again after 30 minutes or so.

Earlier, for Venus v3.00~15, you posted having "installation to busy, real time data link disabled" issues. I am wondering if your system is really busy with something directly after the update. The error messages you displayed are most likely caused by timeouts between VRM and Venus.

0 Likes 0 ·
ceriw avatar image ceriw jpasop (Victron Energy Staff) ♦♦ commented ·
updated to ~22. remote VE configure now working. unable to test remote firmware update as Quattro is now already on v502.


0 Likes 0 ·
bonzai avatar image
bonzai answered ·

Hello, is it possible to download the individual versions somewhere? special v3.00~17

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, no sorry; we don’t keep those available
0 Likes 0 ·
Bert Beijl avatar image
Bert Beijl answered ·


v3.00.~22 installed on Raspberry Pi 3 with touchscreen.Touchscreen does not come up, after deleting or renaming /etc/venus/headless it does, but screen does not dim automaticly after X seconds. Same issue on v2.93. Back to v2.92, no problem.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mucwendel avatar image
mucwendel answered ·

I just updated to this version on Cerbo GX and it seems to run normal.

ESS is much faster than before. Switching 1,5kw on and off just takes 4 sec. instead of 12 sec. last year.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ok thanks!
0 Likes 0 ·
Tom Büschgens avatar image Tom Büschgens commented ·
May I ask which grid-meter is deployed for your system?
0 Likes 0 ·
becker avatar image
becker answered ·

I´ve tried /Ac/Frequency for my (mqtt) input-gridmeter:


but on remote console there is no frequency.

1678127117567.png (10.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

eliott avatar image
eliott answered ·

Hi! Is it a bug or a feature that after before the mk3 update the charge phase was ext. control and after it now shows bulk? (everything else is unchanged, same can-bus bms)

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Elliot, thats an intended change.
2 Likes 2 ·
Mark avatar image
Mark answered ·

When running v3.00~22 can’t access the home pages on any device including GX touch 50 screen, (no digital inputs in use!)

when I revert back to v2.93 everything functions as per normal!.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hey what hardware do you have? A Cerbo GX?
0 Likes 0 ·
Mark avatar image Mark mvader (Victron Energy) ♦♦ commented ·

Hi, yes Cerbo GX installed

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ Mark commented ·

Hi Mark, I've sent you a mail

(2023-3-25: solved)

0 Likes 0 ·
rafka avatar image
rafka answered ·

after an update to v3.00~22 I can't access node-red any more. Any attempt to access leads to the following error. Venus OS is running on an Cerbo GX.


Any ideas on how to fix this?

1678536327811.png (15.0 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You must use a secure connection. So https://venus.local:1881
Accessing Node-RED and Signal K

0 Likes 0 ·
rafka avatar image rafka Stefanie (Victron Energy Staff) ♦♦ commented ·
Thanks. That did the trick.
0 Likes 0 ·
l81ker avatar image
l81ker answered ·

installed 3.00 ~23 but lost GUIMods which reports as incompatible.

Rolled back to 3.00 ~22 and GUIMods back to normal.


@Kevin Windrem for your awareness too.

1678721369806.png (40.4 KiB)
1678721617350.png (38.3 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem commented ·
GuiMods v7.18 fixes this. You should see this update now.

As mentioned previously, the beta release threads should be limited to STOCK Victron firmware. This is necessary to limit the time Victron engineers spend here in the beta release threads.

If you are running GuiMods or other third party additions, please uninstall them and verify the problem is with stock firmware prior to posting an issue here.

Problems with third party additions like GuiMods are best addressed in the related GitHub repo issues. Posts to GitHub are more likely to be noticed by the package author.

0 Likes 0 ·
Kevin Windrem avatar image
Kevin Windrem answered ·

Please keep issues regarding GuiMods and other packages out of the beta test threads. Victron engineers need these threads to focus on the stock firmware in order to move forward rapidly.

The best place to post such issues is in the GitHub repo for the package (GuiMods in this case).

FYI, v3.00~23 posted under my radar . GuiMods v7.18 is available now with support for ~23.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

David avatar image
David answered ·

Can you please clarify / elaborate on This:

  • Recognise Batrium BMS

I have Batrium connected and its always been detected fine? Has there been some enhancements?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, no nothing changes. Except that it knows it's a Batrium. In some places the old version will have shown that its a unknown generic canbus bms battery; now it will say Batrium.
1 Like 1 ·
hummingbear avatar image hummingbear commented ·
@David I have a batrium BMS and have been debating whether I want to connect it to VenusOS or not. What benefits are you seeing? I've seen issues with BMS's being connected to VenusOS in that they take over the charging parameters from the MPPT systems which I don't like, but I would like the ability for the BMS to turn off charging during a high cell voltage or low temp situations. Curious how you're using it and your experience.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ hummingbear commented ·
Hi, dvcc is the feature that makes the bms take control; and that setting remains off when connecting the batrium
0 Likes 0 ·
pepe1395 avatar image
pepe1395 answered ·

I do not have any device NMEAnderthal (0183) on my boat, my CerboGX is connected to a Seatalk NG network, Raymarine name for NMEA 2000. Yesterday I connected my iPad Mini4 to the CerboGX and I tried iRegatta app: it works perfectly! It will be great when the GX device will be able to convert from 0183 to 2000. Another good reason to buy a Cerbo. Bravo Victron!


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hey @Pepe1395 , thanks for testing that out and good to hear it all worked out of the box as intended!

For converting from 0183 to NMEA2000: that is possible, using Signal K. I've never done it myself, but think its more or less sufficient to configure Signal K server to listen to the serial port in which you plugged in the USB/NMEA0183 converter.

Below is a screenshot of the relevant settings. For more info, see our manual of Venus OS Large including Signal K, which then refers to Signal K documentation and community support channels.


0 Likes 0 ·
1679235835478.png (118.4 KiB)
kris avatar image
kris answered ·

The data is taken from N2K the second from NMEA183 as you can see in the video the wind is being sent NMEA183.

I use Cerbo GX.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

David avatar image
David answered ·

Somthing very strange happened to my system after .26 was released. It seems the data reported in the GX was different to what was being fed to it by my Batrium BMS. The result is the system ran my battery down to limits lower than the BMS would normally allow - GX device was ignoring the discharge current limit and was blissfully discharging at a constant 30amps for well over 12 hours. I then got low battery warnings from VRM.

I reverted back to .25 and after the reboot the data seems to be reporting correctly. At first, I figured there was probably a bug in .26, but I upgraded again to it and it's still reporting OK. So Im at a loss as to what caused this, but as you can see from my screenshot - what it thinks was happening should have been impossible.

It was discharging at a constant 30amps - which is VERY weird, Im in a grid connected ESS and so loads vary all the time. There is no circumstance where the discharge current would remain constant for that long. Impossible.If I hadn't of noticed this, I think the low voltage protections would have saved the battery anyway, but it should never of happened. Maybe a quirk after the first update?


victron.png (81.4 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @David noted, thank you. We'll look into that. Matthijs
0 Likes 0 ·
David avatar image David mvader (Victron Energy) ♦♦ commented ·
Thanks. If it helps, I can post VRM portal ID (if safe to do so)
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ David commented ·
Hi David, not need for that. And I recommend not to do that. Its not unsafe, but what will happen is that people will try to add your system to their VRM account; which then makes the system send emails to you asking for your permission
0 Likes 0 ·
dylan07 avatar image dylan07 commented ·

Had a similar issue with an earlier version on v3~14, where the battery was 100% and PV ramped up to max and started to back feed to the grid ~2500W ~50A dc (no feed back enabled). changed from battery life disabled to enabled, no change, then to keep battery’s charge which stopped in somehow.

Connected or just a random event on my side I don't know, reverted back to 2.92 after that.

0 Likes 0 ·
wolferl avatar image
wolferl answered ·

I see some strange behaviour with .27 when using node red exporting to InfluxDB.

I use the data more or less directly in Grafana and it looks like node red has a time lag at exporting the data to the database of 10s.

This could be repeated as well when i queried the data in influxDB without Grafana. Data was only available after 10 seconds.

Reverted back to .21 the lag was gone and data was available nearly instant...

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kurtinge avatar image
kurtinge answered ·

Small typo ?

Changes v3.00~26 -> v3.00~37

I guess it should be 27 and not 37 ?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Right! Corrected. Thank you
0 Likes 0 ·
hominidae avatar image
hominidae answered ·

..after upgrading from 2.92 to 3.00b26 on my Cerbo GX, the historical data in VRM seems basically gone (or being wrong). Calculations seem to be based on the first day, when v3.00b was up and running...all previously sent data from v2.92 is not taken into the calculations anymore.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hi @Hominidae , can you post a screenshot of what data you're referring to?
0 Likes 0 ·
hominidae avatar image hominidae mvader (Victron Energy) ♦♦ commented ·

...I don't know where exactly the problem is, but I upgraded to v300b26 two days ago. Before, on that day, consumption "from grid" over the last 30d was at 2% (sorry, no screenshot from that day). Now, two days into v3.00b26 and no additional consumption, because PV intake was more than plenty and min SoC had never been reached, the value increased to 18%.


Based on logs from my Wallbox, which integrates into the Cerbo and Grid-Meter, the values to the right seem is the statistics that are off / seem to have changed


0 Likes 0 ·
1680205523263.png (70.6 KiB)
1680205735008.png (166.6 KiB)
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ hominidae commented ·
Hi, thank you for those. I don't know what the issue is either; I'll ask a colleague to look into that.
0 Likes 0 ·
hominidae avatar image hominidae mvader (Victron Energy) ♦♦ commented ·
thanks for that...I just want to add, that although I do not have a screenshot showing 2% in "30d from grid", I discussed that with a co-worker and shared the portal screen over, I am not completely insane, I hope. Maybe the issue was there all along with 2.92, I don't know.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ hominidae commented ·
What you could do is go to the Advanced page, then select a long time range, like 90 days, and then download the kWh excelsheet there.

Those circular graphs (and also the others) in your screenshot all originate from that source data.

1 Like 1 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ commented ·
hi @Hominidae , how is your system working now?

We didn't find out what happened, and so far can't explain it either. But from what we see it was some temporary thing and all works fine now: would be good to have your confirmation on that so we don't have to delay the release of v3.00 of this.

0 Likes 0 ·
hominidae avatar image hominidae mvader (Victron Energy) ♦♦ commented ·
Hi @mvader (Victron Energy)

Thanks for your message and following up on this.

Yes, I am still on v3.00b29 and the problem did not appear again ever since. Based on the exchange I had with your support team, this is not reproducable. Please consider it a false positive or a single "glitch".

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ hominidae commented ·
thats good to hear ; thank you!
0 Likes 0 ·
mark-a avatar image
mark-a answered ·

I updated to v3.0 yesterday as I'm trying to get installed the signalk-victron-ble[1] plugin from the App-store, which failed on 2.93. The problem still exists in the v3.0 beta. The plugin needs the python module venv which is not installed and can't be installed neither when running."npm install signalk-victron-ble" from the command line.

[1] I have my BlueSolar and BMV-712 connected with original VE.Direct to USB cables but I'd like to see my Orion and SmartBatterySense in the VRM too.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

fenix avatar image
fenix answered ·

Mopeka Bluetooth no more available... i cannot find the button for bluetooth

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources