question

mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v3.00~20 available for testing

UPDATE 2023-02-24: v3.00~20 is now available. Fixes the issue that was introduced in ~19.

UPDATE 2023-02-24: v3.00~19 has been made available for testing. Note that it has an issue related to MQTT and also the HTML5-App and possibly VRM real time controls. A new version, v3.00~20 is expected later today.

UPDATE 2023-02-20: v3.00~18 has been made available for testing. Fixes Node-RED related issue, see below.


Hello!

After releasing v2.93 earlier this week, its time to resume v3.00 beta testing. The new available version is v3.00~17.


What is new in v3.00?

  • Peak shaving for ESS
  • Disable the touch feature on a GX Touch: great for rental and other systems where the whish is to display system status while not allowing any other user interaction.
  • Improved ESS control speed
  • RV-C canbus protocol for (mostly USA-built) motorhomes: lots of improvements


The first two bullets are new per v3.00~17.


Introduction to Venus OS beta testing

In case you don't know what this message is about, please start with reading this link, which explains the Venus OS beta program. Venus OS is the software running on all our GX devices, such as the Cerbo GX.


How to post an issue?

By posting an answer below. Do please keep all findings organised: one answer issue per issue. So first check the existing threads if your issue has already been seen. And if it does, add a comment saying "me too". And preferably some more details. And in case its not listed yet, add a new Answer.

Note that Answers and Comments are two different things on this portal.

Lastly, before posting issues, preferably first revert to the latest official release (v2.93), to double check if the issue you're seeing was present there as well. Regressions require a different treatment than other issues and bugs.

And include information about the results/differences in behaviour in your report.


Changes v3.00~19 -> v3.00~20

  • Fix the issue that was introduced in ~19.

Changes v3.00~18 -> v3.00~19

  • Internal changes only
  • Has known issue related to MQTT and also the HTML5-App and possibly VRM real time controls. A new version, v3.00~20 is expected later today.


Changes v3.00~17 -> v3.00~18

  • Node-RED: fix the Node-RED Victron control nodes. The previous version (v3.00~17) broke all control nodes.


Changes v3.00~15 -> v3.00~17

General

  • ESS: Add peak shaving option (by observing the AC input current limit using PowerAssist)
    • Peak shaving already worked in Keep batteries charged mode; no changes there, other than making it more obvious by adding in the Peak shaving menu entry.
    • Peak shaving did not work will in the Optimised modes. It did work as long as battery SOC was above the configured ESS Minimum SOC level, but once discharged there the system would not assist the loads. This is now solved: use the new peak shaving option in the ESS menu, to let the system keep PowerAssisting when needed. And as soon as the peak is over, it will recharge the battery using power from the grid, while prioritising solar. Note that there is a 5% hysteresis on that: lets say Minimum SOC is set to 80%, it will then start recharging back to that 80% once (by peak shaving) the battery dropped to 75%.
    • The default setting, when using the Optimised mode, is off. To not change behaviour of running systems.
    • Warning: this works for the critical loads only. Not by energy meter.
    • For further details, see screenshots below.
  • GX Touch: add option to disable the touch input. See settings -> I/O -> Digital inputs for the new feature. This is intended for systems where the GX Touch is wanted to show the users what the system is doing; but nothing else. The status of the touch (enabled/disabled) is toggled by pulling the gpio down to ground. More information about locking a system down is here; that text was recently updated, amongst other things a "Hardening a GX device" chapter was added.
  • EV Charging Station: show progress indication during a firmware update.
  • GUI, in the Multi & Quattro advanced menu, reword Reset to Restart. Less ambiguous in relation to a factory reset.
  • VRMLogger: add various new fields to be sent to VRM to improve the dashboard and dashboard controls.
  • Support the Fronius Tauro via SolarAPI: This is a rare edge case. Customers should use Sunspec instead of SolarAPI whenever possible, as per documentation. This change allows using SolarAPI in cases where Sunspec cannot be used. For example where modbus-RTU is in use on the DataManager and modbus-TCP cannot be used.
  • Energy meters:
    • Fix issue with EM24 reported values being more erratic since earlier v3.00 releases. Now the behaviour is back to how it was pre v3.00
    • Fix issue with EM540 phase sequence check for three phase systems. It reported the phase sequence as being incorrect while it wasn't.


Few changes that were also made available in v2.93:

  • Fix a problem where Remote Console wouldn't work, and required a factory reset to be repaired. Any systems now having the issues will be fixed automatically once updated to v2.93 or v3.00~16.
  • Fix timezone bug related to ESS Scheduled Charging: after changing the time zone, a reboot was required to make that use the new time zone. Bug was introduced in v2.80. Thank you Patrick M. for your help on this!
  • Add the new Scheduled mode and more for the EV Charging Station. Fixes "unknown" showing when the EV Charging Station is configured for that mode. For more information on that, read here.


Developer related

  • RaspberryPis: fix bluetooth connection to VictronConnect using the rpi-built-in bluetooth radio. This was broken during v3.00 development.
  • Node-RED, update node-red-contrib-victron from v1.4.26 to v1.4.27:
    • Added option to input nodes to only broadcast changed values (see issue #147)
    • Added missing input-vebus paths: /Bms/PreAlarm and /VebusChargeState
    • Update documentation
  • Update the uPnP data (see this commit)
  • Update PHP from v7.4.28 to v7.4.33; next step is no longer using PHP at all.


Internals

  • Update MK3 firmware from v215 to v216. If already on v215, this update will happen automatically. If running an earlier version, the update will need to be triggered manually, as explained below.
  • Prepare VE.Bus firmware updater for some internal changes.


Changes v3.00~14 -> v3.00~15

General

  • add logging of generator runtime to VRM Portal (actual visualisation might still need work)
  • ESS: add support for all EM300 meters
  • ESS: add option to scheduled charging to allow discharging the battery (if SOC is below the configured minimum) while in the window; and more.
  • EV Charger: various features and fixes
  • Add support for Pylontech batteires having 16 cells in series (rather than usual 15 cells). Thank you Brian Finley!
  • Force good settings for Hubble batteries (DVCC on, STS off, SVS recommended off)

Protocols

  • Lots of improvements concerning RV-C; to be detailed
  • Modbus-TCP: fix issue related to inverter/charger state vs “ext control”.


Changes v3.00~8 -> v3.00~14

General

  • Fix Zigbee (DRF2685C) detection. (also available in Venus OS v2.93)
  • VE.Bus BMS v2: Improvements to remote firmware update feature
  • VE.Bus BMS v2: Add sending the pre-alarm status to VRM.
  • Bluetooth improvements (I'll elaborate on this later)
  • Fix bugs in the GUI that could cause it to show glitches and/or get stuck.
  • Add Thai language


Modbus-TCP

  • Fix register 31, the /State path for the VE.Bus inverter/chargers. Since v2.89 it returned value 252, Ext Control, for systems where the Inverter/charger is externally controlled. Instead of 3 (Bulk), 4 (Absorption) and so forth. Breaking customer integrations. (also available in Venus OS v2.93)


Venus OS Large

  • Update signalk-server from 1.44 to 1.46.2


Changes v3.00~4 -> v3.00~8

General

  • Multi/Quattro: Fix issue causing a repetitive low battery alarm in case the battery is disconnected
  • ESS: Fix bug introduced in v3.00~2 related to external control mode.
  • Add progress indicator (0 to 100%) to Venus OS firmware download.
  • Fix tank temperature unit (Fahrenheit)
  • Add new VE.Bus product ids (2681, 2723, 2766, 2776)
  • Add diagnostic fields for Multis/Quattros (uptime counter per unit, terminal voltage, Vsense voltage for L1 master and DC ripple)


Modbus-TCP

  • com.victronenergy.battery: Add /Dc/0/Power and /Mode, add missing fields to /State enum
  • com.victronenergy.digitalinput: Add "Generator" to /Type enum
  • com.victronenergy.multi (applies to RS products): fix in enum /State


Venus OS Large


Changes v2.92 -> v3.00~4


  • For systems having multiple BMSes connected, allow selecting which one should be used for DVCC. It also allows the use of a BMV for SOC tracking -- by selecting BMV as battery monitor -- while still using the BMS for DVCC. A bit of a niche issue for special systems, more technical background here: https://github.com/victronenergy/venus/issues/901 (but please don't start posting on our github - thanks).
  • Detect Hubble batteries, untested as of yet.
  • Add Polish translations, thank you Jakub T for helping with that!
  • ESS: increase control speed of systems using todays supported meters (ET112, ET330, EM24, and also the ABB ones) a little. But, for faster meters, such as the EM540 which is not available yet, increase it very significantly. Requires updating the built-in MK3-chip, see next bullet.
  • Include a newer version of onboard MK3-chip firmware, v215. Updating that has a 1 to 10% chance of a short system outage (Multi/Quattro shuts down in VE.Bus Error 14, restarts after 30 seconds). And therefore the update needs to be initiated manually from within the menu. Note that this is a reversible action, no need to worry about being unable to roll back. After updating, and then rolling Venus OS back to v2.92 or some other earlier version, the MK3 will automatically (and silently) be downgraded to the for that version of Venus OS required MK3-firmware version.
  • Improve text for tank sensor name in pump configuration.
  • ESS: Fix bug where PV is not used for loads when scheduled charging to 100% during daytime
  • Fix bug where a PV-inverter on AC-in-2 would not be shown in the ESS overview. The workaround was to configure the PV inverter as being on AC-in-1. Not needed anymore.


Venus OS Large


Under water / developer

  • Various small under the hood changes, mostly resulting in small reductions of CPU load
  • Replace Hiawatha webserver with nginx; which is better kept up to date (security)
  • Include various OE Dunfell fixes
  • DVCC: simplify transmission of the charge voltage setpoint by sending it always, rather than only if devices that work with it are detected. This won't make a difference to any commonly known system type.


MK3 firmware update related screenshots

On systems not updated yet, you'll see this (after going to the Device list, and then into the MultiPlus, Quattro or EasySolar listing):

1666825009093.png


And for anyone wanting to make sure its updated, in that same menu, scrolling all the way down to the Device submenu, and going in there, and scrolling down again, you'll find this listing:

1666825094337.png

Wherein the 212 digits are the version number, and thats the old one. And here is what you see after the update:


1666825165306.png


Note that this is necessary only for this one update. Hereafter, updates will be silent again, like they used to be; since there is no longer a risk of a short system outage.



Prior threads:

Venus OS
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi all, earlier today we released v3.00~18, that fixes the Node-RED Victron control, aka write-, nodes. The previous version (v3.00~17) broke those.

Thank you for your reports on that!

2 Likes 2 ·

Hi all, this morning we released v3.00~19 for testing. Note that it has an issue related to MQTT and also the HTML5-App and possibly VRM real time controls. All just monitoring tools; no serious impact I'd expect.


A new version, v3.00~20 is expected later today. Meanwhile, if this causes a problem, you can always use the backup firmware function to revert to v3.00~18, or install latest official release, v2.93.

0 Likes 0 ·

v3.00~20 is now available. Fixes the issue that was introduced in ~19.


No known issues, other than some issues related to Node-RED and the new “only changes” feature; which is fixed in code and those fixes will most likely be included in v3.00~21


If you see any issues, welcome to report!

0 Likes 0 ·
17 Answers
satmaster200 avatar image
satmaster200 answered ·

Hi!

Seems as the new option in NodeRed to input nodes to only broadcast changed values

bildschirmfoto-2023-02-18-um-000212.png

is not working. When enabled, I do not get any changes at all.

Tested with the "Relay" Node(toggled the relay many times):
bildschirmfoto-2023-02-18-um-000324.png

If the "only changes" is disabled,

216095631-a6d28f46-738b-409f-af38-af8d8983fc19.png

values re-appear every few seconds:

bildschirmfoto-2023-02-18-um-000543.png


Thanks a lot for your help and your great software!


3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dirk-Jan Faber avatar image Dirk-Jan Faber commented ·

I can confirm that this is not working as should. I have made an issue for this https://github.com/victronenergy/node-red-contrib-victron/issues/161
Background is that, under the hood, the relay broadcast their messages slightly different as other nodes.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ Dirk-Jan Faber commented ·
hi @satmaster200 this is fixed per v3.00~21, available just now.
1 Like 1 ·
satmaster200 avatar image satmaster200 mvader (Victron Energy) ♦♦ commented ·

Hi mvader! Excellent, just tested now, works like a charm! Great Idea we can choose now to round values, makes the flows a lot sleeker!

Great job!

Much appreciated!


1 Like 1 ·
daniel avatar image
daniel answered ·

Hello !

In version Venus OS v3.00~17 (also ~16) Large, NodeRED does not work properly. This simple FLOW on/off MPPT not working. In version ~15 it worked without problems.

I have this problem on two installations (Venus GX, RPi)

flow.png


flow.png (22.1 KiB)
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dirk-Jan Faber avatar image Dirk-Jan Faber commented ·

Please update to v3.00~18 and try again.

0 Likes 0 ·
daniel avatar image daniel Dirk-Jan Faber commented ·
Tested, work fine. Thanks.
0 Likes 0 ·
semlohnhoj avatar image
semlohnhoj answered ·

Hi,

I have a NodeRed flow that changes the On/Off state of my Multi RS Solar from "Inverter Only" to "On" at 00:30AM when electricity is cheap. This worked fine in 3.00~15 but does not work at all in 3.00~17. See flow below:

1676801037125.png

The "Charging Started" debug message is displayed but the RS stays in "Inverter Only" mode. I've reverted the firmware back to 3.00~15 and confirmed it works again.



1676801037125.png (39.5 KiB)
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dirk-Jan Faber avatar image Dirk-Jan Faber commented ·

Please update to v3.00~18 and try again.

0 Likes 0 ·
semlohnhoj avatar image semlohnhoj Dirk-Jan Faber commented ·
Yes, confirmed, 3.00~18 resolved this issue.
0 Likes 0 ·
mr-manuel avatar image
mr-manuel answered ·

Hello,

it seems that the "show: item.valid" in the QML files is not working anymore.I get displayed a lot of options in the GUI with no values. I reverted back to 2.93 to check and there it works as expected.

1676828114286.png


1676828114286.png (25.2 KiB)
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem commented ·

Yes this is true. It was mentioned in the v3.00~14 release note. You need to change from "VisualItemModel" to "VisibleItemModel". There are also some limitations which I posted here:

https://community.victronenergy.com/questions/179527/bug-hiding-gui-objects-not-working.html?childToView=180447#answer-180447

Note that VisibleItemModel only exists starting with v3.00~14. Prior to that, your code must use VisualItemModel.

0 Likes 0 ·
mr-manuel avatar image mr-manuel Kevin Windrem commented ·

Thanks! I checked the original *.qml files and there are also still "VisualItemModel" objects with "show: idem.valid" items. Probably they have to still change that.

0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem mr-manuel commented ·

The only file I found was PageNotifications.qml and it's only child does not have a show: property. So all is well. I suspect Victron will change this before release.

If you have other specifics, you might post here so Victron can address them.

Obviously, third party additions will need to modify their code also.

@Jeroen

0 Likes 0 ·
Mark avatar image
Mark answered ·

mutliplus has appeared on Victron connect after update!…..is this to be expected?6817a1a3-ee4c-430d-bb2d-02274d422976.png


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Mark I'm not so sure. Since you won't be able to do anything with that; at least not anytime soon. I'll make sure thats double checked. Thanks!
2 Likes 2 ·
mr-manuel avatar image
mr-manuel answered ·

Edit: This was solved. Solution in the comments.

After the update from v2.92 to v3.00-17 my PV inverter is not shown anymore in the pages overview, if the position is set to 0 (AC Input 1).

5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mr-manuel avatar image mr-manuel commented ·
@Izak (Victron Energy Staff) indeed I had to set the settings manually. All is working now like it should. You don't have to investigate further. Thanks a lot
1 Like 1 ·
mr-manuel avatar image mr-manuel commented ·

Ok, this is related to another problem. The values "/Settings/SystemSetup/AcInput1" and "/Settings/SystemSetup/AcInput2" in "com.victronenergy.settings" weren't written also in v2.92.

https://community.victronenergy.com/questions/76999/ac-inputs-on-venus-os-on-raspberry-pi.html


0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mr-manuel commented ·
Hi @mr-manuel we'll look into that, thanks.
1 Like 1 ·

Hi @mr-manuel , can you confirm something for me. 1) You have a Quattro, 2) with a genset on AC-in-1, 3) the grid on AC-in-2, but 4) your PV-inverter's position is configured as AC-in-1?

If this is the case, simply move the PV-inverter to the other AC-input and that should resolve it.

It's because we fixed this bug: https://github.com/victronenergy/venus/issues/1015

I think a migration step may be required, which we will look into. If you can confirm my blind diagnosis, it will help me a lot.

0 Likes 0 ·
mr-manuel avatar image mr-manuel commented ·

Hello @Izak (Victron Energy Staff),

thank you for your fast response.

1) Since it's a test and development setup, I have only a Raspberry Pi. I tested to emulate a MultiPlus with the official dummy script https://github.com/victronenergy/dbus-systemcalc-py/blob/master/scripts/dummyvebus.py and my custom script https://github.com/mr-manuel/venus-os_dbus-multiplus-emulator, where I cloned all the values from my production envoirment with a MultiPlus II-GX 48/5000/70-50

2) There is only Grid on AC Input 1

3) There is no AC Input 2

4) Config technically it obviously don't work on position 0 and 2 because of this lines https://github.com/victronenergy/dbus-systemcalc-py/blob/d01d04427930c5c5ce08de016af7895bd0e9b710/delegates/pvinverter.py#L66-L80 since the values are missing in "com.victronenergy.settings". I troubleshooted now for hours, but can't find the reason, why the values from the emulated MultiPlus aren't used. All values on "com.victronenergy.vebus.ttyS3" are identical to the production system.

If you wan't I can give you SSH and GUI access.

Maybe the problem is less complex and the MultiPlus II is writing this settings to "com.victronenergy.settings"?


0 Likes 0 ·
mr-manuel avatar image
mr-manuel answered ·

Since the QML pages have to be changed to hide for empty content, wouldn't it also be an idea to hide unused phases for PV inverters and grid meters in the device list? Like on the system overview page unused phases are also hidden.

Edit: It is already in "PageAcInModelFpGenset.qml" but not in "PageAcInModelDefault.qml".

1676961724476.png

1676961748066.png


1676961724476.png (31.4 KiB)
1676961748066.png (27.4 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

we'll take a look at that @mr-manuel thank you!
1 Like 1 ·
juf avatar image
juf answered ·

Hello,


have rebook my rpi and get new ID‘s for some devices.
Thats bad for mqtt and self written scripts.


regards

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

michaeld avatar image michaeld commented ·
This is an existing issue not just with this beta. Doesn't seem to affect VE.direct devices, just VE.Bus, and only using the MK3-USB on a Pi. Changing USB port definitely does it but also sometimes a reboot changes the VRM instance ID. They already fixed it for VE.direct devices so hopefully VE.Bus will be fixed at some point too!
1 Like 1 ·
lykke avatar image
lykke answered ·

I run a system with two BMS's + a SmartShunt.

Updated from 2.xx to 3.18 and now only one BMS is visible in Node Red. Updated to 3.20, but still only one BMS is visible in Node Red (Both are visible as usual on Remote Consol).

1677315680284.png

1677315711752.png

PS: Thank you for implementing Node Red, it makes automations so much easier :-)


1677315680284.png (21.3 KiB)
1677315711752.png (46.7 KiB)
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dirk-Jan Faber avatar image Dirk-Jan Faber commented ·

Can you file a bug report here? It looks like the device list of Node-RED is either not seeing the second device or is overwriting the first with the second. If possible, can you check if both have a unique /DeviceInstance on the dbus?

0 Likes 0 ·
lykke avatar image lykke Dirk-Jan Faber commented ·

Will file a bug report. How do I check the "/DeviceInstance"? I can SSH into the Cerbo. I checked the MQTT stream but was only able to see one SIMP BMS (DeviceInstance 512)

1677335160375.png



0 Likes 0 ·
1677335160375.png (70.6 KiB)
lykke avatar image lykke lykke commented ·

I think my Node Red installation has become corupt. I had to reselect all the Victron nodes and now it seems only some of them works as intenden - I will redo the config from scratch. That doesn't change the fact that I can only see the one battery.

0 Likes 0 ·
n-dee avatar image
n-dee answered ·

Any plans to adress the grid-setpoint issues in this beta?
(my setting: 0w)

1677353976893.png


1677353976893.png (109.7 KiB)
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

daniel avatar image daniel commented ·

I have the same problem, regulation it is slower than in previous versions with ET112.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ daniel commented ·
Hey both, noted, we’ll look at that Matthijs
0 Likes 0 ·
bobke avatar image
bobke answered ·

Upon my communication of a mode-red firmware v.3.00-15 dashboard problem, I was happy that I received a quick reaction with the suggestion to try the beta version v3.00-20.

After this upgrade I did by means of the firmware upgrade on remote console my remote console only has a white screen. No root access anymore possible via SSH.The RPI screen has only the Victron blue power logo and one small sentence with root@taspberyypi.....
The touch screen function does not work anymore.
What can I do to resolve this or to access the RPI again? Or is the only solution to do a complete re-installation starting from scratch


4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bobke avatar image bobke commented ·

I could connect a wireless keyboard and give the command reboot on this last line, that works, but that was no solution. Tried to give some other commands as rm /etc/venus/headless, but this was not possible: responses on this single line were not clear to me.

0 Likes 0 ·

Do you have GuiMods installed? At least that's what the white screen symptom suggests. In that case please open a new question in the Modifications space and mention GuidMods in the title so the author can find it easily. This is the wrong thread for GuiMods related things.

0 Likes 0 ·
bobke avatar image bobke Stefanie (Victron Energy Staff) ♦♦ commented ·
The problem is that I cannot check any more if this installed, because I do not have any control facility anymore,There is a little change now in the siuation since yesterday (after several power-off/ons). After display of the Victron logo now configuration is starting but resulting on my RPI screen in a complete white screen and in the remote console I have still only the Hot-keys part, the rest is white.
0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem bobke commented ·

If you are running GuiMods, please consult the ReadMe for SetupHelper for a mechanism to blind uninstall it and GuiMods.

https://github.com/kwindrem/SetupHelper

Failing that, you can connect a serial terminal to the GPIO pins and may be able to uninstall from there.

if not, it's time to reflash the SD card and start from scratch.

If you can get to the logs, please post them to the issues list for GuiMods.

Please move any future discussions to a GitHub issue for the package. This thread is specifically for issues with the unmodified beta firmware.

https://github.com/kwindrem/GuiMods

0 Likes 0 ·
lukeclose avatar image
lukeclose answered ·

Hi Guys, Since updating to latest OS my VRM has stopped displaying AC Loads

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Luke, did you solve this?
0 Likes 0 ·
ben4solar avatar image
ben4solar answered ·

Is there a way to still have VRM remote console input control when using the disabled touch feature on a GX Touch? Currently when I disabled activate touch control it locks the touch panel, local remote console and VRM external remote console.

Could there be a toggle button next to the relay control on the controls page in VRM?

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem commented ·

I think it makes sense for the touch disable to only affect the LOCAL GUI. I understand that some "local" GUIs would use a web browser and that would not be locked out. So maybe a "touch disable scope" is needed.

The current implementation is for a closure to toggle the touch on and off. I think it would be better for the disable to be level sensitive so that an external switch could positively display the enabled/disabled condition.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ Kevin Windrem commented ·
hi both, that would be nice ofcourse, but for now this is what it is.


We're working on a brand new gui, which will work differently with regards to Remote Console, both locally and via VRM; and then I can see how we'll be able to work around this issue of touch also blocking touch on Remote Console both locally and remotely.


0 Likes 0 ·
Dirk-Jan Faber avatar image Dirk-Jan Faber commented ·
That is only true for the mouse control. When you activate the disable touch feature, you should still be able to control the system via local remote console and VRM external remote console using the keyboard. It is also still controllable on the device if you plug in an USB keyboard.

The toggle only disables mouse and touch control. I'll update the documentation to make that more clear.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ Dirk-Jan Faber commented ·
:thumbsup: !
0 Likes 0 ·
djprofusion59 avatar image
djprofusion59 answered ·

Hello for me all is good, juste the traduction is not ok for the new features (in French for me)


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dirk-Jan Faber avatar image Dirk-Jan Faber commented ·

In some cases it takes a while before we get all new terms correctly translated. Feedback and improvements on existing translations are always welcome.

0 Likes 0 ·
Bert Beijl avatar image
Bert Beijl answered ·

Goodmorning,

I just updated my Raspberry 3 with touchscreen to v3.00.21. The touchscreen hangs and accept no input/touch. Remote console works. Same in version 2.93. Back to v2.92, no problems.

img-0239.jpg

Regards, Bert


img-0239.jpg (86.6 KiB)
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem commented ·
have you removed the /etc/venus/headless file?
0 Likes 0 ·
Bert Beijl avatar image Bert Beijl Kevin Windrem commented ·
Yes! Thanks!!
0 Likes 0 ·
modian avatar image
modian answered ·

Good morning,

updating higher version than v3.00-18 generates reboots on the Cerbo GX in my installation several times a day. So far I could not find out under which circumstances this happens. I'm using NodeRed and serialbattery as well

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Bert Beijl avatar image
Bert Beijl answered ·

Touchscreen on Raspberry Pi 3 does not dim after x seconds. Same problem in v2.93. v2.92 is OK

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources