question

re18 avatar image

Connect ruuvi to CCGX or Venus GX

Hi Victron Community

I‘m using a CCGX and I like to add some Ruuvi Temperature sensors. Since the CCGX has no bluetooth I‘m wondering, if it is possible to add them via adding a bluetooth dongle?


CCGX Color ControlVenus GX - VGXBluetoothruuvi sensors
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hey @RE18 , hope you don’t mind your question getting used to become the central point for everyone around using a ruuvi on a CCGX or Venus GX. I’ve slightly edited your question to prevent confusion - hope thats ok.
re18 avatar image re18 mvader (Victron Energy) ♦♦ ·
Perfect, thank you.

I want to add that we have tested the UB400 on a MultiPlus-II GX with a USB Hub (Digitus Slim Spider) and it works.

10 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi all,

In this post, I have listed all dongles tested by Victron, as well as others.

Generally speaking, any USB Bluetooth dongle featuring Bluetooth 4.0 will (most likely) work on GX device.

The main purpose of this list is to guide which USB Bluetooth dongle buy and use to get wireless temperature monitoring using the Ruuvi wireless temperature sensors. To use mainly on a CCGX, Venus GX, and also the Cerbo GX. Why the Cerbo GX? Thats because even though the Cerbo GX features built-in bluetooth, that doesn't work reliably enough. More details about that on in the GX product range datasheet.

For now we won't be stocking them ourselves, since that will only make them rather expensive for anyone to buy; whilst freely available on the internet for just a few USD up to 10 or 20 USD, without ourselves, and our dealer network, to be in the middle.

List of tested dongles by Victron, that work:

  • Logilink BT0037
  • TP-Link UB400(UN)
  • Ewent EW1085R4
  • Laird BT820
  • Laird BT851

All above list was tested from -17 to 70C.


List of tested dongles that don't work:

  • TP-Link UB500(UN)
  • Avantree BTDG-45 (Avantree DG45)
  • Nobrand 5.0 USB dongle (amazon link)


List of dongles tested by others that work:

  • Insignia (NS-PCY5BMA2) for $14.99, tested by @Roamer105 , see below.
  • Kinivo BTD-400 - tested by @Al , see below
  • Ideapro USB bluetooth adapter 4.0 - tested by see below


And some comments on what doesn't work: several Bluetooth 5 dongles that we tested do not work. Most or even all Bluetooth 4, or 4.2, did work. Reasons for them not working differed per unit. Some might benefit from a newer kernel, or newer library of linux-included firmware files. But our aim was just to test what works and what not, so we stopped there, and did not, and are not aiming to in the near future either, spent time on making them work.

Whilst finding a compatible WiFi dongle can be difficult, Bluetooth is -luckily- different.


More tests welcome!

If you tried another one, and it works, please let everyone know by posting here - thanks!


Victron VE.Direct Bluetooth Dongle won’t work for this

The Victron VE.direct Bluetooth dongle is not designed to connect to a CCGX or Venus GX, it is only for devices like MPPT, Phoenix inverter or BMV-700/702.


What does Bluetooth add?

Bluetooth on a GX Device currently servers two purposes:

1) you can configure the ethernet and wifi networking, using the VictronConnect app.

2) you can read temperature and humidity from the Ruuvi wireless sensors (requires Venus OS v2.80 or later).

17 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ps. I ordered four dongles on Amazon, which we'll test ourselves and confirm here if they work or not.


  • TP Link UB400, Amazon ASIN B07NQ5YGDW, EUR 9,50
  • Macly Bluetooth 5.0 USB, Amazon ASIN B08FH88MBX, EUR 6,99
  • Avantree ‎BTDG-45-BLK, Amazon ASIN B08GM1MV6B, EUR 14,99
  • TP Link UB500, Amazon ASIN B098K3H92Z , EUR 14,50

The Amazon ASIN number is the unique reference to an item on Amazon. Note that I took those ASINs from www.amazon.nl, and they are probably listed under a different ASIN on the other Amazon markets/websites.

joe-d avatar image joe-d mvader (Victron Energy) ♦♦ ·
Thank you...let us know which ones worked for the Venus GX. I assume all that you have to do is plug it in and the GX USB slot and it automatically recognizes it along with the Ruuvi sensors? Also, I have a GPS antenna plugged into the USB next to the microSD card slot so I assume I can use the USB next to the Ethernet port (on the other side)?

Joe

philippe avatar image philippe mvader (Victron Energy) ♦♦ ·

@mvader (Victron Energy) Hi, I installed the TPLink UB500 on the Venus GX (v2.80~36) and have a couple of Ruuvi laying arround. The parameters on the menu, Bluetooth and the IO/Bluetooth sensor appears but no devices. When I dig into the OS, It seems that the scan does not work.

Bluetooth Monitor >> Status: Command Disallowed (0x0c)

Bluetoothctl >> [bluetooth]# scan on Failed to start discovery: org.bluez.Error.InProgress

Seems that another process/service is already running or cause a conflict. Hope you have some ideas what is going wrong :D

Happy 2022. Best regards, Philippe

Hi phillippe thanks, we tested the same. doesn't work.
philippe avatar image philippe mvader (Victron Energy) ♦♦ ·

@mvader (Victron Energy) Hi Matthijs. I assume we are in the linux built 5.10 and this will not change quickly??

So apparently in the btusb.c the next entry is missing. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1948502

/* Tp-Link UB500 */
{ USB_DEVICE(0x2357, 0x0604), .driver_info = BTUSB_REALTEK }

it will be solved in a futur release, or it can be added and compile the kernel.

https://askubuntu.com/questions/1370663/bluetooth-scan-doesnt-detect-any-device-on-ubuntu-21-10/1371453#1371453

Hope you can do something with this information.

Hi, we are at 5.10 and indeed I don’t see a need to go spend resources on fixes like this.


Why not get a dongle that is tested to do work instead?


changing that will mean also testing again that nothing breaks, etc etc.


same for ant other dongles that don’t work - no matter the reason: we will not spend time on making them work; however trivial.

That bluetooth works on a CCGX and Venus GX is already unexpectedly nice, and there are enough dongles that do work without requiring work.

Sorry to be firm on this, but to make progress, we need focus.

philippe avatar image philippe mvader (Victron Energy) ♦♦ ·
Totally understood. Just I was faster then the tread to buy the dongle and the ruuvi's. Did spot only later on the fact that it is normally only supported on the Cerbo and not on the Venus/CCGX, but another 400€ to buy a Cerbo, is just over it. I have only the Venus for 2 years. But thanks for coming back with the details.
joe-d avatar image joe-d mvader (Victron Energy) ♦♦ ·

I installed the ideapro USB Bluetooth Adapter 4.0 on my Venus GX and it seems to work. I do not see the temp on the Remote Console but I can see the sensor on VRM-Advanced (with temp widget selected) .

I noticed that the GX relays will not use the bluetooth temperature sensors? Will that be fixed?

Also, will there be a way to rename the sensor? Right now I see Ruuvi XXXX (XXXX is serial number) on the Remote Console (Settings->I/O->Bluetooth sensors) but in VRM-Advanced it shows up as Temperature [25]. Its tough to keep track with many sensors.

Digging into this further, the Ruuvi does show up on the main screen of the GX Remote Console and can be setup as "Battery", "Fridge: or "Generic" types (this "type" does not seem translate to VRM Advanced display, still shows Temperature [25]), but the Dashboard of VRM does show the Ruuvi information and "type"


Also can setup bluetooth sensor for relay operation.....still confused on how to setup a single relay that can be controlled by multiple sensors and what is Condition 1 and Conditon 2? Is this explained somewhere?
Hi, I’ll add that dongle to the list. Thank you!

Setting a custom name (Device list -> My sensor -> Device submenu) works for me. Also on VRM advanced page. We’ll check the rest. For further discussion, pls start a new thread - or post an answer to the beta thread, since ruuvi is still beta.

Dont use this one, I’d like to keep it clean and for dongle compatibility only, thank you!

joe-d avatar image joe-d mvader (Victron Energy) ♦♦ ·
Yes, this worked for me as well to rename Ruuvi. THX

Understand to keep this thread clean.

Hi all, an update, I added various dongles that do work (we tested them here in the office) to above list. And also listed a few that don't. see above.

I've ordered a couple of TP-Link UB400 dongles and they do offer Ruuvi compatibility for CCGX units. It is, however, unclear what procedure should be followed in order to disable the built-in bluetooth functionality on a Cerbo.

Would anybody be able to indicate the procedure to be followed when the built-in device is being replaced by the dongle, as recommended?

The internal bluetooth functionality is disabled as usual in the menu structure: Device list > Settings > Bluetooth > Enable <Off>. After this the inserted USB dongle takes over.

As the dongle bluetooth interface isn't visible in the menu structure there isn't a way of setting the pin code as a filter (and to provide additional security). This could be an additional risk in a setting where temperature readings are used to control relay functionality.

Perhaps the usb enabled bluetooth dongle parameters (enable, pin) could be made visible in the future?

I’ve got 3 Ruvvi sensors on my narrowboat and the one furthest away from Cerbo keeps dropping out. Plugged in one of the recommended Bluetooth dongles. Then what do I do?
Doh I’ve worked it out. Turn off the Bluetooth in settings and the dongle takes over. Not sure it’s good for security though but Ruvvi working fine now
ejrossouw avatar image
ejrossouw answered ·

I was waiting for this ;) The VenusOS is on all the GX devices so from that point of view, it should be ok, but the fuctionality will only be available next year. However, getting bluetooth fuctionality on the Venus or CCGX using a bluetooth dongle, I do not actually have the answer given I have never seen anybody actually use it like that.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

Venus OS is running on all GX devices but only the Cerbo GX has Bluetooth.

The VE.direct Bluetooth dongle is not designed to connect to a CCGX or Venus GX, it is only for devices like MPPT, Phoenix inverter or BMV-700/702.

https://www.victronenergy.com/media/pg/VE.Direct_Bluetooth_Smart_dongle_manual/en/introduction.html#UUID-b9ae5428-910d-2666-2ca7-7f430615d80c

https://www.victronenergy.com/media/pg/VictronConnect_Manual/en/compatible-victron-products.html

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

roamer105 avatar image
roamer105 answered ·

I installed 4 Ruuvi sensors. They are great and quite accurate. I use a CCGX running the latest beta firmware. Since between the Tank 150 and GPS receiver the two USB connectors are both used. I simply added a small hub, moved the Tank 150 to the hub along with an Insignia Bluetooth adapter from Best Buy.

Without even restarting the CCGX it showed Bluetooth active and found all of the Ruuvi devices. No issues.

Thanks!

5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Did you buy this from the USA?

I live in the USA. The recommended Bluetooth adapter in this thread is not available in the USA. So I got an Insignia (NS-PCY5BMA2) version of it for $14.99.

The Ruuvi sensors came from the factory via DHL. No issues, no extra cost.


Hi @Roamer105 . Could you explain what needs to be done on the CCGX once the Bluetooth dongle is connected to "connect" to the Ruuvi? I'm running VenusOS 2.80-36 on the CCGX.

Thanks

Go to settings - I/O - Bluetooth sensors and click enable. It will show the sensors it finds. Enable them too

They will appear in the device list where you can change the name etc.

Thanks - much appreciated
Al avatar image
Al answered ·

I've just ordered 4 Ruuvi tags, some active USB extension cables and took a punt on a dongle:

Kinivo BTD-400 Bluetooth 4.0 USB Adapter (Low Energy Wireless Dongle) - Windows 10 / 8.1 / 8 / 7 / Vista , Raspberry Pi , Linux , Mac (2011 & beyond) and Stereo Headset Compatible by BlueRigger LLC
https://www.amazon.co.uk/dp/B007Q45EF4/ref=cm_sw_em_r_mt_dp_MGG6XE7V4PVTR4NAEV1H_encoding=UTF8&psc=1

I saw lots of similar dongles but many explicitly state they don't work on linux or Mac, I'm assuming we need dongles that will work with native linux drivers to talk with VenusOS? Which is why this one looked good.

I'll update when they all arrive late next week hopefully, and see if they play with the CCGX.

I also saw quite a few Bluetooth 5 dongles with aerials for 100m range, it would be interesting to see if any of these worked too!?

51wnirxtql-ac-sl1500.jpg

https://www.amazon.co.uk/dp/B09HJV51FR/ref=cm_sw_em_r_mt_dp_dl_J3A8344H552X7JSN0CZQ?_encoding=UTF8&psc=1



8 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

*Update. Ruvvi Tags arrived to the UK customs paid today (Ordered Friday night, arrived Tuesday Morning) , and I can confirm the Kinivo BTD-400 I ordered from Amazon link above, works plug and play in the CCGX. I did use the Ruuvi android app to update Ruuvi firmware first, but the Kinivo BT dongle I just plugged in to the CCGX and turned on bluetooth, currently running Venus OS v2.80-36, all populated happily.

Just a quick test and I found they connect happily at 17m distance indoors line of sight.

screenshot-20220111-141946.png

great! added to the list above, thank you.
Um - how did the info appear on your (front) screen? I can see the RUUVI, I can see its details, it shows in VRM - but nothing on the "front page" of the screen (at the bottom, like your example). I'm obviously missing something. This is all on a Cerbo GX, latest software (2.80~36) - etc. Also how does one remove a Ruuvi Sensor? It's no longer on my Cerbo GX - but still on VRM!!!
It look like @Al is running OS Large on a CCGX ?

I didn't know it could ?!

Hi @mje I haven't tried myself but I think you should be able to delete from VRM, but there was a thing about hanging sensors in v2.80~36.. not sure if that's relevant.

delete.jpg

I installed GuiMods which adds a few extra features to the flow overview display to see the temps: https://community.victronenergy.com/idea/77971/venus-os-modification-scripts.html


delete.jpg (102.2 KiB)
Thanks - deleted from VRM.

I'm adding your scripts to my Cerbo!
Waiting for more Ruuvi to arrive before I test.


What sort of range are yo getting with that, I need something that will do approx 15m. Through cold room wall.



Hi @Alan 15m for Ruuvi to GX should be fine, but it depends on what the cold room wall is made of? The usb extenders seemed to work well if you need them, but I swapped the USB cable for an AV Access USB extender over CAT as I was and still have regular CCGX reboots, but I think that's more a limitation with the CCGX processor or GuiMods, either way the reboots are not a big deal, and both ways of extending if necessary should be fine especially if you have a Cerbo / rpi. The AV Access extender: https://www.amazon.co.uk/dp/B01EV33R8S?ref_=cm_sw_r_cp_ud_dp_GBR039GDN7Y3BZYB27TK

brezzi avatar image
brezzi answered ·

Will the data of the ruuvi sensor be avalible in NodeRed?

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hi @brezzi , yes it will. Might take a little while (weeks), but it will. And welcome to community!
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ ·
ps, for further discussion on node-red, please use the Modifications section on Community.
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

@Al - I got one of the long range bluetooth USB dongles from Amazon -

https://www.amazon.com.au/gp/product/B08LVH5BCP/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

It immediately connects, no issues so far, and I can see all the Ruuvi sensors on my property (some 20M+ away through a steel shed).

I will leave it connected and see how it goes for a while.

13 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks Guy, that's good to know and interesting as it seemed quite a few of the Bluetooth 5 dongles tested above didn't work.

Hi @Guy Stewart (Victron Community Manager) .

This long range dongle is not currently available. Any other suggestions?

Where are the steps to add Ruuvitag info to the GX Touch? Thank you!!


Hi Guy, very interested in this solution. It seems to be available here in Amazon Canada, but it specifically states it does not support Linux (and Mac OS etc). So should I be ok to go ahead and order it? Or is it maybe something unusual that it did work for you. Thanks.
There is nothing special that I am doing, so I think it will work just the same for you.

You would be another one of only a few data points, so taking a little chance that it might not work.

Amazon is usually pretty good at returns if necessary.

randy-s avatar image randy-s Guy Stewart (Victron Community Manager) ♦♦ ·

I got the BT dongle and not sure how to install it. I’ve done a lot of searching and reading and no joy. I plugged it into the USB port right beside the USB port the Touch 50 plugs into, rebooted the Cerbo, and I can’t find anything in the settings that shows this new dongle.


Any chance you could give me a quick walk-through of the steps required to get this up and running? Also, once successful, how would the Ruuvi tags (or even Victron Connect app on my iPad) know which BT to connect to - the original built-in BT or my newly added USB-BT device? Thanks.

Hi @Randy S , the Ruuvi's don't need to connect to anything. They broadcast the information, and any bluetooth radio, aka dongle, can listen and retrieve the information.


Make sure your Cerbo is running the latest official version, which is v2.84.

And go to Settings -> I/O -> Bluetooth sensors. That is where you find the settings.



randy-s avatar image randy-s mvader (Victron Energy) ♦♦ ·
Thankyou for the reply. Sorry, perhaps I wasn’t clear. I have 3 Ruuvis. I can see all of them through the Ruuvi app on my iPhone/iPad. I can only see 2 of them on the Cerbo. The furthest away one does not show up. I read in several places including this thread that the BT radio was not very strong in the Cerbo and it was better to install a dongle. So I did….or tried to. I got the exact same one that Guy tried and was successful with. Being advertised as long-range was attractive due to the mounting location of my Cerbo and location of the last Ruuvi.

My question was about how to install the dongle. I did as per my description above, but I don’t know if there are some other steps. I do not see this dongle as an entity, and don’t know where- all to look. The various locations on the Cerbo look exactly as they did before. I can see the 4 hardwired temperature sensors and the same 2 Ruuvis as before. My concern is perhaps the new dongle is not working. How would I determine if it was correctly installed and working correctly. Thanks.


Hi @Randy S , that is a good point: at the moment it is not possible to see if the inserted dongle is working correctly. I'll think about how we can fix that in a future version.


If the dongle you're using is one in above list, then most likely it works.


Note that "long range" can mean many things (better antenna, but it can also refer to a Bluetooth Long Range specification, which I don't think the Ruuvi uses), and the signal strength will still be limited by the Ruuvi itself.


I recommend to use an extension cable and decrease the distance between the missing ruuvi and the bluetooth radio. 99% chance your issue a range problem.

randy-s avatar image randy-s mvader (Victron Energy) ♦♦ ·
I find this whole thing puzzling and perplexing - how can a device not know that something is connected to it?! However, I will make an observation - there is one Ruuvi that is in a freezer outside on the dock, about 25’ away from the Cerbo. It did not show up on the Cerbo by itself. However, about 15 minutes after plugging the BT dongle into the Cerbo, I did see it show up. Also required was some combination of re-booting the Cerbo and/or powering it off on on (pulling the fuse). I cannot be certain of cause/effect because there seemed to be a great deal of randomness to the whole process. So for now I’ve concluded the dongle must be working.


One other potentially significant observation; again not conclusive because of the apparent randomness of cause and effect. But it appears that if the Bluetooth link between the iPhone/iPad app gets broken, there is no way to pair them again unless you remove the BT dongle and start from scratch (power down/up etc). While in this state there is no way to access Remote Console. That’s a major problem!

I must say this appears to be an extremely fragile and unreliable system. It seems to require randomly switching settings on and off until it works, and then it works until it doesn’t, again for often unknown reasons, and then once again just randomly “doing stuff” until it starts working again. It extrem frustrating and disappointing.

I would add though that the philosophy and conceptual design of the Victron components is outstanding. Brilliant. But execution of the concept and user interface and interaction is lacking.

Hi all, just purchased a DIGITECH - XC4956 V4.0 Bluetooth USB dongle From Jaycar for my CCGX, its fully operational no problems at all.

Cheers..

daniele-calabrese avatar image
daniele-calabrese answered ·

I did install 3 sensors in my 40 feet boat with the existing bluetooth sensor even if i bought the suggested tp-link usb dongle. here is the screen shotScreen Shot 2022-02-24 at 14.07.33.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

pdonner avatar image
pdonner answered ·

The main article of this topic comments upon the Cerbo GX bluetooth functionality: "Cerbo GX features built-in bluetooth, that doesn't work reliably enough." There is also a reference to the the GX product range datasheet, where the nature of the problem is explained in this way: "The Bluetooth function in the Cerbo GX stops working when the internal temperature is too high."

In order to evaluate usefulness of the built-in bluetooth functionality of the Cerbo, it would be helpful to hear the specifics of these limitations.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dave Rae avatar image
Dave Rae answered ·

Bluetooth dongle from Jaycar, DIGITECH XC-4956 v4.0 on the CCGX seems to function correctly.

cheers

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

How do you know if it is fully functional Dave? As you can see from the response I received above from mvader, apparently there is no way to tell if it working correctly. I cannot even determined if it is installed.