Idea

Kevin Windrem avatar image
Kevin Windrem suggested

Venus OS modification scripts

I have created a number of setup scripts that simplify several Venus modifications. These have been discussed elsewhere but wanted to put all my changes in one place.

EDIT: I have renamed the repos to make it simpler to reinstall them on a Venus device, and also included commands you can copy/paste into the Venus command line to install each package.

The first command set is if you have internet access from the Venus device.

The second command is if don't have internet access. The command needs to be run on another unix computer that does have internet access (Mac OS qualifies). The resultant .tar.gz file is then copied to a USB memory stick, inserted in the Venus device. The install occurs when the Venus device reboots. You can do multiple installs if the .tar.gz file names are unique.

I've undertaken a major rewrite to the script code that makes it easier to write install/uninstall scripts and came up with SetupHelper that's used in all my scripts. You need it for all the other scripts.

https://github.com/kwindrem/SetupHelper

wget -qO - https://github.com/kwindrem/SetupHelper/archive/current.tar.gz | tar -xzf - -C /data
mv /data/RpiGpioSetup-current /data/RpiGpioSetup
wget https://github.com/kwindrem/SetupHelper/archive/current.tar.gz
mv current.tar.gz SetupHelper.tar.gz


TankRepeater solves an issue with NMEA2000 tank systems that report multiple tanks. Without TankRepeater, all tanks from that system are reported on the same tank tile with changing values.

https://github.com/kwindrem/TankRepeater

wget -qO - https://github.com/kwindrem/TankRepeater/archive/current.tar.gz | tar -xzf - -C /data
mv /data/TankRepeater-current /data/TankRepeater
wget https://github.com/kwindrem/TankRepeater/archive/current.tar.gz
mv current.tar.gz TankRepeater.tar.gz

GeneratorConnector interconnects the generator digital input (if any) to the generator's start/stop logic. This allows Venus to sync up with a generator start or stop that's done outside of Venus. It also adds status to the Generator Overview.

https://github.com/kwindrem/GeneratorConnector

wget -qO - https://github.com/kwindrem/GeneratorConnector/archive/current.tar.gz | tar -xzf - -C /data
mv /data/GeneratorConnector-current /data/GeneratorConnector
wget https://github.com/kwindrem/GeneratorConnector/archive/current.tar.gz
mv current.tar.gz GeneratorConnector.tar.gz

I had previously published a "Mobile Overview" enhancement that adds voltage, current and frequency to the AC in and out tiles in addition to a major layout change.

To that, I added a couple of other tweaks: I hide the Tile Overview and move Settings and Notifications to the top of the Device list.

Each modification can be installed or removed independent of the others.

https://github.com/kwindrem/GuiMods

wget -qO - https://github.com/kwindrem/GuiMods/archive/current.tar.gz | tar -xzf - -C /data
mv /data/GuiMods-current /data/GuiMods
wget https://github.com/kwindrem/GuiMods/archive/current.tar.gz
mv current.tar.gz GuiMods.tar.gz

I recently switched from a CCGX to a Raspberry Pi 4 and had a difficult time getting the display set up properly. Most notable was screen saver and dimming were missing.

https://github.com/kwindrem/RpiDisplaySetup

wget -qO - https://github.com/kwindrem/RpiDisplaySetup/archive/current.tar.gz | tar -xzf - -C /data
mv /data/RpiDisplaySetup-current /data/RpiDisplaySetup
wget https://github.com/kwindrem/RpiDisplaySetup/archive/current.tar.gz
mv current.tar.gz RpiDisplaySetup.tar.gz

I discovered that some of the digital inputs on the Raspberry Pi were high and some were low with nothing connected to the pins. The issue is a default for the Broadcom chip that initializes the first 8 GPIO pins to have pull-ups and the rest to have pull-downs. This required an overlay to straighten out.

https://github.com/kwindrem/RpiGpioSetup

wget -qO - https://github.com/kwindrem/RpiGpioSetup/archive/current.tar.gz | tar -xzf - -C /data
mv /data/RpiGpioSetup-current /data/RpiGpioSetup
wget https://github.com/kwindrem/RpiGpioSetup/archive/current.tar.gz
mv current.tar.gz RpiGpioSetup.tar.gz

The Raspberry Pi has no VeCan (CANbus) ports. I found the link describing the alternatives and built a rather complex setup script that handles (hoepfully) 8 different interfaces and the two can ports can0 and can1. While I wrote this for the Pi, it should allow adding CANbus interfaces to other Venus devices that only have one VeCan port.

I have only tested this with the CANable USB interface so if you are brave and have other interfaces, please beta test the script for me.

https://github.com/kwindrem/VeCanSetup

wget -qO - https://github.com/kwindrem/VeCanSetup/archive/current.tar.gz | tar -xzf - -C /data
mv /data/VeCanSetup-current /data/VeCanSetup
wget https://github.com/kwindrem/VeCanSetup/archive/current.tar.gz 
mv current.tar.gz VeCanSetup.tar.gz

As we all know, any modifications we make to the VenusOs file set are overwritten by a VenusOs update. Automatic reinstallation is a key part of SetupHelper.

One of the issues I had was maintaining each script when a new VenusOs version was released. This is especially time-intensive during beta testing. Each package has "FileSets", one for each Venus version going back to v2.40. A new version's file set is automatically created if there are no changes to files modified by the package from one of the previous versions. If changes are detected, the package is automatically uninstalled, or more accurately not automatically reinstalled when a VenusOs update occurs.

Enjoy, and please let me know if you find problems.

Venus OS
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Very nice Kevin, as a suggestion - Some pictures of the new screens would also help others to visulise the changes as well
0 Likes 0 ·
llubi avatar image
llubi commented

Hi Kevin!

I think it will be awesome for the campervan, RV, trailer, 4x4 users to use some of the tank space for at least external and internal temperatures.

I downloaded the QML (no without problems) and tried to modify, but never worked... so if you find any time in the future to put it in one of your updates, I’ll be very grateful, and sure lot of other people!

thanks,

Albert

22 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Done!

The latest GuiMods includes temps in the tanks column on the Mobile Overview. Any temp sensors that show up in the Devices list should appear there.

https://github.com/kwindrem/GuiMods

Also update SetupHelper

https://github.com/kwindrem/SetupHelper

Temps are NOT on the Flow overview. That will take more thought to figure out the best way.


0 Likes 0 ·

THAAAAANNNKSSSSS!!!!!

0 Likes 0 ·

... And I did add temps to the Flow overview. Either a single row of temps/tanks if 4 or less, or two rows of up to 4 tanks and 4 temps. After that, the lists scroll horizontally. It's tight but seems to work OK on my 7" screen.

enhanced-mobile-overview-screen-shot.png

enhanced-mobile-overview-screen-shot-split-temps-a.png


0 Likes 0 ·

Hello @Kevin Windrem


,

Any chance of giving the option to only display Celsius Temp's
I have 4 temp sensors and displaying both C & F makes for a cluttered display


Also I have two MPPT controllers, I get two lots of solar information displayed, however the information for the 2nd Solar Controller is a duplicate of the 1st (lower Instance numbered) controller.

1622819567095.png

0 Likes 0 ·
1622819567095.png (25.5 KiB)

Thanks for the input.

I added a C/F/both selection for temp display. It's set during setup so you need to install again.

I believe I fixed the duplicated PV Charger info but can't check it here. Please let me know if it's fixed.

0 Likes 0 ·

can't update as get the 2 following errors when executing this command

root@einstein:~# wget -qO - https://github.com/kwindrem/GuiMods/archive/current.tar.gz | tar -xzf - -C /data

tar: invalid magic

tar: short read

SetHelper update does work though

0 Likes 0 ·

Something was wrong with the tag. Recreated it and you should be able to download now.

0 Likes 0 ·

So initially when attempting the mv command I get the following error

root@einstein:~# mv /data/GuiMods-current /data/GuiMods

mv: can't rename '/data/GuiMods-current': Directory not empty

So a directory listing shows the following

root@einstein:/data# ls -l

drwxrwxr-x 4 root root 4096 Jun 5 05:10 GuiMods

drwxrwxr-x 3 root root 4096 Jun 5 05:14 GuiMods-current

drwxrwxr-x 3 root root 4096 Jun 5 00:22 SetupHelper

drwxrwxr-x 2 root root 4096 Jun 5 05:10 SetupHelper-current

etc....

So I removed both GuiMods & SetupHelper directories and tried again.

Both wget & mv commands work and I end up with:

root@einstein:/data# ls -l

drwxrwxr-x 3 root root 4096 Jun 5 05:33 GuiMods

drwxrwxr-x 2 root root 4096 Jun 5 05:35 SetupHelper

drwxr-xr-x 3 root root 4096 Jun 5 05:09 conf

drwxr-xr-x 2 www-data root 4096 Oct 26 2020 db

etc....


Now when executing /data/GuiMods/setup

I get the following error

root@einstein:/data# /data/GuiMods/setup

creating file set for v2.70~16

ERROR v2.70~16 main.qml no replacement file

ERROR v2.70~16 OverviewMobileEnhanced.qml no replacement file

ERROR v2.70~16 TileTank.qml no replacement file

ERROR: incomplete file set for v2.70~16 - can't continue


Is this because the Firmware has updated to v2.7~16

I'll move back to v2.70~15 and check

ok so works for v2.70~15


Temps now in Celsius however Solar is still wrong

1622872221263.png



0 Likes 0 ·
1622872221263.png (22.1 KiB)

You did the right thing with the rm -r GuiMods ...

I'll add that to the instructions.


v2.70~16 was released for beta today but pulled down later due to issues. I couldn't get tanks to appear and others found other issues.

So v2.70~15 is the latest for now.

I've tried another change for the PV Charger duplication. I only have one so can't test. Give the latest a try and let me know.

0 Likes 0 ·

No luck, Solar still the same


1622876082222.png

0 Likes 0 ·
1622876082222.png (17.7 KiB)

An update.

I checked the files (and contents) and it appears that OverHub.qml was not getting updated on simply installing over the top of the existing installation.

So I uninstalled, removed both the GuiMods directories and the did a new install.

All appears to be working now.
1622878129269.png

0 Likes 0 ·
1622878129269.png (20.2 KiB)

Glad you got it working. Thanks for struggling through with me.

I'm in the process of revamping the install/update process to make this less painful with less commands from the command line.

0 Likes 0 ·
@Kevin Windrem I keep seeing CPU temps shown on the interface.. would this be an option to add to your script?

I started looking at a simple tank input too but gave up and will wait for the Stetson board being developed!

Steve

0 Likes 0 ·

I pulled someone else's RPI temp mod off the community, I think here:

https://community.victronenergy.com/idea/75515/victron-gx-devices-internal-temperature-on-ui-and.html

I'm in the process of evaluating the TankEdge MODA capacitive tank sensors with the GX Tank 140 as a simple, low cost tank solution with Venus. Waiting on sensor and the GX Tank to arrive but will report back when tests are complete. The Stetson board will support resistive tank sensors like other Venus devices. The Stetson board could be modified to accept voltage based tank sensors with a resistor value change.

0 Likes 0 ·
Show more comments

Hi Kevin,

Solar display has broken again (within the last two weeks).

Gone back to displaying the first Solar instance Twice instead of the 2nd one.
Also missing the V & A details for the 2nd entry

1628237304575.png

0 Likes 0 ·
1628237304575.png (23.8 KiB)
Should be fixed now. Please test
0 Likes 0 ·
Show more comments
Kevin Windrem avatar image
Kevin Windrem commented

I have updated the Flow Overview to include tanks displays and voltage, current, frequency to many of the tiles:

18247-screen-shot-2021-03-17-at-30646-pm.png


The Mobile Overview page now also has a vertically scrolling list for tanks.

https://github.com/kwindrem/GuiMods

17 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Good work!

Ooh, you got PV Charger voltage and current, how or does this work for multiple MPPT's?

0 Likes 0 ·

Thanks Kevin. Nice work.

For unknown reason it doesn't show PV voltage and current for me. Cerbo GX here.

bildschirmfoto-2021-03-18-um-130909.png

0 Likes 0 ·

I think you will need to manually specify the MPPT device instance in the code.

0 Likes 0 ·

Thank you, Mark.

I've been through the code, but fail to see where it calls up the device instance from the MPPTs.

What I can see from OverviewHub.qml is that it looks at dbus-service for PV chargers.

0 Likes 0 ·

The code I have in place counts the number of solar charger dBus services and displays voltage and current if there is ONLY one.

There is space in the tile for a second voltage/current pair but no where to identify which one is which.

I'm open to making changes. Ideas/suggestions???

0 Likes 0 ·

So that explains why it's not working for me. I have two PV chargers connected. The second one just sits there w/o PV connected and comes into play with reserve panels when it gets tight in terms of low PV power.

0 Likes 0 ·

I found some real estate and was able to add two sets of solar charger info including custom names. It grabs the first two PV chargers it finds and ignores the rest.

Hopefully this will address most of the users.

The alternative would be to make a scrolling list. but in such a small area that may not be a good idea.

0 Likes 0 ·

Looking good though sun is down. Thanks.

bildschirmfoto-2021-03-18-um-191758.png

0 Likes 0 ·

I have 3 MPPT's the Amps and V's are not displayed... Could be due to 3 and not 2 being available. Is it not easier to just display totals for all PV?

I also don't see V and A in Critical or AC Loads (is this included)

1623770293785.png

0 Likes 0 ·
1623770293785.png (33.6 KiB)
Your system uses a different Flow Overview layout and I have not modified that one.


0 Likes 0 ·
Thanks Kevin... Its the Cerbo GX with 2.70~19 on at the moment.

Can I change something for GuiMods work?

0 Likes 0 ·

All the mods I made in OverviewHub.qml would need to be migrated to OverviewGridParallel.qml. Two challenges:

  1. the tile spacing is completely different.
  2. OverviewGridParallel uses different connection: sys. ... which I'm not looking for.

OverviewAcValues.qml ObjectAcConnection.qml would need changes to accommodate the different connections.

There may be more issues.

0 Likes 0 ·
Thanks - no problem!!
0 Likes 0 ·

@Kevin Windrem

and on another installation (RPi4), which has the RpiDisplaySetup running, the GuiMods does nothing, means no changes to the GUI and the console output is rather limited compared to what I saw on the Cerbo. Maybe a conflict with RpiDisplaySetup?

This is what I get:

root@raspberrypi4:~# /data/GuiMods/setup

This package modifies the GUI in several areas

All modificaitons are explained below with a choice to install each one individually

Available actions:

  Install and activate (i)

  Uninstall (u) and restores all files to stock

  Quit (q) without further action

  Display setup log (s) outputs the last 100 lines of the log

  Display Log (l) outputs the last 100 lines of the log

Choose an action from the list above: i

BusyBox v1.31.0 (2021-03-07 19:57:11 UTC) multi-call binary.

Usage: basename FILE [SUFFIX]

++ Package installed

adding GuiMods/setup to reinstallScriptsList

completed

root@raspberrypi4:~#


0 Likes 0 ·

The reason you aren't seeing any mode is the script is failing. There should be several more prompts asking what to install and those aren't being asked.

I found the bug and there's an update in GitHub so grab another copy.

https://github.com/kwindrem/GuiMods

I also made some changes to SetupHelper to add a reinstall option that is NOT compatible with the current version of GuiMods. (It SHOULD have worked as before but it isn't!!!)

So grab another copy of Setup Helper also (sorry).

Let me know if you still have problems

0 Likes 0 ·

Found one more bug but it's fixed now.

0 Likes 0 ·

Thank again, Kevin.

It's now working too.

0 Likes 0 ·
Rene Mullie avatar image
Rene Mullie commented

Great Mod!

It would be to great usage to add option so specify custom/extra tile to Flow Overview: extra shunt, Mppt etc based on Dbus paths which can be specified in GuiMods setup console.

So you can 'build'your custom Tile based on Dbus variables or fixed/text/title input. This obviously should be a template to accommodate the available space/lines etc per parameter etc.

BTW: really smart how you build the auto-update script to survive the VenusOS updates automatically; in this way you can customize a setup and forget about it ;-)


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Splitting the Tank column into Tanks and Temperatures is on my to-do list.

I currently use a separate thermometer for inside, outside and refrigerator temperatures but am considering moving temps to Venus.

0 Likes 0 ·
dirkmuc avatar image
dirkmuc commented

Hello @Kevin Windrem,

I just stalled the PiCAN2 DUO HAT on my RPi4 2GB with Venus 2.70-4 large 16.

as an out put I got this

VeCan configurations
can0 PiCAN Hat (MCP2515)
can1 PiCAN Hat (MCP2515)

Choose an action from the list above: d

information for can0
  udev info  vendor=  model Id=  vendor id=  serial=
  overlay: dtoverlay=mcp2515-can0-overlay,oscillator=16000000,interrupt=25
  services: can-bus-bms.can0 mqtt-n2k.can0 vecan-dbus.can0
information for can1
  no udev information available
  overlay: dtoverlay=mcp2515-can1-overlay,oscillator=16000000,interrupt=25
  services: can-bus-bms.can1 mqtt-n2k.can1 vecan-dbus.can1

VeCan configurations
can0 PiCAN Hat (MCP2515)
can1 PiCAN Hat (MCP2515)

Choose an action from the list above:

So it seem everything is working fine. Next step is to attach my new REC-BMS to it and see if it is working. But this will take some time, the cells have not arrived yet.

Thanks for your script!

Cheers

Dirk

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Excellent. Did you need to add the PiCAN or were they there automatically?

0 Likes 0 ·

Hello @Kevin Windrem,

I had nothing to add. Everything was installed automatically.

The CANBUS is also shown in the GUI, so I assume it is correctly integrated into the system.

Thanks again

Cheers

Dirk

canbus.png

0 Likes 0 ·
canbus.png (33.6 KiB)
Kevin Windrem avatar image
Kevin Windrem commented

The current GitHub repos support v2.70~5. While there's no file set for this version in the repos but the boot-time reinstall succeed any way.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

stepir avatar image
stepir commented

@Kevin Windrem have you tested it with v.2.70~11 ?

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes.

I create file sets by comparing the files I need to modify between Venus versions so I always know if a new Venus version needs a new replacement. This pretty much guarantees the mods will work If the setup script can't find a matching version of the unmodified file, the script won't install the package.

A look at the current file sets indicates that v2.70~11 includes new versions of two of the files I modify and that no file sets exist for more recent versions, so those are the latest modifications.

0 Likes 0 ·

thanks!!! will give it a try next days!

0 Likes 0 ·
rzaenger avatar image
rzaenger commented

Hi Kevin,

First of all, thanks for your scripts, which I also use for my setup with a Raspi 4 and the original 7'' display in my campervan.

Some adjustments and translations into German I did graphically and a bit fake with the green LEDs as well and time format too.

Now I use a grid meter ET112 from Victron and let me display the load on the AC side, but I do not use an inverter. Unfortunately, only the power is displayed, but not voltage and current, which is however visible in the menu...

Where can I put here to display that either under AC load in addition or , even better: on the left side at AC input?

It would be enough for me and maybe others if you could show us a way....

What do you think? Is this technically feasible?

Best regards Rolandbildschirmfoto-2021-06-08-um-125308.png

bildschirmfoto-2021-06-08-um-125903.png

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

All of the powers are calculated in system all and presented to the GUI as separate parameters in dBus. Voltage, current and frequency aren’t available via system all, so I go to the inverter’s dBus parameters for that. To get info from the grid meter would require realizing one exists and pulling the data from it’s dBus parameters instead of the inverter.

I don’t have a grid meter so I can’t say how you’d determine the dBus service to pull from. Systemcalc might provide a clue.

0 Likes 0 ·

Thank you very much. I will go to see what I can find in dBus area...

0 Likes 0 ·

Hallo Roland,

in Deutsch sieht schöner aus!

Ist es für dich möglich, "eingedeutschte" Ansicht weiterzugeben?

Oder... welche Möglichkeiten gibts es, die Anpassungen selber durchführen?

Gruß Johann

0 Likes 0 ·
Grid meter values will now show up in the AC input tile
0 Likes 0 ·
Kevin Windrem avatar image
Kevin Windrem commented

I just completed work to support the new tanks system which was included in v2.70~16.

In addition, I've added automatic updates for all my packages, and also manual first-time installation for these packages from a menu-based interface.

Automatic updates pull from GitHub or a USB stick with the archives on it. Auto updates from GitHub must be enabled, however updates from a USB stick are always active.

Manual installs are done through the new SetupHelper setup script.

The tedium in the original post regarding package installation is no longer needed. Just do the one for SetupHelper then run other updates/installs from there.

Refer to the SetupHelper repo for more details.

https://github.com/kwindrem/SetupHelper

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

running v2.71~1

I have used the new /data/SetupHelper/setup to install. This worked OK

Then enabled Auto updates

Then disabled Auto updates

Tried to uninstall choosing <u> option, it says

restarting SetupHelper service

SetupHelper/setup: completed

But the uninstall doesn't work. GuiMods still running

Then ran /data/GuiMods/setup and chose uninstall from this menu, and this then did uninstall the GuiMods.

Update:

I removed both the Setuphelper & GuiMods directories, and now I can't install GuiMods at all.

After a couple of reboots I did manage to get SetupHelper to download and moved to its correct install location.

However SetupHelper will not install GuiMods, and trying to download GuiMods directly doesn't work.

It appears to download as per:

root@einstein:~# wget -qO - https://github.com/kwindrem/GuiMods/archive/current.tar.gz | tar -xzf - -C /data

root@einstein:~# ls /data -l

drwxrwxr-x 3 root root 4096 Jun 18 14:38 GuiMods-current

drwxrwxr-x 3 root root 4096 Jun 18 14:20 SetupHelper

But then a few moments later the GuiMods-current directory disappears

ls: /data/GuiMods-current: No such file or directory

root@einstein:~# ls /data -l

drwxrwxr-x 3 root root 4096 Jun 18 14:20 SetupHelper

drwxr-xr-x 3 root root 4096 Jun 18 14:27 conf


0 Likes 0 ·

The setup script for SetupHelper and GuiMods are separate so uninstalling SetupHelper only uninstalls the automatic updates system. You can run the GuiMods uninstall by asking SetupHelper to install GuiMods, then select uninstall from THAT script. Confusing I know.


Re your update:

I have fixed this issue. If auto updates are disabled, the SetupHelper service no longer touches -current directories

Thanks for your input. Sorry you found a bug.

0 Likes 0 ·
Kevin, will the solar tile show separate AC sensors, IE currently I have 3 x separate Ac sensors one for each grid Tie Inverters output and I see one figure only,


would be nice to see all 3 Sensors separately ???
0 Likes 0 ·
I haven't done anything with PV Inverters so whatever there is stock. The only PV tile I modifies was PV Charger.
0 Likes 0 ·
kvan avatar image
kvan commented

Using Venus 2.71 on an RPi4 with Touchscreen. Greatly appreciate your RpiDisplaySetup for brightness and timeout! Look forward to setting up temps and tank monitoring going forward. Like your support for two MPPTs. Thank you for the excellent work and support!


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Paul B avatar image
Paul B commented

Hi Kevin Great screen update and very helpfull.

I have a 220v single phase site that has 3 grid tie inverters using 3 x AC current Sensor's installed on one Inverter and these just show as ONE total figure in watts ,

My question is would it be at all possible to also split the one figure into 3 separate readout figures in Watts or watts and amps etc


1626593118372.png

6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I would need a PV Inverter so I could identify the service(s) and extract the power, voltage and current from them. I don't have a PV Inverter so I'd need to guess at the parameters.

If you are up to help with debuting, I'd need dbus-spy dumps of the service, then you would need to help debug my changes.

0 Likes 0 ·

Hi Kevin yes happy to help out with debuging your update, please send me what you would like by email



0 Likes 0 ·
Send me your contact information to kwindrem@icloud.com
0 Likes 0 ·

I posted a version of GuiMods that expands the PV Inverter tile and includes name and power for up to 3 PV Inverters.

This is on a test branch for your evaluation since I don't have any PV inverters to test with. Paul, once you have tested, I'll merge this into main.

https://github.com/kwindrem/GuiMods/tree/PvInverterTest

You must install this version manually. The SetupHelper automatic updates will NOT see this version but the timestamp should prevent auto updates from overwriting it.

0 Likes 0 ·
Will install next time on site and advise
0 Likes 0 ·
I merged the changes into the main branch (untested) by accident. So if your system is connected to the internet and has automatic package updates enabled, you'll get the update automatically.


In any case, let me know how things go and if I need to make any changes.

Anyone else have a PV inverter system that could test these changes also?

0 Likes 0 ·
Kevin Windrem avatar image
Kevin Windrem commented

I just posted an update to GuiMods. All setup configuration items have been moved to run-time Settings accessible in Device List / Settings / Display & language / GuiMods.

It is no longer necessary to rerun the setup script to make changes in what is displayed and what modifications are visible. Besides the addition of the configuration menus, there are no functional changes to the mods themselves except:

It is now possible to show/hide tank and temperature information on the Flow Overview.

it is also now possible to select between 12 and 24-hour time format as shown on the Flow and Mobile overviews.

https://github.com/kwindrem/GuiMods

The motivation for this change was the complexity of making a small change via the setup script. It was necessary to go through all the configuration questions to make that one change. I probably do this more than most users but

As always, please let me know if you experience issues with this update or have suggestions for improvements.

10 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks Kevin. For installations that are connected to the internet - will it update automatically or do I have to rerun installation script?
0 Likes 0 ·
If you have automatic updates enabled, GuiMods WILL update automatically.
0 Likes 0 ·
If you don't have automatic updates turned on in SetupHelper, you can use the manual update (again in SetupHelper).
0 Likes 0 ·

Thanks, turned on automatic updates and got it to work.

0 Likes 0 ·
Kevin, my Venus had the GUImods installed only - and has updated to fw 2.80~11, So I have had to reinstalled helper and gui mods. I also tried uninstall as well and then reinstalled helper and the guimods.

My problem is that when I press i to install it goes straight through and installs as it was orginally, I cant get in to change the setup settings anymore this is both for helper and guimods,

Any idears ???



0 Likes 0 ·

Sorry for the confusion. The GuiMods setup script was getting very complex with lots of items to walk through just to change one item. So I moved all the setup options to the menu system:

Device List / Settings / Display & Language / GuiMods

There's a submenu for the power gauges and another to show package versions.

Note that Access level needs to be Installer or Superuser to change some of the settings (like gauge settings)

I attempt to transfer the settings you set in the setup script to the menu.

From /data/SetupHelper/setup, you'll find the GitHub auto update enable/disable and manual updates in the same menu as install, uninstall, etc.

With GuiMods installed, you can enable/disable automatic package updates from GuiMods menu as well.

So there is no difference between reinstall and install for these packages.

0 Likes 0 ·

Yes found it thats a good spot and easy to adjust as well.

for the PV inverters as per picture below there are small "--" showing even when there is only one pv connected - and there is even one mixed in with the first set of numbers as well.

No big deal as its just cosmetic anyway,

Ill be going to the site thatr has 3 PV inverters on monday so will install the update then on there site and see if all 3 show

1628321679679.png

1628321868648.png


0 Likes 0 ·
1628321679679.png (32.6 KiB)
1628321868648.png (32.7 KiB)

Thanks for the feedback.

I'll look at the display issues. Those dashes should not be appearing and the one PV inverter's name and power should be showing. (The name comes from the name you set in the PV Inverter's Device submenu and would be blank if you didn't set one.)

I also noticed your inverter's gauge is showing close to max power. That can't be correct with only 460 watts coming from the battery. I calculate the power level for the inverter core and I must not be factoring in the PV Inverter power properly.

This is the first time I've seen a system with a PV inverter so we'll need to go through some debugging to get it working.

0 Likes 0 ·

don't worry about the power difference untill 24 hours has passed as there is a 75 watt overstatement at the moment as the new upgrade to 2.80~11 caused the PV to reset thus it has to re calibrate a zero point this will happen tonight. Also there is NO place to change the name as its fixed to show "PV inverter on output" when you use the AC sensor's as far as I can find. as you can see its still showing 74 watt even though it pitch black outside also I thing the word Greed should be Green. also the graph looks ruffly correct to me but you would now better ???

1628351507841.png

1628351860188.png

1628351465726.png

0 Likes 0 ·
1628351465726.png (21.6 KiB)

v2.8 of GuiMods does some more work on the PV Inverter stuff. Please check this out and report.

I fixed the alignment of -- but these should not be appearing. The lines should either be filled in or blank. I can't find anything in the code that explains things but made some changes to maybe help identify the problem area.

Update: I did find a potential error in the parameters I was attempting to use to get power from the PV Inverters. Trying another I found in on-line documentaiton

A screen shot of dbus-spy for one of the PV inverters would help a lot.

I also think I fixed the issue with the power Multi power gauge. In your screen shot, the Multi is producing in the neighborhood of 500 watts so should not be close to the overload power. That gauge calculates inverter power which isn't provided by the system Calculations were not subtracting the contribution from PV inverters on the Multi/Quatro output.

0 Likes 0 ·
abucas01 avatar image
abucas01 commented

Hi Kevin,
I was wondering if it would be possible for you to display temperatures with more precision.
The raw sensor value appears to be stored to 4 decimal places (I can see this in my Grafana data), and for my Grafana graphs I am displaying the temps to 2 decimal places using the following formula (Raw Sensor value *100) - 273.15 see picture (note my fridge is not on)
1628415538319.png
It would be nice to have the temps on the GX display with a 1 decimal place precision, rather than the whole integer that Victron are offering.
Would probably need to add the offset (if any ) as well so (Raw Sensor value * 100) - 273.15 + Offset

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Just made the changes. Thanks for the idea

0 Likes 0 ·
Fantastic, thanks for that
0 Likes 0 ·
Paul B avatar image
Paul B commented

Kevin the read me file is not displaying when you go to https://github.com/kwindrem/GuiMods


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sorry. Fixed now.

No update to version number.

0 Likes 0 ·
Paul B avatar image
Paul B commented

Hi Kevin, Updated the site to 2.80~11 THEN by installing your the new software to the CCGX then I wanted to install tobi17 chargery software but this software bricks the CCGX on 2.80~11 so I reinstalled the CCGX software back to factory then upgraded it again to 2.80~11 then reinstalled your software and all worked well. however the customer then wanted tobi's software as it was a choice one or the other (I thought) anyway I then downgraded the CCGX back to FW 2.72 thinking that your software would stop working, HOWEVER its still working fine on 2.72 and tobi's software also installed. (his is not working fully but thats a different issue)

I was just suprised that your new software still worked on 2.72 FW

On another issue and you have access to that site via VRM and the 3 AC sensors do not work we still get only one value showing. of interest today I am seeing two values on the solar but both are the same figure, this is because the GUImods updated to 2.8


1628742680403.png

1628742446696.png

5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Also when the battery is charging there is a red indicator that moves out from the right of the battery - maybe change the graph to look like the sample screen shown. just a thought thats all left from center is discharge and right from center is charge maybe the + and - could also be C or D (more like a Amp meter display)

1628743227680.png

1628742924822.png

0 Likes 0 ·
1628742924822.png (27.7 KiB)
1628743227680.png (27.7 KiB)

Looks like I've made some progress.

The stock PV Inverter tile shows power of all PV inverters summed together. Below that, I've added the name and power of three individual PV Inverters. With only one, those two values will be the same and redundant. A second PV inverters will activate another pair of lines in the tile. Then the individual power values should sum to the total at the top of the tile.

The name comes from the name you enter in the Device submenu for the inverter. It doesn't look like you added one so it's displayed as a dash.

Cruiser Island (if that's this system) is only showing one PV Inverter in the devices list. If it's not there and in the Devices List on the CCGX then my menu mods won't see it either.

I have some cosmetic tweaks: a little more space below the gauge and the double WW.

On the battery gauge, charging current is shown to the right and discharging to the left. It uses the maximum charging current entered in the DVCC menu. My guess is yours is not defined or set to 0. If you don't use DVCC, turn it on, set the current to whatever your battery bank can accept, then turn it back off. With a zero charging max current, the zero point on the gauge will be on the right side of the battery tile. The red line is the actual charging current and it's red because the max charging current is zero.

I don't see gauges on the inverter or the AC Loads tile. This is probably because you haven't set the three current thresholds for the inverter: peak, a max continuous at best conditions and a max continuous at worst conditions. There's also a max AC output current you need to set. The readme has a little better explanation.

PS: I try to keep my packages compatible with previous versions of Venus OS. Glad it worked for you.

0 Likes 0 ·

yes the PV name is blank because there are 3 ac sensors connected I think, and there is no way to change there names as far as I can see. Victron dont seem to show each one they just show one total in the devices menu, even on the ccgx and under that device there is no way to change the name

1628747455688.png

1628747346938.png1628747664592.png


0 Likes 0 ·
1628747346938.png (20.0 KiB)
1628747664592.png (19.9 KiB)
1628747455688.png (13.8 KiB)
Kevin Note that we are using the AC current sensors to pickup the output from each of the PV inverters. As the AC current sensors are being used we then only see ONE pv inverter in the device list. I think this is the way it works.
0 Likes 0 ·
Sorry this didn't work out for you. I'll clean things up and add an option to show/hide the expanded information so it doesn't get in the way.


I'm not sure if there are other options for sensing PV Inverter power that might provide separate information for each unit. The energy meters come to mind but that might get costly and might not even work. I don't recall seeing a way to configure one as a PV inverter monitor. If you find something, let me know.

0 Likes 0 ·
llubi avatar image
llubi commented

Hi Kevin!

I had it workin in V2.70 but I updated to 2.72 and now I get “tar:invalid magic” according to google it’s something related to checksum of the file, but no one else seems to have the problem, first time was super easy, and I double and triple checked all the spelling. Tried with GuiMods and SetupHelper, same problem for both.
Working on root@Cerbo GX by SSH

Any help, please?


thanks!


albert

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Albert,


I had exactly the same last weekend when i was upgrading from 2.66 to 2.80~14 and tried to apply Kevin his mods. I found out that this error comes in when the file is not downloaded at all. Especially when installing the "RPIGpioSetup" there is a misspelling in the wget command. It might be an other problem as well of course but i hope this gives you a bit of direction to the solution. BTW i did not have a problem installing Guimods and the other mods just the RPIGpioSetup.



0 Likes 0 ·
Thanks! I’m in roaming so it might be a connection problem, will check it!
0 Likes 0 ·
Rob Duthie avatar image
Rob Duthie commented

Re the raspi canbus to USB interface. I have had i working OK on prior to Ver 2.66.

After that had issues, I am using the canble. SLcan rules file i have used below.

Do you think this file still applies.?

When i do the a ifconfig the can0 link comes up but i only see the rx packets of data no tx data packets

# CANtact/CANable USB module

ACTION=="add", ENV{ID_BUS}=="usb", ENV{ID_VENDOR_ID}=="ad50", ENV{ID_MODEL_ID}=="60c4", SYMLINK+="ttycan0", RUN+="/usr/bin/logger [udev] CANtact detected - running canusb_add.sh!", RUN+="/usr/local/bin/canusb_add.sh $kernel", ENV{VE_SERVICE}="ignore"

ACTION=="remove", ENV{ID_BUS}=="usb", ENV{ID_VENDOR_ID}=="ad50", ENV{ID_MODEL_ID}=="60c4", RUN+="/usr/bin/logger [udev] CANtact removed - running slcan_remove.sh!", RUN+="/usr/local/bin/slcan_remove.sh"

Tyring to get the Stetson HAT back on track, but after these latest version i have lost some functions and partly running runs.

Regards

Rob D

NZ

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jwfrary avatar image
jwfrary commented

Hi @Kevin Windrem quick question about the generator connector mod, when you say digital input exactly what are you meaning?

thanks for your work on this, we are about to deploy a new system and I’ll be playing with this!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image
Kevin Windrem commented

Cerbo as well as some other "GX devices" have on/off (aka "digital") inputs. One of the selections for these is to tell the GX device whether the generator is running or stopped. In the stock code, all this does is generate a notification that the generator is in the "wrong" state (stopped when it should be running).

GeneratorConnector displays the generator running state on the Generator Overview page and connects that digital input to the manual start/stop logic. So if you start the generator from it's control panel, the GX device's manual generator state will switch to running. Same for stopping the generator from it's local panel.

There's also a warning in the STATUS tile if the GX device expects the generator to be running because of the "conditions" logic and it is reported as stopped by the digital input.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks, that makes sense.


Having a CCGX i lack those digital inputs. I feel a cerbo upgrade coming at some point.

At the moment in use a DIgital Muliti control panel to switch the current limit in the system for the generator but it would be neater if it could be kept within the GX device!


0 Likes 0 ·
stepir avatar image
stepir commented

hi @Kevin Windrem


I finally implemented your script on my CCGX running 2.73!

Can I just ask you what the horizontal coloured bars represents?


screenshot-2021-09-24-at-171910.png

/EDIT: never mind I got - the power gauge!!!!

THANKS!!

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The gauges show you power relative to maximums for your system. To be useful, you need to set the gauge limits. Refer to the ReadMe for details.

0 Likes 0 ·
Yes sorry I read it but did not immediately understood those were the gauges!! Thanks it looks amazing!!


Question: would you consider implementing 'remaining capacity' (similar the one you have for the battery) for the thanks as well? based perhaps on the last 24hrs consumption? or the average of the last week?


Thanks again

0 Likes 0 ·
Sorry, I don't have the ability to add tank history collection.


The remaining time for the battery is calculated in the battery monitor. I just display it.
0 Likes 0 ·
understood ! Thanks Kevin
0 Likes 0 ·
Rob Duthie avatar image
Rob Duthie commented

Hi Kevin

Just being doing more testing using the Ver 2.08.19 with your latest Gui mods with a raspi 3b+ done 2 complete test install to confirm operations.

When using a Multiplus2 with a VE bus Mk3 inteface, it disables the power bars and status on the overview screen unplug the Mk3 and it comes back OK, With VE direct connected inverters all OK.?

Any ideas to test and check for.

Relay pages and Canbus all going perfectly on testing with USB and Pican etc.

Regards

Rob D

NZ

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bigbadbob76 avatar image
bigbadbob76 commented

Hi Kevin.

I have installed your GeneratorConnector script on my Rpi2 running venus 2.66 and configured my generator "running" input to be gpio2 and start relay output to be gpio3, (made appropriate changes to gpio_list and venus io setup)

Generator shows as connected and running in venus device list when I take gpio2 low but this is not reflected in the generator overlay.

Overlay says generator not connected and manual start button does not allow a start attempt.

Looking at the source code for GeneratorConnector this suggests "state" is not valid.

without GC installed- settings>Generator Start/Stop>State shows correctly

but with GC installed it shows ---

System comprises a multiplus with manual grid/gen input transfer switching.

could you please advise if I've missed something.

Cheers.

Bob.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bigbadbob76 avatar image
bigbadbob76 commented

ok so further..."Looking at the source code for GeneratorConnector this suggests "state" is not valid."

it looks like "State" comes from the VEbus so of course my multi is not a quatro so won't generate this state. I'll open a separate topic for this.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks for update to v2.60 startstop.py Kevin. works great now. I thought it was me. it usually is. :-)
0 Likes 0 ·
Thanks for update to ShutdownMonitor too.

The annoying warning about no dbus service has gone. :-)


0 Likes 0 ·
Al avatar image
Al commented

Hi @Kevin Windrem I wanted to try out the GUI Mod and SetupHelper, as they look great and handy, thanks for your work! but I'm having some issues trying to install.. Ok I'm no programmer, but have been using WinSCP on my Win10 Laptop to modify the QML files after reading this or one of your other threads before.

I'm able to run the command for SetupHelper and move directory and run Setup in WinSCP's command window.. but it doesn't allow user input to select (i) install, and just hangs for ages.

Is there another way to select install?

This is on a CCGX, although I also have an old 7" Tablet with Kiosk mirroring if that's relevant, have I missed where the 'Venus Command line' input is, and is WinSCP the wrong tool?

Thanks

Al



2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I'm not familiar with WinSCP but what you need is a tool, that allows you to pull the command line from a remote device to your computer. In the unix and Mac world, I use ssh from a terminal window. I think most people on Windows use PuTTY.
0 Likes 0 ·
Hi

Just a note on WinSCP has a built in tool for command line and putty is included as well. Thats all i ever use to SSH into the raspi to upload files and check and reprogram etc. And works very well. Give it a try.

Regards

Rob D

NZ

0 Likes 0 ·
grovesr avatar image
grovesr commented

Hello Kevin,

Thank you for this awesome software. I am running a cerboGX ver 2.73 and I have installed SetupHelper (v2.10) and used that to install GuiMods (v3.16). The installation seemed to run fine, but I am not seeing the GuiMods option under Settings->Languages&display. I looked at the install log in /var/log/SetupHelper and found the following:


@40000000616d878a0fb5c05c SetupHelper/setup: creating root setup options directory /data/setupOptions
@40000000616d878a1095b07c SetupHelper/setup: creating package options directory to /data/setupOptions/SetupHelper
@40000000616d878a134b4ee4 SetupHelper/setup: creating SetupHelper Settings
@40000000616d87b039c442ec SetupHelper/setup: installing SetupHelper service
@40000000616d87b03b74f08c SetupHelper/setup: adding SetupHelper/setup to reinstallScriptsList
@40000000616d87b10066d244 SetupHelper/setup: creating /data/rcS.local
@40000000616d87b104004cb4 SetupHelper/setup: creating SetupHelper version Setting
@40000000616d87b214e914ac SetupHelper/setup: completed
@40000000616d87b31165ba4c SetupHelper/packageAutoUpdater: starting up
@40000000616d8a5a31810304 SetupHelper/packageAutoUpdater: starting up
@40000000616d8a5e2aa5c344 packageAutoUpdaterTraceback (most recent call last):
@40000000616d8a5e2aaad80c packageAutoUpdater  File "/usr/bin/dbus", line 379, in <module>
@40000000616d8a5e2ab4fdb4 packageAutoUpdater    ret = obj.object.get_dbus_method(method.name, iface.name)(*args)
@40000000616d8a5e2ab933d4 packageAutoUpdater  File "/usr/bin/dbus", line 175, in object
@40000000616d8a5e2ac1de94 packageAutoUpdater    self._object = self.bus.get_object(self.service, self.path)
@40000000616d8a5e2ac5eda4 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 243, in get_object
@40000000616d8a5e2ae88134 packageAutoUpdater    follow_name_owner_changes=follow_name_owner_changes)
@40000000616d8a5e2ae894bc packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 250, in __init__
@40000000616d8a5e2b17e604 packageAutoUpdater    self._named_service = conn.activate_name_owner(bus_name)
@40000000616d8a5e2b180544 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 182, in activate_name_owner
@40000000616d8a5e2b181cb4 packageAutoUpdater    self.start_service_by_name(bus_name)
@40000000616d8a5e2b18286c packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 280, in start_service_by_name
@40000000616d8a5e2b183fdc packageAutoUpdater    'su', (bus_name, flags)))
@40000000616d8a5e2b184b94 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 653, in call_blocking
@40000000616d8a5e2d870d5c packageAutoUpdater    message, timeout)
@40000000616d8a5e2d91d714 packageAutoUpdaterdbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.victronenergy.settings was not provided by any .service files
@40000000616d8bee369cc044 SetupHelper/packageInstaller: running GuiMods setup script - choose install to complete installation
@40000000616d8bef05cdf834 GuiMods/setup: creating package options directory to /data/setupOptions/GuiMods
@40000000616d8bef06b90be4 GuiMods/setup: creating file set for v2.72
@40000000616d8bef2317fc64 GuiMods/setup: ERROR v2.72 main.qml no replacement file
@40000000616d8bf104d501d4 GuiMods/setup: ERROR v2.72 OverviewMobileEnhanced.qml no replacement file
@40000000616d8bf115e727a4 GuiMods/setup: ERROR v2.72 TileTankEnhanced.qml no replacement file
@40000000616d8bf134c2282c GuiMods/setup: ERROR v2.72 MarqueeEnhanced.qml no replacement file
@40000000616d8bf21b5d8bec GuiMods/setup: ERROR v2.72 PageSettingsDisplay.qml no replacement file
@40000000616d8bf22a98982c GuiMods/setup: ERROR v2.72 Tile.qml no replacement file
@40000000616d8bf3020a6c3c GuiMods/setup: ERROR: incomplete file set for v2.72 - can't continue
@40000000616d8d50371cc1cc SetupHelper/packageAutoUpdater: starting up
@40000000616d8d54244ff3ac packageAutoUpdaterTraceback (most recent call last):
@40000000616d8d5424649104 packageAutoUpdater  File "/usr/bin/dbus", line 379, in <module>
@40000000616d8d54246f993c packageAutoUpdater    ret = obj.object.get_dbus_method(method.name, iface.name)(*args)
@40000000616d8d542471a4ac packageAutoUpdater  File "/usr/bin/dbus", line 175, in object
@40000000616d8d542476e854 packageAutoUpdater    self._object = self.bus.get_object(self.service, self.path)
@40000000616d8d542478827c packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 243, in get_object
@40000000616d8d5424931b14 packageAutoUpdater    follow_name_owner_changes=follow_name_owner_changes)
@40000000616d8d5424a48804 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 250, in __init__
@40000000616d8d5424bfefa4 packageAutoUpdater    self._named_service = conn.activate_name_owner(bus_name)
@40000000616d8d5424c4dd5c packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 182, in activate_name_owner
@40000000616d8d5424cc1504 packageAutoUpdater    self.start_service_by_name(bus_name)
@40000000616d8d5424ccff64 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 280, in start_service_by_name
@40000000616d8d54250f01d4 packageAutoUpdater    'su', (bus_name, flags)))
@40000000616d8d54250f1174 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 653, in call_blocking
@40000000616d8d54265ad324 packageAutoUpdater    message, timeout)
@40000000616d8d54267c2a4c packageAutoUpdaterdbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.victronenergy.settings was not provided by any .service files
@40000000616d952002799d14 SetupHelper/setup: installing SetupHelper service
@40000000616d952004f883ac SetupHelper/setup: completed
@40000000616d95332d3bfa9c SetupHelper/packageAutoUpdater: starting up
@40000000616d95372f7e8be4 packageAutoUpdaterTraceback (most recent call last):
@40000000616d95372f82dd5c packageAutoUpdater  File "/usr/bin/dbus", line 379, in <module>
@40000000616d95372f92f674 packageAutoUpdater    ret = obj.object.get_dbus_method(method.name, iface.name)(*args)
@40000000616d95372f9534ac packageAutoUpdater  File "/usr/bin/dbus", line 175, in object
@40000000616d95372f9fb044 packageAutoUpdater    self._object = self.bus.get_object(self.service, self.path)
@40000000616d95372fa161dc packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 243, in get_object
@40000000616d953731d52614 packageAutoUpdater    follow_name_owner_changes=follow_name_owner_changes)
@40000000616d953731d6eb34 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 250, in __init__
@40000000616d95373210f694 packageAutoUpdater    self._named_service = conn.activate_name_owner(bus_name)
@40000000616d95373213b5b4 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 182, in activate_name_owner
@40000000616d95373231bd34 packageAutoUpdater    self.start_service_by_name(bus_name)
@40000000616d95373236ca2c packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 280, in start_service_by_name
@40000000616d953732410744 packageAutoUpdater    'su', (bus_name, flags)))
@40000000616d95373244d004 packageAutoUpdater  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 653, in call_blocking
@40000000616d953732e20dec packageAutoUpdater    message, timeout)
@40000000616d9537332cf99c packageAutoUpdaterdbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.victronenergy.settings was not provided by any .service files

I'm not sure where to go from here... Do you have any suggestions?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

pyemarine avatar image
pyemarine commented

Kevin

I have 4 tanks with tank-edge MODA sensors and when trying to get these to work with a yacht devices nmea2000 tank interface that supports voltage based input, i am also running into issues witht he read out. I am using an iseries panel, which they said has voltage regulated power sends, also got the diode harness to prevent feedback, it still won't work accurately or reliably. Did you abandon this attempt ? From your earlier findings it looked pretty hard and frustrating to get reliable readings, especially when paralleling the send return to a TE display as well as a Cerbo

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The MODA sensors have extremely high output impedance and can't be connected to anything except the iseries panel. I haven't taken this any further but do know what would be needed:

A very high impedance op-amp buffer on the MODA sensor output. A positive and negative supply would be needed for the op-amps since the sensor output reaches 0 volts. There are modules that would create the positive and negative supply voltages from a battery, so it's possible to make this happen.

I don't think that even with the buffers, you could connect directly to the Cerbo tank inputs since these expect a resistive sensor of fairly low resistance. Even if it worked, the inputs are calibrated for resistance, not voltage so there would be an error of about 10% in the middle of the range.

0 Likes 0 ·
bigbadbob76 avatar image
bigbadbob76 commented

Hi Kevin.

Just so you're aware.

When trying to install on venus v2.66 i get this -

root@raspberrypi2: /data/GuiMods/setup
ERROR: incomplete file set for v2.66 - can't continue


5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I just tried a blind install on a CCGX running v2.66 and everything installed properly. No errors.


The blind install is the best way to clean things up that aren't working as expectedly as it replaces everything without running any scripts.

0 Likes 0 ·

Hi Kevin, what do you mean with "blind install"? I've updated my 2.72 to 2.80~21 large and everything worked. I've tried to update 4 days ago the GuiMods version with the SetupHelper to the latest version. After update I could see the options in the display-section, but I also got the error with the incomplete file set. At the next boot my Raspberry 3+ now stops at boot-screen. No access. I see the victron logo and a cursor blinking.

0 Likes 0 ·

The incomplete file set problem is a problem on my end. I checked the v2.80~21-large-23 (the latest available) and SetupHelper did NOT install. I'll need to build a file set for that version and future large versions. However, GuiMods should be functional. Just no auto updates for now.

I'll report back when a new version of SetupHelper is available.

It is unlikely that any of my scripts or modifications could lead to a boot failure. The most likely problem is a file system corruption indicating you need to flash a new system SD card. I realize this is a drastic step as it wipes out all setups, so you might want to investigate further:

You may be able to get a clue about what is going on by connecting a serial terminal to the PI's serial port pins using something like the AdaFruit serial cable. You may need to change the cmdline.txt in the boot partition on the system SD card to:

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty0 logo.nologo


This will also allow the display to show the boot process.

If you have access to another unix-based system, you can use gparted to examine the SD card and look for file system corruption. This also gives you the possibility of retaining settings by moving the data partition (last one on the SD card) to a new SD card flashed with Venus OS.


FYI:

"blind install" is done using a USB stick without any user interaction at the command line or the GUI. You copy a file to the stick, put it in the GX device and reboot twice.

More info in the SetupHelper and GuiMods ReadMe:

https://github.com/kwindrem/GuiMods

https://github.com/kwindrem/SetupHelper

0 Likes 0 ·

There's a new version of SetupHelper that supports v2.80~21-large-23 on GitHub

https://github.com/kwindrem/SetupHelper


The blind install file is included in the repo, but here's the link:

https://github.com/kwindrem/SetupHelper/blob/main/venus-data.tgz

The Read Me file in the repo contains detailed blind install instructions but here is a brief set

  1. Copy the downloaded file as is (do not unpack!!!) to a USB stick or SD card.
  2. Place the media in the GX device (but not as the system card)
  3. Reboot twice from the Venus GUI
  4. Remove the media so it doesn't start the process over again.


0 Likes 0 ·
Thank you Kevin for that detailed answer! I'll check it and give feedback here...
0 Likes 0 ·
dsfas9 avatar image
dsfas9 commented

Hi Kevin,


Is it something with me or did version for GuiMods is removed? Still see Setup Helper version.

f0e0844c-cfed-4782-b5cc-91e405fa099e.png

18 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes, I noticed the "current" tag was missing. It's back now.
0 Likes 0 ·
@Kevin Windrem I still only see version number for SetupHelper (v3.12), GuiMods are missing from the list.
0 Likes 0 ·
How are you installing the packages? A blind install is not possible and probably the easiest.
0 Likes 0 ·

They were auto updating up to v4.11 of GuiMods2, then auto update stopped and I reinstalled both through Putty.

0 Likes 0 ·

Hello, my cerbo looks exactly like in your picture. How did you fix the problem? I have already reinstalled SetupHelper several times via USB, as Kevin wrote in the article from November 22nd, 2022, unfortunately no change.

0 Likes 0 ·

The blind install process is great, but if there are errors you don't see them. Make sure you are using from a freshly downloaded copy of venus-data.tgz from here:

https://github.com/kwindrem/SetupHelper/blob/main/venus-data.tgz

Further troubleshooting will require command line access.

Packages are stored in /data/<packageName> and contain a version file. Check to see if the package is actually getting updated from GitHub or by the blind install.

SetupHelper is at v3.13, GuiMods is at v5.2

You could run the setup scripts from the command line like the old days:

/data/SetupHelper/setup
/data/GuiMods/setup

Errors are logged in: /data/log/SetupHelper and may provide a clue

tail -50 /data/log/SetupHelper | tai64nlocal

"known" packages are stored in a file: /data/packageList. Just a thought, but maybe this got corrupted somehow. Try deleting the file, a fresh copy will be created with all of my packages in it.

rm -f /data/packageList

Then run setup scripts from the command line

And please report back if you get this working and what you did so I can work to make things more robust.

0 Likes 0 ·

Hello Kevin, that was exactly what I feared, unfortunately I have no idea about command line access and the like, I can read in, but it gets very difficult, especially since English is also not my language :-) That was also the reason why I postponed the installation so far until you offered a blind install process. Is there a way to reset the Cerbo to factory settings?

0 Likes 0 ·

Yes, there is a "blind" reset to factory defaults which wipes everything in the persistent storage, including where my packages are stored. It uses the same mechanism I use with a Victron-supplied venus-data.tgz

https://www.victronenergy.com/media/pg/CCGX/en/factory-reset.html

This is a drastic measure since all your GX device configuration is reset as well.

You should also reinstall the Venus OS firmware also. You can do this from the Firmware menu by switching the Update feed, update, switching the feed back to its previous value and updating again.

Or you can update from SD/USB with files from here:

http://updates.victronenergy.com/feeds/venus/

"candidate" for release candidate (ignore develop and testing!!!)

Then select images, then your platform (einstein) for Cerbo

the .swu file should be copies to SD/USB media and inserted into Cerbo. Then go to Firmware / Install firmware from SD/USB.

But this is much more complicated than using online updates and probably makes sense only if Cerbo isn't connected to the internet.


0 Likes 0 ·

ok to delete some 'old' folders?


1637691986466.png


0 Likes 0 ·
1637691986466.png (61.7 KiB)

looks there are some issues when installing

1637692030889.png


0 Likes 0 ·
1637692030889.png (22.4 KiB)
Show more comments

The error from the log indicates there is a problem accessing GitHub. The autoUpdater uses the following command to get SetupHelper's version from the current tag:

wget -qO - https://raw.githubusercontent.com/kwindrem/SetupHelper/current/version

it should return v3.13 but is apparently not returning anything

You can get the same information by pasting this command into a web browser

https://raw.githubusercontent.com/kwindrem/SetupHelper/current/version

If the web page link doesn't work there might be a network issue preventing access.

You can delete the -backup1 and -backup1 directories. They were never used and are no longer created. Not sure why FlowOverview is in /data. It can be deleted too.

I don't see /data/packageList which is automatically created when setup scripts run. But this requires the latest SetupHelper.

GuiMods2 is obsolete and should be removed, but should be uninstalled first. (The new GuiMods will uninstall GuiMods2 automatically.)

You appear to not have the latest GuiMods (probably v3.16 from the date) so it's wget may also be failing, just not shown in the log excerpt you sent.

Try the web links for SetupHelper and GuiMods and let me know if you get a version number or an error message.

BTW, venus-data.tgz on the SetupHelper repo had v3.12 not v3.13. This might help. I don't recall what was in v3.12 (I apparently deleted the tag.) So you might just try a new blind install.


I'm truly sorry for all the problems. This was supposed to be easy.

0 Likes 0 ·

@Kevin Windrem


got it to work!!, ran this

  
                            
  1. rm -f /data/packageList  and reinstalled both GuiMods and SetupHelper

1637692240217.png

0 Likes 0 ·
1637692240217.png (26.9 KiB)

@klaus60

@dsfas9 got his system working by removing /data/packageList

Here's a link to a SPECIAL venus-data.tgz that does that while installing SetupHelper and GuiMods.

I won't make this standard at this point, at least not yet

The idea behind the packageList file is other packages can add themselves to that list or you can change the GitHub branch that gets downloaded. This special blind install would wipe that out and require reinstalling their package.

https://www.dropbox.com/sh/qr0w9uakb7av84k/AAC6DFeEhoLCpG1z1YJsufNLa?dl=0

0 Likes 0 ·

Hello Kevin, unfortunately I can't get it to work. The file from the Dropbox tried several times via a USB-stick, but nothing changes, all that remains is probably a reset.

0 Likes 0 ·
Unfortunately, without a way to look at logs, etc I would agree you probably need to reset to factory defaults and reinstall Venus OS.


When I needed to do this a while back, I went through all the setups menus and wrote down everything so I could manually get back to the previous condition.

0 Likes 0 ·
dsfas9 avatar image
dsfas9 commented

@Kevin Windrem I believe '2' should be removed from installation instructions


1637692693919.png

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You are correct. The Read Me will be updated with the next change.
0 Likes 0 ·
Hi Kevin, you've changed the file, Does it make sense to try again with the new file?
0 Likes 0 ·

Yes. I'd try this one that resets packageList to defaults:

https://www.dropbox.com/sh/qr0w9uakb7av84k/AAC6DFeEhoLCpG1z1YJsufNLa?dl=0

0 Likes 0 ·
andyc avatar image
andyc commented

Hi you've done some great work on this.


is there any way to display "todays yield" on this?

looked at victron protocol and it has label h20? thats ve direct

many thanks andy


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Al avatar image
Al commented

Hi @Kevin Windrem I really like GuiMods! Thanks, but I realised my install has not been updating:

screenshot-20220107-001157.png

Earlier in this thread you and @Rob Duthie made me realise I needed to install the PuTTY addon for WinSCP, and that worked for the original installation, thanks guys.

I never managed to get a 'blind install' from sd card to work on the CCGX for some reason?

This time again when trying to update, I can see the updated directories for SetupHelper and GuiMods in the /Data/ folder after renaming and deleting the old, but setup stalls and I still only see the older package versions as above:

failed-install.jpg

I'm not sure what this means or why it is stopping the install, I've tried re-naming the NO_REPLACEMENT as just a qml, and deleting it and also leaving it and deleting the .orig etc but setup still doesn't like it, any thoughts?

incomplete.jpg

I want to update as my two ve.can and one ve.direct MPPT's are jumbled up together, which I think they should view correctly now with the later versions.

screenshot-20220107-124953.png

screenshot-20220107-125015.png

TIA

Al

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image
Kevin Windrem commented

The INCOMPLETE file set and the NO_REPLACEMENT indicate that the setup script could not match the original version of a file with the ones in the package file sets. So it can't choose the appropriate replacement file.

What the error indicates is that the setup script can not match the original version of that file with any in my file sets so it can not choose the appropriate replacement. Most likely, this means the original file has been modified somehow. It also could mean that the file in GuiMods FileSets was modified. Point being, they differ in some way.

The easiest way to recover from this situation would be to update the Venus firmware to the same version. You can do this with a flash drive containing the .swu file for your platform and v2.73.


5 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ok thanks, I guess it's likely I messed or miss placed a file when editing the qml.. Oops if so.


I assume I can also just boot back to v2.72 and then update again to v2.73 . .. and then reinstall GuiMods etc? that's what I'm doing now anyway #fingerscrossed

0 Likes 0 ·
Yes, that will work.

This issue has come up a couple of times so I probably need to find a way around it. If you still have v2.72 stored on your GX device, then boot to that the use the on-line update to grab a fresh copy of v2.73. (You can't just boot back to the v7.32 stored on the system.)

The mechanism I am using accommodates new venus versions without having to update the package if there are no new original file changes from a previous version. But it relies on the original file not being modified. Not really a great solution.

0 Likes 0 ·
Al avatar image Al Kevin Windrem ·

Installed! Brilliant :)

I see the solar chargers are now displayed separately, but only the Ve.direct MPPT's name is fetched, the two Ve.can MPPT's are just '--' Is this normal? They're named on VRM etc

screenshot-20220107-175740.png

Also where do I check what version is running I can't find it anywhere anymore?

0 Likes 0 ·
I pull /CustomName from dbus. Victron insists that for external devices, the device is responsible for providing the custom name and doesn't create a local one. You may be stuck with that.
0 Likes 0 ·
Al avatar image Al Kevin Windrem ·

Thanks Kevin for the PV tile update, it really helps to see more clearly the power generated on each array.

@mvader (Victron Energy) is it possible for the dbus CustomName for Ve.Can Mppt's to display with GuiMods in future? - I realise it's not officially supported, but just wondering?

At the moment we get dashes ( -- ) where the name should be, but the Ve,Direct Mppt's display their name (900 Wp) ?

screenshot-20220204-121140.png


0 Likes 0 ·
mianfrar avatar image
mianfrar commented


Hello I have a cerbo cx with venus 2.72 Large and bms driver https://github.com/Louisvdw/dbus-serialbattery (doesn't work above this version at the moment) and when I reboot to install the setuphelper nothing happens, so I I did it on the command line and I get the following:


> root@einstein:/data#

> root@einstein:/data# /data/SetupHelper/setup

> creating file set for v2.72-large-19

> ERROR v2.72-large-19 PageSettings.qml no replacement file

> ERROR: incomplete file set for v2.72-large-19 - can't continue



i have done the same for guimods and if they were installed. If you have a solution for this I would appreciate it.


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I had the same problem but on v2.85. Solution was to copy/rm the following files:

root@raspberrypi2:/data/SetupHelper/FileSets/v2.85# cp /opt/victronenergy/gui/qml/PageSettings.qml .

root@raspberrypi2:/data/SetupHelper/FileSets/v2.85# rm INCOMPLETE PageSettings.qml.NO_REPLACEMENT


To get RpiDisplaySetup to run I did the following:

root@raspberrypi2:/data/RpiDisplaySetup/FileSets/v2.85# cp /opt/victronenergy/gui/start-gui.sh .
root@raspberrypi2:/data/RpiDisplaySetup/FileSets/v2.85# rm INCOMPLETE start-gui.sh.NO_REPLACEMENT

Hope this helps anyone who comes across this.


0 Likes 0 ·
andyalford avatar image
andyalford commented

I have been in touch with Kevin on Github about a problem I am having with VEcanSetup, and wondered if anyone else is getting the same thing. Or not?

With CANable Pro attached as can0, it works upon setup, but disappears on reboot. I need to disconnect and reconnect the USB plug and then it appears properly. So it seems some kind of sensing problem at system reboot.

If no-one else can give me a pointer, I will go through the scripts and report any problems I find as a reply to this comment.

P.S. hooray to Kevin for an excellent Mod !!

P.P.S. I have a REC-BMS attached to the CANable Pro, if that is important information.

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I solved the problem, so sharing that for anyone else with same experience.

I was having problems with VeCanSetup not initialising my CANbus REC-BMS.

When I dug around in the files, I found that if /etc/venus/canbus_ports was a little sensitive to content. In my case, I needed to have just "can0" and a Carriage Return, and then it initialised on boot. After multiple attempts at running /data/VeCanSetup/setup the file had a lot of duplicate entries "can0 can0 can1 <CR> can0" etc...

I will be trying a dual CAN installation in a few weeks, so I will be able to test this further soon!! But for now I have CANable working with VeCanSetup and Pi 3B+ as expected. :-)

0 Likes 0 ·
Thanks for reporting. canbus_ports file corruption has been fixed in v2.13
0 Likes 0 ·
johanndo avatar image
johanndo commented

Hi Kevin, do you have by chance an idea how to change the kbd language on the venus OS, I did it 3 years ago, but forgot how I patched it. On the new version it drives me crazy.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Your Opinion Counts

Share your great idea, or help out by voting for other people's ideas.