question

mvader (Victron Energy) avatar image

Venus OS v2.80~24 available for testing

Hello all,

A new version available for field testing, v2.80~24.

First of all, thank you for all the feedback in the previous thread; much appreciated, even if I haven't gotten round to answering each individual one.

Several issues are fixed in this release, some won't be.

In case you don't know what this message is about, please start with reading this link, which explains the Venus OS beta program.

The version we're working on, v2.80, has a few highlights: the new AC Load monitoring, the new DC metering function, and also various improvements to the HTML5 MFD App, including the addition of translations as well as the added support for the Ruuvi Tag wireless temperature sensors.


What to test?

Same as before: the new features I mentioned just now. As well as, just like announced previously, basically everything: there are several major changes in v2.80, which can each make things break in unexpected places. For those interested in the details, the changes I'm referring to here are (a) that the used Python version has been updated from 2.7 to 3, (b) the Open Embedded release was upgraded from Zeus to Dunfell, and lastly (c) we changed to a read-only rootfs. All combined this means that lots of tools and packages used will have changed to a newer version, and lots of Victron code has been changed to be compatible with Python 3.


How to post an issue?

Preferably all issues are organised as answers to this question. One answer per issue. So first check the existing threads. If you have the same as someone else already reported, welcome to add a comment saying "me too". And preferably some more details. And in case its not listed yet, add a new Answer. Note that Answers and Comments are two different things here on community.

Lastly, if possible please revert to v2.73, to double check if the issue you're seeing was present there as well. Regressions require a different treatment than other issues and bugs, and one of the first things that needs doing in triaging a report is distinguishing between the two.


The plan for v2.80

Development and testing will continue for quite a while; we won't make September anymore :), and not even October. So rather then promising a new months lets stick to the more generic "end of this year".


Change log below.


All the best and have a good weekend,


Matthijs Vader


Changes since previous test version, which was v2.80~21:

Generic:

  • Keep the new wireless sensor support (bluetooth) disabled by default, since in some cases it reduces the WiFi throughput. This reduced WiFi throughput will remain a problem, and the solution to use WiFi and the Ruuvi wireless sensors at the same time is to insert an external USB WiFi dongle, as explained in the manual.
  • Remove the previously added Backup & restore settings feature. There are some things in there that don't work yet, and this feature is (unfortunately) postponed till later.
  • Increase the maximum possible power value for starting a generator, was 100kW now 1MW. Thank you Jens-Uwe P for reporting.
  • Reduce CPU load induced by MQTT, which mostly happens when looking at the VRM Portal Dashboard, real-time type. The (extra) CPU load that is happening then is still slightly above how it was on v2.73, but reduced compared to previous v2.80 versions.
  • Tank inputs on Cerbo GX and Venus GX: increase max tank resistance to 300Ohms, thank you Alex Muir for asking.


HTML5 MFD App:

  • Show the inverter/charger widget even when the AC Inputs are configured to Generator or Not available.
  • Fix fault description for non-VE.Bus chargers
  • Fix on/off state buttons for non-VE.Bus chargers


Known issues

  • When configured as a DC Monitor (alternator, and so forth), the information from a BMV-712 or SmartShunt is not transmitted onto NMEA2000, ie its not supported by NMEA2000-out. The exception is when configured as Solar charger.


Previous changelogs:


Complete v2.80 change log, compared to v2.73:

(still..) no time for that now, I'll make that later.



Venus OS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

11 Answers
dennis avatar image
dennis answered ·

MQTT high load from 100% CPU to ~50% CPU reduced. Great work!

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Nice! I’ll pass that along to the developer as well.
dsfas9 avatar image
dsfas9 answered ·

374d3163-2d8b-4f1e-a884-40323109d350.pngGetting blank page running ~24 with Gui Mods. Reverted to ~17 to fix the issue.


2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem mvader (Victron Energy) ♦♦ ·
Fixed now in v3.16 of GuiMods
Paul B avatar image
Paul B answered ·

This site has 2 x Multiplus 5000 units on FW 487 configured in Parallel

I have set the grid set point two -1000

yet its exporting -1493 and was exporting -2400 a while ago Tried dvcc on and off

Tried rolling back to 2.8~21 still the same

Site is on our VRM

1634526226676.png

1634526119034.png1634526571828.png


1634526119034.png (39.1 KiB)
1634526226676.png (42.2 KiB)
1634526571828.png (18.0 KiB)
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

If it is fluctuating approx 400w around your setting (-1400w to -600w) then thats unfurtunately pretty normal.
At least that's what I'm seeing @ firmware 2.73. (Setting -20 and fluctuating -450 to +450)

I have seen it as high as -3500 watts and for long periods so something is not really correct. I have not seen the issue in 2.73 though,
daniel avatar image
daniel answered ·

I have problem with solar radiation sensor Si-RS485TC. Sensor don't work with any 2.80 version Venus OS on RPi3. The sensor data is not even displayed, but in the version 2.70 sensor working properly. Tomorrow I'll test if the sensor works on CCGX.

Update : Sensor on CCGX work with Venus OS 2.80~24 without problem.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Jaco Reinecke avatar image
Jaco Reinecke answered ·

This has happened twice now, where the system does not pick up the Carlo Gavazzi, on v2.80~24.

After a load-shedding event when power returns, the system does not register the Carlo anymore, and nothing I do can make it register again.


I tried to:
Reboot the Cerbo 3-4 times.
Unplugging the Victron RS485 to USB cable from the Cerbo, with a reboot and without.
Redetect the inverter.
Reset the inverter.

The only option that has worked twice so far was to re-install v2.73, once installed, reboot it again, and then the Carlo is picked up again.

Can then re-install v2.80~24 if one wants, till the next load-shedding event.

During this time it "sounds like" the inverter is in some mode as it works as if it is discharging/charging the batteries, but it is not, as no current is entering or leaving the batteries that I could see.


EDIT: Had another load-shedding just now, on v2.73 all works perfectly.

6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Jaco Reinecke , next time this happens, can you leave it in that state and let me know? Then I'll ask someone to login to see the status; thank you!
Jaco Reinecke avatar image Jaco Reinecke mvader (Victron Energy) ♦♦ ·

@mvader (Victron Energy) the next load-shedding ... still waiting for one.

Jaco Reinecke avatar image Jaco Reinecke mvader (Victron Energy) ♦♦ ·
@mvader (Victron Energy) 2nd load-shedding since last night will be over at 8h30 this morning.


If someone can have a quick look then, I would appreciate, as the system will be "in limbo" till the Carlo is picked up again after 8h30


Hi again, as also discussed elsewhere: this issue is due to the dbus-serialbattery driver you are using. Nothing to do with the standard Venus OS.


The problem is that that driver isn't properly terminating; and as such holding up the process of refinding the Carlo Gavazzi energy meter.


Jaco Reinecke avatar image Jaco Reinecke mvader (Victron Energy) ♦♦ ·

Yes, thank you @mvader (Victron Energy).

I first reported it to the driver supplier before reporting it here. Have also been provided with a workaround, so absolutely no stress nor worries. I've got it from here. Will be testing it momentarily. ;-)
Thank you guys for the awesome support!

nickdb avatar image
nickdb answered ·

@mvader (Victron Energy) Not specific to this version, under the BMS entry -> Device, the GX reports the BMS version detected from the BMS.

Currently this is a 2-digit field, is it possible to increase this to 3 digits so firmware like 1.0x can be displayed?

See below.

Thanks

screenshot-2021-11-08-at-092941.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Paul B avatar image
Paul B answered ·

2 x Multiplus 5000 in Parralle incorrect ac1 \in and ac1 out AMPS reading

We are seeing that the INCOMING amps are displaying incorrectly ie as below shows it as 9.2 when in fact its actually 17 amps.

this affects the AC limit setting as if I set the Shore power limit to 10 amps it really is drawing 20 amps

this is a DUAL 24/5000 multiplus system this issue was seen on fw487 I have just taken it ti 489 and there has been no change


Cerbo on 2.80~24

ESS assistant has been installed

Has anyone got a suggestion as to why this is happening and / a solution ???


even the AC out is reading incorrectly 2145w/228v it really should say 9.41 amps


I am thinking that a very bad power factor maybe causing this, but the readings are so wrong that its very misleading.

If it is power factor then maybe separate PF corrected number should also be shown




1636530451436.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Paul B avatar image
Paul B answered ·

Error: mk2vsc-33 on Multiplus 3000/120 230v 50 amp

This is happening when using the VRM and downloading the multiplus setup

this started to happen on firmware 487, with a VE BMS assistant installed - But the ve-BMS was unplugged and I was trying to do a remote update/upgrade the fw to 489 but this stalled at 20.5%

thinking it was a remote upgrade issue - I have done the below

so now I have manually upgraded the firmware to 489 by going to site. thinking this would fix the issue

we have a cerbo connected on 2.80~24 (also connected to the VRM)

we have one VE-BMS connected

there is NOW no assistant installed as 489 FW does not require it with the new tick box ticked and the ve-bms is working correctly as when I unplug the VE-bus cable from the VE-BMS the inverter shows low bat and switch's to pass through as it should.

so everything is working on site and the vrm and remote console is working but I still get this error : Error: mk2vsc-33

but the below error still occurs when I try to download the setup

Anyone got any ideas as to how to overcome this issue

1636020564429.png

The secound battery monitor is a 123smart BMS

1636021114137.png1636021080115.png

multiplus ve.bus

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, I had similar problems on the weekend upgrading my Multiplus II to version 490. The first problem was that the upgrade would not continue past the init stage (20.5%). This was fixed by powering up the AC input. I also found that I was unable to download the config unless power was present on the AC input. Given that you also need to unplug any other VE Bus devices (i.e., Digital Multi Control) I would suggest this is a job best done onsite using a windows laptop with VEConfigure installed. I hope this helps.

had identical issue of being stuck at 20.5%, had to manual update with windows laptop

went from v481 to v490.

@mvader (Victron Energy)

jurekz avatar image
jurekz answered ·

As I see there is few changes around AC which are interesting for me.

I'm using not typical instalation (during being build) Fronius Inverters and Eastron SDM630 grid metter (with Modbus driver found in that portal) - what is important i do not have VEBUS central device yet. On Venus 2.73 it worked bad - meter was discovered and even power was calculated but not shown that values on Venus and in VRM portal.

There is changed in 2.80 version (I did not test previous builds 2.80)

Meter is shown properly in Venus:

venus.jpg

Even in VRM in instalation view:

vrm1.jpgBut not in detailed VRM view:

vrm2-2.jpg

What is strange - it shows proper power on each phase, even on the chart!!! (is calculated properly) but not in summary AC Load!!! Why?

That value is also not used to daily graph and value:

vrm3.jpg

Mayby this is because I'm unable to set up Settings/System/AC Input 1 as a Grid - but as I see this setting is not remembered without Victron central device.



venus.jpg (59.1 KiB)
vrm1.jpg (23.2 KiB)
vrm2-2.jpg (50.2 KiB)
vrm3.jpg (67.6 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image
nickdb answered ·

What's happened to this project? It has all gone quiet with no updates since this update.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jurekz avatar image
jurekz answered ·

What is the changes to version Venus OS v2.80~29

Maybe this is a good idea to keep in thee catalogue notes with changelog?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.