question

mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v2.80~14 available for testing

UPDATE 2021-08-20: v2.80~14 was released last night. One change only: better reporting of power per PV tracker in the Inverter RS and SmartSolar RS, to be used on the VRM Dashboard in detailed mode.


Good morning all,

As of this morning, a new version is available to be tested in the field, v2.80~13. In case you don't know what all this is about: this message is part of the Venus OS Beta test program. Read that link for more information.


What to test? (same as with v2.80~10/11)

The new DC meter features of the BMV-712 and SmartShunt. Note though that more is coming there, such as proper visualisation on the Overviews. What is available is just the basics.

And then furthermore basically everything needs testing: similarly as the previous major release, v2.70, also this version contains major upgrades in the foundations. The main one being that the Python version was changed from 2.7 to 3. Also the Open Embedded release was upgraded from Zeus to Dunfell, and lastly we changed to a read-only rootfs. All combined this means that (a) lots of tools and packages used will have changed to a newer version, and (b) lots of Victron code has been changed to be compatible with Python 3.


How to post an issue?

Preferably all issues are organised as answers to this question. One answer per issue. So first check the existing threads. If you have the same as someone else already reported, welcome to add a comment saying "me too". And preferably some more details. And in case its not listed yet, add a new Answer. Note that Answers and Comments are two different things here on community.

Lastly, if possible please revert to v2.72, to double check if the issue you're seeing was present there as well. Regressions require a different treatment than other issues and bugs, and one of the first things that needs doing in triaging a report is distinguishing between the two.


The plan with v2.80

Development and testing will continue for quite a while; I expect at least until somewhere in September; possible also into October this year.

It does look more and more likely that there will be a v2.73 soon, which will then start with a v2.73~1 in the candidate feed.


Changes since previous test version, v2.80~11:

  • Fix issue causing Cerbo GX-es with a serialnumber below HQ2026 to be incompatible with newer GX Touches. In such case, the GX Touch display would flash at powerup and then remain off. Not anymore. Thank you Matthias for reporting & helping to fix this.
  • Fix various regressions introduced earlier in v2.80 development, all related to the switch to Python3:
    • Generator start/stop timezone issue
    • ESS Scheduled charging timezone issue
    • ESS BatteryLife timezone issue
    • Remote settings using VictronConnect issue
    • Demo mode issue
    • VRM transmission exception handling issue
  • VRM: transmit status of L2 in a North American split-phase system, to enable proper visualisation. This relates to the recently introduced MultiPlus-II 12V 3000VA 2x120V. Note that the VRM Dashboard itself still needs to work to use this information. Its the last one: all other user interfaces (VictronConnect, GX Touch / Remote Console) already show information on L2.
  • VRM: transmit power per tracker, right now needed for the VRM Dashboard, rather than current. (added in v2.80~14)


Complete v2.80 change log, compared to v2.72, todays official version:

User interface (on screen & remote console)

  • Add eject button to the offline firmware update menu.
  • Fix issue that caused the overview to change when switching off the Multi in a system configured for ESS
  • Fix an issue where the grid meter reading disappeared from the gui when the Multi is off
  • Fix I/O settings visibility.

DVCC & managed batteries

  • Force DVCC settings for Pylontech batteries as per documentation (DVCC on, SVS and STS both off). This is now the same as already in place for various other battery makes.
  • Add full support for the Inverter RS, including CVL, CCL, SVS, STS and SCS.
  • Switch off inverters when a managed battery says DCL=0, just as it works for inverter/chargers already.
  • Only use the selected battery monitor; affects systems that have a managed battery and a BMV (or similar) Victron battery monitor installed.

ESS

  • Change the "Total of all phases" mode to be symmetrical: all phases are adjusted to convert the same amount of power from, as well as to, DC. In the past, this option primarily avoided passing power through the DC-bus to avoid inefficiency, but didn't take full advantage of the billing arrangement to use all the available power when there is a shortfall on another phase. Now it divides the work equally across the phases, thereby making the full capacity available, and with no impact on billing.

    An example: at night, no solar, there is a large load on L1 - say 6kW. And no load on the other phases, and a 3 x 3kVA inverter/charger configuration. Old: the L1 inverter/charger would be at max power, discharging, which resulted in buying ~3.5kW. New: all three inverter/chargers are each doing 2kW, zero Watts on the meter.

    Similarly in a excess PV situation: if there would be 6kW excess PV on L1, and the same inverter/charger configuration, then in the old situation it would charge the battery with one inverter/charger only, and the rest of the power would be sold back to the grid. In the new situation, it all inverter/chargers will be charging at approximately equal power, and the total being 6kW of charger.

    Lastly, note that the balance of feeding in excess PV power coming from solar chargers, has not been changed. There is no need to actively make that symmetrical, since when there is so much energy available that its necessary each inverter/charger will automatically start operating at full power. No need to actively manage that.


Other

  • Support the new DC Monitor feature, recently released as a firmware update for the BMV-712s (v4.07) and SmartShunts (v4.07). The purpose is to be able to use those dc meters not as a battery monitor but as a dc meter. For example to measure the output of an alternator, or a wind generator. Or, measure the power draw of a certain load or group of loads. First of all to visualise it, and later it can perhaps be used in DVCC as well. Note that this release is just the first step, more coming later such as proper visualisation in the overview and VRM.
  • Fix issue causing Cerbo GX-es with a serialnumber below HQ2026 to be incompatible with newer GX Touches. In such case, the GX Touch display would flash at powerup and then remain off. Not anymore. Thank you Matthias for reporting & helping to fix this.
  • Support exfat filesystem, for large removable media (sdcards, usb sticks). Note that this is not for the raspberrypis, since (only they) still ship with a version of Linux that does not support exfat.

Bluetooth

  • Fix Bluetooth pincodes starting with a 0; this was broken since the first release of BLE functionality in Venus OS.
  • Implement keep-alive functionality: improves robustness with certain phones by avoiding Venus OS thinking its still connected and then remaining connected while its not.
  • Fix GX device not being visible on other phones while already connected to one. Now it is visible in the 2nd phone, but then with an explanation that to connect, the other phone needs to actually disconnect first. This is now on par with how other Victron products work with Bluetooth.

Developer / under the hood

  • Change the rootfs to be default read-only. Careful, this is quite the change in case you're modifying your rootfs. The reason behind this is quality and robustness. Every boot is now the same, instead of an initial boot possibly being different from the second or the third. And less writes to the storage, which reduces the wear, and more advantages. The downside is obviously that its a bit more hassle in case you want to modify the software. To learn how, read here this commit.
    • /opt/victronenergy/swupdate-scripts/remount-rw.sh will make it writable again (until the next swu update)
    • additional services should now be stored in /opt/victronenergy/service instead of /service or else they won't survive a reboot
    • closes https://github.com/victronenergy/venus/issues/217
  • Change the used Open Embedded release from Zeus to Dunfell. More details about OE releases are here. For a long time, Venus OS was based on Rocko. Recently we changed it to Zeus, which was an intermediary step to get to Dunfell. Dunfell is relatively recent LTS (long term support) version; so happy to be at that version, and expecting to be able to leave it at this for quite some time to come.
  • Change the used Python version from v2.7 to v3.. This was something we needed to do anyway, and sort of a requirement that comes with switching over to Dunfell. For those that wrote their own code this does mean work. See also this post on community.


Known issues

  • On some Venus GX-es, v2.80 doesn't install. To fix this, we'll soon release a v2.73~1 (and thereafter a v2.73 official) that fixes that, and which will need to be installed before updating to v2.80 is possible on those Venus GX-es.
  • dbus-mqtt keepalive has a regression since v2.80~9 in how the keepalive works; see comments below for details. Will be fixed in the next v2.80 release candidate.
Venus OS
8 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

drdiesel avatar image drdiesel commented ·

Since changes are already being made to the BMV-712s, would it be possible to add a consumed watt hour accumulator along side amp hour?

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ drdiesel commented ·
hi drdiesel, we'll consider that; thank you for the suggestion.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·
hi all, last night a new version was released. v2.80~14. Just one change. Rather than making a new post, I've updated the above.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hi, I noticed I missed to add one thing to the change log. Included in above, already in the previously released test version which was v2,80~11, is a change in ESS:


ESS

  • Make phase compensation symmetrical
    • All phases are adjusted to convert the same amount of power from DC.
    • A shortfall on one phase is now compensated for on another.
0 Likes 0 ·
David avatar image David mvader (Victron Energy) ♦♦ commented ·
This sounds like a major change, can you please elaborate on it? When it applies? Exactly what it does etc?
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ David commented ·
Hi David, yes for sure. Probably later this week.
0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·
Hi all, I've updated the change log to explain the ESS change that makes the Total of all phases mode operate symmetrical rather than just avoiding discharging on one phase and charging on the other one.


See above for details; and let me know if there is any unclarity; or doubt in the new operation. Thanks!

0 Likes 0 ·
Bogdan Nedelcu avatar image Bogdan Nedelcu commented ·

Regarding "Change the "Total of all phases" mode to be symmetrical" does this mean that a single three phase inverter is able to redirect all power received from PV to a single phase where the load is present if the rest of phases are zero? If my understanding is correct this will transform the three phase to a mono-phase if no consumers are present on other phases.

0 Likes 0 ·
11 Answers
nickdb avatar image
nickdb answered ·

Can confirm the VC/VRM config issue is resolved.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

ok good!

0 Likes 0 ·
romain-bourdy avatar image
romain-bourdy answered ·

Hello,

Not sure if related, have not checked recently but seems like my ccgx has a quite high load.


root@ccgx:~# uptime
 12:35:18 up 10:21, load average: 3.38, 3.42, 3.48
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Elimac avatar image
Elimac answered ·

I'm running version 2.72 on my Venus GX HQ17xxxx and I can't seem to be able to install this new version. Same happened with 2.80~13. Is this normal?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·
Hi Elimac, yes its a known issue. We’ll soon release a v2.73~1 that fixes that. It needs to prepare before v2.80 can be installed.


This issue is on Venus GX only.


0 Likes 0 ·
Rob Duthie avatar image
Rob Duthie answered ·

Running raspi 3B+

Canbus to USB Not function anymore only RX data packets received only

VE direct to USB Ok

Grid meter to USB OK

PV inverters OK

SPI and serial links don't work anymore

Since the new Ver 2.70 to 2.80 all these have stopped working

Prior to Ver 2.66 all worked OK with rocko packages.

I have put a halt on the Steton Hat due these issues unless you run with Ver2.66 which all works OK except the bluetooth if used with a dongle is OK.

Just done retest with the zeus packages in ver 2.66 with the release version as since rocko packages are gone there are issues with setting password for shh always fails password.?

Regards

RobD

NZ

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem commented ·

Works here. Tested two different VE.Direct USB adapters on my RPI 4 running v2.80~14 connected to a BMV-700. Could it be RPI 3 specific?

0 Likes 0 ·
scuba-shan avatar image
scuba-shan answered ·

MQTT seems borked. My client seems to work for a few minutes after a reboot then no longer receive any data. I'm sending keepalive. It looks like other users have reported the same on previous versions - https://community.victronenergy.com/questions/96161/venusgx-mqtt-unstable-after-272-firmware-upgrade.html

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hi @Scuba Shan , since v2.80~9, there is a regression in doing the keepalives by sending something to /system/0/Serial. Before v2.80~9, it worked both when publishing empty messages as well as messages with something in it. Since v2.80~9, the payload is checked. Sending for example { value: "" } doesn't work anymore at the moment. We'll soon release a new v2.80 version that fixes this; thanks for reporting.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ commented ·
ps. meanwhile, there are two workarounds: (a) publish an empty message, or (b) switch to the new keepalive system.
0 Likes 0 ·
scuba-shan avatar image scuba-shan mvader (Victron Energy) ♦♦ commented ·
Thanks, that sorted it :)
0 Likes 0 ·
thomasw-1 avatar image
thomasw-1 answered ·

I did not see that feature working so far regardless which multiphase setting:

1629812269574.png

1629812210696.png



1629812210696.png (7.4 KiB)
1629812269574.png (7.6 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hi Thomas, what this change does is make the DC power symmetrical over the phases, not the grid feed-in.


So, if there are AC loads somewhere, Or single-phase or otherwise non-symmetrical PV Inverters, then you'll see what you show in the screenshot.


And, the change made doesn't affect feeding in excess PV power from solar chargers.

0 Likes 0 ·
Jaco Reinecke avatar image
Jaco Reinecke answered ·

Hi, still cannot upgrade from v2.72 to version 2.80~ 14

Appears my Venus still gets "errors" trying to upgrade ... don't worry, got the answer, will be fixed later.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hi Jaco, yes that issue has been found and solved here. We’ll this week release a v2.73~1 which fixes it.


that will need to be installed first. And thereafter you can go to v2.80 again. Some (unknown) percentage of Venus GX-es is having this issue.

0 Likes 0 ·
daryl avatar image
daryl answered ·
  • A shortfall on one phase is now compensated for on another.

Does this mean that in a 3 phase system, large single phase loads (greater than the capacity of one of the inverters) will cause another inverter to generate the excess required to stop importing power overall from the 3 phases?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·
Exactly @daryl , see above changelog, yesterday I updated this change to be more descriptive
0 Likes 0 ·
Kevin Windrem avatar image
Kevin Windrem answered ·

Some of the CANbus services are missing from some of the builds. Here's the list as of v2.80~15:

raspberrypi2 and raspberrypi4 are missing

mqtt-n2k.can0

mqtt-n2k.can1

vecan-dbus.can0

vecan-dbus.can1

nanopi is missing

vecan-dbus.can1

ccgx

vecan-dbus.can1


canvu500 is complete

beaglebone is complete

einstein is complete

I checked the large raspberrypi4 build which is missing all 4 services like the "normal" RPI 4 build above. I did not check other large packages!

In previous versions, templates for the services were provided and a service needed to be created from the templates. Starting with v2.80, all services are included in /opt/victronenergy/service and no templates are provided to create others.

My VeCanSetup package creates the missing services (lifted from the einstein build) which will get us through for now, but if the service changes in the future, what I install would be wrong!

16 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hi Kevin,

maybe below explains what you're looking for? Note that a CCGX does not have a CAN1 since it has only one can port. Similar for the Nanopi, etc.


root@einstein:/opt/victronenergy/service-templates# ls -al
drwxr-xr-x   16 root     root          1024 Aug 31 13:48 .
drwxr-xr-x   48 root     root          3072 Aug 31 13:48 ..
drwxr-xr-x    3 root     root          1024 Aug 31 13:28 can-bus-bms
drwxr-xr-x    3 root     root          1024 Aug 31 13:23 dbus-bornay-windplus
drwxr-xr-x    3 root     root          1024 Aug 31 13:41 dbus-cgwacs
drwxr-xr-x    3 root     root          1024 Aug 31 13:23 dbus-fzsonick-48tl
drwxr-xr-x    3 root     root          1024 Aug 31 13:23 dbus-imt-si-rs485tc
drwxr-xr-x    3 root     root          1024 Aug 31 13:23 dbus-modbus-client.serial
drwxr-xr-x    3 root     root          1024 Aug 31 13:23 dbus-modem
drwxr-xr-x    3 root     root          1024 Aug 31 13:28 dbus-motordrive
drwxr-xr-x    3 root     root          1024 Aug 31 13:28 dbus-valence
drwxr-xr-x    3 root     root          1024 Aug 31 13:28 gps-dbus
drwxr-xr-x    4 root     root          1024 Aug 31 13:28 mk2-dbus
drwxr-xr-x    3 root     root          1024 Aug 31 13:41 mqtt-n2k
drwxr-xr-x    3 root     root          1024 Aug 31 13:28 vecan-dbus
drwxr-xr-x    3 root     root          1024 Aug 31 13:28 vedirect-interface


0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem mvader (Victron Energy) ♦♦ commented ·
Great. I missed the templates directory. I'll fix my scripts to use those instead of ones I copied from Einstein.

My scripts can add additional CANbus ports to any GX device so the nanopi and CCGX could have two can ports with USB adapters.

0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Kevin Windrem commented ·

Hi Kevin

Re the canbus ports setup i am am trying to use your Vecan set up to no avail, How do you start it when in the program i have installed the file into the data file using SSH etc using WinSCP etc.

I use only Pican and Canble USB devices they all worked OK on the older version 2.66 no problems at all, these new version 2.73 will no work on raspi 3B+ i use to use a script file to change these setting to make it work automatic.

I use to change DEV to can0 on all the files required, The ifconfig shows no can0 port anymore.

This is all for the rapsi Stetson HAT project i am trying to get going again for every body who asks.

Any help would be helpfull. i have looked at the latest version of Vecan setup.

Regards

Rob D

NZ

0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem Rob Duthie commented ·
Are you getting any errors? Have you also installed SetupHelper? all my setup scripts rely on common functions that are part of SetupHelper.


/etc/venus/canbus_ports needs to have can0 in it but I assume you know that.


v2.80 is changing a bunch of things that I'm not sure how to handle:

for einstein, there is a canbus_ports.in and can bus_ports is a symlink to /run/venus/canbus_ports. I think /run is a ramdisk so there must be code to initialize canbus_ports, maybe from can bus_ports.in????

If I modify /etc/venus/canbus_ports and reboot, the file reverts to the state before modification.

It looks like the backlight files are done the same way.

Looks like raspberrypi4 works the "old" way. Not sure about other builds.

@mvader (Victron Energy) , we could use some explanation. Should we be modifying the .in files? both?

0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Kevin Windrem commented ·

Hi Kevin

Correct i use the can0 ports command.

No i don't use the setup helper as the set up file won't start, how do you start it?

Below is the ifconfig return data it receives data Ok no TX? This applies to CanUSB and the PiCan hardware as well.

can0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-0-00

UP RUNNING NOARP MTU:16 Metric:1

RX packets:2520 errors:0 dropped:2 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:100

RX bytes:16065 (15.6 KiB) TX bytes:0 (0.0 B)


Regards

Rob D

NZ

0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem Rob Duthie commented ·

SetupHelper is another package:

https://github.com/kwindrem/SetupHelper

SetupHelper includes an automatic update mechanism for all my packages. If you don't want to run that, you don't run /data/SetupHelper/setup. Just the presence of SetupHelper will allow the setup script for other packages to run.


After installing both SetupHelper and VeCanSetup files in /data

run /data/VeCanSetup/setup.

The script allows configuring can0 and can1 interfaces picked from the list of devices I found here:

https://github.com/victronenergy/venus/wiki/RaspberryPi-CAN-Interfaces

The only one I've used is CANable USB. I tried both the slcand and Candlelight firmwares. Slcand is the default loaded on Canable USB.


0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Kevin Windrem commented ·
Hi

Yes i installed the setup helper files into the data folder etc. just how do you start the install set up process the setup file is a txt file?


0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem Rob Duthie commented ·
the setup files are bash shell scripts so:

/data/VeCanSetup/setup


0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Kevin Windrem commented ·
Hi Kevin

Got it, not thinking..



0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Kevin Windrem commented ·
Hi Kevin


Yes done all that installed setup helper Vecan helper etc. it does changes to file sets etc. Still only get RX data no TX data on either Cantact/canable USB or Pican setups.?

This what happen in the early days of getting the canbus going on raspi units.

Any other ideas?

Regards

Rob D

NZ

0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem Rob Duthie commented ·
what is candump showing?

candump any will show traffic for all canbus ports

0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Kevin Windrem commented ·



Hi Kevin

Sample of the can dump file:

root@raspberrypi2:~# candump can0

can0 359 [7] 00 00 00 00 08 50 4E

can0 351 [8] 14 02 90 01 D0 07 CC 01

can0 307 [8] 12 34 56 78 56 49 43 00

can0 305 [8] 00 00 00 00 00 00 00 00

can0 355 [4] 64 00 63 00

can0 356 [6] 89 14 00 00 CF 00

can0 35C [2] C0 00

can0 35E [8] 50 59 4C 4F 4E 20 20 20

can0 359 [7] 00 00 00 00 08 50 4E

can0 351 [8] 14 02 90 01 D0 07 CC 01

can0 355 [4] 64 00 63 00

can0 356 [6] 88 14 FE FF CF 00

can0 35C [2] C0 00

can0 35E [8] 50 59 4C 4F 4E 20 20 20

can0 305 [8] 00 00 00 00 00 00 00 00


0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem Rob Duthie commented ·
try

candump -xde any

also make sure the canbus port is enabled:

Device List / Services / CANbus port (1) or VE.Can port and that the profile is correct.

I can't read the candump but it does indicate what's coming and going before processing.

0 Likes 0 ·
Show more comments
svaeyens avatar image
svaeyens answered ·

Maybe I'm missing something, but I don't have the option to install 2.80-14 in the Cerbo console.
I have a Cerbo GX running 2.73 and have the "Latest release candidate" Update feed selected. When I check for an update in the console, I get "No newer version available".
I'd really want to test the ESS symmetrical option for my 3 phase setup, was already working on a node red implementation of this using mode 3 but having symmetrical available in mode 1 would make things a lot easier.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·
Hi @svaeyens , no you’re not missing anything - at the moment there is no version other than v2.73. We interrupted the v2.80 testing


now that v2.73 has been released, we’ll resume v2.80 shortly.

Matthijs

0 Likes 0 ·
Dosheimer avatar image
Dosheimer answered ·

Hi! I am ready to test the new DC meter feature of the BMV-712 and SmartShunt as I would like to add my Silentwind wind turbine into my existing Victron Lithium cruising sailboat setup. Where can I find more information about which kind of energy meter I need to purchase and which settings I have to do in my BMV-712. Also the question: Can I use the latest public released firmware for the BMV-712 for that or do you provide a beta firmware for that and where to get it?
Thanks for the DC meter in advance! I am long waiting for that feature!

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·
Hi, you only need the smartshunt (or the bmv-712 and its shunt).


no extra hardware is necessary.

With regards to which fw version to need, see changelog on Victron Professional. I think the latest is good, for sure no beta is needed.

0 Likes 0 ·