question

kenyon avatar image

System Overcharging

I have a site with a battery going into overvoltage alarm. I have updated all firmware and checked the charging parameters.

It apears that the VENUS GX connected is the one 'dictating" the incorrect charge settings.

System config:

Venux GX FW 2.60 DVCC enabled
Quattro 15kVA FW 476 (was 430 with same issue) with ESS
150/70 Smart MPPT
250/70 Smart MPPT
2 x BlueNova 52V 8kWh (to make 16kWh battery)

Charge absorb settings are set to 56.2V, Float at 55.5V.

When Venus GX is disconnected Charging on all devices stops at 56.2V

The moment VE.Bus is connect to the GX the charging (on Generator) goes up over 60V (battery cuts off at this point). This also happens with the battery comms disconnected.

Any pointers on how to fix this?

MultiPlus Quattro Inverter ChargerVenus GX - VGXLithium Batterychargingovervoltage
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @Kenyon,

Enable Grid feed-in for AC and DC MPPT in the ESS menu of the GX device.

If you are not allowed to export - set the export limit to 0W - but still keep them both enabled.

cleanshot-2021-01-22-at-181306.jpg

This should help prevent this.


2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Guy Stewart (Victron Community Manager),
Thanks a lot. Is this a new FW version thing? All my other sites are doing fine.

@Kenyon,

Yes, there was a change in 2.60 for BlueNova battery turning on detection, then enforcing DVCC on, Shared Voltage Sense off & Shared Temp Sense off.

Paul B avatar image
Paul B answered ·

check the voltage reference cable (V- Sense) on the quattro, and or make sure its connected to the batteries main bus bar.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Using DVCC, BMS on Can Bus. Comms 100%. Correct battery voltage, current SoC is showing on the Venus.


Paul B avatar image
Paul B answered ·

I think more site info is needed. and some screen shots of settings for all the items would help especially the Voltage settings, as something is not set correctly.


OR

My supposition is that you have a grid tie inverter on the AC1 out or on the AC1 in

if AC1 out and that you have possibly not setup assistants for PV frequency shift.

if ac1 in then there is no frequency shift control and the gen out put goes to zero but the grid tie is still outputting and the out put is greater than the loads


thus when the batteries are full and the gen is running then the solar keeps outputting and the power has no where to go except to raise battery voltage then the inverter CUTS off to protect the systems.

would also happen when no gen and the batteries are full and the loads are less than whats being used. (if ac1 out is being used)


this is JUST A guess. if you dont have a grid Tie solar connected anywhere then I am totally wrong here


4 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Paul,

No. No PV inverters are in the installation. ESS assistant is installed with PV GT settings off. The problem only exists when the venus gx is connected. DVCC is enabled and I have confirmed that the parameters "dictated" by the BMS are correct on the venus (current limit OK and charge voltage 56.2V). I have tried disconnecting all other devices from the venus and only having the VE.Bus quattro connected - same issue. MPPT parameters are controlled by the venus (DVCC) but i have put in default charging parameters on them anyway - and disabled them for this test.

This screenshot shows quattro config and actual charging voltage (shown on venus) this is with only quattro connected and the same result with the battery BMS also connected.

All charging parameters are "correct" but charger still goes straight to bulk or absorb, even at 56.5V ... I dont know what voltage it goes up to - i did not wait to find out, highest i saw was 60V.

P.S. some time ago I did have another with PV grid-tie where I accidentally forgot to re-enable the PV GT on ESS assistant after I ran a firmware update - fixed once i realized my mistake. No the case on this site.

charge-setting-and-actual-voltage-2021-01-16-13124.jpg

ess-settings-2021-01-17-094000.jpg

The only thing i have not tried yet is to reinstall the venus OS.

Interesting other event I was called by friend to a site where his CCGX was showing all connected devices and real-time values correctly from the main menu but on the dashboard/display widgets everything was blank and "unknown". I reinstalled the Venux OS and all was ok. It seams somehow just part the widget App got corrupted. Very weird - never seen it before -

im wondering if we have a similar issue here where part of the DVCC app is corrupt? Perhaps the flash memory is corrupted and not retrieving correct DVCC register value for charge voltage? sending an 0xFFFFFFFF or something. I guess i should read from Modbus registers to see what values are stored/sent back? - will try re-flash the OS first...

just a double check is the quattros voltage sense wire connected correctly. and for that mater are all of the voltage senses correctly connected

I really dont have any other pointers. I once had this issue on one of the very first versions of a MPII 48/5000 as every now and again I got a runaway DC voltage, I ended up installing a BMV712 and then used DVCC from the BMV as the voltage reference this fixed it through a Venus GX . (anyway the MP was replaced in the end and the problem went away).

I have also noticed it occurring on a grid tie site when frequency shift that was not set correctly. not your issue as you have no PV

also had it but again with grid Tie PV if the lithium batteries FILLed to quickly the frequency shift did not respond quickly enough and thus the voltage spicked, to solve this one I put a contactor in to turn off 2 x Gt inverters), if the DC volts went over 58volts and this turned the grid Tie solar units off.

None of these are a solution but maybe something has a hint in it somewhere that may help

Thanks Paul. I'm not using a Vsense cable I stopped using it on venus-DVCC connected/enabled batteries. I have a lot of sites with this configuration and much higher charging rates which are working fine.

I will give this venus OS downgrade a few days and see if it has changed. Then go back the v2.60 and note if the problem persists.