question

jacola avatar image

3 Phase Multiplus-II system with Pylontech dead after some days

I am fighting with a new install.

Venus GX, 16pcs pylontech, hub, venus, 3x multiplus-II, grid connected
Due to distance to the farm entry where i have the ET340, i use external control and Modbus/TCP to control the system.

The system worked for some days, but strangely the FI in the pumphouse (quite far away) started tripping in the night with no obvious reason, might be unrelated.

Now the system is in error state, "grid relay fault", it constantly throws the SMA solar system off-grid when it tries something, and shows error codes on the multipluses which are not documented. My installer has no clue and things "some problem down the line" but there are no changes and the system worked for some days without any issues.
Hardware defect in the Multiplusses ?

Problem got worse because the Pylontech batteries where pretty discharged and used the rest of the energy to power themselves (and possibly the Multiplusses ?), so now they are "dead", the can hub from pylontech is "dead" as well as it feeds of the 48V of the battery.

I am lost and currently my installer seems to be clueless also, he thinks it is probably my problem as i use external control (ESS mode 3) ...

here a short video of the error blink codes of 2 multiplus, the third one does the same as the right one.

https://www.dropbox.com/s/n7sc9zvfuv6fh5b/IMG_4812.MOV?dl=0


HELP, please. I have now cut the multiplusses from the grid so that at least the solar production works and is not constantly thrown off.

Johannes






Multiplus-IIESSPylontech3 phase
6 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Johannes


Are you running the latest firmware on your multi's?

What happened when you turned the units off and on again? did it go straight into the error state?

Hi EwakdErasmus,
i dont know about the firmware. I asked the installer and he said they should be updated, but i don't know how to check the version. The "extended error information" as described in Error 11 handling is NOT visible, so maybe not.
Is there a way to find out the firmware version via VenusGX (i am not the installer .. dont have the tools yet).
When i switch off and on, they all come up (low battery indicator lit, of course, as the battery pile is dead/no power), take about 30 seconds with just low volate lit, then relays click, my SMA solar inverter connected nearby goes off grid, and then they show the error as depicted in the video. Pylontech is not visible to Venus as there is no 48V ..
And to answer this precisely - the error is not intermittent, it is "static" in the sense that the devices do not come up without the error.

Johannes


my installer says they run on version 474

Hi @jacola

There is a way to verify the firmware in VRM, go to Remote Console (click the enter button on the top right), Navigate to your multi using the up-down keys, go into your multi bu using the right directional key (or clicking), and then lower down the list you will see an option called "Device" in here you will see your firmware version there.

You will also see product id. You can then verify if you are running the latest firmware version. I don't know what Multi you have, but I think the latest firmware version is 475.


You can check your firmware version and download a new version at: https://professional.victronenergy.com/downloads/firmware/

Note that the first 4 numbers have to match your product ID.

As a start please update your firmware version, and see if the issue is still there.

Hi @EwaldErasmus,

thank you ! they are on 474 which was "up to date" apparently about 2 weeks ago when they were installed.
I will need a "professional" login to even get the release notes, right ?
And i will need special tools and adapters to talk with the Multiplusses, cannot be done from Venus, or can it ?

My provider of the system says it seems 2 Multiplus have the same problem, it is unlikely they break and it is probably some "external reason" and i can unmount them and send them in for check/repair. That is super annoying, i am end user .. and left alone with that problem. But well, maybe i can electrocute myself with the tries ..

Do you think 474 would be "good enough" ?

Second question, about the 48V supply. My batteries are "dead" now, especially as the Pylontech comms hub is powered from the 48V system and there is no 48V any more. Seems a crazy idea for me that the batteries power their hub and as they have discharged now the system is stuck and not coming back ..
Can you or anyone say if the Multiplus will (when it works correctly of course) provide the 48V, even if there is a low voltage error due to a shut down battery, or am i completely stuck with this ?

I wish i would not have bought that ESS. It was sold as "reliable and easy to use", what i experience now is far from that. I am a comms professional, do Modbus/TCP and bridges, gateways etc since 25-30 years, but that i have to disassemble high voltage systems, update firmware etc for a system which failed 2 weeks after installation seems really weird.

Johannes


Hi @jacola wiring bms equipment to the battery is a best practice given if mains fails it or an inverter develops a problem, the bms will still be powered.

An ESS system is very easy to install and reliable if installed per manufacturers instructions, however unforeseen house wiring issues or grid power problems can make for a challenge if it rears it head. The Victron may have actually highlighted a longstanding issue and that is all part of the safety it offers.

If you connect to the Venus remotely, some settings can now be managed remotely by downloading the config file and amending it before uploading.

Finally, you can create an account on Victron professional and get access to the latest info without being a pro.


3 Answers
warwick avatar image
warwick answered ·

In my experience, Error 11 is a result of a wiring issue on your AC side. I’ve had a very difficult to find issue once at a client that was “working fine” before we installed their system.

The multi complained about error 11 from the start and after lots of investigation, we discovered a wiring issue deep in the house wiring where cables had been pulled forcefully through a conduit and stripped. If I recall correctly, house neutral and earth were touching and the multi does not tolerate that.

However, everything else in the house seemed to work with it. If I recall correctly, one of the symptoms of this was that if the Eskom neutral was disconnected, the house continued to be powered.

I don’t know anything about Pylontech (other than that they are the most problematic batteries by volume of issues posted in this forum) but I cannot see how they would not be “woken” up by the Multi Charger. I know of people who have used them without the BMS cable plugged in - so if the BMS is dead, this is the same situation.

11 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

OK, i will try to cut off segments of my internal farm grid and see if the error orginates from a specific segment or it generally happens.

Let me know how it goes.

will do. my first issue that it seems to be more or less impossible to get the system up again, with the discharged batteries .. i am a bit frustrated but that is how it is.
I will try to connect a 48V power supply to the battery bus to power the multiplusses so i can at least get that part separately tested.

Do you not have panels and MPPTs attached? That is always the great benefit of DC connected PV - it can wake the system up when dead.

unfortunately, no .. the panels are using an SMA which is independent of the ESS. which now is fortunate because at least that part works reliably (however the multiplusses, when trying to connect to the grid, disrupt it/throw it off)

i'll give it a try with a 48V 60W power supply .. if it gets fried it gets fried ..

What voltage does that 48V supply put out ? The Pylons need about 52v to charge if i recall correctly. Not sure how they will react to a lower voltage? Hopefully BMS will reject it and the current can then go to the Multi to switch on.

well, it's a 48V small industrial power supply, with 60W it is NOT capable of bringing anything up, BUT i still have some progress.
It was enough to power the pylontech hub and also wake up the batteries, some of them still have enough charge, so they then maintain the voltage.
I tried then to engage the multiplusses in switch setting "1" (charging only), which worked OK, but when they connect to the grid, one of them makes loud and agressive humming. It is the one which also showed an overload error earlier, so i guess that one is broken, for no obvious reason for me. Early fault ? My system provider wants to be paid to come by and check the system, or i may unmount and send back the devices .. i am not too comfortable to do this so i guess i bite the bullet and pay. hopefully the "repair" of the multiplus which died within 30 days after installation won't take too long. We'll see ...
Here is a video of the error codes shown of 2 inverters before connecting to the grid (2 different ones), and a video with the sound when connected ..
I am also going to make put that up as a new topic, not talking about the batteries, maybe someone has a similar experience or can explain the blink code (which is not explained in the app).
1) starting up in charger only mode
https://www.dropbox.com/s/0c73jf0xul8nije/Video%2022.07.20%2C%2019%2046%2016.mov?dl=0

2) connecting in charger only mode, no load, no battery, idle https://www.dropbox.com/s/20e3ebb3fbkg2fi/Video%2022.07.20%2C%2019%2046%2027.mov?dl=0

3) error when switching on with charger/inverter modehttps://www.dropbox.com/s/ueh69piwmqcy00o/Video%2022.07.20%2C%2019%2052%2022.mov?dl=0


Johannes


Hey Johannes Are you able to logon to the venus gx and go through the errors on their. it should be reading the information from each of the inverters and give us a better detailed description of what is happening. When you put them into charge are they charging the batteries. if they are you may want to let them charge up the batteries. then turn them on with all the breakers to the rest of your grid turned off to see if there are any errors then.

yes, sure. "login" you mean via remote console or via ssh or other low level tools ? the system is online on vrm, i can give access also. I haven't seen any phase specific messages other than one time a "L1 overload".
BUT: when setting to charger only, the loud humming of one inverter does not sound correct at all, so i have switched off the multipluses for now to avoid further potential damage to batteries or other things.
I also bite the bullet and pay the vendor to come and check the system out.
I will be happy to report back here, i can also try if the units, when set to "charge only", can charge the battery despite the loud humming ..

As the system is new and you have already got the guys coming out to check. better to leave alone till they have checked. will be interesting to hear what the cause is be it faulty unit or an issue in one of your sub DB's.
Vrm is a great tool. you can also go into the remote console from VRM or through your lan if you know the IP address of you Victron GX. this way you can trouble shoot things a bit easier and see what each of the inverters/ battery BMS are doing.
please keep us posted.

Hi Johannes
I see you have opened another question and have mentioned the Ground relay test failure. My understanding that if you are connecting into a DB where by your Ground and neutral on linked at your main DB and then you have Sub db's where the ground to neutral are bonded you will have issues. Basically on the inverter the ground relay in the Multiplus config should be disabled in such circumstances. when you are operating in island then you need it enabled.
What I am unsure of is whether the tests will continue and if they do how you would resolve this problem.


dgnevans avatar image
dgnevans answered ·

On your system you should have a breaker for each of the outputs and inputs for the Multiplus'. trip these breakers and then power off and power on the multiplus. see if they wake up without the error. Then turn on the input breakers feeding your multiplus. if they power on without error and start charging the system then there is an error on your wiring.
Confirm is the system charging from grid power or how do you charge the Pylontech?

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks @dgnevans. No outputs are connected .. only the grid side. If i trip those breakers the Multiplusses are off, they have no power. That makes me even more scratch my head. There is no "transfer" function used ..
Pylontechs are charged from apparent "grid power".
I have an ET340 at the entry of the farm (connected with 20kva capacity to the public grid). Behind that ET340 are 3 PV systems (2x SMA 3-phase, 6kw and 8kw, and one Solax 1.2kw), plus all consumers. Due to the distances on the farm ("internal grid" is probably 1km) i have that meter at the entry connected to a local controller and run the algorithms to do ESS external control (mode 3) from there. Actually very simple - i control the ESS via modbus/tcp to balance phases and provide power or charge simply based on the net in/out on the three phases.
So the batteries are charged if i have excessive power on my "minigrid" which otherwise feeds back to the grid (and i still feed up to 10kw into the grid once the battery is full).
This all worked well for some days ..

Ok So you are using it as a grid tied storage. understood.
Look at this page https://www.victronenergy.com/live/ve.bus:ve.bus_error_codes

if you go down to diagnosing error code 11 if goes into more detail as to how you can pin this down to one particular issue. In order to enable this mode you generally have to select a region which then means you have to comply to the regulations in that country. Often these issues are a grounding issue as to how the system is bonded between neutral and ground and earth leakages detected in the system.

jacola avatar image
jacola answered ·

OK. so the miracle is solved. It seems the whole thing has NOTHING to do with wiring on my side.
Here is what we found out (i also posted that in another post):
- my external loop did not take any provisions to stop discharging at a "safe" limit, so i commanded the system to discharge the batteries until they shut down. I thought safety measures are enforced by the ESS even in external mode, but here: no.
- when being about "empty", pylontech voltage apparently dropped briefly to 36V resulting in the system shutting down and entering an error condition, from which it did not recover.
- multiplus-ii seems to not be able to correctly start up with no 48V power on the battery side. at least not when set to normal operations mode. it throws those relay errors but they seem to be incorrect.
We took the following steps to bring the system up again:
- switch all multiplus "off"
- make battery work (that is another story, but we got it to provide the 48V again)
- switch multiplus to "charger only" mode (they still failed to come up in normal mode)
- command the ESS to charg the batteries until they reached about 13%
- switch multiplus off for several seconds, then switch on in "normal" mode

and the system started to work again.

So the conclusion is that multiplus behaves erratic if the battery voltage is not stable/too low and thows those errors, locks into an error mode, frequently disrupts the grid trying to come up (seen on the SMA which gets thrown off the grid) and not recovering from the situation.
Now my external control loop will (hopefully) switch the ESS off once the batteries are down to 10% - better losing 10% capacity than ending in a locked system.
Hope this helps anyone running into the same problem

Johannes




2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Great. You don’t want to go lower that 90% DoD anyway.

Great glad you have resolved your issue. You may want to stop discharge at 20% remaining as this will prolong the life of your batteries.