paddyglenny avatar image
paddyglenny asked

Factory reset for ccgx? Wifi will not connect?

Dear support staff

I am attempting to connect a new ccgx with the Victron portal.

Contacting the distributor from whom I bought is a very slow process- they have no telephone service and take two to three days to respond to an email. Then the process of backwards and forwards questioning takes days and days.

I paid for the more expensive asus usb network device (usb n14) but am unable to connect to the wifi networks here at the clients house. Every other device I have, tablets, phone, laptop all connect without a single hitch but this bloody ccgx, even though it finds the networks no prob will attempt to connect once then never again. I cannot make it forget the network to try anew nor can I command it to attempt to connect.

CCGX Color Controlwifi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Murray van Graan avatar image Murray van Graan commented ·

Which firmware are you running in the CCGX?

0 Likes 0 ·
paddyglenny avatar image paddyglenny Murray van Graan commented ·

I will check when I go back to the jobsite on Monday. It will be the version it was installed with- I planned on updating it as soon as I had an internet connection....which thus far I have been unable to achieve. ..

1 Like 1 ·
6 Answers
paddyglenny avatar image
paddyglenny answered ·

Yay! Success!

After a few stumbles along the way, I managed to update the firmware via a usb flashdrive and then as if my magic getting online via wifi happened very easily.

Thank you to everybody who helped me out here.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Justin Cook avatar image
Justin Cook answered ·

@PaddyGlenny, without being in front of the unit it's a bit hard to tell, but failure to connect to WiFi (barring a non-compatible wifi dongle, which it sounds like is not the case) is most commonly caused by an incorrect password being entered into the CCGX; since it finds the networks, the dongle is ruled out as the cause of the problem, which largely narrows down the problem to an incorrect wifi password.

I know how aggravating it can be to enter a complex wifi password into the CCGX using its buttons; please be advised that you can connect a USB keyboard to the CCGX to make this process easier.

Please see the CCGX manual, and particularly section 1.6, for more information on internet connectivity.

Once the wifi is successfully connected, you will of course need to manually "add installation" to the client's VRM portal to be able to access the device, but naturally the wifi connection must be correctly established first.

There isn't a factory reset option in the CCGX, but the "reboot" option in Menu>Settings>General>Reboot? may be of assistance; I'd recommend rebooting the device and then, after connecting a USB keyboard if desired, and then re-entering the wifi password for your selected network and I feel certain that you'll be successful in achieving connection.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

paddyglenny avatar image
paddyglenny answered ·

Justin, whereas I appreciate your taking the time and trouble to answer, the password is not the issue. You are right that it's a pain in the ass entering a password, especially a long one such as both these networks have, but I have tried over and over and even had the client enter it and had him watch over my shoulder while I did it for the hundredth time and confirm it was entered correctly. I re-entered it on my phone to confirm and the phone gets connected immediately. And you know why I've done it so many times? Because the device won't remember the password.

I select IP configuration: automatic (although I've entered the ip address manually as well).

Then I enter the password.

Then I select "save changes" by pressing the centre button.

Then, but only if I have rebooted the unit, it briefly shows "connecting" before showing "disconnected".

If I didn't reboot, it doesn't even try to reconnect, just stays at "disconnected".

If I exit the screen and come back, the "ip configuration" is back at "unknown" and the password has disappeared.

And I can find no way to get it to forget the networks, to allow me to re-enter the info...but you might be onto something inasmuch as the first time I entered the password, I entered it it possible it is refusing to forget that initial password, I wonder?

Whatever, it is a bloody unsatisfactory piece of kit. The client has bought almost €10,000 worth of Victron components, all let down by a distributor who takes 72 hrs to answer an email and a ten cent item like this ccgx that amazingly cost €525!!! That's about $700, and far off the price of an i-phone 10.....but at least with a smart phone you get the option to do a factory reset.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

JohnC avatar image JohnC ♦ commented ·

Just a 'perchance' comment Paddy. What does the 'Ethernet' screen show? Wifi won't connect if you're cabled, but will failover to wifi if the cable is pulled..

0 Likes 0 ·
ejrossouw avatar image
ejrossouw answered ·

Hi @PaddyGlenny Sorry to see you are still having an issue. In your other post on the same issue, the many walls and distance from router was a possible limiting factor. Another possible way of testing the device's signal strength is plugging it into a laptop at the same location and check it's signal strength. As a last resort powerline plugs may be a way to offer a quick reliable wired connection.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

paddyglenny avatar image paddyglenny commented ·

Yes, I have tried 6 different devices and are able to connect without problem. I even did a speed test with my cheap, old Samsung cellphone and it managed a download speed of 6 Mbps.....

Also I moved my phone and mobile hotspot far away, until the ccgx showed only 10% signal strength (bearing in mind it is showing approx 35 and 47% signal strength for the two wifi networks) and it connected just fine, so I doubt now it is the signal strength giving the problem.

I am wondering if it could be some kind of network security issue? Perhaps the wifi networks' routers require some kind of protocol that the ccgx can't handle, but that all my other devices take in their stride?

The thing is, this crap €525 ccgx doesn't tell you anything!!!! It gives you ZERO info on what the issue is. Doesn't say "password incorrect", nothing.

I am rapidly reaching the point of putting it down to the reality that the ccgx is an ill-thought out piece of junk and that I should get the client's money back and tell him that despite Victron's claim that you can connect with their portal and view you pv system online, in fact it cannot be done via wifi.

Oh, and in answer to your suggestion re powerline plugs, there are no plugs in the room! I would have to go to the hassle of installing one...but the client is now balking at the time I'm spending, so far with no success, getting this unit online.

I have also considered running an ethernet cable to the unit but that would need a 20 metre cat5 cable passing through 4 rooms....and understandably the guy doesn't feel like paying for that either, especially as he has shelled out €525 for the ccgx plus €125 for the asus network adaptor and so far about 6 hrs of my labour......with zero tangible results.

At this point, both he and I want to see Victron step in and take ownership of this issue. Thus far no support staff have even replied.....

0 Likes 0 ·
ejrossouw avatar image ejrossouw paddyglenny commented ·

It sure kept you uncomfortably busy. What is still missing for me is a test of the actual device and since devices can vary widely in capability. I'd as a last resort suggest you disable the WPS / WPA /WPS-2 (All security) on the router as another possible test.

I think the wifi network aspect should be explored further as the dongle may well not be suited to the specific environment or equipment it connects to or even have a fault. Another dongle should also preferrably be tried just to be sure. Also, I find with some networks if it is hidden after you connected to it, the device may not connect. Even more strange, I found some of my IT devices can actually see hidden networks. This is why installer has to be so multi-skilled today. No manufacturer will or can guarantee their equipment is compatible with everything out there and I also found even small changes in firmware can sometimes play havoc with equipment.

In summary:

  1. What can you see on the log from the router when the device connects?
  2. Can the device connect to the network from the same location if it e.g. plugged into your laptop?
  3. Can you disable all security (the WPA etc.encryption) on the router as a test?
  4. Can you try another dongle? (same one Victron uses ;) I keep one spare just for situations like this.)

PS - This is a public forum and not a Victron Support site. This is a community of like minded people helping each other ;) with the kind oversight and intervention of Victron support staff sometimes.

0 Likes 0 ·
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @PaddyGlenny

You're getting good answers from the community here, so I saw no reason to chime in.

I'm sorry that your distributor is non-responsive, I hope you have another distributor you can choose to go to that does give the mandatory support. For complaints about distributors you can go to the Victron sales agent for your regio:

As an installer I assume you've had training?

In any Victron training it is emphasized that for a reliable and stable connection, a network cable is -always- the first choice. Using wifi leads to exactly the problems you describe here.

for restoring a GX device / updating firmware, please read this manual:

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

paddyglenny avatar image paddyglenny commented ·

Daniel, thank you for responding. Firstly, yes I will update the firmware and see if that helps. Secondly, no, I have had no training from Victron. I am an electrical engineer with 45 years of field experience and have completed many pv systems but always with Sunny Island, Aurora or Danfoss hardware- this is my first Victron install (and probably the last).

May I ask a couple of questions of you please?

Why bother advertising and offering the wifi connectivity option if you have not yet made it work reliably. Nowhere in any of the sales literature did I see the warning "Don't bother buying this if you hoping to rely on wifi connectivity."

Also, if you job title is "support staff", why not , indeed, chime in and offer support when it is requested rather than leaving it to the general public. If you have answers to the questions I posed, I'd love to hear them. Please try to bear in mind my client has purchased around €12000 worth of Victron products and understandably would like to see me getting the professional and courteous after sales support such a sum of money would normally warrant.

I am still no wiser why the unit will not remember the passwords. Nor has anybody been able to tell me how to reset it back to the settings it was delivered with.

Are you able to offer me any help with these matters? Or give me a step by step procedure for diagnosing the problem I have?

0 Likes 0 ·
Daniël Boekel (Victron Energy Staff) avatar image Daniël Boekel (Victron Energy Staff) ♦♦ paddyglenny commented ·

Hi @PaddyGlenny

Please read:

For support, the first rule is always: all firmware up to date. so best to first do is update the CCGX up to the latest firmware. you could have done this before even heading to the customer for installing the system.

in this case, just run a 'loose' network cable temporarily to the CCGX and update the firmware. if wifi still doesn't work, try closer to the access point, try a different wifi dongle, try a wifi repeater, etc. (basic trouble shooting)

But still: a wired connection is always the best option (if possible).

Installers are -strongly- advised to follow Victron training, it's free of charge. a lot of distributors even demand this from their installers.

0 Likes 0 ·
Warwick Bruce Chapman avatar image Warwick Bruce Chapman commented ·

Also note the upgrade method using an SD card @PaddyGlenny but I have to emphasize the point about using an Ethernet cable. You cannot rely on WiFi. Rather run 100m CAT5 if necessary.

0 Likes 0 ·
Warwick Bruce Chapman avatar image
Warwick Bruce Chapman answered ·


Please use forget network.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

CCGX Product Manual

CCGX Product page

Additional resources still need to be added for this topic