question

William Kennaway avatar image
William Kennaway asked

Venus GX WiFi turned off

I have a RV with various Victron hardware installed. I bought this setup 2nd hand 9 months ago & was not fully shown how it all worked. About a month ago when using my iPhone I mistakenly turned off the WiFi on the GX & now cant find a way to turn it back on. Also for the last 9 months it has not been logging/updating info on the VRM system. I have an account & it was logging at first. Because I move around a lot is it possible to use iPhones hot spotting (we have 2) laptops (also 2) & connect the venus to internet for logging & updating. Then use the laptops for reading & changing settings on my equipment? One more question. I have a 4G micro SD card. What format does it need to be to use with the GX for logging when not connected? Fat, FAT32 or NTFS?
Venus GX - VGXremote consolewifi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
JohnC avatar image
JohnC answered ·

Hi William.

There's actually a 'caution' in the manual about turning off the Venus wifi, but there should be an easy way back.

To much to rewrite the manual here. All your questions should be answered here (and the ones you haven't asked - yet): https://www.victronenergy.com/live/venus-gx:start

Also the CCGX manual covers a lot more stuff common to both: https://www.victronenergy.com/live/ccgx:start

What you use for internet connection is pretty much stock stuff we all use commonly. If you have VRM access to view, then all should work for you.

The SD card is also in the manual: "SD and SDHC type microSD cards of 32 GB capacity and smaller are sold containing FAT12, FAT16 or FAT32. They can be used without a problem, unless they are subsequently re-formatted to a different file system".

Sorry to make you work for this, but you did say you 'weren't shown'. Now you have been.. :)

Good luck.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

William Kennaway avatar image
William Kennaway answered ·
Below I have attached some instructions from the GX manual. On my GX there is a button to the left of the 14 pin connector (looking from the front there is none on the right) which I have pressed with no change to my WiFi connection status. It also goes on to say if I press for longer than 4 sec's it will reset back to default settigs. Nothing happened either (default is WiFi on) 3.2 Small button located to the right of the green 14-Terminal Connector Block Short press: WiFi Access point on/off A single short press toggles the internal WiFi access point on and off. The LED indicates its state: when the LED blinks green slow, then the built-in Access Point is disabled. when the LED is green and blinking fast, then the built-in Access Point is enabled Without getting access to onboard WIFI I cannot connect anything else. Can you explain/help how to connect (for instance) a laptop using a iPhone as a hotspot to access the Venus Gx via Ethernet cable or similar so I can then turn on the WiFi on the GX. Please.
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yeh ok, I'd try via ethernet cable too.

If you have no router - Set laptop to connect to the web via the iPhone wifi. Test it. Ethernet cable from Venus to lappy. (Dang, I'm told some new lappys don't have an E port)

Now 'share' your lappy's web connection with the Venus. If it's a Mac lappy I can't tell you how to do that, but I believe can be done. Just google for how.

On Win10, go 'Network and internet Settings' > 'Change adaptor options' > right click on 'Wifi' (not the ethernet connection) > 'Properties' > 'Sharing' > tick both boxes > OK it. (Whew!).

Your Venus should now be uploading to VRM. Open a browser to VRM and access your Venus via 'Remote Console'.

Bit beyond the scope of a Victron forum, blood-brothers, eh..

Good luck. Come back if you need..

0 Likes 0 ·
Sorry to take so long to get back. Been traveling in the RV. Had a bash today with your solution. Connected my freshly installed windows 10 laptop to my iPhone using WIFI. Tested & all good. Connected the ethernet cable from the Venus GX to my laptop. When thru 'Network and internet Settings' > 'Change adaptor options' > right click on 'WIFI' (not the ethernet connection) > 'Properties' > 'Sharing' & found that both boxes were already ticked. Ok'd it. Using task manager I check for internet activity & there was none on WIFI or ethernet? Went thru the same procedure & un checked the boxes. Restarted the laptop got back to the same properties & sharing & checked both boxes. Still no transfer/internet activity. Can you think of any thing I maybe doing wrong. Any help would be appreciated. Yours Willie K
0 Likes 0 ·

There's a recent post, different kit though, that might help: https://community.victronenergy.com/questions/38982/wifi-access-point-inadvertently-disconnected-on-mu.html

What I suggested is a clunky workaround without a dedicated router, but it can work.

One other.. With VRM up on a lappy browser, try grabbing another browser tab at the same time, and type venus.local into the address bar. If you actually have a web connection set up right on the GX, that will give you access to the GX screen directly.

If no web link, it won't work, so back to sorting the link..

0 Likes 0 ·