question

bigal avatar image

VRM+BMV712 - No Batt Temp

I have recently hooked up my BMV712/MPPT Solar to VRM portal via VenusOS - its really great and loving it so far.

I have battery temp being fed into the network by Smart Battery temp sensors. And this works as I can see Batt Temp on the solar? (or was it the BMV?)

Anyway - I was wondering if I am doing something wrong as despite the battery temp being on the network, it is not passed through to VRM.

Thanks

Al


BMV Battery MonitorVRMTemperature Sensortemperature
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
bigal avatar image
bigal answered ·

Just confirmed - yes its the smart solar that gets the temp. It doesn't seem to pass the temp on to the BMV for some reason.

6 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @bigal

That is correct, it's only transmitted to the MPPT's

But I think that since recently, it should also be visible on VRM:

2019-11-06

  • Added a battery temperature graph widget for solar chargers

  • Added battery temperature to the solar charger summary widget

https://www.victronenergy.com/live/vrm_portal:change_log

ChristofferBengtsson avatar image ChristofferBengtsson Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hallo @Daniël Boekel (Victron Energy Staff),

I didn't want to start a new thread but I have the exact same issue as described above. The temperature is available in the Victron Connect app but does not feed into the Venus OS/VRM portal. I have enabled DVCC but "used sensor" is blank. When I try to plot the temperature data in VRM I get "No data available".

My setup is:

MPPT 100/20. Firmware: v1.49
BMV-712. Firmware: v4.03
Raspberry Pi 3b+ running Venus OS v2.60~19
Smart Battery Voltage/Temp bluetooth sensor connected to the MPPT using VE.Smart Networking.

Can you help me understand what I am doing wrong?

Best
Christoffer Bengtsson

Hi @ChristofferBengtsson

I've just learned that the temperature is not (yet) forwarded to VRM, hopefully it will be in feature firmwares.

ChristofferBengtsson avatar image ChristofferBengtsson Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hi @Daniël Boekel (Victron Energy Staff),

This is really a shame but it does explain why I am not seeing any data. It would be great to have this feature implemented. Is it part of your current firmware/software roadmap for Venus/VRM?

Hi @ChristofferBengtsson

It's on the wish-list to implement.

ChristofferBengtsson avatar image ChristofferBengtsson Daniël Boekel (Victron Energy Staff) ♦♦ ·

Awesome! I will look out for it then. Is it a limitation in Venus OS or VRM?