anacrhy2007 avatar image
anacrhy2007 asked


I have now had 3 CERBO GX units.

I) Brand new out the box CERBO GX (series that had apparent 48VDC issues)
No issues with VE-CAN, BMS-CAN or VE-BUS. Also HDMi worked flawlessly on a std HDMi screen.
I changed the screen to an older LCD with VGA input and an HDMi to VGA converter. The moment the
HDMI to VGA converter was plugged in the HDMi port blew. I wrote this down to a faulty VGA to HDMi
converter. Send it back, not stock, Victron took over two months to repair / replace, supplier supplied
a new unit (in fairness he did say he wasn't sure if it was okay or not and to test).

II) Installed unit received as mentioned in point I), left out HDMi. Plugged in order:
- USB 1 (LEFT) power monitor
- USB 2 (Middle) power monitor
- VE-CAN (MPPT), Terminator
- BMS-CAN (Battery comms), Terminator
Before I could even plug in the power connector the battery BMS made a tick sound and everything
turned off, BMS dead. Plugged in Cerbo power and cerbo is also dead. Had to send it for repairs,
still waiting for it to be returned.

III) Received a brand new Cerbo GX as a replacement for the very first unit that had the HDMi issue,
took 2 months.
Plugged in order:
- USB 1 (Left) power monitor
- USB 2 (Middle) Power monitor
- Ve-CAN (MPPT), Terminator
- BMS-CAN TERMINATOR (left out Victron Type A cable)
Everything ran perfectly, tested VRM portal and all 100%.
- Plugged in BMS-CAN Cable, within 15 seconds battery BMS shuts down. Same problem as before
BMS damaged, tracks burnt on BMS PCB. So had BMS replaced again. At this point it is obvious that
Pylontech's Force LV1 BMS is absolute rubbish, clearly that's why they discontinued it. Replaced the
BMS but this time NO COMMS. And it worked great.
- Tried the HDMi port and it was completely dead with native HDMi and VGA adapter, no display. Just
left the screen out, no big issue. Note that the VGA adapter had been replaced an is working 100%

Still the same Cerbo GX as point III) still no BMS-CAN. Worked 100%, installed a new Multiplus ii 48/8000 had that up and running on VE-BUS. Logged perfectly. So today I started reading up on the "modify" side and noted that one can get past the blank HDMi screen by SSH and changing some parameters. So I connect the very same HDMi cable (screen is not even turned on yet) and the unit goes shhh dwah! and that's it, another Cerbo GX in the garbage. Note that at this point no modifications had been done yet.

All the above mentioned Cerbo GX units fall within the 48VDC issue models.
In my 23 years in data cabling, CCTV and Solar installs I have never, up to now, blown a port on a CAN, RS485, RS232 or network. Not even without incorrect cable pinouts.
I refuse to believe that all these failures are coincidental or "user error"

cerbo gxcommunication protocolpylontech lv hub
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alexandra avatar image Alexandra ♦ commented ·


It could be a ground fault issue. (Not referring to the 48v power supply ones HQ2201- HQ2220.)

Have you got any voltage between live and neutral in the install?

1 Like 1 ·
2 Answers
anacrhy2007 avatar image
anacrhy2007 answered ·

Just a follow up on this. The Cerbo GX was replaced with one of the newer units (not the 48VDC issue ones) and now all is working fine including screen. I have not had the balls to plug the BMS in again, rather connected a smart shunt.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

groningen avatar image
groningen answered ·

Thanks for the feedback @Anacrhy2007.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources