mick-finch avatar image

GX GSM not logging data into VRM Portal

We recently installed a GX GSM into our Colour Control. We followed the instructions and it is fully connected to the Colour Control with an Optus sim card the the APN 'yesinternet'. The '3G' symbol along with two bars of service is showing in the top right hand corner of the Colour Control.

If it is fully connected, why is the VRM portal not running the updates? I have it set to run updates every 15 minutes.

I deleted the installation from our portal and tried to add it back in. To add it back in, I had to have an internet connection to the Colour Control for it to detect the VRM portal ID. I turned on my personal hot-spot from my phone and plugged a WiFi USB adapter into the Colour Control. It connected straight away and I then re-registered the installation into our VRM portal. It updated and logged data for the past three days straight away. I then reconnected the Colour Control to the GSM and waited 15 minutes for the portal to update and re-log the data. The portal hasn't run the update and I am now getting 'last update 30 minutes ago'.

Why isn't the GSM logging data if it is fully connected? What are we doing wrong that is causing this?

CCGX Color ControlVRMgxupdate
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Mick Finch, I noticed a second post on the same topic, lets keep this in one; I’ve deleted the other one. Thanks.

Hey @Mick Finch. I’m sorry thats its proving so difficult to make this work. Exactly this is the issue with cellular: it can be real easy, but also very difficult.

please add a comment in reply to mine with more information:

1) what provider and subscribtion are you using? In what country?

2) two bars is not a lot, but it should be enough. One thing to try and make sure reception is not the issue you are having is to move it closer to a cell tower. Just the GX device and the modem would be enough, no need to move the whole install.

3) what do you see in the GSM menu? Post a photo preferably. Then it will be easier for people to help you.

4) Have you already installed Venus OS version v2.31? If not pls do

5) in the vrm portal menu, you can see the last error. Post a photo of that too. And first read up on those errors, see VRM Portal chapter in the CCGX manual.

6) try a simcard from another provider.

mick-finch avatar image mick-finch mvader (Victron Energy) ♦♦ ·

Hi there

1. We are using an Optus Prepaid sim in Australia.

2. Yes the firmware is updated to v2.31.

3. We have tried sim cards from a number of providers and only the Optus one works.

4. As shown on the pictures, the error number displayed is #154. I think this is because we disconnected the CCGX from the internet connection from an Ethernet cable (we had to source one so that we could generate some data on the VRM portal. This is not a long term solution, we were relying on the GSM). We were originally getting #159. Please note, we have read through the manual and it did not help as the information provided on #159 was 'this is a catch-all error and cannot be categorized.'

5. See photos below. If you would like our IMEI and VRM portal ID, please provide an email address so we can send them to you privately.

vrm-ccgx.jpg (2.4 MiB)
gsm-ccgx.jpg (2.2 MiB)
vrm.png (941.4 KiB)
gsm.png (858.0 KiB)

Hi @mvader (Victron Energy Staff)

Just wondering what your progress is on this issue.


@Mick Finch,have you tried setting the APN to ‘everywhere’ and rebooting?

Or another apn, see here:

And if you google for Optus APN you also find other Optus resources.

Alternatively, put the simcard in a phone, check/make internet work. And then look in phone settings what APN is used, and enter that on the GX Device.

And yet another thing you can try is Pauls advice below (connect the GX to a computer).

Lastly, you could buy a simcard from a specialised m2m data company; and they’ll be able to help you set this up.

I’m sorry that its not easier, but this is the typical problem there is with sim cards and m2m communication.

And to more directly answer your qeustion regarding our progress: I don’t think that there is a an issue or software bug on our side. Its more likely to be a configuration issue (apn) or incompatibility.

I hope you’ll be able to sort it, all the best, Matthijs

2 Answers
Paul B avatar image
Paul B answered ·

I would take the GSM unit out of the ccgx and then install it on a computer and make sure that that computer then has a internet connection through the new GSM unit.. if it does not then sort that issue out before you put it back in the ccgx

this way you will know that the GSM unit is working how it should then reconenect it to the CCGX

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Paul, I’ve never tried that: did you? Does this work?

Could indeed be a nice way to test the hardware. But it doesn’t test any of the settings that @Mick Finch made in his GX device, such as the APN.

Paul B avatar image
Paul B answered ·

This also maybe the issue as well this maybe the same issue with the GSM unit, closley related area thats all , its a maybe ???

this is the latest release candidate update infor so its not released yet.

you can see the info in The modifcations area of the forum

Changelog of v2.31~4:

  • Fix WiFi not always automatically reconnecting when the gui was left in the WiFi menu: when in that menu, the GX device continuously scans for WiFi networks; and that prevents the system from automatically reconnecting to a WiFi network that ended up in a Failure state. Now, it will automatically leave that menu after five minutes of inactivity.
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, thanks for trying to help, but this is not related