sailorzach avatar image
sailorzach asked

Installed VE.Bus Smart Dongle but Multiplus does not show up

I have a Raspberry PI setup that runs Venus OS and connects to my Ruuvi sensors and MPPT charge controllers (via Bluetooth and, respectively). I have a MultiPlus 12/3000/120-50 120V that I want to connect to the system so I bought a Victron VE.Bus Smart Dongle.

I just ran a standard UTP RJ45 from my engine room where the MultiPlus is located and connected the ethernet cable to the Dongle and the Dongle to the battery bank directly. The Victron Connect app on my phone allowed me to add the device to the network as a Smart Dongle but the Inverter doesn't show up in the system. VRM online doesn't show any devices. Venus.local doesn't show the device.

One other note: Firmware was updated from 1.07 (I think) to 1.13. I am transmitting battery voltage and temperature.

I was under the impression that I would use the Smart Dongle to see and control the inverter. Please let me know what I need to do to make that happen. Thank you.

Venus OSmultiplus ve.busHelpVE.Bus Smart Donglesystem integration
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
sailorzach avatar image
sailorzach answered ·

To answer my own question: the cable was bad. Replaced it and the Dongle started showing up in Victron Connect and I could control the Inverter from there but it never showed up in VRM so I bought an MK3 USB and plugged the RJ45 cable into there (after removing it from the VE.Smart network; I tried not doing that first and my system hard shutdown). Plugged the USB into my Raspberry PI 4 and it worked like a charm except now I can't connect to it via Victron Connect because MK3 USB doesn't have bluetooth. Funny how I couldn't find this information anywhere.

I've added a Morpeka LPG sensor and need to bite the bullet and run the cables for the BMV 712 to complete the install. Pretty happy overall.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

Additional resources still need to be added for this topic

Victron Venus OS Open Source intro page

Venus OS GitHub (please do not post to this)