Daniel avatar image
Daniel asked

Battery not recognised by GX System (Pylontech US2000C, Victron MultiPlus 2 3000 GX, 2xMPPT)

Hello Community,

build a new offgrid system with Victron & Pylontech. Started with on Pylon US2000C to get it running but the Battery is not recognised by the Victron system. First we had the wrong Cable (Typ B) and in this case the battery was visible in RemoteConsole. Problem was that voltage reading between Victron and Pylontech was different. After changing it to Typ A Cable between GX and Pylon the reading was still wrong, so we made a factory reset of GX module and build up from scratch. Now the battery is not recognised at all. Firmware is up-to-date for all Victron components. Firmware of US2000C I cannot see. Any ideas?


Some more details:
This is how it looks like in VRM dashboard.

vrmdashboard.jpgVRM Device list says:

  • Gateway, Product MultiPlus-II, Firmware version v.2.90
  • VE.Bus System, Product MultiPlus-II 48/3000/35-32 (ACOut2 switchable) , Firmware version 497

Pylontech US2000C, Run LED ist flashing:


(Edit 2)

This is how everything is connected to MP2 GX:

Multiplus-IIPylontechgx device
vrmdashboard.jpg (45.5 KiB)
runled.jpg (29.2 KiB)
mp2-connections.jpg (146.9 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Daniel avatar image
Daniel answered ·

Ok, found the issue. GX device. Menu path: Settings → Services → VE.CAN port.
CAN-bus speed was set to wrong value. Correct value is:

can-bus-speed.jpg (17.9 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

faberj avatar image faberj commented ·
Excellent, very helpful ... I also work with Victron systems and Pylontech Batteries but never had that issue, actually I was reading your post for giving some ideas but I would have never thought of the error you had. Thank you for posting your solution
0 Likes 0 ·
Alexandra avatar image Alexandra ♦ faberj commented ·


Reading the manual helps alot. The specific GX setting is found there.

1 Like 1 ·