question

Sarah avatar image
Sarah asked

Smart MPPT 150/85 VECan controller Bluetooth issues

567aa858-0c5b-40da-a005-15de4e3e1ead.jpegd3ddbbff-a76b-40f0-b941-9947d1af2e7f.pngHi all a puzzling situation that I would appreciate your input on. During a recent upgrade to incorporate a Lynx Smart BMS into our system I lost Bluetooth connectivity to one of my VE.Can connected Smart MPPT VE.Can rev2 solar controllers (firmware v3.10) when it was restarted (I have two). I am as positive as I can be that I did not disable Bluetooth myself.

When I connect to the two devices (VictronConnect (v5.72 & 5.73b1) over VRM (VE.Can/Cerbo (VensOS v2.90~14)/VRM) to re-enable Bluetooth I get two different product info pages - one with the Bluetooth option and on the other there is no Bluetooth option (see screenshots). Both units are the same age and have the same config - apart from this issue they are continuing to operate normally. I have also tried using VE.Direct/Cerbo/VRM and get the same product info pages. Resetting the device to default settings did not have an impact.

So my first question - is it normal for the Bluetooth option to completely disappear like this?

Moving on - so my thinking suggests this is either a bug that was triggered when I hooked up my Smart BMS to Ve.Can, operator error, or hardware fault with super impeccable timing. So, from a trouble shooting perspective I am going to assume that the Bluetooth has somehow become disabled.

Hence my second question - the manual suggests I should be able to re-enable the bluetooth via VRM, is this correct? Or is my overriding problem the missing bluetooth option mentioned above.

"5.4 Disabling and enabling bluetooth. Connect with the VictronConnect App to the solar charger. Note that if Bluetooth has been disabled, a connection via its built-in Bluetooth is not possible anymore. In that case use the VE.Direct to USB interface, the VE.Direct Bluetooth Smart dongle or VRM to connect to the solar charger." https://www.victronenergy.com/media/pg/Manual_SmartSolar_MPPT_150-70_up_to_250-100_VE.Can/en/configuration-and-settings.html#UUID-330502da-9b37-93ce-dc17-09c2a4e131ce

Thanks in advance.

VRMVictronConnectBluetoothVE.Cansmart mppt
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kevgermany avatar image kevgermany ♦♦ commented ·
If Victron Connect is able to see both MPPTs via Bluetooth and you can see the info/history for both, then it hasn't been disabled on either.

If you turn off 1b and disconnect it, what does victron connect sho for 1A


0 Likes 0 ·
Sarah avatar image Sarah kevgermany ♦♦ commented ·
@kevgermany thanks for the reply. When I view the devices in VictronConnect I can see both devices through the VRM page, but when I look at the LOCAL bluetooth devices page I can only see the 1B.Solar controller. I have tried both a phone and laptop and neither can see the 1A.Solar device on Bluetooth.
0 Likes 0 ·
1 Answer
Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi @Sarah

What might help is power cycle the MPPT that does not show the Bluetooth Enabled switch. This means disconnecting it from PV and battery for a few minutes and reconnecting it (battery first).

When this does not work, the internal bluetooth dongle might be broken.

Kind regards,

Thiemo van Engelen

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sarah avatar image Sarah commented ·

Thanks @Thiemo van Engelen (Victron Energy staff) I will give that a try. I have power cycled the PV Array but not both PV Array and battery simultaneously. It might be a week or so before I am back on the boat and will let you know.

0 Likes 0 ·
Sarah avatar image Sarah Sarah commented ·
@Thiemo van Engelen (Victron Energy staff) Full power cycle as you suggested worked! Many thanks.
0 Likes 0 ·