question

henri-bergius avatar image
henri-bergius asked

Digital inputs stay “stuck” on 2.80

We have a bilge float switch wired into a digital input port of the Cerbo GX. After updating to 2.80, we’ve had it happen twice that the alarm stays on even after we’ve pumped the bilge dry. Rebooting the Cerbo makes it switch back to the “ok” state.

At this stage the float switch is back dow, but the state is still shown as “Alarm” and Cerbo is still beeping:

e67c4e68-8767-4c89-bedd-26f03d525e64.jpeg

After a reboot the state goes back to “Ok”:

ced5f5ba-455e-4c3b-a006-de3ce12dd8a8.jpeg
Since this didn’t happen with the previous Cerbo firmware, but has happened now twice after the 2.80 update, I’m assuming that this is a new bug.

Here are the settings we use:

93deb9ed-d08e-4372-80e9-19df586e3581.jpeg

(Somewhat unrelated, it seems “invert alarm logic” doesn’t work over MQTT. In Signal K with the Venus plugin I see the state as “Alarm” when it is “Ok” on Cerbo, and vice versa)

cerbo gxbug reportvenus os v2.80
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi again,

I tried to reproduce this on a Cerbo on my desk here; and could not.

Also tried it with inverted alarm logic, also unable to reproduce.

See video:

https://www.dropbox.com/s/5n5vzeiju0df872/IMG_5335.MOV?dl=0

this is on v2.81. And with regards to this functionality its all the same between v2.80, v2.81 and v2.82~2.

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

And same thing in the exact same configuration, bilge alarm and all three settings (enable alarm and the teo invert settings) enabled.


Unable to reproduce.

Can it be something in your wiring?

0 Likes 0 ·
henri-bergius avatar image henri-bergius mvader (Victron Energy) ♦♦ commented ·

It totally could be wiring. I haven’t multimetered it yet since it is all a little tricky to access.

However it is slightly suspicious that this behaviour started after upgrading to 2.80, and that a reboot fixes it.

I’m not able to do it this weekend, but I’ll check the connection early next week just to be sure.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ henri-bergius commented ·
Hi Henri, yes its a strange coincidence.

Is your system online on VRM? What is the URL? Because then we could do something else:

1. enable Remote Support in Settings -> General; this allows us to login.
2. reproduce the issue
3. don't reboot, but let me know its in the state - then a colleague or I will login and see if we can find out more checking out the actual system.

Pls let me know if thats an option for you; I'll be available today. Not always, but will keep an eye out.

0 Likes 0 ·