question

tan-tonge avatar image

IMT Irradiance Sensor - Venus OS / Raspberry Pi - Not Connecting Properly

I am working on a small solar and 12V battery system using a SmartSolar Charger, Phoenix Inverter, and SmartShunt with a RPi running Venus OS v2.73 for monitoring. This is intended to be a solar power demonstration unit so it would be very helpful to measure irradiance and cell temperature with an IMT sensor and have a few Si-RS485TC-2T-v-MB available.

However, I am having trouble getting the sensor to connect properly. I am using a USB to RS485 serial adapter with the FTDI chipset as recommended and it can be seen and seems to connect for a couple seconds every minute or so but no readings show up.


Sensor shows up but shows "Not Connected":

20211229-153622.jpg

Does seem to connect every ~1-2 minutes but nothing shows up:

20211229-154033.jpg

I have no trouble accessing the sensor using Si Modbus Configurator from my PC and can read values from it. I do see the G value change when shining a light on it. Everything seems to be configured properly there according to https://www.victronenergy.com/media/pg/Cerbo_GX/en/installation.html#UUID-d4b7dfe9-4ee0-53bc-8959-c567ed63cebb and the IMT application note.

imt1.png

imt2.png

The VRM does show "Meteorological sensor [1] Product Id" to be b030 after connection but nothing else in the data export.

Pretty stumped as the device is seems to be recognized but not getting any data through. Any ideas to help me troubleshoot this?




Venus OSVenus GX - VGXRaspberry Pisensor
20211229-154033.jpg (402.8 KiB)
imt1.png (69.2 KiB)
imt2.png (92.9 KiB)
20211229-153622.jpg (257.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.