article

osaether avatar image
osaether Posted · · edited ·

Service to turn Multiplus on/off via digital input

A frequent requested feature of mine (and others on forums discussing off gird systems) is a means to turn on or off the Multiplus with a switch. With a stand-alone Multiplus you can connect an external switch but when the Multiplus is connected to a CCGX or VGX the external switch does not work and you have to dig deep into the remote console to turn the Multiplus on/off.

I have created a service that monitors a digital input and when it goes from high to low it turns the Multiplus ON if is is OFF and OFF if it is ON.


I had to create a new digital input type: #10, "Inverter control".


Below is a link to the python service repository. Patches for the gui-files and dbus-digitalinputs service can be found in the "diffs" folder. Under releases there is a prebuilt installer for the VGX.

https://github.com/osaether/dbus-inverter-ctrl.git


For those of you that want to build it, here is the Bitbake recipe I used to build the installer:

https://gist.github.com/osaether/324c9c1aa60f072b32373f4def188e4f


I have yet not verified this since I don't have a Multiplus at home but the dbus command and path to the Multiplus is the same as on my remote cabin.

Use at your own risk!


Ole

Venus GX - VGX
30 comments
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Tried this on 2.30~39 today and it does not work as expected. I get python errors when writing to the dbus so there must have been a change in dbus lately. I will get back when I have figured it out.

Issues fixed now and repo updated.

I tried it out his weekend and it works very well. See video below. This feature is most useful for off-grid systems where the zero load power of the inverter will drain the batteries in the winter months where we have no or very little sun.

Your browser does not support HTML5 video.

Will it be possible also to change to "Charger mode" remotely?

Hi, yes that would be possible but in the repo above it is ON/OFF.

Hi,

did you already know the 'safety switch' assistant in the MultiPlus? It can be used driven by an Aux input of the Multi (and as this Aux input can also be wired to the Venus relay you can even switch remotely -> watch out where you power the Venus device from);

Regards,

Bob

1554807349096.png (41.5 KiB)
Mark avatar image Mark ♦ Bob (Victron Energy Staff) ♦ ·

My understanding is that the 'safety switch' assistant ONLY switches off the AC output & NOT the actual inverter, accordingly there will still be a stand-by current/power draw of >20W, which is the primary reason for wanting to fully switch off the unit.

1554864442278.png (50.1 KiB)

Yes that is why I did it like this. I want to turn off the Multuplus. Same behavior as in the GUI. See below.

multi2.jpg (38.5 KiB)
multi1.jpg (45.0 KiB)
VicRVUsr avatar image VicRVUsr Bob (Victron Energy Staff) ♦ ·

A note to Bob (Victron Energy Staff): Another reason why this alternate method of switching the Multiplus on and off is important is the Safety Switch assistant cannot be used in conjunction with the Li-Ion BMS assistant, as documented in the assistant itself:


You can guess what kind of batteries I have...

capture.jpg (16.4 KiB)

Thank you. This is the one I've been waiting for, to get the power system on the offgrid cabin that I want it. Needed to get the WAF (Wife acceptance factor) too. :)


And thanks to Espen (cabin neighbor) who helped me with the setup.

Your'e welcome!


Is your cabin in Norway?

I live on spitsbergen. And have a cabin up here too.

If was on when input is high, and inverter off when input is low would help more.

Because else you need som feedback to know if you turn the inverter on or off.

Then also bms and other security switch would benefit as well.

Hi @Rune Eilertsen Yes that is easy to change but I prefer a momentary push-button for my application. In the button in the video above the light is wired to the AC out of the inverter.

I will update the example so that this can be configured. When I have time...

Hi Ole,

This is a long awaited feature. Unfortunately, I don't get it to work.

On “Digital Input 1”, when I select “Inverter Control”, it goes back to “Disabled”.

The service “dbus-inverter-ctrl” is up and running, and the Multiplus is on tty05.

(My push-button on the digital input 1 is also confirmed to work, as when input1 is set to pulse-meter it counts the pulses.)

/Espen

Hi @Espen. I am suspecting that I have not got the Type settings correct. If you are comfortable editing files on your Venus, stop the inverter-ctrl service:

svc -d /service/dbus-inverter-ctrl

Edit the file /data/conf/settings.xml and scroll down to <Digitalinput> and find the <_1> section and change the Type to 10:

<Type default="0" max="10" type="i" silent="False" min="0">10</Type>

Save the file and exit, then reboot your Venus.

Hi Ole,

Thank you. I can confirm that the settings is working now.

I'll go to the cabin later today to also check the powerbutton on the venus .

/Espen H

Hi,

I can confirm that it’s working now!

Thank you so much Ole :)

/Espen

Hi, I'd like to install this on an rpi running venus os. I found out the image hasn't been made for the rpi. I'm lost as to how to go about building or manually installing it. I can manually edit the patches in easily enough, but don't know where to go from there. Please be kind to me as I'm pretty new at Yocto and the Victron-specific stuff.

Thanks in advance for any help, this will help my WAF of my install with the Multiplus greatly!.

Hi! I have now built an installer for rpi and uploaded to github. It's the file, dbus-inverter-ctrl_0.6-r0_cortexa7hf-neon-vfpv4.ipk here:

https://github.com/osaether/dbus-inverter-ctrl/releases/tag/v0.6


You will probably have to change the digital input pin in the scripts.

Thanks! Yes, I suspect I'll have to change the inputs, I could not find any kind of mapping from Rpi to the Venus GUI's input number so I'll just play with them on the bench until I find one that switches in the GUI and use that one. Getting another Rpi just in case I'm too fumble fingered...

It's working on the Pi now! Thanks very much for writing this and supporting us!

I was able to use the same input however I did have to correct the type settings from your reply to Espen above. The Multiplus address changed since it was on a USB port. Once I fixed that it worked like a charm! I also changed the off mode to charge only (replaced the 4 with a 1 in two places in the python service script).


For reference here's a chart of the Rpi inputs used by the Venus OS, I used pin 29, pulled it low and reversed the polarity in the inverter control setup, though that may not have made any difference:

Rpi Pin # GPIO # Device Instance Normal state
37 26 5 low
35 19 4 low
33 13 3 low
31 6 2 high
29 5 1 high
1 3V3 pull low pins hi thru 10k
39 GND pull hi pins low thru 10k

Hi Ole,

I did see in your release notes that you removed "inverter control" from the mainpage. (over to service?)

But I have it still on the main page.

Hi @Espen I checked and you are right. I will try to figure out another way to do this. I was gone in some earlier versions of Venus.

This service does not work with Venus v2.30~50. I don't know why yet. Reverting back to Venus 2.30~47 and it works. We need to wait for the ~50 release notes from @mvader (Victron Energy Staff) to see if there is a change related to this. Maybe they changed how the digital inputs work?

The Venus 2.30~50 release notes are out now and there are no changes related to this. Despite that, this service is working fine on ~47 but not on ~50. I will try to debug it but my impression is that Victron don't want us to create custom services. Given the lack of feedbcak from Victron in this thread.


Hi @osaether, . Found and fixed now; in v2.31~2 test version at this moment.

Sorry for not recognising this sooner and thanks for reporting

osaether avatar image osaether mvader (Victron Energy) ♦♦ ·

I tried v2.31~2 now and the digital input works as expected. Thanks!

Ps. You wrote:

> I will try to debug it but my impression is that Victron don't want us to create custom services.

Not at all. I think its an honour that people like you spend so much time building on top of our work.

The lack of response sometimes is that its difficult to debug / help with software not under our control. And a lack of time. Also for me there is only 24h in a day.

Ps2: next time, be aware that for digital inputs (and lots of other things in Venus OS); you can see all changes here: https://github.com/victronenergy/meta-victronenergy/commits/master


The commit making the bug is in there (quite far down) and the fix is now the second last from the top.


You’ll see v2.40 there. To understand v2.31; read the “maintenance releases” chapter in the readme in the venus repo.

Thanks


Article

Contributors

_OS_ contributed to this article