question

mvader (Victron Energy) avatar image
mvader (Victron Energy) asked

Venus OS v2.70~12 available for testing

UPDATE 2021-05-21: today we made v2.70~15 available for field testing. Only one change: fix the menu being unavailable after setting the access level to User only. Thank you @vga for finding and reporting this! We overlooked this when making a change. How to recover if your in that situation depends: when auto-update is enabled, just await your GX device being autoupdated. If not, you need to reset the GX device to its defaults, for which I've added instructions below.


UPDATE 2021-05-20: today we made v2.70~14 available. The main change is that, per ~14, the previous issue/bug/regression for having multiple tank senders with different device instance but same data instance, is fixed. And secondly some change related to the raspberrypi packages; which is really minor except for the handful of people/hobbiests/tinkerers that use that exotic thing.


Good day!

v2.70~12 is available for testing.

This post is intended for all people participating in the Venus OS Beta test program. Read that link for more information about the program.

To learn more about the changes made in earlier v2.70 beta versions, make sure to read these two links:


What to test?

Still the same as last time: basically everything. In v2.70 we have amde multiple low level changes. the OE version has been updated from Rocko to Zeus and the Linux kernel has been updated from 4.19 to 5.10. And as a result, bugs and regression may hide in the most unexpected of corners.

Sofar, the status is that its all proving to be quite stable.


The plan with v2.70

We're getting close to having all wanted functionality included; the main missing item is the new tank overview page. Once thats done there will be some more time of testing and then final release.


Change log v2.70~12

  • User interface and various:
    • Change the name of the battery measurements menu to "Battery Measurements" and add a help text indicating that it is (also) for the MFD HTML5 app. This same info is also used for the VRM Dashboard.
    • Better handle AC-Coupled PV on the output of an Inverter RS by adding AC Frequency item, and by showing negative current and power instead of clipping that to zero.
    • Show firmware version of a Fronius datamanager on the Device subpage.
    • Add EM24 Ethernet meter phase configuration setting
    • Improve the CAN-bus statistics page so it all fits on one screen.
    • Mark menu items that are only visible in debug or other special modes with a color; so thats its clear that its not visible in normal usage.
  • Tank monitoring
    • Add tank level alarms. (high level alarm and low level alarm)
    • Add new fluid type, Gasoline, to fully match the NMEA2000 supported set of fluid types.
    • Support tank senders that send out levels for multiple tanks using different data instances, such as the Garnet Seelevel N2K product, and the Maretron FPM100. Details also here: https://github.com/victronenergy/venus/issues/551.
  • NMEA2000-out: include SOH in the NMEA2000-out function. Note that Victron battery monitors such as the BMV series don't have SOH; this applies only when using a lithium battery with integrated CAN-bus *and* that has SOH.
  • Can-bus BMS: support CCL & DCL current limits above 3276A.
  • VRM data transmission: change the logging frequency of min/max cell voltage/temperature to fix the gaps in the graphs on VRM.


Known issues

  • The new tank overview, as visible in the GX Tank manual, is not included yet
  • FIXED IN v2.70~14: Since v2.70~12, tank data was jumping around if you have multiple different tank senders with one instance the same and the other not the same.
  • Setting access level to User limits the Settings menu to just a handful of items. See thread below for details.


Looking forward to your reactions, and all the best, Matthijs

Venus OS
17 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

hi all, today we released v2.70~14 for field testing, with only a minor change so rather than making a new post I've update this one.

0 Likes 0 ·
Kevin Windrem avatar image Kevin Windrem mvader (Victron Energy) ♦♦ commented ·

OK, so I'll bite: what are the changes for my "exotic thing" (RPI 4)?

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ Kevin Windrem commented ·

haha, yours is not exotic. This is about the package type installs:
https://github.com/victronenergy/venus/wiki/install-venus-packages-on-Debian

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

hi all, today we released v2.70~15 for field testing, one change only: fixes the menu issue when setting the access level to user only.

0 Likes 0 ·
alan-peng avatar image alan-peng commented ·

Hello,

There is a issue in AC input power and current reading for new MP II 12/3kva-230vac, the overview ac in power is zero while actually take 1400W from grid for charging. Also detail data is not right as well. This bug could be Venus OS or MP 12/3kva firmware. See screenshot.

I am running the latest OS firmware 2.70~15 and 481.

Regards

Alan

1622088139029.jpeg

1622088163988.jpeg

0 Likes 0 ·
1622088139029.jpeg (159.5 KiB)
1622088163988.jpeg (172.6 KiB)
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ alan-peng commented ·

Hi Alan, thank you. I’ve asked a colleague to look into this. Matthijs

0 Likes 0 ·
alan-peng avatar image alan-peng mvader (Victron Energy) ♦♦ commented ·

Hello Matthijs,

The readings are correct when revert back to office release 2.66. So the bug related to the beta version 2.70~15.

Regards,

Alan

0 Likes 0 ·
alan-peng avatar image alan-peng alan-peng commented ·

Updated: from 2.66, I updated to 2.70~15 again. Now readings are correct. Very Strange! Anyway, everything is fine now. Thanks for attention.

Regards

Alan

0 Likes 0 ·
Stephen Phillips avatar image Stephen Phillips commented ·

This may be of interest .

I have noticed on the last few Beta versions that my HDMI cat 5 extender doesn't work that is connected to my Cerbo.

This cat5 Extender has a HDMI input that comes from my Cerbo .

One local HDMI Output. As well as this function it extends the HDMI signal over cat5 to a second monitor. 50 meters away by means of a decoder BOX.


This works fine on 2.66.

Upgrade to 2.7-15 and it doesn't work at all.


When I bypass it and plug the monitor in. It works but the image fills about 2/3 of the screen .

Then a Reboot cerbo fixes it and it works on the extender as well on the primary monitor .


The extender still doesn't work work for my second monitor.


Go back to official release firmware 2.66 and it all works fine .


I must assume that the beta only allows one resolution output that is not compatible with the hard ware I have . Maybe standard 640x480 is not enabled on 2.7-15 or something similar that the extender can not transmit ?.

I know this is not standard config , but this application is used in large installations when the system is installed in a shed and monitored from the house 50 meters away.


This may be a software bug or my HDMI extender will not be compatible with the HDMI resolution coming out of cerbo moving forward ?

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ Stephen Phillips commented ·

Hi Stephen, we changed to a newer Linux kernel, which automatically includes updated HDMI drivers. It sounds like that might be the issue you're having. I'm not sure if there is anything we are able to do about this, HDMI is a rather complex protocol. We'll look at this, but only after first releasing v2.70.


ps. I'm sure you know, but for any co-readers: this is basically why we don't support cable extenders. Your best changes for a working one would be a totally passive one; ie. a cable with super high quality conductors in it, and no electronics at all. But that will have a limited max length by theory/design.

Ethernet/wifi is already much easier to extend, so another option is Remote Console and/or the HTML overview. See http://venus.local/app.

0 Likes 0 ·
ray-mont avatar image ray-mont commented ·

just made this comment on @vga ’s issue and

i have the same issue that with this beta firmware no wifi adaptor is found on 1 of mine Raspberry PI 3B+ no version number on both boards

WiFi works OK on one
the other one it can’t find the onboard WiFi adaptor 2.70~6 nor ~15

going back to version 2.66 and WiFi is working again

for me this is not an issue as I normally do not use the WiFi option

ray

ps victron connect reports that both rpi‘s are 3b plus version 1.3

the problem pi is also reported as a 3b plus version R62fb7ec1-e0ce-4774-a0c1-b7fa407a10d4.jpeg

187a953a-eb19-4d3b-bf1b-d049ae778a36.jpeg

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ ray-mont commented ·

Hi @ray-mont; noted thanks. I don't know what the issue is and I'm afraid we won't fix this before releasing v2.70. Ofcourse anyone thats affected by this on his raspberrypi can always stick to v2.66 which doesn't have the issue.


Lets use @vga his thread to discuss this further:
https://community.victronenergy.com/questions/89981/venus-os-v270-wifi-not-working.html?childToView=90589#answer-90589

0 Likes 0 ·
matthias-roetzer avatar image matthias-roetzer commented ·

@mvader (Victron Energy)

Hi Matthijs,

tested on v2.70~15

Quote: "Better handle AC-Coupled PV on the output of an Inverter RS by adding AC Frequency item, and by showing negative current and power instead of clipping that to zero."

I was thinking that would resovle the following, but apparently it does not. Inverters connected to AC out of MP2 5k (3~) are clipped to zero while shown as grid feed in (metered by inverter). See green arrows. While in the advanced graphs section the real value (negative power) is shown on AC Out instead of zero! This behaviour happens with and without dedicated PV inverter metering. So in the case belwo the PV inverter power isn't really zero but I've testet what happens if it is zero.

All the best,

Matthias


2021-05-31-144442.jpg

0 Likes 0 ·
2021-05-31-144442.jpg (144.0 KiB)
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ matthias-roetzer commented ·

noted Matthias, I've asked a colleague to look into this, also your other one.

0 Likes 0 ·
matthias-roetzer avatar image matthias-roetzer commented ·

@mvader (Victron Energy)

Hi Matthijs,

What I have noticed as well since a while is that the dashboard needs sometimes a long time (up to several minutes) to refresh the charging/discharging state of the battery. eg it says discharging, but current and power is positive, and the other way arround. So the values seem to be correct but the text seems to be not in sync with the values. I think that this behaviour did not occour in the previous release or maybe previous previous release.

All the best,

Matthias


2021-05-02-084516.jpg


0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hey all, an update: we released ~16 to candidate just now. Which adds the long sought for tank overview as well as some other changes.

I’ll type a more complete message for that later tonight.

0 Likes 0 ·
wkirby avatar image wkirby ♦♦ mvader (Victron Energy) ♦♦ commented ·

Tanks overview looks good. This will make some people very happy I think.

0 Likes 0 ·
6 Answers
Kevin Windrem avatar image
Kevin Windrem answered ·

I can confirm the NMEA2000 tank sensor limitation has been eliminated. v2.70~12 works out of the box with my SeeLevel 3-tank system.

Excellent work!!!

TankRepeater is now obsolete. RIP For those that are using it, you should uninstall it because it causes side effects: one of the tanks is duplicated!

I found a few issues:

With my tank system, the alarm settings are disabled.

I did notice the low/high indication in the GUI is still hard-coded to 20%/80%. If this is coming, I won't spend the time to the waring threshold to the alarm settings. But I will if this isn't planned for v2.70.

I can't find a place to set a custom name for my tanks. Is this yet to be added?

The order of tanks displayed changes with each restart of the gui (killall gui) or reboot.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Haha yes party! It was a surprise for me as well.


below a screenshot with the available tank level alarm settings. Sorry for the rotation; its late here and this will have to do. :-). This is for the low level alarm; and high level is exactly the same.

RIP to your TankRepeater work indeed Kevin! And thank youfor all the efforts, it helped a lot of people out for a long time!


image.jpg

0 Likes 0 ·
image.jpg (4.0 MiB)
vga avatar image
vga answered ·

I have updated my Victron Cerbo GX to Venus OS v2.70~12. When changing Access Level to "User", I lost the menu, meaning I'm not able to revert to "User & Installer" Tried to install the same image on a RPi3+ with the same result. Is there any other way to change User Access Level than through the GUI or do I have to reset?

vga

13 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Kevin Windrem avatar image Kevin Windrem commented ·

If you have console/ssh access, you can run dbus-spy

Go to com.victron.settings

change Settings/System/AccessLevel to a value of 1 for User & Installer and 2 for SuperUser.

If you have a computer that can read ext4 volumes, you can also mount the SD card and make changes there

You want the last partition which is /data.

edit conf/settings.xml and carefully edit the change the current value for AccessLevel.

0 Likes 0 ·
vga avatar image vga Kevin Windrem commented ·

Thanks @Kevin Windrem, the dbus-spy was new to me and worked fine for the RPi installation with ssh access, really cool feature!

Unfortunately, the CerboGX don’t have ssh enabled, so I’m a bit stuck. Does the CerboGX contain an storage card that I could mount on a computer? Or maybe I should try to connect to it with this guide: https://community.victronenergy.com/questions/18359/venus-not-reachable-mistake-modifying-etcdbus-1sys.html

vga

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ vga commented ·

Hi, I’ve seen and reproduced it. Thanks for reporting!

I made an issue, see below. For now, I’d recommend to just wait a little. Do you have auto updating enabled? Then its likely that your Cerbo will fix itself once it installs the version where we fix this.


https://github.com/victronenergy/venus/issues/823

0 Likes 0 ·
vga avatar image vga mvader (Victron Energy) ♦♦ commented ·

Thanks for looking into it!

Sadly I don't think auto-update is enabled on the CerboGX. Any other options to recover?


vga

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ vga commented ·

Hi, I see you also have Remote Support disabled. And indeed, auto update disabled as well.

The link you sent might work for a Venus GX, but not for the Cerbo.

One solution would be to use a serial console cable, explained here: https://www.victronenergy.com/live/ccgx:root_access#connecting_on_the_serial_console

The other would be to make a usb stick with a script on it that will be copied to the data partition on boot. And then executed either that same boot or the next one. And in the script set the access level back.

Or maybe while at it we can make a script that removes all settings except for the factory installed files. And which removes itself at end of execution.

More on this tomorrow.



0 Likes 0 ·
vga avatar image vga mvader (Victron Energy) ♦♦ commented ·

Ok, so no backdoors then :(

The CerboGX works in a way with vrm, so there is no rush, but I would be happy if I can avoid opening the unit for the serial interface.

But I am curious on what the possibilities through USB device and scripts can do. If the script could rename the /data/conf/settings.xml so the next boot would create a new clean one, that would probably solve this issue


vga

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ vga commented ·

Hi @vga, here is how to recover your GX device:

1. download the venus-data.tgz file (dropbox link)
2. copy it onto a usb-disk (don't unpack or unzip that file).
3. boot with the usb-disk inserted and wait for a while: until the GX Device is fully started up)
4. remove the pendrive
5. power cycle the device, or as an alternative and when available, use the Reboot function in the Settings -> General menu.


During this boot, the GX device will erase its settings and auto-reboot itself.


Ps. for anyone curious: yes, this will fully reset a GX device to its factory defaults. We'll test and experiment a bit more, and then also document this in the manual and such. Which means another thank you to @vga, your questions finally got us on the right track to have a proper working and usable factory reset option.



0 Likes 0 ·
Show more comments
Rob Duthie avatar image
Rob Duthie answered ·

Testing Ver 2.70.15 venus on Raspi 3B+ as below

Testing Ver 2.71.1 venus on Rapsi 3B+ as below no change

Internal bluetooth works OK

USB GPS OK.

Relays outputs all 6x OK

Digital inputs all OK

USB VE direct port OK

Smart shunt, MPPT, Phoenix Inverters,VE bus inverters all OK.

USB Energy meter PV meters all working OK.

WiFi OK

Screen brightness OK

USB Canbus not working

VE Direct serial not working

Analog settings page input blank screen missing

Loaded my standard script file from previous Ver V2.60.66 to test all worked OK prior.

Regards

Rob D

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Hi Rob,


Opkg is always set to release after you update your GX device. You always need to sync that yourself. Use the set-feed.sh script for that.


i dont know what you mean with this: “ Testing of the Raspi model 3B+for Ver > 2.70.12 venus software”? What version did you actually test?


for some other things, like canbus, some vedirect, and analog settings page: please reread your text and add some missing interpunctuation and/or a test result. I’m sorry but need to read multiple times to try and understand what you mean, and am still not sure. Add what works and what doesnt. Or in what situation, or after what change it doesnt work anymore. Try to be more concise.


for canbus, you’ll have to test more. Same for serial port, I’m not yet convinced there is an issue. Perhaps you need to redo it with opkg set correctly from the start?

0 Likes 0 ·
Kevin Windrem avatar image
Kevin Windrem answered ·

I have a short list of issues, all tank related. These were mentioned previously as well,

  1. No custom tank names for NMEA2000 tanks
  2. No alarms settable for NMEA2000 tanks. The menu appears but the parameters are grayed out
  3. Order of tanks displayed in the Mobile Overview changes with each reboot. Position on the display is important for quickly scanning information. If there isn't a way to fix the order on the input side, would it be possible to sort the list in the GUI code for display?
  4. No name and color entries for Fuel (gasoline) fluid type in TileTank.qml. (The selection is present in the setup page.) Result is tank name is displayed as "TANK"


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

raphael avatar image
raphael answered ·

It would be quite handy to calibrate the temperature sensors, since they can be off by quite a bit. The real temperature of the temperature probe location is 17°C...They are showing 15, 16 and 19°C in my case.

(I used the sensors of my tree MultiPlus II 5kVA and connected them to the Cerbo GX.)

screenshot-20210528-231333-brave-beta-1.png


4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Rob Duthie avatar image Rob Duthie commented ·

Hi

Yes you can calibrate the sensors in the start up menu.

0 Likes 0 ·
raphael avatar image raphael Rob Duthie commented ·

According to a post from the 11th of May, it is still not possible to calibrate the sensors:

https://community.victronenergy.com/questions/16735/is-there-a-way-to-calibrate-the-temperature-senor.html

Can you show, how to calibrate?

Thank you for your help!

0 Likes 0 ·
Mark avatar image Mark raphael commented ·

You need to enable the superuser settings to adjust the temperature offset!

0 Likes 0 ·
raphael avatar image raphael Mark commented ·

Thank you so much! That solved my problem!

If others have the same problem, there is the description of how to get superuser rights:

https://www.victronenergy.com/live/ccgx:root_access#set_access_level_to_superuser

0 Likes 0 ·
matteo-fossati avatar image
matteo-fossati answered ·

Very ha;pay for the new tank presentation very clear...but... there is still no possibility to order it or at least to use the N2K instance to order the visualisation?da09b5e6-1763-4b06-a06a-bea9495e3d18.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.