question

bkeepers avatar image

Multiplus Compact 12/2000/80 won't turn on

When I turn on the Multiplus Compact 12/2000/80 (on a sailboat) to invert or charge, I get one very brief flash of the yellow light and then nothing else. Connecting with VE.Bus smart dongle does not show that it's connected to the multiplus. I can connect with the MK3 and VictronConnect and it shows that the multiplus is attached but off, but when I go into Product Info, it just hangs reading configuration.

I tried cutting power to the inverter for 4+ seconds, and replacing the MEGA fuse, but neither seems to affect anything. It has a digital multi control attached, so I tried toggling the dip switches to disable it and just power on with the switch on the unit, but I see the same behavior. I've tested voltage at the inverter and it matches what I'm reading off the distribution point.


Relevant history:

This started yesterday. While running the generator to charge the batteries I decided to turn on the air con, something we've done occasionally in the past. The multiplus immediately faulted and reset. When it turned back on, the digital multi control panel said that was in bulk charging, but the batteries were not receiving any current. After toggling it off it would not turn back on.

We've been using this multiplus for over a year. A couple months ago we upgraded to Lithium batteries. We leave the inverter on 24/7 now, so we're definitely taxing it more. We usually charge from solar, so we've only a once or twice used it to charge from generator since upgrading to lithium (mostly to test that we had it configured right, and we ran the air con then too).

A week or so ago we were pushing the inverter so hard that we burned up the internal MEGA fuse. I presume the 2000w inverter uses a 175A fuse, but I only have 100A spares at the moment, so that's what I replaced it with for now. I tried swapping it out with a fresh one after our incident yesterday, but still no luck.


Any advice? Did I kill my Multiplus?

MultiPlus Quattro Inverter ChargerPhoenix Invertercharger
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
bkeepers avatar image
bkeepers answered ·

Update: after some more testing, it looks like the issue is with the MEGA fuse. Even though there is continuity and no resistance, I'm only getting ~3v coming through the fuse. I'm out of spare MEGA fuses at the moment, so I tested by directly connecting the positive cable to the other side of the fuse terminal and the multiplus operators normally. I'll leave it disconnected for now until I can get to a port and get new fuses.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jwfrary avatar image
jwfrary answered ·

try disconnecting the ve.bus cable to the multi from the DMC.

Check the fuse you put in is actually good with a meter. Check the voltage at the terminals, battery and multi under the cover.


1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I tested a fuse and am seeing 0.0 resistance. Voltage at multi matches voltage at distribution bus.

I disconnected the ve.bus cable and was able to get the device to turn back on. I then disabled power-assist in settings to ensure it wouldn't try to pull from batteries (due to undersized fuse) when powering AC loads with a generator.

With the generator running, I put significant AC loads on it and it reset and won't turn back on again.

Are there any other fuses on this thing? Would an undersized fuse on the DC side have this effect when passing through AC from a generator? Seems like something else is going on here.