question

timm avatar image

Color Control GX no longer sees Multiplus w v2.62 firmware

On Feb 8th at 21:00 hrs my system lost connection with the Multiplus. No SOC and other info is available on the Color Control or on the NMEA 2000 network.

It appears that this was coincident with the release of v2.62 of the Color Control firmware. The system is now running on v2.63 and continues to not display the normal data.

I have a Multiplus 24/3000/70 connected via VE.Bus to NMEA and then NMEA to VE.Can to Color Control. The Color Control is set to automatically update software.

Anyone have ideas on how to resolve this?

Best!

Tim


victron-ve-bus-loss.jpg

MultiPlus Quattro Inverter ChargerCCGX Color ControlFirmware Update Issue
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi Tim, to start, I recommend to revert back to the previous firmware version, see Settings -> Firmware -> Backup firmware. Then all will be as i.

and your MultiPlus is running a rather old fw version, that most people won’t have anymore. I’ll look into that and get back to you.


5 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks for the advice!!

The Color Control has updated to 2.63 so only 2.62 is available as Backup Firmware. I worked on 2.61 which I tried to load from SD card, but it does not recognize the .swu file. Is it prevented from going to lower releases? If so, is there a way around it?

I hesitated to update the MultiPlus software as I believe it requires v2 hardware for the VE.Bus to NMEA adapter. I believe I only have v1 (see below)?

Please advise next steps, if any.

Best!

Tim

VE.BUS to NMEA adapter:

bus-to-nmea-1.jpg


bus-to-nmea-1.jpg (271.7 KiB)

Hi, loading a v2.61 .swu file should work just fine. I'm not sure why it doesn't for you; try another card, or a usb stick, or something like that first perhaps? And make sure just one .swu file is on that medium.


Then, for what to do: what do you use that NMEA2000 cable for? You need that data on N2K for on your MFD or something similar?


What I'd do, or at least try, is:

1. connect that MultiPlus directly to your GX Device, and disconnect that ve.bus to nmea2000 cable from your system.

2. connect the gx to your nmea2000 network, we have an adapter cable for that.

3. enable NMEA-2000 feature (see NMEA2000 chapter in the manual)

4. now, see if what it is you do on NMEA2000 still works ok. And if it does, put the VE.Bus to NMEA2000 cable in the bin (good riddance!) and update your MultiPlus. No more limitations, all up to date.


If it doesn't, but then I'm curious why, put that VE.Bus to NMEA2000 cable back in place.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ ·

Ps i forgot one step, see edited msg

timm avatar image timm mvader (Victron Energy) ♦♦ ·

I decided to take your advice and didn't downgrade the Color Control GX. I ran a new cable for VE.Bus to connect the MultiPlus and the Color Control directly.

Results: Steps 1,2 and 3 done. Everything works well with the exception of PGN 127506 from the MultiPlus. I understand that this needs to be enabled but I cannot find any instructions. I have both Maretron and Actisense software. This is a dedicated inverter battery bank, so the limitations of 127506 from the MultiPlus don't apply.

Thanks for your help so far! Any additional suggestions on the last piece are welcome!

Best!

Tim

Hi Tim, nice!

I'm not sure how that is done, and can't find any documentation about it either. I'll find out and get you an answer; might take a couple of days.

Meanwhile, also for anyone else coming across this post, please read our (today updated) NMEA2000 & MFD integration guide to have the latest guidance.